VeraCrypt - Бесплатное надёжное шифрование дисков с открытым исходным кодом

  • Начало
  • Исходный код
  • Загрузить
  • Документация
  • Поддержать разработку
  • Форум

Содержание

Эта документация поставляется по принципу "как есть", без гарантии отсутствия ошибок и любых других гарантий. См. подробности в разделе Отказ от обязательств.

  • Предисловие
  • Введение
  • Руководство для начинающих
  • Том VeraCrypt
    • Создание нового тома VeraCrypt
    • Избранные тома
    • Системные избранные тома
  • Шифрование системы
    • Скрытая операционная система
    • Операционные системы, поддерживающие системное шифрование
    • Диск восстановления VeraCrypt (Rescue Disk)
  • Правдоподобное отрицание наличия шифрования
    • Скрытый том
      • Защита скрытых томов от повреждений
      • Требования безопасности и меры предосторожности, касающиеся скрытых томов
    • Скрытая операционная система
  • Главное окно программы
    • Меню программы
    • Монтирование томов
  • Обычное размонтирование против принудительного
  • О рисках, связанных со сторонними расширениями файлов
  • Распараллеливание
  • Конвейеризация
  • Аппаратное ускорение
  • Горячие клавиши
  • Ключевые файлы
  • Токены безопасности и смарт-карты
  • Смарт-карты EMV
  • Портативный (переносной) режим
  • Поддержка TrueCrypt
  • Преобразование томов и разделов TrueCrypt в формат VeraCrypt
  • Руководство по преобразованию томов для версий 1.26 и новее
  • Параметры монтирования по умолчанию
  • Языковые пакеты
  • Алгоритмы шифрования
    • AES
    • Camellia
    • Kuznyechik
    • Serpent
    • SM4
    • Twofish
    • Каскады шифров
  • Алгоритмы хеширования
    • BLAKE2s-256
    • SHA-256
    • SHA-512
    • Whirlpool
    • Streebog
  • Поддерживаемые операционные системы
  • Использование в командной строке
  • Модель безопасности
  • Требования безопасности и меры предосторожности
    • Утечки данных
      • Файл подкачки
      • Файлы дампа памяти
      • Файл гибернации
    • Незашифрованные данные в ОЗУ
    • Шифрование оперативной памяти в VeraCrypt
    • Защита памяти в VeraCrypt
    • Физическая безопасность
    • Вредоносное ПО (malware)
    • Многопользовательская среда
    • Подлинность и целостность данных
    • Выбор паролей и ключевых файлов
    • Изменение паролей и ключевых файлов
    • Операция Trim
    • Распределение износа (Wear-Leveling)
    • Перераспределённые сектора
    • Дефрагментация
    • Журналируемые файловые системы
    • Клонирование томов
    • Дополнительные требования безопасности и меры предосторожности
  • О безопасном резервном копировании
  • Разное
    • Использование VeraCrypt без прав администратора
    • Общий доступ по сети
    • Работа VeraCrypt в фоновом режиме
    • Том, смонтированный как сменный носитель
    • Системные файлы VeraCrypt и программные данные
    • Как удалить шифрование
    • Удаление VeraCrypt
    • Цифровые подписи
  • Устранение затруднений
  • Несовместимости
  • Замеченные проблемы и ограничения
  • Вопросы и ответы
  • Технические подробности
    • Система обозначений
    • Схема шифрования
    • Режимы работы
    • Формирование ключа заголовка, соль и количество итераций
    • Генератор случайных чисел
    • Ключевые файлы
    • PIM (Персональный множитель итераций)
    • Спецификация формата томов VeraCrypt
    • Соответствие стандартам и спецификациям
    • Исходный код программы
    • Сборка VeraCrypt из исходного кода
      • Руководство по сборке в Windows
      • Руководство по сборке в Linux
  • Связь с авторами
  • Правовая информация
  • История версий
  • Благодарности
  • Ссылки


  • Документация
  • Поддержать разработку
  • Форум

Документация >> Предисловие

Предисловие

Обратите внимание, что хотя большинство глав этой документации применимы в целом ко всем версиям VeraCrypt, некоторые разделы в первую очередь предназначены для пользователей версий VeraCrypt для Windows. Следовательно, такие разделы могут содержать информацию, которая не подходит для версий VeraCrypt для Mac OS X (macOS) и Linux.


Документация >> Введение

Введение

VeraCrypt это программное обеспечение, предназначенное для создания томов (устройств хранения данных) и работы с ними с использованием шифрования на лету (on-the-fly encryption). Шифрование на лету означает, что данные автоматически зашифровываются непосредственно перед записью их на диск и расшифровываются сразу же после их считывания, то есть без какого-либо вмешательства пользователя. Никакие данные, хранящиеся в зашифрованном томе, невозможно прочитать (расшифровать) без правильного указания пароля/ключевых файлов или правильных ключей шифрования. Полностью шифруется вся файловая система (имена файлов и папок, содержимое каждого файла, свободное место, метаданные и др.).
Файлы можно копировать со смонтированного тома VeraCrypt и на него точно так же, как и при использовании любого обычного диска (например, с помощью перетаскивания). При чтении или копировании из зашифрованного тома VeraCrypt файлы автоматически на лету расшифровываются (в память/ОЗУ). Аналогично, файлы, записываемые или копируемые в том VeraCrypt, автоматически на лету зашифровываются в ОЗУ (непосредственно перед их сохранением на диск). Обратите внимание: это не означает, что перед шифрованием/дешифрованием в ОЗУ должен находиться весь обрабатываемый файл. Никакой дополнительной памяти (ОЗУ) для VeraCrypt не требуется. Пояснение, как всё это работает, приведено в следующем абзаце.

Предположим, у нас есть видеофайл формата .avi, хранящийся в томе VeraCrypt (следовательно, этот видеофайл полностью зашифрован). Пользователь указывает правильный пароль (и/или ключевой файл) и монтирует (открывает) том VeraCrypt. Когда пользователь дважды щёлкает мышью по значку этого видеофайла, операционная система запускает приложение, ассоциированное с файлами такого типа – в данном случае это, как правило, мультимедийный проигрыватель. Затем мультимедийный проигрыватель начинает загружать маленькую начальную часть видеофайла из зашифрованного тома VeraCrypt в ОЗУ (память), чтобы приступить к воспроизведению. Во время загрузки части файла VeraCrypt автоматически расшифровывает её (в ОЗУ), после чего расшифрованная часть видео (хранящаяся в ОЗУ) воспроизводится медиапроигрывателем. Пока эта часть воспроизводится, медиапроигрыватель начинает считывать другую небольшую часть видеофайла из зашифрованного тома VeraCrypt в ОЗУ (память), и процесс повторяется. Данная операция называется шифрованием/дешифрованием на лету, она работает для файлов любых типов (не только видео).

Обратите внимание: VeraCrypt никогда не сохраняет на диске никаких данных в незашифрованном виде – такие данные временно хранятся только в ОЗУ (оперативной памяти). Даже когда том смонтирован, хранящиеся в нём данные по-прежнему остаются зашифрованными. При перезагрузке Windows или выключении компьютера том будет размонтирован, а хранящиеся в нём файлы станут недоступными (и зашифрованными). Даже в случае непредвиденного перебоя питания (без правильного завершения работы системы), хранящиеся в томе файлы останутся недоступными (и зашифрованными). Чтобы получить к ним доступ вновь, нужно смонтировать том (и правильно указать пароль и/или ключевой файл).

Краткий учебник по началу работы см. в главе Руководство для начинающих.


Документация >> Руководство для начинающих пользователей

Руководство для начинающих пользователей

Как создать и использовать контейнер VeraCrypt

В этой главе содержатся пошаговые инструкции о том, как создавать, монтировать и использовать том VeraCrypt. Настоятельно рекомендуем вам ознакомиться и с другими разделами данного руководства, так как они содержат важную информацию.

ШАГ 1:

Если вы этого ещё не сделали, загрузите и установите программу VeraCrypt. Затем запустите её, дважды щёлкнув по файлу VeraCrypt.exe или по ярлыку VeraCrypt в меню Пуск в Windows.

ШАГ 2:

Должно появиться главное окно VeraCrypt. Нажмите кнопку Создать том (на иллюстрации она выделена красным).

ШАГ 3:

Должно появиться окно мастера создания томов VeraCrypt.

На этом этапе нам нужно выбрать место, где будет создан том VeraCrypt. Том может находиться в файле (также именуемом контейнером), в разделе или на диске. В этом примере мы выберем первый вариант и создадим том VeraCrypt внутри файла.

Поскольку эта опция выбрана по умолчанию, просто нажимаем кнопку Далее.

ШАГ 4:

Сейчас нам нужно выбрать, какой том VeraCrypt мы хотим создать – обычный или скрытый. В этом примере мы выберем первый вариант и создадим обычный том.

Поскольку эта опция выбрана по умолчанию, просто нажимаем кнопку Далее.

ШАГ 5:

На этом этапе требуется указать место создания тома (файла-контейнера) VeraCrypt. Обратите внимание: контейнер VeraCrypt ничем не отличается от любого другого обычного файла. Например, его можно перемещать или удалять как любой другой файл. Также ему потребуется имя файла, которое мы выберем на следующем этапе.

Нажмите кнопку Выбрать файл.

Появится стандартное диалоговое окно выбора файлов Windows (при этом окно мастера создания томов останется открытым в фоне).

ШАГ 6:

В этом руководстве мы создадим наш том VeraCrypt в папке F:\Data\ и присвоим тому (файлу-контейнеру) имя MyVolume.hc (как показано на иллюстрации выше). Разумеется, вы можете выбрать любое другое имя и расположение файла (например, поместив его на USB-флешку). Обратите внимание, что файла MyVolume.hc пока не существует – VeraCrypt его создаст.

ВАЖНО: Имейте в виду, что VeraCrypt не будет шифровать никакие имеющиеся файлы (при создании файла-контейнера VeraCrypt). Если на данном этапе выбрать какой-либо уже существующий файл, он будет перезаписан и заменён новым созданным томом (то есть перезаписанный файл будет уничтожен, а не зашифрован). Зашифровать имеющиеся файлы вы сможете позднее, переместив их в том VeraCrypt, который мы сейчас создаём.*

Выберите в файловом окне желаемый путь (место, где вы хотите создать контейнер). В поле Имя файла введите имя, которое вы хотите дать файлу-контейнеру.

Нажмите кнопку Сохранить.

Окно выбора файлов должно исчезнуть.

На следующих этапах мы вернёмся в окно мастера создания томов VeraCrypt.

* Обратите внимание, что после того, как вы скопируете существующие незашифрованные файлы на том VeraCrypt, вы должны надёжно удалить (затереть) исходные незашифрованные файлы. Для надёжного стирания существуют специальные программы (многие из которых бесплатны).

ШАГ 7:

В окне мастера создания томов нажмите Далее.

ШАГ 8:

Здесь можно выбрать для тома алгоритмы шифрования и хеширования. Если вы не знаете, что лучше выбрать, просто оставьте предложенные значения и нажмите Далее (см. подробности в главах Алгоритмы шифрования и Алгоритмы хеширования).

ШАГ 9:

Здесь мы укажем, что хотим создать контейнер VeraCrypt размером 250 мегабайт. Разумеется, вы можете указать любой другой размер. После того, как вы введёте размер в поле ввода (оно выделено красным), нажмите кнопку Далее.

ШАГ 10:

Мы подошли к одному из самых важных этапов: нам нужно выбрать для тома хороший пароль. Какой пароль следует считать хорошим, написано в этом окне мастера. Внимательно прочитайте данную информацию.

После того, как вы определитесь с хорошим паролем, введите его в первое поле ввода. Затем введите тот же самый пароль в расположенное ниже второе поле ввода и нажмите кнопку Далее.

Примечание: кнопка Далее будет недоступна до тех пор, пока в полях ввода не будут введены одинаковые пароли.

ШАГ 11:

Произвольно перемещайте мышь в окне мастера создания томов в течение хотя бы 30 секунд. Чем дольше вы будете перемещать мышь, тем лучше – этим вы значительно повысите криптостойкость ключей шифрования (что увеличит их надёжность).

Нажмите кнопку Разметить.

Сейчас должно начаться создание тома. VeraCrypt создаст файл с именем MyVolume.hc в папке F:\Data\ (как мы указали в шаге 6). Этот файл станет контейнером VeraCrypt (то есть он будет содержать зашифрованный том VeraCrypt). В зависимости от размера тома, создание тома может длиться довольно долго. По окончании появится следующее окно:

Нажмите OK, чтобы закрыть это окно.

ШАГ 12:

Итак, только что мы успешно создали том VeraCrypt (файловый контейнер). Нажмите кнопку Выход в окне мастера создания томов VeraCrypt.

Окно мастера должно исчезнуть.

На следующих этапах мы смонтируем том, который только что создали. Сейчас мы должны были вернуться в главное окно VeraCrypt (которое должно быть всё ещё открыто, в противном случае выполните заново шаг 1, чтобы запустить VeraCrypt, а затем перейдите к шагу 13).

ШАГ 13:

Выберите в списке букву диска (на иллюстрации она помечена красным). Она станет буквой диска со смонтированным контейнером VeraCrypt.

Примечание: в нашем примере мы выбрали букву диска M, но вы, разумеется, можете выбрать любую другую доступную букву.

ШАГ 14:

Нажмите кнопку Выбрать файл.

Появится обычное окно выбора файлов.

ШАГ 15:

В окне выбора файлов найдите и укажите файловый контейнер (который мы создали на шагах 6-12). Нажмите кнопку Открыть (в окне выбора файлов).

Окно выбора файлов должно исчезнуть.

На следующих этапах мы вернёмся в главное окно VeraCrypt.

ШАГ 16:

В главном окне VeraCrypt нажмите кнопку Смонтировать. Появится окно ввода пароля.

ШАГ 17:

Укажите пароль (который мы задали на шаге 10) в поле ввода (на иллюстрации оно отмечено красным).

ШАГ 18:

Выберите алгоритм PRF, который был использован при создании тома (по умолчанию VeraCrypt использует PRF-алгоритм SHA-512). Если вы не помните, какой PRF использовался, просто оставьте здесь автоопределение, но монтирование в этом случае займёт большее время. После ввода пароля нажмите OK.

Сейчас VeraCrypt попытается смонтировать наш том. Если пароль указан неправильно (например, вы ошиблись при вводе), VeraCrypt известит вас об этом, и потребуется повторить предыдущий этап (снова ввести пароль и нажать OK). Если пароль правильный, том будет смонтирован.

ШАГ 19 (ЗАКЛЮЧИТЕЛЬНЫЙ):

Итак, мы только что успешно смонтировали контейнер как виртуальный диск M:.

Этот виртуальный диск полностью зашифрован (в том числе зашифрованы имена файлов, таблицы распределения, свободное место и т. д.) и ведёт себя как настоящий диск. Вы можете сохранять (или копировать, перемещать и т. д.) файлы на этом виртуальном диске – они будут шифроваться на лету в момент записи.

Если вы откроете файл, хранящийся в томе VeraCrypt, например, в медиапроигрывателе, этот файл будет автоматически расшифровываться в памяти (в ОЗУ) непосредственно в момент считывания, то есть на лету.

ВАЖНО: Обратите внимание, что когда вы открываете файл, хранящийся в томе VeraCrypt (или когда сохраняете/копируете файл в томе VeraCrypt), повторно пароль не запрашивается. Правильный пароль нужно указать только один раз – при монтировании тома.

Открыть смонтированный том можно, например, двойным щелчком по элементу, выделенному на иллюстрации синим цветом.

Просматривать содержимое смонтированного тома можно точно так же, как содержимое любого другого диска. Например, открыть Компьютер (или Мой компьютер) и дважды щёлкнуть по соответствующей букве диска (в нашем случае это буква M).

Вы можете копировать файлы (или папки) в/из том(а) VeraCrypt, как если бы вы копировали их в любой другой обычный диск (например, с помощью перетаскивания). Файлы, считываемые или копируемые из зашифрованного тома VeraCrypt, автоматически на лету расшифровываются в ОЗУ (в памяти). Аналогично, файлы, записываемые или копируемые в том VeraCrypt, автоматически зашифровываются на лету в ОЗУ (непосредственно перед их записью на диск).

Обратите внимание, что VeraCrypt никогда не сохраняет на диске данные в незашифрованном виде – незашифрованные данные хранятся лишь временно в ОЗУ (памяти). Даже при смонтированном томе данные в этом томе остаются зашифрованными. При перезагрузке Windows или выключении компьютера том будет размонтирован, а все находящиеся в нём файлы станут недоступными (и зашифрованными). Даже в случае случайного перебоя электропитания (то есть при некорректном завершении работы системы) все хранящиеся в томе файлы будут недоступными (и зашифрованными). Чтобы снова получить к ним доступ, потребуется смонтировать том. Как это сделать, описано в шагах 13-18.

Если вам нужно закрыть том, сделав его содержимое недоступным, можно либо перезагрузить операционную систему, либо размонтировать том. Для этого сделайте следующее:

Выберите нужный том из списка смонтированных томов в главном окне VeraCrypt (на иллюстрации он отмечен красным) и нажмите кнопку Размонтировать (на иллюстрации она также отмечена красным). Чтобы снова получить доступ к хранящимся в томе файлам, потребуется смонтировать том. Как это сделать, описано в шагах 13-18.

Как создать и использовать раздел/устройство, зашифрованное VeraCrypt

Вместо создания файлов-контейнеров вы можете воспользоваться шифрованием физических разделов или дисков (то есть создавать тома VeraCrypt на основе устройств). Чтобы это сделать, повторите шаги 1-3, но на шаге 3 выберите второй или третий параметр и следуйте инструкциям мастера. При создании тома VeraCrypt на основе устройства внутри несистемного раздела/диска, монтирование этого тома выполняется кнопкой Автомонтирование в главном окне VeraCrypt. Информацию о зашифрованных системных разделах/дисках см. в главе Шифрование системы.

ВАЖНО: Настоятельно рекомендуем ознакомиться с другими главами этого руководства – они содержат важную информацию, которая здесь опущена, чтобы проще было объяснить азы.


Документация >> Том VeraCrypt

Том VeraCrypt

Существует два типа томов VeraCrypt:

  • на основе файла (контейнер)
  • на основе раздела/устройства (несистемного)

Примечание. Помимо создания виртуальных томов указанных выше типов, VeraCrypt также может шифровать физический раздел/диск, на котором установлена Windows (подробности см. в главе Шифрование системы).

Том VeraCrypt на основе файла – это обычный файл, который может находиться на любом устройстве хранения данных. Он содержит (является хостом) полностью независимое зашифрованное виртуальное дисковое устройство.

Раздел VeraCrypt – это раздел на жёстком диске, зашифрованный с помощью VeraCrypt. Также можно шифровать целиком жёсткие диски (в том числе подключаемые по USB), флеш-накопители USB ("флешки") и устройства хранения данных других типов.

Следующий раздел >>


Документация >> Том VeraCrypt >> Создание новых томов

Создание нового тома VeraCrypt

Чтобы создать том VeraCrypt на основе файла или чтобы зашифровать раздел/устройство (для этого требуются права администратора), нажмите кнопку Создать том в главном окне программы. Появится окно мастера создания томов VeraCrypt. Сразу за этим мастер начнёт сбор данных для генерирования мастер-ключа, вторичного ключа (режим XTS) и соли для нового тома. В сборе данных, которые должны носить как можно более случайный характер, участвуют перемещения мыши, нажатия клавиш и другая получаемая из системы информация (см. подробности в главе Генератор случайных чисел). При создании тома VeraCrypt мастер предоставляет необходимые подсказки и сведения, однако некоторые настройки требуют пояснения.

Алгоритм хеширования

Здесь можно выбрать хеш-алгоритм, который будет применять VeraCrypt. Выбранный алгоритм используется генератором случайных чисел (как функция псевдослучайного смешивания) для генерирования мастер-ключа, вторичного ключа (режим XTS) и соли (см. раздел Генератор случайных чисел). Также он используется в формировании (деривации) ключа заголовка тома и вторичного ключа заголовка (см. раздел Формирование ключа заголовка, соль и количество итераций).

Сведения о доступных хеш-алгоритмах приведены в главе Алгоритмы хеширования.

Обратите внимание: вывод хеш-функции никогда не используется непосредственно как ключ шифрования. Дополнительные сведения см. в главе Технические подробности.

Алгоритм шифрования

Здесь выбирается алгоритм шифрования, который будет применяться в новом томе. Обратите внимание, что выбранный алгоритм шифрования после создания тома изменить уже нельзя. Дополнительные сведения см. в главе Алгоритмы шифрования.

Быстрое форматирование

Если этот параметр выключен, форматированию подвергается каждый сектор нового тома. Это означает, что новый том будет целиком заполнен случайными данными. Быстрое форматирование занимает гораздо меньше времени, но оно менее надёжно, так как пока весь том не будет заполнен файлами, существует вероятность определить, как много данных он содержит (если свободное пространство не было предварительно заполнено случайными данными). Если вы не уверены, нужно ли включать или выключать быстрое форматирование, рекомендуем оставить этот параметр выключенным. Обратите внимание, что параметр Быстрое форматирование доступен только при шифровании разделов/устройств, за исключением Windows, где он также доступен при создании файловых контейнеров.

ВАЖНО: При шифровании раздела/устройства, внутри которого вы планируете затем создать скрытый том, оставьте этот параметр выключенным.

Динамический («растягивающийся») том

Динамический контейнер VeraCrypt представляет собой предраспределённый разрежённый (sparse) файл NTFS, чей физический размер (реально занимаемое место на диске) увеличивается по мере добавления в контейнер новых данных. Обратите внимание, что физический размер контейнера (реально занимаемое контейнером место на диске) не уменьшается при удалении файлов из тома VeraCrypt. Физический размер контейнера может только увеличиваться до максимального значения, указанного пользователем при создании этого тома. По достижении указанного максимального значения физический размер тома будет оставаться постоянным.

Учтите, что разрежённые файлы можно создавать только в файловой системе NTFS. При создании контейнера в файловой системе FAT, параметр Динамический будет недоступен (“затенён”).

Имейте в виду, что размер динамического (на основе разрежённого файла) тома VeraCrypt, сообщаемый Windows и VeraCrypt, будет всегда равен его максимальному размеру (который был указан при создании этого тома). Чтобы узнать текущий физический размер контейнера (действительно занимаемое им место на диске), щёлкните правой кнопкой по файлу-контейнеру (в Проводнике Windows, не в VeraCrypt), и выберите пункт Свойства – в поле На диске будет указано реальное значение.

ВНИМАНИЕ: Скорость выполнения операций у динамических (на основе разрежённых файлов) томов VeraCrypt значительно ниже, чем у обычных томов. Кроме того, динамические тома VeraCrypt менее безопасны, так как они позволяют определить количество незанятых секторов в томе. Более того, если при записи данных на динамический том окажется, что в файловой системе, где находится файловый контейнер с данным томом, недостаточно свободного места, это может привести к повреждению зашифрованной файловой системы.

Размер кластера

Кластер это единица хранения данных. Например, один распределённый кластер в файловой системе FAT – это однобайтовый файл. Когда файл увеличивается и превосходит границу кластера, распределяется ещё один кластер. В теории это означает, что чем больше размер кластера, тем больше тратится места на диске и тем выше производительность. Если вы не знаете, какой размер выбрать, используйте значение, предложенное по умолчанию.

Тома VeraCrypt на дисках CD и DVD

Если вы хотите сохранить том VeraCrypt на CD или DVD, то сначала создайте на жёстком диске контейнер TrueCrypt на основе файла, а затем запишите («прожгите») его на CD/DVD с помощью любой программы для записи CD/DVD (в среде Windows XP и более новых версий Windows для этого можно воспользоваться средством записи CD, входящим в комплект поставки этой ОС). Имейте в виду, что если вы собираетесь монтировать том VeraCrypt, хранящийся на носителе, допускающем только чтение (например, на CD/DVD) в Windows 2000, том VeraCrypt должен быть отформатирован в FAT. Причина этого в том, что Windows 2000 не может монтировать файловую систему NTFS на носителях только для чтения (в отличие от Windows XP и более новых версий Windows).

Аппаратный/программный RAID, динамические тома Windows

VeraCrypt поддерживает аппаратные/программные массивы RAID, а также динамические тома Windows.

Windows Vista и новее: динамические тома отображаются в диалоговом окне Выбрать устройство как \Device\HarddiskVolumeN.

Windows XP/2000/2003: если вы намереваетесь отформатировать динамический том Windows как том VeraCrypt, помните, что после создания динамического тома Windows (с помощью Windows-средства Управление дисками) нужно перезагрузить операционную систему, чтобы том стал доступен/виден в диалоговом окне выбора устройства в мастере создания томов VeraCrypt. Также учтите, что в окне Выбрать устройство динамический диск Windows отображается не как одно устройство (элемент), а как все тома, из которых состоит динамический том Windows, и вы можете выбрать любой из них, чтобы отформатировать весь динамический том Windows.

Примечания к созданию томов

После нажатия кнопки Разметить в окне мастера создания томов (последний этап), последует небольшая задержка, в течение которой система собирает дополнительные случайные данные. Затем для нового тома генерируются мастер-ключ, ключ заголовка, вторичный ключ (режим XTS) и соль с показом содержимого мастер-ключа и ключа заголовка.

Для большей безопасности можно отключить вывод на экран частей содержимого пула случайных чисел, мастер-ключа и ключа заголовка, сняв отметку в правом верхнем углу соответствующего поля:

Примечание: отображаются только первые 128 бит пула/ключей (а не всё содержимое).

Можно создавать тома FAT (будет это FAT12, FAT16 и FAT32 – определяется автоматически по количеству кластеров) или NTFS (однако нужно иметь в виду, что тома NTFS могут создавать только пользователи с правами администратора). Смонтированные тома VeraCrypt можно в любое время переформатировать в FAT12, FAT16, FAT32 или NTFS. Они ведут себя точно так же, как стандартные дисковые устройства, поэтому можно щёлкнуть правой кнопкой мыши по значку смонтированного тома VeraCrypt (например, в окне Компьютер или Мой компьютер) и выбрать команду Форматировать.

Более подробные сведения о создании томов VeraCrypt см. в разделе Скрытый том.

Следующий раздел >>


Документация >> Том VeraCrypt >> Избранные тома

Избранные тома

Избранные тома удобны во многих случаях. Например, если у вас есть:

  • том, который всегда должен монтироваться на конкретную букву диска;
  • том, который нужно автоматически монтировать при подключении к компьютеру устройства с этим томом (скажем, контейнер, находящийся на USB-флешке или внешнем жёстком диске USB);
  • том, который нужно автоматически монтировать при входе в вашу учётную запись в операционной системе;
  • том, который нужно всегда монтировать только для чтения или как сменный носитель.

Примечание: см. раздел Замеченные проблемы и ограничения о проблемах, которые могут повлиять на избранные тома, если в Windows включена функция "Быстрый запуск".

Чтобы сконфигурировать том VeraCrypt как избранный, сделайте следующее:

  1. Смонтируйте том (на ту букву диска, на которую вы хотите его монтировать всегда).
  2. В главном окне VeraCrypt щёлкните правой кнопкой мыши по смонтированному тому и выберите команду Добавить в избранные.
  3. В появившемся окне упорядочивания избранных томов выберите нужные параметры для этого тома (см. ниже).
  4. Нажмите OK.
Избранные тома можно монтировать несколькими способами: Чтобы смонтировать все избранные тома, выберите Избранное > Смонтировать избранные тома или нажмите горячую клавишу монтирования избранных томов (Настройки > Горячие клавиши). Если нужно смонтировать только один из избранных томов, выберите его из списка в меню Избранное. При этом будет нужно ввести для данного тома пароль (и/или ключевые файлы) (если только он не находится в кэше). Если ввод правильный, том будет смонтирован. Если он уже смонтирован, то будет открыто окно Проводника с ним.

Избранные тома (указанные или все) можно автоматически монтировать при каждом входе в Windows

Чтобы это настроить, сделайте следующее:

  1. Смонтируйте том, который должен автоматически монтироваться при вашем входе в свою учётную запись Windows (на ту букву, на которую нужно, чтобы он монтировался всегда).
  2. В главном окне VeraCrypt щёлкните правой кнопкой мыши на смонтированном томе и выберите команду Добавить в избранные.
  3. В появившемся окне упорядочивания избранных томов включите параметр Монтировать выбранный том при входе в систему и нажмите OK.

Теперь при каждом входе в Windows станет нужно указывать для тома пароль (и/или ключевые файлы), и если данные введены правильно, том будет смонтирован.

Примечание: VeraCrypt не будет спрашивать пароль, если включено кэширование (запоминание) пароля предзагрузочной аутентификации (Настройки > Шифрование системы), а пароль у тома такой же, как у системного раздела/диска.

Избранные тома (указанные или все) можно автоматически монтировать при каждом подключении к ПК устройства, на котором они находятся

Чтобы это настроить, сделайте следующее:

  1. Смонтируйте том (на ту букву, на которую нужно, чтобы он монтировался всегда).
  2. В главном окне VeraCrypt щёлкните правой кнопкой мыши на смонтированном томе и выберите команду Добавить в избранные.
  3. В появившемся окне упорядочивания избранных томов включите параметр Монтировать выбранный том при подключении устройства, на котором он расположен и нажмите OK.

Теперь всякий раз, когда вы будете, например, вставлять в USB-порт компьютера флеш-накопитель USB с томом VeraCrypt, станет выдаваться запрос пароля (и/или ключевых файлов) (если только он не кэширован), и если данные введены правильно, том будет смонтирован.

Примечание: VeraCrypt не будет спрашивать пароль, если включено кэширование (запоминание) пароля предзагрузочной аутентификации (Настройки > Шифрование системы), а пароль у тома такой же, как у системного раздела/диска.

Каждому избранному тому можно присвоить особую метку

Эта метка – не то же самое, что метка тома в файловой системе, она отображается внутри интерфейса VeraCrypt вместо пути тома. Чтобы присвоить тому метку, сделайте следующее:

  1. Выберите Избранное > Упорядочить избранные тома.
  2. В появившемся окне упорядочивания избранных томов выберите том, метку которого вы хотите отредактировать.
  3. Введите метку в поле Метка выбранного избранного тома и нажмите OK.

Для каждого избранного тома можно настроить ряд других параметров

Например, любой том можно монтировать как доступный только для чтения или как сменный носитель. Чтобы это настроить, сделайте следующее:

  1. Выберите Избранное > Упорядочить избранные тома.
  2. В появившемся окне упорядочивания избранных томов выберите том, параметры которого вы хотите настроить.
  3. Выберите нужные вам параметры и нажмите OK.

Системные избранные тома отображаются в окне упорядочивания избранного (Избранное > Упорядочить избранные тома) в порядке их монтирования, когда вы выбираете команду Избранное > Смонтировать избранные тома или нажимаете соответствующую горячую клавишу (Настройки > Горячие клавиши). Чтобы изменить порядок отображения томов, используйте кнопки Выше и Ниже.

Обратите внимание, что избранный том может также быть разделом, входящим в область действия ключа шифрования системы, смонтированным без предзагрузочной аутентификации (например, разделом на зашифрованном системном диске с другой операционной системой, которая сейчас не выполняется). Когда вы монтируете такой том и добавляете его в избранные, больше не нужно выбирать команду Система > Смонтировать без предзагрузочной аутентификации включать параметр монтирования раздела с шифрованием системы без предзагрузочной аутентификации. Вы можете просто смонтировать избранный том (как объяснено выше) без установки каких-либо параметров, поскольку режим монтирования тома сохранён в конфигурационном файле со списком ваших избранных томов.

ВНИМАНИЕ: Если буква диска, присвоенная избранному тому (сохранённая в конфигурационном файле) занята, этот том не будет смонтирован, а сообщение об ошибке не выводится.

Чтобы удалить том из списка избранных, в меню Избранное выберите команду Упорядочить избранные тома, выделите нужный том, нажмите кнопку Убрать и затем нажмите OK.

Следующий раздел >>


Документация >> Том VeraCrypt >> Системные избранные тома

Системные избранные тома

Системные избранные тома удобны, например, в следующих ситуациях:

  • у вас есть тома, которые нужно монтировать до загрузки системы и служб приложений и перед входом пользователей в систему;
  • у вас есть общие сетевые папки, расположенные в томах VeraCrypt; настроив такие тома как системные избранные, вы тем самым гарантируете, что общие сетевые ресурсы будут автоматически восстанавливаться операционной системой при каждой перезагрузке;
  • вам нужно, чтобы такой том монтировался на одну и ту же букву диска при каждой загрузке операционной системы.

Обратите внимание, что в отличие от обычных (несистемных) избранных томов, системные избранные тома используют пароль предзагрузочной аутентификации, поэтому необходимо, чтобы системный раздел/диск был зашифрован (также примите к сведению, что включать кэширование пароля предзагрузочной аутентификации не требуется). Кроме того, поскольку предзагрузочный пароль набирается с использованием американской раскладки клавиатуры (это требование BIOS), при создании системного избранного тома пароль необходимо ввести, используя американскую раскладку клавиатуры, нажимая те же клавиши, что и при вводе пароля предзагрузочной аутентификации. Если пароль системного избранного тома не идентичен паролю предзагрузочной аутентификации при американской раскладке клавиатуры, то он не будет смонтирован.

При создании тома, который вы хотите позже сделать системным избранным, необходимо явно установить раскладку клавиатуры, связанную с VeraCrypt, на раскладку США, и нажимать те же клавиши, что и при вводе пароля предзагрузочной аутентификации.

Системные избранные тома можно настроить так, чтобы они были доступны из VeraCrypt только пользователям с правами администратора (выберите Настройки > Системные избранные тома > Просматривать/размонтировать системные избранные тома могут лишь администраторы). Этот параметр следует включать на серверах, чтобы предотвратить возможность размонтирования системных избранных томов пользователями без административных привилегий. На не серверных системах этот параметр можно использовать для того, чтобы системные избранные тома не влияли на действия с обычными томами (Размонтировать все, авторазмонтирование и т. д.). Кроме того, при запуске VeraCrypt без прав администратора (а это стандартное поведение в Vista и более новых версиях Windows), системные избранные тома не отображаются в списке букв дисков в главном окне VeraCrypt.

Чтобы сконфигурировать том VeraCrypt как системный избранный, сделайте следующее:

  1. Смонтируйте том (на ту букву, на которую нужно, чтобы он монтировался всегда).
  2. В главном окне VeraCrypt щёлкните правой кнопкой мыши на смонтированном томе и выберите команду Добавить в системные избранные.
  3. В появившемся окне упорядочивания системных избранных томов включите параметр Монтировать системные избранные тома при старте Windows и нажмите OK.

Системные избранные тома отображаются в окне упорядочивания избранного (Избранное > Упорядочить системные избранные тома) в порядке их монтирования. Порядок отображения томов изменяется кнопками Выше и Ниже.

Каждому системному избранному тому можно присвоить особую метку. Эта метка – не то же самое, что метка тома в файловой системе, она отображается внутри интерфейса VeraCrypt вместо пути тома. Чтобы присвоить тому метку, сделайте следующее:

  1. Выберите Избранное > Упорядочить системные избранные тома.
  2. В появившемся окне упорядочивания системных избранных томов выберите том, метку которого вы хотите отредактировать.
  3. Введите метку в поле Метка выбранного избранного тома и нажмите OK.

Обратите внимание, что в окне упорядочивания системных избранных томов (Избранное > Упорядочить системные избранные тома) можно настроить ряд других параметров для каждого системного избранного тома. Например, любой том можно монтировать как доступный только для чтения или как сменный носитель.

ВНИМАНИЕ: Если присвоенная системному избранному тому (сохранённая в конфигурационном файле) буква диска занята, данный том не будет смонтирован, при этом сообщение об ошибке не выводится.

Обратите внимание, что Windows требуется использовать ряд файлов (например, файлы подкачки, файлы Active Directory и др.) до того, как будут смонтированы системные избранные тома. Поэтому такие файлы нельзя хранить на системных избранных томах. Тем не менее их можно хранить на любом разделе, который входит в область шифрования системы (например, на системном разделе или на любом разделе системного диска, целиком зашифрованного с помощью VeraCrypt).

Чтобы удалить том из списка системных избранных, выберите Избранное > Упорядочить системные избранные тома, выделите нужный том, нажмите кнопку Убрать и затем нажмите OK.


Документация >> Шифрование системы

Шифрование системы

VeraCrypt позволяет "на лету" шифровать системный раздел или весь системный диск, то есть раздел или диск, где установлена Windows и с которого она загружается.
Шифрование системы обеспечивает наивысший уровень надёжности и безопасности, так как все файлы, включая любые временные файлы, создаваемые Windows и приложениями в системном разделе (как правило, без вашего ведома и согласия), файлы гибернации, файлы подкачки и т. д., всегда остаются зашифрованными (даже при внезапном пропадании питания). Кроме того, Windows записывает множество данных, которые потенциально могут нести конфиденциальную нагрузку, например имена и пути открываемых вами файлов, запускаемые вами программы и др. Все такие файлы-журналы и записи в реестре также всегда остаются зашифрованными.
Примечание касательно SSD-накопителей и операции TRIM: При шифровании системы на твердотельных накопителях (SSD) важно учитывать последствия операции TRIM, которая потенциально может раскрыть информацию о том, какие сектора на диске не используются. Инструкции о том, как операция TRIM работает с VeraCrypt и как управлять её настройками для повышения безопасности, см. в документации в главе Операция TRIM.
Шифрование системы включает в себя предзагрузочную аутентификацию, означающую, что любому пользователю для получения доступа, возможности работы в зашифрованной системе, чтения и записи файлов на системном диске и т. д. будет нужно вводить правильный пароль перед каждой загрузкой (стартом) Windows. Предзагрузочную аутентификацию обеспечивает загрузчик VeraCrypt (Boot Loader), расположенный в первой дорожке загрузочного диска и на Диске восстановления VeraCrypt (Rescue Disk, см. далее).
Обратите внимание, что VeraCrypt выполняет шифрование имеющегося незашифрованного системного раздела/диска "на месте", то есть прямо при работе операционной системы (во время шифрования системы можно продолжать пользоваться компьютером как обычно, без каких-либо ограничений). Аналогично, зашифрованный с помощью VeraCrypt системный раздел/диск можно расшифровать "на месте", во время работы операционной системы. Процесс шифрования/дешифрования можно прервать в любой момент, оставить раздел/диск частично незашифрованным, перезагрузить или выключить компьютер, а затем возобновить операцию с той точки, в которой она была остановлена.
При шифровании системы применяется режим XTS (см. раздел Режимы работы). Технические детали шифрования системы см. в разделе Схема шифрования главы Технические подробности.
Чтобы зашифровать системный раздел или весь системный диск, выберите Система > Зашифровать системный раздел/диск и следуйте инструкциям мастера. Чтобы расшифровать системный раздел/диск, выберите Система > Окончательно расшифровать системный раздел/диск.
Из-за требований BIOS предзагрузочный пароль вводится с использованием американской раскладки клавиатуры. Во время шифрования системы VeraCrypt автоматически и прозрачно переключает клавиатуру на американскую раскладку, чтобы гарантировать, что введённый пароль будет соответствовать паролю, введённому в предзагрузочном режиме. Однако эту защитную меру может обойти вставка пароля из буфера обмена. Чтобы предотвратить любые проблемы, возникающие из-за этого, VeraCrypt отключает возможность вставки паролей из буфера обмена в мастере системного шифрования. Таким образом, чтобы избежать ошибок из-за неверного пароля, необходимо вводить пароль, используя те же клавиши, что и при шифровании системы, обеспечивая постоянный доступ к зашифрованной системе.

Примечание. Windows 7 и более новые версии Windows по умолчанию загружаются с особого маленького раздела. Этот раздел содержит файлы, необходимые для загрузки системы. Право записи в этот раздел Windows даёт только приложениям с административными привилегиями (при работе системы). В режиме загрузки EFI, который используется по умолчанию на современных ПК, VeraCrypt не может зашифровать этот раздел, поскольку он должен оставаться незашифрованным, чтобы BIOS мог загрузить из него загрузчик EFI. Это, в свою очередь, означает, что в режиме загрузки EFI программа предлагает зашифровать только системный раздел, на котором установлена ​​Windows (позже пользователь может вручную зашифровать другие разделы с данными с помощью VeraCrypt). В устаревшем режиме загрузки MBR программа выполняет шифрование этого раздела, только если вы выбрали шифрование всего системного диска (а не шифрование только раздела, в котором установлена Windows).

Следующий раздел >>


Документация >> Шифрование системы >> Скрытая операционная система

Скрытая операционная система

Возможны ситуации, когда кто-то вынудит вас расшифровать операционную систему. Зачастую вы просто не сможете этому воспротивиться (например, при вымогательстве). На этот случай VeraCrypt позволяет создать скрытую операционную систему, наличие которой должно быть невозможно доказать (при условии соблюдения некоторых правил). Таким образом, вам не потребуется расшифровывать скрытую операционную систему или сообщать от неё пароль. См. подробности в разделе Скрытая операционная система, глава Правдоподобное отрицание наличия шифрования.

Следующий раздел >>


Документация >> Шифрование системы >> Операционные системы, поддерживающие системное шифрование

Операционные системы, поддерживающие системное шифрование

В настоящий момент VeraCrypt поддерживает шифрование следующих операционных систем:
  • Windows 11
  • Windows 10
Примечание. Следующие операционные системы (помимо прочих) не поддерживаются: Windows RT, Windows 2003 IA-64, Windows 2008 IA-64, Windows XP IA-64 и встроенные/планшетные версии Windows.
См. также раздел Поддерживаемые операционные системы
Следующий раздел >>


Документация >> Шифрование системы >> Диск восстановления VeraCrypt

Диск восстановления VeraCrypt (Rescue Disk)

При подготовке к шифрованию системного раздела/диска VeraCrypt требует, чтобы вы создали так называемый диск восстановления VeraCrypt (USB-диск в режиме загрузки EFI, CD/DVD в устаревшем режиме загрузки MBR). Он нужен в следующих случаях:
  • Если экран загрузчика VeraCrypt не появляется при старте компьютера (или если не загружается Windows), возможно, повреждён загрузчик VeraCrypt. С помощью Диска восстановления VeraCrypt загрузчик можно восстановить и, таким образом, вернуть доступ к зашифрованной системе и данным (при этом, однако, всё равно будет нужно ввести правильный пароль). В режиме загрузки EFI на экране Диска восстановления выберите Restore VeraCrypt loader binaries to system disk. В устаревшем режиме MBR вместо этого выберите Repair Options > Restore VeraCrypt Boot Loader. Затем нажмите "Y", чтобы подтвердить действие, извлеките Диск восстановления из разъёма USB или из CD/DVD-накопителя и перезагрузите компьютер.
  • Если загрузчик VeraCrypt часто повреждается (например, из-за некорректно написанного ПО активации) или если нужно, чтобы на жёстком диске не было загрузчика VeraCrypt (например, если вы хотите использовать альтернативный загрузчик/менеджер загрузки для других операционных систем), то можно загружаться непосредственно с Диска восстановления VeraCrypt (поскольку он тоже содержит загрузчик VeraCrypt) без восстановления загрузчика на жёстком диске. В режиме загрузки EFI просто вставьте Диск восстановления в разъём USB, загрузите с него компьютер и затем на экране Диска восстановления выберите Boot VeraCrypt loader from rescue disk. В устаревшем режиме загрузки MBR вам потребуется вставить Диск восстановления в CD/DVD-накопитель и ввести пароль на экране Диска восстановления.
  • Если вы вводите правильный пароль, но VeraCrypt говорит, что пароль неверный, возможно, повреждены мастер-ключ или другие важные данные. Диск восстановления VeraCrypt позволяет их восстановить и, таким образом, вернуть доступ к зашифрованной системе и данным (разумеется, при этом будет нужно ввести правильный пароль). В режиме загрузки EFI на экране Диска восстановления выберите Restore OS header keys. В устаревшем режиме MBR вместо этого выберите Repair Options > Restore VeraCrypt Boot Loader. Затем введите пароль, нажмите "Y", чтобы подтвердить действие, извлеките Диск восстановления из разъёма USB или из CD/DVD-накопителя и перезагрузите компьютер.

    Примечание. Эту функцию нельзя использовать для восстановления заголовка скрытого тома, находящегося внутри скрытой операционной системы (см. раздел Скрытая операционная система). Чтобы восстановить заголовок такого тома, нажмите кнопку Выбрать устройство, выберите раздел, следующий за разделом с обманной системой, нажмите OK, выберите Сервис > Восстановить заголовок тома и следуйте инструкциям.

    ВНИМАНИЕ: При восстановлении ключевых данных с помощью Диска восстановления VeraCrypt также происходит восстановление пароля, который был действителен на момент создания Диска восстановления. Поэтому при каждой смене пароля необходимо уничтожать ранее созданный Диск восстановления VeraCrypt и создавать новый (для этого выберите Система > Создать Диск восстановления). В противном случае, если неприятель знает ваш старый пароль (например, он получил его с помощью одной из программ-перехватчиков клавиатуры) и найдёт ваш старый Диск восстановления VeraCrypt, он сможет воспользоваться им для восстановления ключевых данных (мастер-ключа, зашифрованного старым паролем) и, следовательно, расшифровать ваш системный раздел/диск.
  • Если Windows повреждена и не может загрузиться после ввода правильного пароля в строке ввода пароля VeraCrypt, то с помощью Диска восстановления VeraCrypt можно окончательно расшифровать раздел/диск до начала загрузки Windows. В режиме загрузки EFI на экране Диска восстановления выберите Decrypt OS. В устаревшем режиме MBR вместо этого выберите Repair Options > Permanently decrypt system partition/drive. Введите правильный пароль и дождитесь завершения операции дешифрования. После этого вы сможете, например, загрузиться с установочного диска Windows, чтобы исправить установку системы. Обратите внимание, что эта функция неприменима для дешифрования скрытого тома внутри скрытой операционной системы (см. раздел Скрытая операционная система).

    Примечание. Если повреждена (не загружается) Windows, её также можно восстановить (или получить доступ к хранящимся в ней файлам), не прибегая к дешифрованию системного раздела/диска. Для этого нужно сделать следующее. Если у вас в компьютере несколько операционных систем, загрузите ту, которая не требует предзагрузочной аутентификации. Если в компьютере всего одна операционная система, можно загрузиться с CD/DVD с WinPE или BartPE, либо с Linux Live CD/DVD/USB. Также можно подключить системный диск как вторичный или внешний диск к другому компьютеру и загрузить операционную систему, установленную на том компьютере. После загрузки системы запустите VeraCrypt, нажмите кнопку Выбрать устройство, выберите нужный системный раздел, нажмите OK, выберите Система > Смонтировать без предзагрузочной аутентификации, введите пароль предзагрузочной аутентификации и нажмите OK. Этот раздел будет смонтирован как обычный том VeraCrypt (то есть данные будут расшифровываться/шифроваться на лету в ОЗУ, как и всегда).
  • В случае устаревшего режима загрузки MBR на Диске восстановления содержится резервная копия исходного содержимого первой дорожки диска (сделанная до того, как туда был прописан загрузчик VeraCrypt), что позволяет при необходимости её восстановить. Первая дорожка обычно содержит системный загрузчик или менеджер загрузок ОС. На экране Диска восстановления выберите Repair Options > Restore original system loader.
Обратите внимание, что даже если вы потеряете свой Диск восстановления VeraCrypt, и его найдёт неприятель, он всё равно не сможет расшифровать системный раздел или диск, не зная правильный пароль.
Чтобы загрузиться с Диска восстановления VeraCrypt, вставьте его в разъём USB или в CD/DVD-накопитель (в зависимости от его типа) и перезагрузите компьютер. Если экран Диска восстановления VeraCrypt не появляется (или, в случае устаревшего режима загрузки MBR, вы не видите элемента Repair Options в группе Keyboard Controls на экране), вероятно, BIOS вашего компьютера настроен так, что сначала выполняется загрузка с жёсткого диска, и лишь потом с USB и CD/DVD. В этом случае перезагрузите компьютер, нажмите клавишу F2 или Delete (сразу же, как появится начальный экран BIOS) и дождитесь появления экрана настройки BIOS. Если экран настройки BIOS не появился, снова перезагрузите компьютер (нажмите кнопку сброса (Reset) на корпусе ПК и сразу же начните постоянно нажимать клавишу F2 или Delete. Когда появится экран настройки BIOS, сконфигурируйте BIOS так, чтобы загрузка системы сначала происходила с USB и с CD/DVD (о том, как это сделать, см. в документации на вашу системную плату/BIOS или проконсультируйтесь в службе техподдержки поставщика ПК). Затем снова перезагрузите компьютер. Экран Диска восстановления VeraCrypt теперь должен появиться.
Примечание. В устаревшем режиме загрузки MBR можно выбрать Repair Options на экране Диска восстановления VeraCrypt, нажав F8 на клавиатуре.

Если Диск восстановления VeraCrypt повредится, вы можете создать новый, выбрав Система > Создать Диск восстановления. Чтобы выяснить, не повреждён ли Диск восстановления VeraCrypt, вставьте его в разъём USB (или в CD/DVD-накопитель, если используется устаревший режим загрузки MBR) и выберите Система > Проверить Диск восстановления.

Диск восстановления VeraCrypt для устаревшего режима загрузки MBR на USB-флешке

Если у вас в компьютере нет CD/DVD-накопителя, то Диск восстановления VeraCrypt для устаревшего режима загрузки MBR можно создать на USB-флешке. Обратите внимание, что вы должны следить за тем, чтобы данные на USB-накопителе не были перезаписаны! Если вы потеряете USB-накопитель или ваши данные будут повреждены, вы не сможете восстановить свою систему в случае возникновения какой-либо проблемы!
Чтобы создать загрузочный USB-диск восстановления VeraCrypt, нужно создать загрузочный USB-накопитель, загрузчик которого запускает ISO-образ. Такие решения, как UNetbootin, которые пытаются скопировать данные внутри ISO-образа на USB-накопитель, пока не работают. В Windows выполните следующие действия:
  • Загрузите необходимые файлы из официального репозитория VeraCrypt на SourceForge: https://sourceforge.net/projects/veracrypt/files/Contributions/VeraCryptUsbRescueDisk.zip
  • Вставьте USB-накопитель.
  • Отформатируйте USB-накопитель в FAT16 или FAT32:
    • Запустите файл usb_format.exe от имени администратора (щёлкните правой кнопкой мыши и выберите Запуск от имени администратора).
    • Выберите USB-накопитель в списке устройств.
    • Выберите файловую систему FAT и установите флажок Quick Format (Быстрое форматирование). Нажмите Start (Пуск).
  • Создайте загрузчик, который может запускать образ ISO:
    • Запустите файл grubinst_gui.exe.
    • Отметьте Disk и затем выберите в списке свой USB-накопитель.
    • Нажмите кнопку Refresh (Обновить) перед Part List и затем выберите Whole disk (MBR) (Весь диск).
    • Оставьте все остальные параметры без изменений, а затем нажмите Install (Установить).
    • Должно появиться окно консоли с надписью "The MBR/BS has been successfully installed. Press <ENTER> to continue ..." ("MBR/BS успешно установлена. Нажмите ENTER для продолжения...").
    • Закройте утилиту.
  • Скопируйте файл "grldr" в корневую папку USB-накопителя (например, если буква диска – I:, то должно быть I:\grldr). Этот файл загружает Grub4Dos.
  • Скопируйте файл "menu.lst" в корневую папку USB-накопителя (например, если буква диска – I:, то должно быть I:\menu.lst). Этот файл настраивает отображаемое меню и его параметры.
  • Скопируйте файл Диска восстановления "VeraCrypt Rescue Disk.iso" в корневую папку USB-накопителя и переименуйте его в "veracrypt.iso". Другой вариант – изменить ссылку в файле "menu.lst".


Документация >> Правдоподобное отрицание наличия шифрования

Правдоподобное отрицание наличия шифрования

На случай, если злоумышленник вынудит вас сообщить пароль, в VeraCrypt предусмотрено два вида правдоподобного отрицания наличия шифрования:
  1. Скрытые тома (см. раздел Скрытый том) и скрытые операционные системы (см. раздел Скрытая операционная система).
  2. Пока не будет выполнено дешифрование, раздел/устройство VeraCrypt выглядит как содержащее случайные данные (в нём нет никаких "сигнатур"). Поэтому должно быть невозможно доказать, что раздел или устройство являются томом VeraCrypt или что они зашифрованы (при условии соблюдения требований, перечисленных в главе Требования безопасности и меры предосторожности). Правдоподобное объяснение, что раздел/устройство содержит только случайные данные, может быть таким: вы уничтожили (стёрли с затиранием данных) содержимое раздела/устройства с помощью одной из программ для удаления информации с перезаписью случайными данными (на самом деле, VeraCrypt также можно использовать для безопасного стирания раздела/устройства, создав внутри него пустой зашифрованный раздел/том на основе устройства). При этом, однако, требуется предотвращать утечки данных (см. раздел Утечки данных), а также иметь в виду, что при шифровании системы первая дорожка диска содержит (незашифрованный) загрузчик VeraCrypt, который можно легко идентифицировать (см. подробности в главе Шифрование системы). В случае шифрования системы, правдоподобное отрицание наличия шифрования достигается созданием скрытой операционной системы (см. раздел Скрытая операционная система).

    Хотя тома VeraCrypt на основе файлов (контейнеров) тоже не содержат никаких опознавательных "сигнатур" (до тех пор, пока не выполнено дешифрование, тома выглядят лишь как набор случайных данных), они не обеспечивают никакого правдоподобного отрицания наличия шифрования, так как практически невозможно правдоподобно объяснить наличие файла, содержащего только случайные данные. Тем не менее, правдоподобного отрицания наличия шифрования можно добиться и при использовании тома VeraCrypt на основе файла (контейнера): для этого нужно создать внутри обычного тома скрытый том (см. выше).

Примечания

  • При форматировании раздела жёсткого диска как тома VeraCrypt (или шифрования раздела на месте), таблица разделов (включая тип раздела) никогда не изменяется (в таблицу разделов не вносится никаких "сигнатур" или "идентификаторов" VeraCrypt).
  • Существуют методы обнаружения файлов и устройств, содержащих случайные данные (таких, как тома VeraCrypt). Тем не менее это никаким образом не должно влиять на правдоподобное отрицание наличия шифрования. Злоумышленник по-прежнему не должен быть в состоянии доказать, что раздел/устройство является томом VeraCrypt или что файл, раздел или устройство содержат скрытый том VeraCrypt (если вы соблюли все условия, описанные в главе Требования безопасности и меры предосторожности и в подразделе Требования безопасности и меры предосторожности, касающиеся скрытых томов).

Следующий раздел >>


Документация >> Правдоподобное отрицание наличия шифрования >> Скрытый том

Скрытый том

Возможны ситуации, когда кто-то заставит вас сообщить пароль от зашифрованного тома. В ряде случаев вы просто не сможете отказаться это сделать (например, при вымогательстве). Благополучно выходить из таких ситуаций, не сообщая пароль от тома с вашими данными, позволяет так называемый скрытый том.
Макет стандартного тома VeraCrypt до и после создания в нём скрытого тома.
Схема обычного тома VeraCrypt до и после создания внутри него скрытого тома.

Принцип такой: том VeraCrypt создается внутри другого тома VeraCrypt (в свободном месте тома). Даже если смонтирован внешний том, невозможно гарантированно утверждать, есть ли внутри него скрытый том или его нет*, так как свободное место в любом томе VeraCrypt всегда заполняется случайными данными при его создании**, и никакую часть (несмонтированного) скрытого тома нельзя отличить от случайных данных. Обратите внимание, что VeraCrypt никак не модифицирует файловую систему (информацию о свободном месте и т. д.) внутри внешнего тома.

Пароль для скрытого тома должен существенно отличаться от пароля для внешнего тома. Перед созданием скрытого тома следует скопировать во внешний том некоторое количество осмысленно выглядящих файлов, которые на самом деле вам скрывать НЕ требуется. Эти файлы нужны, чтобы ввести в заблуждение того, кто вынудит вас сообщить пароль. Вы сообщите только пароль от внешнего тома, но не от скрытого. Файлы, действительно представляющие для вас ценность, останутся в неприкосновенности в скрытом томе.
Скрытый том монтируется так же, как обычный том VeraCrypt: нажмите кнопку Выбрать файл или Выбрать устройство, выберите внешний (хост) том (важно: убедитесь, что этот том не смонтирован). Затем нажмите кнопку Смонтировать и введите пароль для скрытого тома. Какой том будет смонтирован – скрытый или внешний – определяется только введённым паролем (то есть если введён пароль для внешнего тома, то будет смонтирован внешний том, а если указать пароль для скрытого, то смонтируется скрытый том).
Используя введённый пароль, VeraCrypt сначала пытается расшифровать заголовок обычного тома. Если это не удаётся, выполняется загрузка области, где может находиться заголовок скрытого тома (то есть байты 65 536–131 071, содержащие исключительно случайные данные, если внутри тома нет скрытого тома), в ОЗУ и попытка расшифровать её с помощью указанного пароля. Обратите внимание, что заголовки скрытых томов нельзя идентифицировать, так как они выглядят как абсолютно случайные данные. Если заголовок успешно расшифрован (информацию о том, как VeraCrypt определяет, успешно ли он расшифрован, см. в разделе Схема шифрования), то из расшифрованного заголовка (который по-прежнему находится в ОЗУ) извлекаются сведения о размере скрытого тома и выполняется монтирование скрытого тома (по его размеру также определяется его смещение).
Скрытый том можно создавать внутри тома VeraCrypt любого типа, то есть внутри тома на основе файла или тома на основе устройства (для этого требуются права администратора). Чтобы создать скрытый том VeraCrypt, в главном окне программы нажмите кнопку Создать том и выберите Создать скрытый том VeraCrypt. В окне мастера будет вся информация, необходимая для успешного создания скрытого тома VeraCrypt.
При создании скрытого тома для неопытного пользователя может быть весьма затруднительно или даже вообще невозможно установить размер скрытого тома так, чтобы тот не перекрывал данные во внешнем томе. Поэтому мастер создания томов автоматически сканирует карту кластеров внешнего тома (перед созданием внутри него скрытого тома) и определяет максимально возможный размер скрытого тома.***
В случае возникновения каких-либо проблем при создании скрытого тома, см. возможные решения в главе Устранение затруднений.

Обратите внимание, что также можно создавать и загружать операционную систему, располагающуюся в скрытом томе (см. раздел Скрытая операционная система, глава Правдоподобное отрицание наличия шифрования).

* При условии, что были соблюдены все инструкции мастера создания томов VeraCrypt, а также требования и меры предосторожности, указанные в подразделе Требования безопасности и меры предосторожности, касающиеся скрытых томов .
** При условии, что отключены опции Быстрое форматирование и Динамический, а также что том не содержит файловую систему, которая была зашифрована на месте (VeraCrypt не позволяет пользователю создавать скрытый том внутри такого тома). Информацию о методе заполнения свободного пространства тома случайными данными см. в главе Технические подробности, раздел Спецификация формата томов VeraCrypt .
*** Мастер сканирует карту кластеров, чтобы определить размер непрерывной свободной области (если она есть), конец которого совпадает с концом внешнего тома. Эта область вмещает скрытый том, поэтому её размером ограничивается максимально возможный размер скрытого тома. В Linux и Mac OS X мастер фактически не сканирует карту кластеров, но драйвер обнаруживает любые данные, записанные на внешний том, и использует их местоположение, как описано ранее.

Следующий раздел >>


Документация >> Правдоподобное отрицание наличия шифрования >> Скрытый том >> Защита скрытых томов

Защита скрытых томов от повреждений

Если вы монтируете том VeraCrypt, внутри которого находится скрытый том, то можете считывать данные из (внешнего) тома без всякого риска. Однако если вам (или операционной системе) потребуется записать данные во внешний том, есть риск повредить (перезаписать) скрытый том. Чтобы избежать этого, скрытый том следует защитить, о чём и пойдёт здесь речь.
При монтировании внешнего тома введите его пароль, но прежде чем нажать OK, нажмите кнопку Параметры:
Графический интерфейс VeraCrypt
В появившемся окне Параметры монтирования включите опцию Защитить скрытый том от повреждения при записи во внешний том. В поле Пароль скрытого тома введите пароль для скрытого тома. Нажмите OK, а затем нажмите OK в окне ввода основного пароля.
Монтирование с защитой скрытого тома

Оба пароля должны быть правильными; в противном случае внешний том не будет смонтирован. Когда включена защита скрытого тома, VeraCrypt на самом деле не монтирует скрытый том. Он только расшифровывает его заголовок (в ОЗУ) и получает информацию о размере скрытого тома (из расшифрованного заголовка). Затем монтируется внешний том, а любые попытки записи данных в область скрытого тома отклоняются (пока внешний том не будет размонтирован). Обратите внимание, что VeraCrypt никогда и никак не модифицирует файловую систему (например, сведения о распределённых кластерах, объём свободного пространства и т. д.) внутри внешнего тома. Как только том будет размонтирован, защита отключается. При повторном монтировании тома определить, что применялась защита скрытого тома, невозможно. Защиту скрытого тома может включать только пользователь, который укажет правильный пароль (и/или ключевые файлы) для скрытого тома (при каждом монтировании внешнего тома).

Как только операция записи в область скрытого тома отклонена/предотвращена (для защиты скрытого тома), весь хост-том (как внешний, так и скрытый том) становится защищённым от записи до тех пор, пока не будет размонтирован (при каждой попытке записи в этот том драйвер VeraCrypt передаёт системе ошибку "неверный параметр"). Таким образом, сохраняется возможность правдоподобного отрицания наличия шифрования (иначе некоторые несоответствия внутри файловой системы могли бы свидетельствовать, что для этого тома применялась защита скрытого тома). Когда предотвращается повреждение скрытого тома, об этом выдаётся предупреждающее сообщение (при условии, что включена работа VeraCrypt в фоновом режиме, см. главу Работа VeraCrypt в фоновом режиме). Кроме того, отображаемый в главном окне тип смонтированного внешнего тома изменяется на "Внешний(!)":
Графический интерфейс VeraCrypt

Также, в окне Свойства тома в поле Скрытый том защищён выводится:
"Да (защита от повреждений!)".

Обратите внимание, что если было предотвращено повреждение скрытого тома, никакая информация об этом событии в том не записывается. После размонтирования и повторного монтирования внешнего тома в свойствах тома не будет строки "защита от повреждений".

Проверить, защищён ли скрытый том от повреждений, можно несколькими способами:
  1. После монтирования внешнего тома появляется окно с подтверждающим сообщением о том, что скрытый том защищён (если этого сообщения не появилось, скрытый том не защищён!).
  2. В окне Свойства тома, в поле Скрытый том защищён выводится значение Да.
  3. Тип смонтированного внешнего тома – Внешний.

Графический интерфейс VeraCrypt

ВАЖНО: Когда неприятель вынуждает вас смонтировать внешний том, вы, разумеется, НЕ должны монтировать внешний том с включённой защитой скрытого тома. Вы должны монтировать его как обычный том (после чего VeraCrypt будет показывать тип тома не "Внешний", а "Обычный"). Обратите внимание, что пока внешний том остаётся смонтированным с включённой защитой скрытого тома, неприятель может обнаружить наличие скрытого тома во внешнем томе (его можно будет найти до того момента, пока том не размонтирован, и даже некоторое время после выключения компьютера – см. Незашифрованные данные в ОЗУ).

ВНИМАНИЕ: Опция Защитить скрытый том от повреждения при записи во внешний том в окне Параметры монтирования автоматически сбрасывается в выключенное состояние после завершённой попытки монтирования, неважно, успешной или нет (все уже защищённые скрытые тома, разумеется, остаются защищёнными). Поэтому эту опцию нужно включать при каждом монтировании внешнего тома (если хотите, чтобы скрытый том был защищён от повреждений):

Графический интерфейс VeraCrypt

Если вы хотите смонтировать внешний том и защитить находящийся внутри него скрытый том, используя кэшированные пароли, выполните следующие шаги. Удерживая нажатой клавишу Control (Ctrl), нажмите кнопку Смонтировать (или выберите в меню Тома команду Смонтировать том с параметрами). Откроется диалоговое окно Параметры монтирования. Включите в нём опцию Защитить скрытый том от повреждения при записи во внешний том и оставьте поле ввода пароля пустым. Затем нажмите OK.

Если вам нужно смонтировать внешний том, и вы знаете, что в нём не потребуется сохранять никаких данных, тогда наиболее удобным способом защиты скрытого тома от повреждений будет монтирование внешнего тома как доступного только для чтения (см. Параметры монтирования).

Следующий раздел >>


Документация >> Правдоподобное отрицание наличия шифрования >> Скрытый том >> Требования безопасности для скрытых томов

Требования безопасности и меры предосторожности, касающиеся скрытых томов

Если вы используете скрытый том VeraCrypt, то обязаны соблюдать описанные здесь требования безопасности и меры предосторожности.
Отказ от ответственности: мы не гарантируем, что эта глава содержит список всех проблем, связанных с безопасностью, и атак, которые может предпринять ваш неприятель, чтобы получить доступ к данным, хранящимся в скрытом томе TrueCrypt, или ограничить возможность VeraCrypt надёжно хранить такие данные и обеспечивать правдоподобное отрицание наличия шифрования.
  • Если неприятель имеет доступ к (размонтированному) тому VeraCrypt в нескольких точках в течение достаточно длительного времени, он может определить, какие сектора тома изменяются. Если вы изменяете содержимое скрытого тома (например, создаёте/копируете новые файлы в скрытый том или изменяете, удаляете, переименовываете, перемещаете файлы в скрытом томе и т. п.), содержимое секторов (зашифрованный текст) в области, занимаемой скрытым томом, изменяется. Узнав пароль от внешнего тома, неприятель может потребовать объяснений, почему изменились эти сектора. Если вы не дадите правдоподобного объяснения, это может послужить поводом заподозрить наличие скрытого тома внутри внешнего тома.

    Имейте в виду, что случаи, подобные вышеописанному, также могут возникать в следующих ситуациях:
    • Файловая система, в которой у вас хранится контейнер VeraCrypt на основе файла, была дефрагментирована, и копия контейнера VeraCrypt (или его фрагмента) остаётся в свободном пространстве хост-тома (в дефрагментированной файловой системе). Чтобы это предотвратить, сделайте одно из следующего:
      • вместо тома VeraCrypt на основе файла используйте том на основе раздела/устройства;
      • надёжно очищайте (затирайте) свободное пространство в хост-томе (в дефрагментированной файловой системе) после дефрагментации. В Windows это можно делать с помощью бесплатной утилиты Microsoft SDelete. В Linux для той же цели подойдёт утилита shred из пакета GNU coreutils;
      • не дефрагментируйте файловые системы, в которых у вас хранятся тома VeraCrypt.
    • Том VeraCrypt на основе файла-контейнера хранится в журналируемой файловой системе (например, в NTFS). При этом копия контейнера VeraCrypt (или его фрагмента) может оставаться в хост-томе. Чтобы это предотвратить, сделайте одно из следующего:
      • вместо тома VeraCrypt на основе файла используйте том на основе раздела/устройства;
      • храните контейнер в нежурналируемой файловой системе (например, в FAT32).
    • Том VeraCrypt находится на устройстве или в файловой системе, где применяется механизм wear-leveling – равномерное распределение износа блоков (например, флеш-накопитель SSD или USB-флешка). В таком устройстве может оставаться копия (или её фрагмент) тома VeraCrypt. Поэтому не храните скрытые тома в таких устройствах/файловых системах. Подробнее о распределении износа см. в разделе Wear-Leveling, глава Требования безопасности и меры предосторожности.
    • Том VeraCrypt находится на устройстве или в файловой системе, где сохраняются данные (или на устройстве/в файловой системе под управлением или мониторингом системы/устройства, сохраняющих данные) (например, значение таймера или счётчика), которые можно использовать для того, чтобы определить, что один блок был записан раньше, чем другой, и/или чтобы определить, сколько раз блок был записан/прочитан. Поэтому не храните скрытые тома в таких устройствах/файловых системах. Выяснить, сохраняет ли устройство/система такие данные, можно в прилагаемой к устройству/системе документации или связавшись с поставщиком/производителем.
    • Том VeraCrypt находится на устройстве, склонном к износу (где есть возможность определить, что один блок был записан/считан больше раз, чем другой). Поэтому не храните скрытые тома в таких устройствах/файловых системах. Выяснить, предрасположено ли устройство к износу, можно в документации на это устройство или у его поставщика/производителя.
    • Вы делаете резервную копию содержимого скрытого тома, клонируя несущий его хост-том, или создаёте новый скрытый том, клонируя его хост-том. Поэтому так поступать нельзя. Следуйте инструкциям в главе О безопасном резервном копировании и в разделе Клонирование томов.
  • При шифровании раздела/устройства, внутри которого вы намереваетесь создать скрытый том, убедитесь, что выключено быстрое форматирование.
  • В среде Windows убедитесь, что вы не удаляли никаких файлов в томе, внутри которого собираетесь создать скрытый том (при сканировании карты кластеров удалённые файлы не определяются).
  • В среде Linux или Mac OS X (macOS), если вы собираетесь создать скрытый том внутри тома VeraCrypt на основе файла, убедитесь, что этот том – не на основе разрежённого (sparse) файла (Windows-версия VeraCrypt это проверяет самостоятельно, не позволяя создавать скрытые тома внутри разрежённых файлов).
  • Когда скрытый том смонтирован, операционная система и сторонние приложения могут выполнять запись в нескрытые тома (обычно в незашифрованный системный том) незашифрованной информации о данных, хранящихся в скрытом томе (например, имена и расположение файлов, к которым недавно было обращение, базы данных, созданные утилитами индексирования файлов, и др.), самих данных в незашифрованном виде (временные файлы и т. п.), незашифрованной информации о файловой системе в скрытом томе (что может быть использовано, например, для идентификации файловой системы и определения, является ли файловая система той, что во внешнем томе), пароля/ключа для скрытого тома или других конфиденциальных данных. Поэтому необходимо соблюдать следующие требования и предостережения:
    • Windows: Создайте скрытую операционную систему (о том, как это сделать, см. раздел Скрытая операционная система) и монтируйте скрытые тома только тогда, когда запущена скрытая операционная система. Примечание. Когда работает скрытая операционная система, VeraCrypt гарантирует, что все локальные незашифрованные файловые системы и нескрытые тома VeraCrypt доступны только для чтения (то есть никакие файлы не могут быть записаны в такие файловые системы или тома VeraCrypt).* Запись данных в файловые системы разрешена внутри скрытых томов VeraCrypt. В качестве альтернативного варианта, если применение скрытой операционной системы невозможно, используйте "live-CD" с системой Windows PE (целиком хранящейся на CD/DVD и оттуда же загружающейся), гарантирующей, что все данные, записываемые в системный том, записываются в RAM-диск (диск в ОЗУ). Монтируйте скрытые тома только тогда, когда работает система с такого "live-CD" (если нельзя использовать скрытую операционную систему). Кроме того, в течение такого "live-CD"-сеанса в режиме чтения-записи можно монтировать только файловые системы, расположенные в скрытых томах VeraCrypt (внешние или незашифрованные тома/файловые системы необходимо монтировать в режиме только для чтения, либо они не должны монтироваться/быть доступными вовсе). В противном случае вы должны удостовериться, что во время "live-CD"-сеанса приложения и операционная система не выполняют запись никаких конфиденциальных данных (см. выше) в нескрытые тома/файловые системы.
    • Linux: Загрузите или создайте версию "live-CD" вашей операционной системы (то есть live-систему Linux, целиком хранящуюся на CD/DVD и оттуда же загружающуюся), это гарантирует, что любые записанные в системный том данные записаны в RAM-диск (диск в ОЗУ). Монтируйте скрытые тома только тогда, когда запущена такая "live-CD"-система. В течение сеанса только файловые системы внутри скрытых томов VeraCrypt могут быть смонтированы в режиме чтения-записи (внешние или незашифрованные тома/файловые системы должны монтироваться как только для чтения или оставаться вовсе несмонтированными/недоступными). Если вы не можете соблюсти это требование и не в состоянии гарантировать, что приложения и операционная система не выполняют запись никаких конфиденциальных данных (см. выше) в нескрытые тома/файловые системы, вы не должны монтировать или создавать скрытые тома VeraCrypt в среде Linux.
    • Mac OS X: Если вы не гарантируете, что приложения и операционная система не выполняют запись никаких конфиденциальных данных данных перечисленных выше критических типов в нескрытые тома (или файловые системы), монтировать или создавать скрытые тома VeraCrypt в среде Mac OS X нельзя.
  • Когда смонтирован внешний том с включённой защитой скрытого тома от повреждения (см. раздел Защита скрытых томов от повреждения), необходимо следовать тем же требованиям и предостережениям, что и при монтировании скрытого тома (см. выше). Причина этого в том, что из операционной системы может "утечь" пароль/ключ для скрытого тома в нескрытый или незашифрованный том.
  • Если вы используете операционную систему, находящуюся внутри скрытого тома (см. раздел Скрытая операционная система), то в дополнение к вышесказанному необходимо соблюдать следующие требования безопасности и предостережения:
    • Следует использовать обманную операционную систему так часто, как вы пользуетесь своим компьютером. В идеале её следует использовать всегда, когда не требуется задействовать засекреченные данные. В противном случае может пострадать правдоподобность отрицания наличия скрытой операционной системы (если вы сообщили неприятелю пароль от обманной операционной системы, он сможет выяснить, что эта система использовалась не слишком часто, что может навести на мысль о существовании в компьютере скрытой операционной системы). Обратите внимание, что вы можете сохранять данные в разделе с обманной системой в любой момент и без какого-либо риска повредить скрытый том (так как обманная система не установлена во внешнем томе).
    • Если операционную систему требуется активировать, это нужно сделать до того, как она будет клонирована (клонирование это часть процесса создания скрытой ОС — см. раздел Скрытая операционная система), а скрытая операционная система (то есть клон) никогда не должна быть активирована повторно. Причина в том, что скрытая операционная система создана путём копирования содержимого системного раздела в скрытый том (поэтому если операционная система не активирована, скрытая операционная система также будет неактивированной). В случае активации или повторной активации скрытой операционной системы, дата и время активации (и другая информация) могут быть зафиксированы на сервере Microsoft (и в скрытой операционной системе), но не в обманной операционной системе. Поэтому если неприятель получит доступ к сохранённым на сервере данным или перехватит ваш запрос серверу (и если вы сообщили ему пароль от обманной операционной системы), он сможет выяснить, что обманная операционная система была активирована (или повторно активирована) в другое время, а это способно навести на мысль о существовании в компьютере скрытой операционной системы.
      По аналогичным причинам любое ПО, требующее активации, должно быть установлено и активировано до того, как вы приступите к созданию скрытой операционной системы.
    • Когда вам нужно завершить работу скрытой операционной системы и запустить обманную систему, не перезагружайте компьютер. Вместо этого завершите работу системы или переведите её в состояние гибернации (сна), после чего оставьте компьютер выключенным в течение хотя бы нескольких минут (чем дольше, тем лучше), и только после этого включите его и загрузите обманную систему. Это требуется, чтобы очистить память, в которой могут содержаться конфиденциальные данные. Подробности см. в разделе Незашифрованные данные в ОЗУ, глава Требования безопасности и меры предосторожности.
    • Компьютер может быть подключён к сети (в том числе к Интернету), только когда запущена обманная операционная система. Когда выполняется скрытая ОС, компьютер не следует подключать ни к какой сети, включая Интернет (один из самых надёжных способов гарантировать это – отключить от ПК кабель сетевого адаптера, если таковой имеется). Обратите внимание, что при загрузке данных с/на удалённый сервер, на сервере обычно фиксируются дата и время соединения и другая информация. Разного сорта данные также протоколируются и в операционной системе (например, данные автоматического обновления Windows, отчёты приложений, протоколы ошибок и т. п.). Таким образом, если неприятель получил доступ к хранящимся на сервере данным или перехватил ваш запрос серверу (и если вы сообщили ему пароль от обманной операционной системы), он сможет узнать, что соединение было выполнено не из обманной ОС, и это способно навести его на мысль о существовании в вашем компьютере скрытой операционной системы.

      Также имейте в виду, что аналогичные проблемы возможны, если у вас в среде скрытой операционной системы есть какие-либо файловые системы с общим доступом через сеть (вне зависимости от того, удалённая файловая система или локальная). Поэтому во время работы скрытой операционной системы никаких файловых систем с общим доступом по сети (в любом направлении) быть не должно.

    • Любые действия, которые могут быть обнаружены неприятелем (или любые действия, модифицирующие какие-либо данные вне смонтированных скрытых томов), должны выполняться, только когда работает обманная операционная система (если только у вас нет альтернативного правдоподобного объяснения, например, использование системы на "live-CD" для выполнения таких действий). Скажем, параметр Автоматический переход на летнее время и обратно можно включать только в обманной операционной системе.
    • Если BIOS, EFI или любой другой компонент журналирует выключения питания или любые другие события, которые могут свидетельствовать об использовании скрытого тома/системы (например, путём сравнения таких событий с событиями в протоколе Windows), вы обязаны либо отключить подобное журналирование, либо обеспечить надёжное удаление журнала после каждого сеанса (или иначе избежать подобной проблемы соответствующим образом).

В дополнение к вышесказанному необходимо соблюдать требования безопасности и меры предосторожности, перечисленные в следующих главах:
  • Требования безопасности и меры предосторожности
  • О безопасном резервном копировании

Следующий раздел >>

* Это не относится к файловым системам на CD/DVD-подобных носителях, а также к пользовательским, нетипичным или нестандартным устройствам/носителям.


Документация >> Правдоподобное отрицание наличия шифрования >> Скрытая операционная система

Скрытая операционная система

Если системный раздел или системный диск зашифрован с помощью VeraCrypt, то при каждом включении или при каждой перезагрузке компьютера требуется вводить предзагрузочной аутентификации на экране загрузчика VeraCrypt. Может случиться, что кто-то вынудит вас расшифровать операционную систему или сообщить пароль от предзагрузочной аутентификации. Во многих ситуациях вы просто не сможете отказаться это сделать (например, при вымогательстве). VeraCrypt позволяет создать скрытую операционную систему, существование которой невозможно доказать (при условии выполнения некоторых рекомендаций — см. ниже). Таким образом, вам не придётся расшифровывать скрытую операционную систему или сообщать от неё пароль.
Прежде чем продолжить чтение, вам следует ознакомиться с разделом Скрытый том и убедиться, что вы понимаете, что такое скрытый том VeraCrypt.
Скрытая операционная система это система (например, Windows 7 или Windows XP), установленная в скрытом томе VeraCrypt. Доказать, что скрытый том VeraCrypt существует, должно быть невозможно (при соблюдении определённых правил; см. подробности в разделе Скрытый том), и, следовательно, должно быть невозможно доказать, что существует скрытая операционная система.
Однако для загрузки системы, зашифрованной VeraCrypt, необходимо, чтобы на системном диске или на Диске восстановления VeraCrypt (Rescue Disk) находилась незашифрованная копия загрузчика VeraCrypt. Очевидно, что одно только присутствие загрузчика VeraCrypt говорит о том, что в компьютере имеется система, зашифрованная с помощью VeraCrypt. Таким образом, чтобы можно было правдоподобно объяснить наличие загрузчика VeraCrypt, мастер VeraCrypt в процессе создания скрытой операционной системы поможет вам создать вторую зашифрованную операционную систему – так называемую обманную ОС. Обманная операционная система не должна содержать никаких конфиденциальных файлов. Её наличие не составляет секрета (она не установлена в скрытом томе). Пароль от обманной операционной системы можно без опасений сообщить любому, кто станет вынуждать вас выдать пароль от предзагрузочной аутентификации.*
Загружать обманную операционную систему следует так же часто, как вы используете свой компьютер. В идеале вы должны использовать её для всех действий, которые не связаны с конфиденциальными данными. В противном случае может пострадать правдоподобность отрицания наличия скрытой операционной системы (если вы сообщили неприятелю пароль от обманной операционной системы, он сможет выяснить, что эта система использовалась не слишком часто, а это может навести на мысль о существовании в компьютере скрытой операционной системы). Обратите внимание, что вы можете свободно сохранять данные в разделе с обманной ОС без риска повреждения скрытого тома (так как обманная ОС не установлена во внешнем томе – см. ниже).
У вас будет два пароля предзагрузочной аутентификации – один для скрытой системы, а другой для обманной. Если вы хотите загрузить скрытую систему, то просто вводите пароль для скрытой системы на экране загрузчика (который появляется при включении или перезагрузке компьютера). Аналогично, если вам нужно загрузить обманную операционную систему (например, когда вас вынуждает это сделать неприятель), то на экране загрузчика VeraCrypt вы вводите пароль от обманной системы.
Примечание. Когда вы вводите пароль предзагрузочной аутентификации, загрузчик VeraCrypt Boot сначала пытается расшифровать (с помощью указанного пароля) последние 512 байт первой логической дорожки системного диска (где обычно хранятся зашифрованные данные мастер-ключа для нескрытых зашифрованных системных разделов/дисков). Если это сделать не удаётся и если имеется раздел, следующий за активным разделом, загрузчик В случае неудачи и если после активного раздела находится ещё один раздел, загрузчик VeraCrypt (даже если на самом деле на диске нет скрытого тома) автоматически пытается расшифровать (снова используя тот же введённый пароль) область первого раздела, идущего за активным разделом, где может храниться зашифрованный заголовок возможного скрытого тома (однако если размер активного раздела меньше 256 МБ, то данные считываются со второго раздела после активного, поскольку Windows 7 и новее по умолчанию не загружаются с раздела, на котором они установлены). Обратите внимание, что VeraCrypt никогда заранее не знает, существует ли скрытый том (заголовок скрытого тома не может быть идентифицирован, так как он выглядит как состоящий полностью из случайных данных). Если заголовок успешно расшифрован (о том, как VeraCrypt определяет, что он был успешно расшифрован, см. в разделе Схема шифрования), из расшифрованного заголовка (который всё ещё хранится в ОЗУ) извлекается информация о размере скрытого тома и монтируется скрытый том (его размер также определяет его смещение). Технические детали см. в разделе Схема шифрования, глава Технические подробности.
При работе скрытая операционная система выглядит так, как будто она установлена в том же разделе, что и исходная ОС (обманная система). Однако на самом деле она установлена в разделе позади него (в скрытом томе). Все операции чтения/записи прозрачно перенаправляются из системного раздела в скрытый том. Ни операционная система, ни приложения не будут знать, что данные, записываемые и считываемые из системного раздела, на самом деле записываются и считываются из раздела, находящегося за ним (из/на скрытый том). Любые такие данные шифруются и расшифровываются на лету, как обычно (с ключом шифрования, отличным от того, который используется для обманной операционной системы).
Обратите внимание, что будет также третий пароль – для внешнего тома. Это не пароль предзагрузочной аутентификации, а обычный пароль тома VeraCrypt. Его можно без опаски сообщать любому, кто станет вынуждать вас выдать пароль от зашифрованного раздела, где находится скрытый том (содержащий скрытую операционную систему). Таким образом, существование скрытого тома (и скрытой операционной системы) останется тайной. Если вы не вполне понимаете, как это возможно, или что такое внешний том, прочтите раздел Скрытый том. Внешний том должен содержать некоторое количество файлов, похожих на конфиденциальные, которые на самом деле вам скрывать не нужно.
Итак, всего будет три пароля. Два из них можно сообщать неприятелю (для обманной системы и для внешнего тома). Третий пароль, для скрытой системы, должен оставаться в тайне.
Example Layout of System Drive Containing Скрытая операционная система
Пример макета системного диска, содержащего скрытую операционную систему

Создание скрытой операционной системы

Чтобы приступить к созданию скрытой операционной системы, выберите Система > Создать скрытую ОС и следуйте инструкциям мастера.
Сначала мастер проверяет наличие на системном диске раздела, подходящего для скрытой операционной системы. Обратите внимание, что прежде чем вы сможете создать скрытую операционную систему, необходимо создать для неё раздел на системном диске. Это должен быть первый раздел, расположенный после системного раздела, и он должен быть как минимум на 5% больше, чем системный раздел (системный раздел – это тот, на котором установлена ​​работающая в данный момент операционная система). Однако если внешний том (не путать с системным разделом) отформатирован как NTFS, раздел для скрытой операционной системы должен быть, по крайней мере, на 110% (в 2,1 раза) больше, чем системный раздел (причина в том, что файловая система NTFS всегда сохраняет внутренние данные точно в центре тома, и потому скрытый том, который должен содержать клон системного раздела, может находиться только во второй половине раздела).
На следующих этапах мастер создаст два тома VeraCrypt (внешний и скрытый) внутри раздела, следующего первым за системным разделом. Скрытый том будет содержать скрытую операционную систему. Размер скрытого тома всегда равен размеру системного раздела. Причина в том, что в скрытом томе должен находиться клон содержимого системного раздела (см. ниже). Обратите внимание, что клон будет зашифрован с использованием ключа шифрования, отличного от исходного. Прежде чем вы начнёте копировать во внешний том файлы, напоминающие конфиденциальные, мастер сообщит максимально рекомендуемый размер дискового пространства, который могут занимать такие файлы, чтобы во внешнем томе оставалось достаточно места для скрытого тома.
Замечание. После того, как вы скопируете на внешний том некоторое количество файлов, похожих на конфиденциальные, будет просканирована карта кластеров тома, чтобы определить размер непрерывной свободной области, конец которой выровнен по концу внешнего тома. Эта область будет отведена под скрытый том, поэтому она ограничивает его максимально возможный размер. При определении максимально возможного размера скрытого тома будет проверено, что он больше, чем системный раздел (что необходимо, так как в скрытый том нужно будет скопировать всё содержимое системного раздела – см. ниже). Это гарантирует, что никакие данные, хранящиеся на внешнем томе, не будут перезаписаны данными, записанными в область скрытого тома (например, при копировании в него системы). Размер скрытого тома всегда равен размеру системного раздела.
Затем VeraCrypt создаст скрытую операционную систему, скопировав содержимое системного раздела в скрытый том. Копируемые данные будут зашифрованы на лету ключом шифрования, отличным от того, который будет использоваться для обманной операционной системы. Процесс копирования системы выполняется в предзагрузочной среде (до запуска Windows) и может занять длительное время – несколько часов или даже дней (в зависимости от размера системного раздела и производительности компьютера). Этот процесс можно будет прервать, выключить компьютер, загрузить операционную систему, а затем снова продолжить. Однако если его прервать, весь процесс копирования системы придётся начинать сначала (потому что содержимое системного раздела не должно меняться во время клонирования). Скрытая операционная система изначально будет клоном той операционной системы, в которой вы запускали мастер.
Windows создаёт (как правило, без вашего ведома или согласия) на системном разделе множество файлов-журналов, временных файлов и т. п. Кроме того, в файлах гибернации (сна) и подкачки, также находящихся в системном разделе, сохраняется содержимое ОЗУ. Поэтому если неприятель проанализирует файлы в разделе, где находится исходная система (клоном которой является скрытая система), он сможет определить, что, например, вы использовали мастер VeraCrypt в режиме создания скрытой системы (что может навести на мысль о существовании в вашем компьютере скрытой ОС). Чтобы избежать подобных проблем, VeraCrypt после создания скрытой системы надёжно удаляет (затирает) всё содержимое раздела, в котором находится исходная система. Затем, чтобы обеспечить возможность правдоподобного отрицания наличия шифрования, VeraCrypt предложит установить новую систему на раздел и зашифровать её. Таким образом, вы создадите обманную систему, и на этом весь процесс создания скрытой операционной системы будет завершён.
Примечание. VeraCrypt удалит содержимое раздела, в котором находится исходная система, полностью заполнив его случайными данными. Если бы вы раскрыли пароль от обманной системы противнику и он спросил вас, почему свободное место системного раздела (обманного) содержит случайные данные, вы могли бы ответить, например, так: "Раньше этот раздел содержал систему, зашифрованную VeraCrypt, но я забыл пароль предзагрузочной аутентификации (или система была повреждена и перестала загружаться), поэтому мне пришлось переустановить Windows и снова зашифровать раздел".

Правдоподобное отрицание наличия шифрования и защита от утечек данных

По соображениям безопасности, когда работает скрытая операционная система, VeraCrypt гарантирует, что все локальные незашифрованные файловые системы и нескрытые тома VeraCrypt доступны только для чтения (то есть никакие файлы не могут быть записаны в такие файловые системы или тома VeraCrypt).† Запись данных разрешена в любую файловую систему, находящуюся внутри скрытого тома VeraCrypt (при условии, что этот скрытый том расположен не в контейнере, хранящемся в незашифрованной файловой системе или в любой другой файловой системе, доступной только для чтения).
Существуют три основные причины, по которым были приняты такие контрмеры:
  1. Возможность создать безопасную платформу для монтирования скрытых томов VeraCrypt. Обратите внимание, что мы официально рекомендуем монтировать скрытые тома только при работающей скрытой операционной системе. См. подробности в подразделе Требования безопасности и меры предосторожности, относящиеся к скрытым томам.
  2. В некоторых случаях можно определить, что в какое-то время определённая файловая система не была смонтирована (или что какой-то файл в файловой системе не был сохранён или не был доступен изнутри) в определённом экземпляре операционной системы (например, с помощью анализа и сравнения журналов файловой системы, временных меток файлов, журналов приложений, журналов ошибок и т. д.). Это может указывать на то, что в компьютере установлена ​​скрытая операционная система. Подобные проблемы предотвращаются контрмерами.
  3. Предотвращение повреждения данных и возможность безопасной гибернации ("сна"). Когда Windows выходит из гибернации, она подразумевает, что все смонтированные файловые системы находятся в том же состоянии, в котором они были на момент входа в гибернацию. VeraCrypt обеспечивает это, защищая от записи любую файловую систему, доступную как из обманных, так и из скрытых систем. Без такой защиты файловая система может быть повреждена при монтировании одной системой, когда другая находится в состоянии гибернации.

Если вам нужно безопасно перенести файлы из обманной системы в скрытую, выполните следующее:

  1. Загрузите обманную систему.
  2. Сохраните файлы в незашифрованном томе или во внешнем/обычном томе VeraCrypt.
  3. Загрузите скрытую систему.
  4. Если вы сохранили файлы в том VeraCrypt, смонтируйте его (он будет автоматически смонтирован как доступный только для чтения).
  5. Скопируйте файлы в скрытый системный раздел или в другой скрытый том.

Возможные объяснения существования двух разделов VeraCrypt на одном диске

Неприятель может поинтересоваться, зачем вам понадобилось создавать на одном диске два зашифрованных VeraCrypt раздела (системный и несистемный), когда можно было бы вместо этого зашифровать весь диск с помощью одного ключа шифрования. На то может быть множество причин. Однако если вам не приходит в голову никакая (кроме создания скрытой операционной системы), вы можете воспользоваться, например, одним из следующих объяснений:
  • Если на системном диске более двух разделов, и вам нужно зашифровать только два из них (системный раздел и раздел, следующий за ним), оставив другие разделы незашифрованными (например, чтобы обеспечить на этих незашифрованных разделах максимально возможную скорость чтения и записи данных, не нуждающихся в шифровании), единственный способ это сделать – зашифровать два раздела по-отдельности (обратите внимание, что с помощью одного ключа шифрования VeraCrypt может зашифровать весь системный диск и все находящиеся на нём разделы, но не может зашифровать только два из них – с помощью одного ключа можно зашифровать либо один, либо все разделы). В результате на системном диске будут два расположенных рядом раздела VeraCrypt (первый – системный, второй – несистемный), каждый зашифрованный своим собственным ключом (что также имеет место при создании скрытой операционной системы, и потому тоже может быть объяснено таким же образом).

    Если вы не знаете ни одной веской причины, почему на системном диске может быть более одного раздела, примите к сведению следующее:

    Как правило, несистемные файлы (документы) рекомендуется хранить отдельно от системных файлов. Один из наиболее простых и надёжных способов этого добиться – создать два раздела на системном диске: один раздел для операционной системы, а другой для документов (несистемных файлов). Такая практика рекомендуется по следующим причинам:
    • Если повредится файловая система одного из разделов, файлы на этом разделе могут испортиться или стать недоступными, в то время как файлов на другом разделе это не коснётся.
    • Так проще выполнить переустановку системы без потери документов (полная повторная установка ОС включает в себя форматирование системного раздела, что приводит к уничтожению всех хранящихся на нём файлов). При повреждении системы полная её переустановка это, зачастую, единственно возможный путь.
  • Каскадное шифрование (например, AES-Twofish-Serpent) может быть во много раз медленнее, чем шифрование без каскадирования (например, AES). Однако каскадное шифрование более надёжно, чем некаскадное (например, вероятность взлома трёх разных алгоритмов шифрования, скажем, вследствие развития криптоанализа, значительно ниже, чем только одного из них). Поэтому если вы зашифруете внешний том с применением каскадного шифрования, а обманную систему с помощью некаскадного, то сможете ответить, что вы хотели добиться максимальной производительности (и достаточной защиты) для системного раздела, а для несистемного раздела (то есть для внешнего тома), где у вас хранятся самые конфиденциальные данные и куда вы обращаетесь не слишком часто (в отличие от операционной системы, которая используется очень часто и потому нуждается в наиболее высокой скорости), вам была нужна максимальная защита (пусть и ценой потери производительности). На системном разделе вы храните менее секретные данные (но которые вам нужны очень часто), чем данные на несистемном разделе (то есть во внешнем томе).
  • При условии, что внешний том у вас зашифрован с помощью каскадного шифрования (например, AES-Twofish-Serpent), а обманная система – некаскадным алгоритмом (скажем, AES), вы также можете ответить, что хотели избежать проблем, о которых предупреждает VeraCrypt, когда пользователь пытается выбрать каскадный алгоритм для шифрования системы (список проблем приведён ниже). Поэтому, чтобы не осложнять себе жизнь такими проблемами, вы решили зашифровать системный раздел с помощью некаскадного алгоритма. Вместе с тем, для своих самых конфиденциальных данных вы по-прежнему захотели воспользоваться каскадным шифрованием (как более надёжным, чем некаскадный алгоритм), и потому решили создать второй раздел, которого эти проблемы не касаются (поскольку он не системный), и зашифровать его каскадным алгоритмом. В системном разделе вы храните менее важные данные, чем те, которые хранятся в несистемном разделе (то есть во внешнем томе).

    Примечание. Если пользователь пытается зашифровать системный раздел каскадным алгоритмом, VeraCrypt предупреждает, что это может повлечь за собой следующие проблемы (и неявно рекомендует вместо этого выбрать некаскадный алгоритм шифрования):
    • При использовании каскадных алгоритмов шифрования размер загрузчика VeraCrypt больше, чем обычно, поэтому на первой дорожке диска недостаточно места для его резервной копии. Следовательно, при любом повреждении загрузчика (что часто случается, например, из-за неудачно реализованных антипиратских процедур активации некоторых программ), пользователю нужно прибегать к помощи диска восстановления VeraCrypt, чтобы восстановить загрузчик VeraCrypt или загрузить систему.
    • На некоторых компьютерах выход из состояния гибернации ("сна") занимает больше времени.
  • В отличие от пароля для несистемного тома VeraCrypt, пароль предзагрузочной аутентификации требуется вводить при каждом включении или перезагрузке компьютера. Поэтому если пароль предзагрузочной аутентификации длинный (что необходимо в целях безопасности), вводить его так часто может быть очень утомительно. Следовательно, вы можете ответить, что вам было удобнее вводить короткий (и потому менее надёжный) пароль для системного раздела (то есть для обманной системы), а более секретные документы (доступ к которым нужен не так часто) вы предпочли хранить в несистемном разделе VeraCrypt (то есть во внешнем томе), для которого выбрали очень длинный пароль.

    Поскольку пароль для системного раздела не слишком надёжный (потому что он короткий), вы намеренно не храните важные конфиденциальные данные в системном разделе. Тем не менее, вы предпочитаете, чтобы системный раздел был зашифрован, так как храните на нём потенциально важные и умеренно конфиденциальные данные, с которыми работаете ежедневно (например, автоматически запоминаемые браузером пароли от интернет-форумов, историю посещаемых сайтов, запускаемых приложений и т. п.).
  • Если неприятель завладеет вашим компьютером в тот момент, когда смонтирован том VeraCrypt (например, когда вы пользуетесь ноутбуком на улице), он в большинстве случаев сможет прочитать любые хранящиеся в томе данные (данные расшифровываются на лету при их считывании). Поэтому имеет смысл ограничить до минимума время, в течение которого том остаётся смонтированным. Очевидно, что это сделать невозможно или затруднительно, если конфиденциальные данные хранятся в зашифрованном системном разделе или на полностью зашифрованном системном диске (потому что при этом вам пришлось бы ограничить до минимума и время работы с компьютером). Следовательно, вы можете ответить, что для хранения особо важных данных вы создали отдельный раздел (зашифрованный другим ключом, нежели системный раздел), монтируете его только при необходимости, а затем как можно скорее размонтируете (поскольку время монтирования этого тома ограничено до минимума). В системном разделе вы храните данные менее важные (но которые вам часто нужны), чем в несистемном разделе (то есть во внешнем томе).

Меры предосторожности и требования безопасности, относящиеся к скрытым операционным системам

Поскольку скрытая операционная система расположена в скрытом томе VeraCrypt, пользователь скрытой ОС должен соблюдать все правила и меры предосторожности, относящиеся к обычным скрытым томам VeraCrypt. Эти требования, а также дополнительные меры предосторожности, относящиеся именно к скрытым операционным системам, приведены в подразделе Требования безопасности и меры предосторожности, относящиеся к скрытым томам.
ВНИМАНИЕ: Если вы не защищаете скрытый том (о том, как это сделать, см. раздел Защита скрытых томов от повреждения), не записывайте ничего во внешний том (обратите внимание, что обманная операционная система установлена не во внешнем томе). Иначе вы можете перезаписать и повредить скрытый том (и находящуюся внутри него скрытую ОС)!
Если выполнены все инструкции мастера и соблюдены меры предосторожности, указанные в подразделе Требования безопасности и меры предосторожности, относящиеся к скрытым томам, гарантированно утверждать, что в ПК имеются скрытый том и скрытая операционная система, должно быть невозможно, даже если смонтирован внешний том или расшифрована/запущена обманная ОС.

* Нецелесообразно (и поэтому не поддерживается) устанавливать операционные системы в два тома VeraCrypt, встроенных в один раздел, потому что использование внешней операционной системы часто требует записи данных в область скрытой операционной системы (и если бы такие операции записи были предотвращены с помощью функции защиты скрытого тома, это неизбежно вызвало бы сбои системы, то есть ошибки "синего экрана").
† Это не относится к файловым системам на CD/DVD-подобных носителях, а также к пользовательским, нетипичным или нестандартным устройствам/носителям.

См. также: Шифрование системы, Скрытый том


Документация >> Главное окно программы

Главное окно программы

Выбрать файл

Позволяет выбрать том VeraCrypt на основе файла. После выбора вы можете выполнить с томом различные операции (например, смонтировать его, нажав кнопку Смонтировать). Выбрать том также можно перетаскиванием его значка на значок файла ‘VeraCrypt.exe’ (при этом VeraCrypt будет автоматически запущен) или в главное окно программы.

Выбрать устройство

Позволяет выбрать раздел VeraCrypt или устройство хранения данных (например, USB-флешку). После выбора вы можете выполнить с томом различные операции (например, смонтировать его, нажав кнопку Смонтировать).

Примечание. Монтировать разделы/устройства VeraCrypt можно и более удобным способом – см. подробности в разделе Автомонтирование.

Смонтировать

После того, как вы нажмёте кнопку Монтировать, программа VeraCrypt попытается смонтировать выбранный том, используя кэшированные (временно сохранённые в памяти) пароли (если таковые имеются), и если ни один из них не подойдёт, попросит ввести пароль. Если вы введёте правильный пароль (и/или укажете корректные ключевые файлы), том будет смонтирован.

ВАЖНО: Обратите внимание, что когда вы закрываете программу VeraCrypt, её драйвер продолжает работать, и никакие тома VeraCrypt не размонтируются.

Автомонтирование

Эта функция позволяет монтировать разделы/устройства VeraCrypt без необходимости выбирать их вручную (кнопкой Выбрать устройство). VeraCrypt поочерёдно сканирует заголовки всех доступных разделов/устройств в системе (за исключением накопителей DVD и аналогичных устройств) и пытается смонтировать каждый из них как том VeraCrypt. Обратите внимание, что ни том/устройство VeraCrypt, ни шифр, применявшийся при их шифровании, невозможно идентифицировать. По этой причине программа не может просто "найти" разделы VeraCrypt. Вместо этого она пытается выполнить монтирование каждого (даже незашифрованного) раздела/устройства с помощью всех алгоритмов шифрования и всех сохранённых в кэше паролей (если таковые имеются). Поэтому будьте готовы к тому, что на медленных компьютерах данный процесс может занять много времени.

Если введён неправильный пароль, выполняется попытка монтирования, используя кэшированные пароли (если они есть). Если вы указали пустой пароль и не выбрали опцию Ключевые файлы, то при попытке автомонтирования разделов/устройств будут использоваться только кэшированные пароли. Если вам не нужно указывать параметры монтирования, то можно избежать появления запроса пароля: для этого при нажатии кнопки Автомонтирование удерживайте нажатой клавишу Shift (при этом будут использоваться только кэшированные пароли, если они есть).

Буквы дисков будут назначены начиная с той, которая была выбрана в списке дисков в главном окне.

Размонтировать

Эта функция позволяет размонтировать том VeraCrypt, выбранный в списке дисков на главном окне программы. Размонтировать – значит закрыть этот том и сделать для него недоступными операции чтения/записи.

Размонтировать все

Примечание. Информация в этом разделе применима ко всем элементам меню и кнопкам с таким же или похожим названием (например, она также относится к пункту Размонтировать все в системной области уведомлений).

Эта функция позволяет размонтировать сразу несколько томов VeraCrypt. Размонтировать – значит закрыть этот том и сделать для него недоступными операции чтения/записи. Данная функция размонтирует все смонтированные тома VeraCrypt, за исключением следующих:

  • разделы/диски внутри области действия ключа шифрования активной системы (например, системный раздел, зашифрованный VeraCrypt, или несистемный раздел на системном диске, зашифрованном VeraCrypt, смонтированный во время работы зашифрованной операционной системы);
  • тома VeraCrypt, не полностью доступные из-под учётной записи пользователя (например, том, смонтированный из-под другой учётной записи);
  • тома VeraCrypt, не отображаемые в окне программы VeraCrypt. Например, системные избранные тома, которые пытались размонтировать с помощью экземпляра VeraCrypt без прав администратора при включённом параметре Просматривать/размонтировать системные избранные тома могут лишь администраторы.

Очистить кэш

Удаляет из памяти драйвера все кэшированные пароли (где также может находиться содержимое обработанных ключевых файлов). Если в кэше нет паролей, эта кнопка неактивна. О кэшировании паролей см. в разделе Кэшировать пароли в памяти драйвера.

Не сохранять историю

Если эта опция не включена, имена файлов и/или пути последних двадцати файлов/устройств, которые вы пытались смонтировать как тома VeraCrypt, будут запоминаться в файле истории (его содержимое отображается при щелчке по стрелке у выпадающего списка Том в главном окне программы).

Если эта опция включена, TrueCrypt очищает записи в реестре, созданные диалоговыми окнами выбора файлов Windows для VeraCrypt и делает "текущей папкой" домашнюю папку пользователя (в переносном режиме – папку, из которой был запущен VeraCrypt) вне зависимости от того, что выбиралось в диалоговом окне выбора – контейнер или ключевой файл. Поэтому Windows-диалог выбора файлов не будет запоминать путь последнего смонтированного контейнера (или последнего выбранного ключевого файла). Учтите, однако, что описанные в этом разделе операции не гарантируют надёжность и безопасность (например, см. Требования безопасности и меры предосторожности), поэтому настоятельно рекомендуется на них не полагаться, а шифровать системный раздел/диск (см. Шифрование системы).

Кроме того, если эта опция включена, поле ввода пути к тому в главном окне программы очищается свякий раз, когда вы скрываете VeraCrypt.

Примечание. Чтобы очистить историю томов, выберите в меню Сервис команду Очистить историю томов.

Выход

Завершает работу программы VeraCrypt. При этом драйвер продолжает работать, и никакие тома VeraCrypt не размонтируются. При работе в переносном (‘portable’) режиме драйвер VeraCrypt выгружается, если он больше не требуется (например, когда все копии главного приложения и/или мастера создания томов закрыты и нет смонтированных томов VeraCrypt). Однако если вы принудительно размонтируете том VeraCrypt, когда программа работает в переносном режиме, или смонтируете доступный для записи отформатированный как NTFS том в среде Windows Vista или более новых версиях Windows, в этом случае драйвер VeraCrypt может не быть выгруженным при выходе из VeraCrypt (он будет выгружен только при завершении работы системы или её перезагрузке). Таким образом предотвращаются различные проблемы, обусловленные ошибкой в Windows (например, был бы невозможен повторный запуск VeraCrypt, пока есть какие-либо приложения, использующие размонтированный том).

Операции с томами

Изменить пароль тома

См. раздел Тома > Изменить пароль тома.

Установить алгоритм формирования ключа заголовка

См. раздел Тома > Установить алгоритм формирования ключа заголовка.

Создать резервную копию заголовка тома

См. раздел Сервис > Создать резервную копию заголовка тома.

Восстановить заголовок тома

См. раздел Сервис > Восстановить заголовок тома.

Следующий раздел >>


Документация >> Главное окно программы >> Меню программы

Меню программы

Примечание. Для экономии места в этой документации описаны только те пункты меню, которые требуют пояснений, а описание очевидных пунктов опущено.

Тома > Автомонтирование всех томов на основе устройств

См. раздел Автомонтирование.

Тома > Размонтировать все смонтированные тома

См. раздел Размонтировать все.

Тома > Изменить пароль тома

Позволяет изменить пароль выбранного в данный момент тома VeraCrypt (неважно, скрытого или обычного). Изменяются только ключ заголовка и вторичный ключ заголовка (режим XTS) – мастер-ключ остаётся неизменным. Эта функция выполняет перешифровку заголовка тома с использованием ключа шифрования, полученного из нового пароля. Обратите внимание, что в заголовке тома содержится мастер-ключ шифрования, с помощью которого зашифрован этот том. Поэтому после применения этой функции хранящиеся в томе данные не потеряются (смена пароля длится несколько секунд).

Чтобы изменить пароль тома VeraCrypt, нажмите кнопку Выбрать файл или Выбрать устройство, затем выберите том и в меню Тома выберите команду Изменить пароль тома.

Примечание. Об изменении пароля для предзагрузочной аутентификации см. раздел Система > Изменить пароль.

См. также главу Требования безопасности и меры предосторожности.

PKCS-5 PRF

В этом поле можно выбрать алгоритм, который будет использоваться для формирования (деривации) новых ключей заголовка тома (см. подробности в разделе Формирование ключа заголовка, соль и количество итераций) и генерирования новой соли (см. подробности в разделе Генератор случайных чисел).

Примечание. Когда VeraCrypt выполняет перешифрование заголовка тома, исходный заголовок сначала перезаписывается 256 раз случайными данными с целью не дать возможности неприятелю воспользоваться такими технологическими способами, как магнитно-силовая микроскопия или магнитно-силовая сканирующая туннельная микроскопия [17] для восстановления перезаписанного заголовка (тем не менее см. также главу Требования безопасности и меры предосторожности).

Тома > Установить алгоритм формирования ключа заголовка

Эта функция позволяет перешифровать заголовок тома с другим ключом заголовка, сформированным с помощью иной PRF-функции (например, вместо HMAC-BLAKE2S-256 можно воспользоваться HMAC-Whirlpool). Обратите внимание, что в заголовке тома содержится мастер-ключ шифрования, с помощью которого зашифрован этот том. Поэтому после применения этой функции хранящиеся в томе данные не потеряются. См. более подробные сведения в разделе Формирование ключа заголовка, соль и количество итераций.

Примечание. Когда VeraCrypt выполняет перешифрование заголовка тома, исходный заголовок сначала многократно перезаписывается (3, 7, 35 или 256 раз в зависимости от выбора пользователя) раз случайными данными с целью не дать возможности неприятелю воспользоваться такими технологическими способами, как магнитно-силовая микроскопия или магнитно-силовая сканирующая туннельная микроскопия [17] для восстановления перезаписанного заголовка (тем не менее см. также главу Требования безопасности и меры предосторожности).

Тома > Добавить/удалить ключевые файлы в/из том(а)

Тома > Удалить все ключевые файлы из тома

См. главу Ключевые файлы.

Избранное > Добавить смонтированный том в список избранных томов

Избранное > Упорядочить избранные тома

Избранное > Смонтировать избранные тома

См. главу Избранные тома.

Избранное > Добавить смонтированный том в список системных избранных томов

Избранное > Упорядочить системные избранные тома

См. главу Системные избранные тома.

Система > Изменить пароль

Изменяет пароль предзагрузочной аутентификации (см. главу Шифрование системы). ВНИМАНИЕ: Если ключевые данные окажутся повреждёнными, их можно восстановить с помощью Диска восстановления VeraCrypt (Rescue Disk). При этом также будет восстановлен пароль, который был актуальным на момент создания Диска восстановления. Поэтому при каждой смене пароля следует уничтожать прежний Диск восстановления и создавать новый (выбрав Система > Создать Диск восстановления). В противном случае неприятель сможет расшифровать ваш системный раздел/диск с помощью старого пароля (если к нему в руки попадёт старый Диск восстановления VeraCrypt, и он им воспользуется, чтобы восстановить ключевые данные. См. также главу Требования безопасности и меры предосторожности.

Более подробную информацию о смене пароля см. выше в разделе Тома > Изменить пароль тома.

Система > Смонтировать без предзагрузочной аутентификации

Выберите эту опцию, если вам нужно смонтировать раздел, находящийся в области действия шифрования системы, без предзагрузочной аутентификации. Например, вы хотите смонтировать раздел, расположенный на зашифрованном системном диске с другой ОС, которая сейчас не запущена. Это может пригодиться, скажем, когда требуется создать резервную копию или восстановить операционную систему, зашифрованную с помощью VeraCrypt (из другой операционной системы).

Примечание. если нужно смонтировать сразу несколько разделов, нажмите кнопку Автомонтирование, затем нажмите Параметры и включите опцию Монтировать раздел с шифрованием ОС без предзагрузочной аутентификации.

Учтите, что эту функцию нельзя использовать для монтирования расширенных (логических) разделов, расположенных на полностью зашифрованном системном диске.

Сервис > Очистить историю томов

Очищает список с именами файлов (если использовались тома на основе файлов) и путями последних 20-ти успешно смонтированных томов.

Сервис > Настройка Переносного диска

См. главу Портативный (переносной) режим.

Сервис > Генератор ключевых файлов

См. раздел Сервис > Генератор ключевых файлов в главе Ключевые файлы.

Сервис > Создать резервную копию заголовка тома

Сервис > Восстановить заголовок тома

Если повреждён заголовок тома VeraCrypt, такой том в большинстве случаев смонтировать невозможно. Поэтому каждый том, созданный с помощью VeraCrypt (за исключением системных разделов) содержит встроенную резервную копию заголовка, расположенную в конце тома. Для дополнительной безопасности вы также можете создавать внешние резервные копии заголовков томов. Для этого нажмите кнопку Выбрать устройство или Выбрать файл, укажите нужный вам том, выберите Сервис > Создать резервную копию заголовка тома и следуйте инструкциям.

Примечание. Если зашифрована система, то резервной копии заголовка в конце тома нет. Для несистемных томов сначала выполняется операция сжатия, чтобы все данные находились в начале тома, а всё свободное пространство осталось в конце, где будет место под резервную копию заголовка. Для системных разделов выполнить эту операцию сжатия во время работы Windows невозможно, потому и нельзя создать резервную копию заголовка в конце раздела. Альтернативный способ в случае шифрования системы – использование Диска восстановления.

Примечание. Резервная копия заголовка тома (встроенная или внешняя) это не копия исходного заголовка тома, так как тот зашифрован другим ключом заголовка, сформированным с помощью другой соли (см. раздел Формирование ключа заголовка, соль и количество итераций). При изменении пароля и/или ключевых файлов или при восстановлении заголовка из встроенной (или внешней) резервной копии выполняется повторное шифрование как заголовка тома, так и его резервной копии (встроенной в том) с помощью ключей заголовка, сформированных посредством вновь сгенерированной соли (соль для заголовка тома отличается от соли для его резервной копии). VeraCrypt создаёт каждую соль с помощью генератора случайных чисел (см. раздел Генератор случайных чисел).

Для восстановления повреждённого заголовка тома можно использовать резервные копии обоих типов (встроенную и внешнюю). Для этого нажмите кнопку Выбрать устройство или Выбрать файл, укажите нужный вам том, выберите Сервис > Восстановить заголовок тома и следуйте инструкциям.

ВНИМАНИЕ: При восстановлении заголовка тома также восстанавливаются пароль тома и PIM, которые были актуальны на момент создания резервной копии. Более того, если на момент создания резервной копии для монтирования тома требовались ключевые файлы, то после восстановления заголовка для монтирования тома снова потребуются те же ключевые файлы. Более подробную информацию см. в разделе Схема шифрования, глава Технические подробности.

После создания резервной копии заголовка тома создавать новую копию может потребоваться только при изменении пароля тома и/или ключевых файлов, либо когда вы изменяете значение PIM. В противном случае заголовок тома не изменяется, поэтому резервная копия заголовка тома остаётся актуальной.

Примечание. Помимо соли (последовательности случайных чисел), внешние файлы с резервными копиями заголовка тома не содержат никакой незашифрованной информации, и их нельзя расшифровать, не зная правильный пароль и/или не предоставив правильные ключевые файлы. Более подробную информацию см. в главе Технические подробности.

При создании внешней резервной копии заголовка в неё помещаются как заголовок обычного тома, так и область, в которой может храниться заголовок скрытого тома, даже если внутри этого тома нет скрытого тома (чтобы можно было правдоподобно отрицать наличие скрытых томов). Если в томе нет скрытого тома, область, зарезервированная под заголовок скрытого тома, будет заполнена в файле с резервной копией случайными данными (чтобы оставалась возможность правдоподобного отрицания).

При восстановлении заголовка тома потребуется выбрать тип тома, заголовок которого вы хотите восстановить (обычный том или скрытый). За одну операцию можно восстановить только один заголовок тома. Чтобы восстановить оба заголовка, нужно выполнить операцию дважды (Сервис -> Восстановить заголовок тома). Вам будет нужно ввести правильный пароль (и/или предоставить правильные ключевые файлы), а также нестандартное значение PIM (если это применимо), актуальные на момент создания резервной копии заголовка тома. Паролем (и/или ключевыми файлами) и PIM будет также автоматически определяться тип заголовка тома для восстановления, то есть обычный он или скрытый (обратите внимание, что VeraCrypt определяет тип методом проб и ошибок).

Примечание. Если при монтировании тома пользователь два раза подряд неправильно укажет пароль (и/или ключевые файлы) и/или нестандартное значение PIM, то VeraCrypt будет автоматически пытаться смонтировать том, используя встроенную резервную копию заголовка (вдобавок к попытке монтирования с помощью основного заголовка), при каждой последующей попытке пользователя смонтировать том (пока не будет нажата кнопка Отмена). Если VeraCrypt не удастся расшифровать основной заголовок, но в то же время получится расшифровать встроенную резервную копию заголовка, том будет смонтирован с предупреждением, что заголовок тома повреждён (и выводом информации, как его восстановить).

Настройки > Производительность и драйвер

Вызывает окно "Настройки производительности VeraCrypt", в котором можно включить или отключить аппаратное ускорение AES и распараллеливание на основе потоков. Также здесь можно изменить следующий параметр драйвера:

Включить поддержку расширенных кодов управления дисками

Если включено, драйвер VeraCrypt будет поддерживать возврат расширенной технической информации о подключённых томах с помощью управляющего кода IOCTL_STORAGE_QUERY_PROPERTY. Этот управляющий код всегда поддерживается физическими дисками и может потребоваться некоторым приложениям для получения технической информации о диске (например, Windows-программа fsutil использует этот управляющий код для получения размера физического сектора диска).
Включение этой опции приближает поведение томов VeraCrypt к поведению физических дисков, и если она отключена, приложения могут легко различать физические диски и тома VeraCrypt, поскольку отправка этого управляющего кода на том VeraCrypt приведёт к ошибке.
Отключите эту опцию, если возникли проблемы со стабильностью (например, проблемы с доступом к тому или системный BSOD), которые могут быть вызваны плохо написанным ПО и драйверами.

Настройки > Параметры

Вызывает диалоговое окно настроек программы, в котором помимо прочего можно изменить следующие параметры:

Очищать кэш паролей при выходе

Если включено, пароли (а также содержимое обработанных ключевых файлов) и значения PIM, кэшированные (сохранённые) в памяти драйвера, будут удалены при выходе из VeraCrypt.

Кэшировать пароли в памяти драйвера

Если включено, пароли и/или содержимое обработанных ключевых файлов для четырёх последних успешно смонтированных томов VeraCrypt будут кэшироваться (временно запоминаться). Если в настройках включён параметр Кэшировать PIM вместе с паролем, значения PIM, отличные от стандартного, кэшируются вместе с паролями. Это позволяет монтировать тома без необходимости то и дело вводить их пароли (и выбирать ключевые файлы). VeraCrypt никогда не сохраняет никаких паролей и значений PIM на диске (тем не менее см. главу Требования безопасности и меры предосторожности). Кэширование паролей включается/отключается в настройках программы (Настройки > Параметры) и в окне запроса пароля. В случае шифрования системного раздела/диска, кэширование пароля предзагрузочной аутентификации можно включить или выключить в настройках шифрования системы (Настройки > Шифрование системы).

Временно кэшировать пароль при монтировании избранных томов

Если эта опция не включена (а по умолчанию она не включена), VeraCrypt будет отображать окно с запросом пароля для каждого избранного тома во время выполнения операции Монтировать избранные тома, и каждый пароль стирается после монтирования тома (если не включено кэширование паролей).

Если эта опция включена и есть два или более избранных тома, то при операции Монтировать избранные тома VeraCrypt сначала попробует пароль предыдущего избранного тома, и, если он не сработает, отобразит окно с запросом пароля. Эта логика применяется, начиная со второго избранного тома и далее. После обработки всех избранных томов пароль стирается из памяти.

Эта опция полезна, когда избранные тома используют один и тот же пароль, поскольку окно с запросом пароля будет отображаться только один раз для первого избранного тома, а все последующие избранные тома VeraCrypt смонтирует автоматически.

Обратите внимание, что поскольку нельзя предположить, что все избранные тома используют один и тот же PRF (хеш) и один и тот же режим TrueCrypt, VeraCrypt определяет PRF последующих избранных томов автоматически и пробует оба значения режима TrueCrypt (false, true), то есть общее время монтирования будет больше, чем при индивидуальном монтировании каждого тома с ручным выбором правильного PRF и состояния режима TrueCrypt.

Открывать Проводник для успешно смонтированного тома

Если включено, то после успешного монтирования тома VeraCrypt будет автоматически открываться окно Проводника с содержимым корневой папки этого тома (например, T:\).

Менять значок в области уведомлений, если есть смонтированные тома

Если включено, то когда смонтирован том, в области уведомлений на панели задач (рядом с часами) отображается другой значок VeraCrypt.

Исключения:

  • разделы/диски внутри области действия ключа шифрования активной системы (например, системный раздел, зашифрованный VeraCrypt, или несистемный раздел на системном диске, зашифрованном VeraCrypt, смонтированный во время работы зашифрованной операционной системы);
  • тома VeraCrypt, не полностью доступные из-под учётной записи пользователя (например, том, смонтированный из-под другой учётной записи);
  • тома, не отображаемые в окне VeraCrypt, например системные избранные тома, которые пытались размонтировать с помощью экземпляра VeraCrypt без прав администратора при включённой опции Просматривать/размонтировать системные избранные тома могут лишь администраторы.

Работа VeraCrypt в фоновом режиме – Включено

См. главу Работа VeraCrypt в фоновом режиме.

Работа VeraCrypt в фоновом режиме – Выход, если нет смонтированных томов

Если включено, работа VeraCrypt в фоновом режиме автоматически и без выдачи сообщений прекращается, как только в системе не будет смонтированных томов VeraCrypt. См. подробности в главе Работа VeraCrypt в фоновом режиме. Обратите внимание, что данный параметр нельзя отключить, если VeraCrypt выполняется в переносном (portable) режиме.

Автоматически размонтировать тома при неактивности в течение…

По прошествии n минут, в течение которых с томом VeraCrypt не выполнялось никаких операций по записи/чтению данных, этот том будет автоматически размонтирован.

Автоматически размонтировать тома даже при открытых файлах или папках

Этот параметр применим только к авторазмонтированию (не к обычному размонтированию). Он форсирует размонтирование (без выдачи запроса) автоматически размонтируемого тома в случае, если тот содержит открытые в данный момент файлы или папки (то есть файлы/папки, используемые системой или приложениями).

Следующий раздел >>


Документация >> Главное окно программы >> Монтирование томов

Монтирование томов VeraCrypt

Если вы этого ещё не сделали, прочитайте разделы Смонтировать и Автомонтирование в главе Главное окно программы.

Кэшировать пароли и ключевые файлы в ОЗУ

Этот параметр можно задать в окне ввода пароля, чтобы он применялся только к этой конкретной попытке монтирования. Он также может быть установлен как используемый по умолчанию в настройках программы. См. подробности в разделе Настройки > Параметры, подраздел Кэшировать пароли в памяти драйвера.

Параметры монтирования

Параметры монтирования влияют на текущий монтируемый том. Чтобы открыть диалоговое окно Параметры монтирования, нажмите кнопку Параметры в окне ввода пароля. Если в кэше находится правильный пароль, то при нажатии кнопки Смонтировать тома будут монтироваться автоматически. Если вам потребуется изменить параметры монтирования тома, который монтируется с использованием кэшированного пароля, или избранного тома в меню Избранное, то при щелчке по кнопке Смонтировать удерживайте нажатой клавишу Control (Ctrl), либо выберите команду Смонтировать том с параметрами в меню Тома.

Параметры монтирования, принимаемые по умолчанию, устанавливаются в основных настройках программы (Настройки > Параметры).

Монтировать как том только для чтения

Если включено, смонтированный том будет недоступен для записи данных.

Монтировать том как сменный носитель

См. раздел Том, смонтированный как сменный носитель.

По возможности применять копию заголовка, встроенную в том

Все тома, созданные с помощью VeraCrypt, содержат встроенную резервную копию заголовка (расположенную в конце тома). Если вы включите эту опцию, программа попытается смонтировать том, используя встроенную резервную копию заголовка. Обратите внимание, что если заголовок тома повреждён, применять данную опцию не нужно. Вместо этого можно восстановить заголовок, выбрав Сервис > Восстановить заголовок тома.

Монтировать раздел с шифрованием ОС без предзагрузочной аутентификации

Включите этот параметр, если нужно смонтировать раздел, входящий в область действия шифрования системы, без предзагрузочной аутентификации. Пример: вы хотите смонтировать раздел, расположенный на зашифрованном системном диске с другой ОС, которая сейчас не запущена. Это может понадобиться, скажем, когда требуется создать резервную копию или восстановить операционную систему, зашифрованную с помощью VeraCrypt (из другой операционной системы). Обратите внимание, что эту опцию также можно включить при использовании функций Автомонтирование и Автомонтирование всех томов на основе устройств.

Защита скрытых томов

См. раздел Защита скрытых томов от повреждений.


Документация >> Чем обычное размонтирование отличается от принудительного

Чем обычное размонтирование отличается от принудительного

Важно понимать различия между операциями Обычное размонтирование и Принудительное размонтирование, так как это потенциально влияет на пользовательские данные.

Обычное размонтирование

Во время обычного размонтирования VeraCrypt выполняет следующие действия:

  1. Даёт запрос операционной системе Windows заблокировать том, запрещая дальнейшие операции ввода-вывода.
  2. Даёт запрос Windows аккуратно изъять том из системы. Этот шаг аналогичен выполняемому пользователем извлечению устройства через область уведомлений в панели задач.
  3. Указывает диспетчеру монтирования Windows размонтировать том.
  4. Удаляет связь между буквой диска и виртуальным устройством тома.
  5. Удаляет виртуальное устройство тома и стирает ключи шифрования из ОЗУ.

В этой последовательности действий шаги 1 и 2 могут завершиться ошибкой, если в томе есть открытые файлы. Имейте в виду, что даже если все пользовательские приложения, обращающиеся к файлам на томе, закрыты, Windows может по-прежнему держать файлы открытыми до тех пор, пока не будет полностью очищен кэш ввода-вывода.

Принудительное размонтирование

Процесс принудительного размонтирования хотя и отличается, но во многом он похож на обычное размонтирование. По сути, выполняются те же действия, но игнорируются любые сбои, которые могут возникнуть на шагах 1 и 2, после чего продолжается остальная часть процедуры. Однако если есть файлы, открытые пользователем, или ещё не очищен кэш ввода-вывода тома, это может привести к потенциальной потере данных. Эта ситуация аналогична принудительному удалению USB-устройства из компьютера, когда Windows всё ещё сообщает, что оно используется.

Если все приложения, использующие файлы на подключённом томе, были успешно закрыты, а кэш ввода-вывода полностью очищен, то при выполнении принудительного размонтирования не должно происходить ни потери данных, ни повреждения данных или файловой системы. Как и при обычном размонтировании, после успешного завершения принудительного размонтирования ключи шифрования стираются из ОЗУ.

Как выполнить принудительное размонтирование

В VeraCrypt есть три способа выполнить принудительное размонтирование:

  1. Через всплывающее окно, которое появляется, если не удалась попытка обычного размонтирования.
  2. Через настройки программы, включив опцию Принудительное авторазмонтирование даже при открытых файлах или папках в группе параметров Автоматическое размонтирование.
  3. Через командную строку, указав ключ /force или /f вместе с ключом /u или /unmount.

Во избежание непреднамеренной потери или повреждения данных всегда соблюдайте следующие меры предосторожности при размонтировании тома VeraCrypt:

  1. Перед размонтированием убедитесь, что все файлы на томе закрыты.
  2. После закрытия всех файлов не спешите, дайте Windows некоторое время, чтобы полностью очистился кэш ввода-вывода.
  3. Учтите, что некоторые антивирусные программы после сканирования могут оставлять дескрипторы файлов в томе открытыми, препятствуя обычному размонтированию. Если возникает такая проблема, попробуйте исключить том VeraCrypt из сканирования антивирусным ПО. Кроме того, проконсультируйтесь с поставщиком вашего антивируса, чтобы понять, как его продукт взаимодействует с томами VeraCrypt и как убедиться, что он не удерживает открытыми дескрипторы файлов.


Документация >> О рисках, связанных со сторонними расширениями файлов

Понимание рисков использования сторонних расширений файлов с VeraCrypt

Хотя VeraCrypt обеспечивает надёжные возможности шифрования для защиты ваших данных, использование сторонних расширений файлов для файловых контейнеров или ключевых файлов может привести к риску сделать зашифрованные данные недоступными.
В этом руководстве содержится подробное объяснение связанных с этим рисков и излагаются рекомендации, как их снизить.

Риски, связанные с файловыми контейнерами

Использование стороннего расширения файла для файловых контейнеров подвергает вас нескольким рискам:

  • ПЕРЕЗАПИСЬ МЕТАДАННЫХ: Обновление метаданных сторонними приложениями может привести к перезаписи важных частей файлового контейнера.
  • НЕПРЕДНАМЕРЕННЫЕ ИЗМЕНЕНИЯ: Случайный запуск файлового контейнера с помощью стороннего приложения может привести к изменению его метаданных без вашего согласия.
  • ПОВРЕЖДЕНИЕ КОНТЕЙНЕРА: Эти действия могут сделать контейнер нечитаемым или непригодным для использования.
  • ПОТЕРЯ ДАННЫХ: Данные внутри контейнера могут быть безвозвратно потеряны, если контейнер будет повреждён.

Риски, связанные с ключевыми файлами

Аналогичные риски связаны с ключевыми файлами:

  • ПОВРЕЖДЕНИЕ КЛЮЧЕВОГО ФАЙЛА: Непреднамеренное изменение ключевого файла с помощью стороннего приложения может сделать его непригодным для расшифровки.
  • ПЕРЕЗАПИСЬ ДАННЫХ: Сторонние приложения могут перезаписать ту часть ключевого файла, которую VeraCrypt использует для расшифровки.
  • НЕПРЕДНАМЕРЕННЫЕ ИЗМЕНЕНИЯ: Случайные изменения могут сделать невозможным монтирование тома, если у вас нет неизменённой резервной копии ключевого файла.

Примеры расширений, которых следует избегать

Избегайте использования следующих типов сторонних расширений файлов:

  • МЕДИАФАЙЛЫ: Изображения, аудио- и видеофайлы подвержены изменениям метаданных соответствующим программным обеспечением.
  • АРХИВЫ: Файлы ZIP, RAR, 7z могут быть легко изменены, из-за чего нарушится работа зашифрованного тома.
  • ИСПОЛНЯЕМЫЕ ФАЙЛЫ: Эти файлы могут изменяться в результате обновления программного обеспечения, что делает их ненадёжными в качестве файловых контейнеров или ключевых файлов.
  • ФАЙЛЫ ДОКУМЕНТОВ: Файлы Office и PDF могут автоматически обновляться программным обеспечением, что делает их использование рискованным.

Рекомендации

Для безопасного использования примите к сведению следующие рекомендации:

  • Используйте нейтральные расширения файлов для файловых контейнеров и ключевых файлов, чтобы свести к минимуму риск автоматической ассоциации файлов.
  • Храните резервные копии файловых контейнеров и ключевых файлов в защищённых местах, изолированных от доступа по сети.
  • Отключите автоматическое открытие для определённых расширений файлов, которые вы используете для файловых контейнеров VeraCrypt и ключевых файлов.
  • Всегда перепроверяйте ассоциации файлов и будьте осторожны при использовании нового устройства или стороннего приложения.


Документация >> Распараллеливание

Распараллеливание

Если компьютер оснащён многоядерным процессором (или несколькими процессорами), VeraCrypt при операциях шифрования и дешифрования использует все ядра (или процессоры) параллельно. Например, когда нужно расшифровать порцию данных, сначала эта порция делится им на несколько более мелких частей. Количество частей равно числу ядер (или процессоров). Затем все части расшифровываются параллельно (часть 1 расшифровывается потоком 1, часть 2 – потоком 2, и т. д.). Тот же метод применяется и при шифровании.
Таким образом, если в компьютере установлен, скажем, 4-ядерный процессор, шифрование и дешифрование будут выполняться в четыре раза быстрее, чем при использовании одноядерного процессора с эквивалентными характеристиками (соответственно, в два раза быстрее, чем с помощью 2-ядерного процессора, и т. д.).
Увеличение скорости шифрования/дешифрования прямо пропорционально числу ядер и/или процессоров.
Примечание. Процессоры с технологией Hyper-Threading имеют несколько логических ядер на одном физическом ядре (или несколько логических процессоров в одном физическом процессоре). Если в настройках компьютера (например, в BIOS) включена технология Hyper-Threading, VeraCrypt создаёт по одному потоку на каждое логическое ядро/процессор. Так, скажем, на 6-ядерном процессоре, имеющим на одном физическом ядре по два логических, VeraCrypt использует 12 потоков.

Если компьютер имеет многоядерный процессор (или несколько процессоров), также параллельно выполняется и формирование ключа заголовка. В результате при использовании многоядерного ЦП (или многопроцессорного ПК) монтирование тома происходит в несколько раз быстрее, чем при использовании одноядерного ЦП (или однопроцессорного ПК) с аналогичными характеристиками.


Документация >> Конвейеризация

Конвейеризация

При шифровании или дешифровании данных VeraCrypt использует так называемую конвейеризацию (асинхронную обработку, pipelining). Когда какое-либо приложение загружает часть файла из зашифрованного с помощью VeraCrypt тома/диска, VeraCrypt автоматически расшифровывает её (в ОЗУ). Благодаря конвейеризации, приложению не нужно ждать расшифровки любой части файла, оно может начать загружать другие части файла немедленно. То же самое относится к шифрованию при записи данных в зашифрованный том/диск.
Конвейеризация позволяет считывать и записывать данные на зашифрованном диске так же быстро, как если бы диск не был зашифрован (это применимо к томам VeraCrypt и на основе файла-контейнера, и на основе раздела).*
Примечание. Конвейеризация реализована только в версиях VeraCrypt для Windows.

* Некоторые твердотельные накопители (SSD) сжимают данные своими внутренними средствами, что выглядит как увеличение фактической скорости чтения/записи, когда данные поддаются сжатию (например, текстовые файлы). Однако зашифрованные данные не могут быть сжаты (поскольку они состоят исключительно из случайного "шума" без каких-либо сжимаемых шаблонов). Это может иметь различные последствия. Например, программы для тестирования производительности, которые считывают или записывают сжимаемые данные (такие как последовательности нулей), будут сообщать о более низкой скорости на зашифрованных томах, чем на незашифрованных (чтобы избежать этого, используйте программы для тестирования производительности, которые считывают/записывают случайные или другие виды несжимаемых данных).


Документация >> Аппаратное ускорение

Аппаратное ускорение

Некоторые процессоры (ЦП) поддерживают аппаратное ускорение шифрования* AES, которое в этом случае выполняется, как правило, в 4-8 раз быстрее, чем чисто программное шифрование при использовании тех же процессоров.
По умолчанию VeraCrypt использует аппаратное ускорение AES на компьютерах, оснащённых процессорами, поддерживающими инструкции Intel AES-NI. В частности, VeraCrypt использует инструкции AES-NI** при выполнении так называемых AES-раундов (то есть основных частей алгоритма AES). Для генерирования ключей никакие инструкции AES-NI в VeraCrypt не применяются.
Примечание: по умолчанию VeraCrypt использует аппаратное ускорение AES также при загрузке зашифрованной системы Windows и при её выходе из состояния гибернации (при условии, что процессор поддерживает инструкции Intel AES-NI).
Чтобы выяснить, способен ли VeraCrypt использовать аппаратное ускорение AES в вашем компьютере, выберите Настройки > Производительность и драйвер и посмотрите, что написано в поле Процессор в этом ПК поддерживает аппаратное ускорение AES-операций.
Если вы собираетесь приобрести процессор, то узнать, поддерживает ли он инструкции Intel AES-NI (также именуемые "AES New Instructions" – "Новые инструкции AES"), которые VeraCrypt применяет для аппаратного ускорения AES-операций, можно в документации на процессор или у поставщика/производителя. Кроме того, официальный список процессоров Intel, поддерживающих инструкции AES-NI, доступен здесь. Примите, однако, к сведению, что некоторые процессоры Intel, присутствующие в списке совместимых с AES-NI на сайте Intel, в действительности поддерживают инструкции AES-NI только с обновлением конфигурации процессора (например, i7-2630/2635QM, i7-2670/2675QM, i5-2430/2435M, i5-2410/2415M). В этом случае необходимо связаться с поставщиком системной платы/компьютера и обновить системную BIOS, чтобы она включала новейшее обновление конфигурации процессора.
Если нужно отключить аппаратное ускорение AES (например, чтобы использовать только реализацию AES с полностью открытым исходным кодом), выберите Настройки > Производительность и драйвер и отключите опцию Ускорять (де)шифрование AES с помощью AES-инструкций процессора. Обратите внимание, что при изменении состояния этой опции нужно перезагрузить операционную систему, чтобы изменение режима подействовало на все компоненты VeraCrypt. Также учтите, что когда вы создаёте диск восстановления VeraCrypt (Rescue Disk), состояние этой опции записывается в Диск восстановления и используется при каждой загрузке с него (влияя на фазы перед загрузкой и начальной загрузки). Чтобы создать новый диск восстановления VeraCrypt, выберите Система > Создать Диск восстановления.

* В этой главе термин "шифрование" также означает и дешифрование.
** Эти инструкции включают AESENC, AESENCLAST, AESDEC, and AESDECLAST, и они выполняют следующие преобразования AES: ShiftRows, SubBytes, MixColumns, InvShiftRows, InvSubBytes, InvMixColumns и AddRoundKey (подробности об этих преобразованиях см. в [3]).


Документация >> Горячие клавиши

Горячие клавиши

Чтобы задать общесистемные горячие клавиши VeraCrypt, в меню Настройки выберите пункт Горячие клавиши. Обратите внимание, что горячие клавиши функционируют, только когда VeraCrypt запущен или работает в фоновом режиме.


Документация >> Ключевые файлы

Ключевые файлы

Ключевой файл это файл, чьё содержимое объединено с паролем (информацию о методе объединения ключевого файла с паролем см. в разделе Ключевые файлы, глава Технические подробности). Пока не будет предоставлен правильный ключевой файл, ни один том, использующий этот ключевой файл, не может быть смонтирован.
Использовать ключевые файлы необязательно. Тем не менее, их применение даёт ряд преимуществ. Ключевые файлы:
  • могут повысить стойкость защиты к атакам методом полного перебора (brute force), особенно при недостаточно надёжном пароле тома;
  • позволяют использовать токены безопасности и смарт-карты (см. ниже);
  • позволяют нескольким пользователям монтировать один том, используя разные пароли или пин-коды: просто снабдите каждого пользователя токеном безопасности или смарт-картой, содержащими один и тот же ключевой файл VeraCrypt, и позвольте им выбрать свой собственный пароль или пин-код для защиты их токенов безопасности или смарт-карт;
  • позволяют управлять многопользовательским совместным доступом (все владельцы ключевых файлов должны их предоставить, прежде чем том можно будет смонтировать).

Обратите внимание, что VeraCrypt никогда не изменяет содержимое ключевых файлов. Разрешается выбирать более одного ключевого файла; их последовательность не имеет значения. Кроме того, ключевой файл со случайным содержимым может сгенерировать и непосредственно VeraCrypt. Чтобы это сделать, выберите Сервис > Генератор ключевых файлов.
Примечание. Ключевые файлы в настоящее время не поддерживаются для шифрования системы.
ВНИМАНИЕ: Если вы потеряете ключевой файл или в ключевом файле будет изменён хотя бы один бит в первых 1024 килобайтах, то не сможете монтировать тома, использующие этот ключевой файл!
ПРЕДУПРЕЖДЕНИЕ: Если включено кэширование паролей, то в кэше паролей также будет сохраняться содержимое ключевых файлов, использованных для успешного монтирования тома. После этого том можно будет повторно монтировать даже в случае отсутствия/недоступности ключевого файла. Чтобы этого избежать, нажмите Очистить кэш или отключите кэширование паролей (см. подробности в подразделе Настройки > Параметры, пункт Кэшировать пароли в памяти драйвера в разделе Меню программы).
См. также раздел Выбор паролей и ключевых файлов, глава Требования безопасности и меры предосторожности.

Диалоговое окно ключевых файлов

Если вы хотите использовать ключевые файлы (то есть "применять" их) при создании/монтировании томов или изменении паролей, ищите опцию и кнопку Ключевые файлы ниже поля ввода пароля.
VeraCrypt Keyfiles dialog
Эти управляющие элементы присутствуют в разных диалоговых окнах, но всегда выполняют одинаковые функции. Включите опцию Ключевые файлы и нажмите кнопку Ключевые файлы. должно появиться диалоговое окно, в котором вы сможете указать ключевые файлы (чтобы это сделать, нажмите кнопку Файлы или Токен-файлы) или путь поиска ключевых файлов (нажмите кнопку Путь).

Токены безопасности и смарт-карты

VeraCrypt может непосредственно использовать ключевые файлы, находящиеся на токенах безопасности или на смарт-картах, соответствующих стандарту PKCS #11 (2.0 или новее) [23], что позволяет пользователю хранить файл (объект данных) на токене/карте. Чтобы использовать такие файла в качестве ключевых файлов VeraCrypt, нажмите кнопку Токен-файлы (в диалоговом окне ключевых файлов).
Доступ к хранящемуся в токене безопасности или смарт-карте ключевому файлу, как правило, защищён пин-кодами, которые можно ввести либо с аппаратной цифровой клавиатуры ("пинпада"), либо из интерфейса VeraCrypt. Кроме того, возможны и другие методы защиты, например, сканирование отпечатков пальцев.
Чтобы предоставить VeraCrypt доступ с токену безопасности или смарт-карте, необходимо сначала установить программную библиотеку PKCS #11 (2.0 или новее) для этого токена или смарт-карты. Такая библиотека может либо поставляться вместе с устройством, либо её нужно загрузить с сайта поставщика или других сторонних фирм.
Если в токене безопасности или смарт-карте нет файлов (объектов данных) для использования как ключевых файлов VeraCrypt, можно импортировать любой файл на токен безопасности или смарт-карту (если это поддерживается устройством) с помощью VeraCrypt. Для этого:
  1. В диалоговом окне ключевых файлов нажмите кнопку Токен-файлы.
  2. Если токен или смарт-карта защищены пин-кодом, паролем или иным способом (например, сканером отпечатков пальцев), идентифицируйте себя (например, введя пин-код на пинпаде).
  3. В появившемся диалоговом окне Ключевые файлы токена безопасности нажмите Импорт кл.файла в токен и выберите файл, который вы хотите импортировать в токен или смарт-карту.
Обратите внимание, что можно импортировать, например, 512-битовые ключевые файлы со случайным содержимым, созданные с помощью VeraCrypt (см. ниже Сервис > Генератор ключевых файлов).
Чтобы закрыть все открытые сеансы токена безопасности, либо выберите Сервис > Закрыть все токен-сессии, либо задайте и используйте комбинацию горячих клавиш (Настройки > Горячие клавиши > Закрыть все токен-сессии).

Смарт-карты EMV

Версии VeraCrypt для Windows и Linux могут напрямую использовать в качестве ключевых файлов данные, извлечённые из совместимых со стандартом EMV (Europay+Mastercard+Visa) смарт-карт, поддерживающих приложения Visa, Mastercard и Maestro. Как и в случае со смарт-картами, совместимыми с PKCS-11, чтобы использовать такие данные в качестве ключевых файлов VeraCrypt, нажмите кнопку Токен-файлы (в окне ключевых файлов). Отобразятся последние четыре цифры номера карты, что позволит выбрать карту в качестве источника ключевого файла.
Извлекаются и объединяются в один ключевой файл следующие данные: сертификат открытого ключа ICC, сертификат открытого ключа эмитента и жизненный цикл производства карт (CPLC). Они соответственно идентифицируются тегами "9F46", "90" и "9F7F" в системе управления данными карты. Эти два сертификата относятся к приложению, развёрнутому на карте EMV и используемому для динамической аутентификации данных карты во время банковских транзакций. Данные CPLC относятся к карте, а не к какому-либо из её приложений. Они содержат информацию о процессе производства смарт-карты. Поэтому и сертификаты, и данные уникальны и постоянны на любой смарт-карте, совместимой с EMV.
В соответствии со стандартом ISO/IEC 7816, на котором основан стандарт EMV, связь со смарт-картой EMV осуществляется с помощью структурированных команд, называемых APDU, позволяющих извлекать данные со смарт-карты. Эти данные закодированы в формате BER-TLV, определённом в стандарте ASN.1, и поэтому должны быть проанализированы перед объединением в ключевой файл. Для доступа и извлечения данных с карты не требуется PIN-код. Чтобы справиться с разнообразием считывателей смарт-карт, представленных на рынке, используются библиотеки, совместимые со стандартом связи Microsoft Personal Computer/Smart Card. Применяется библиотека Winscard. Изначально доступная в Windows в System32, она не требует установки в этой ОС. В Linux же необходимо установить пакет libpcsclite1.
Поскольку карта доступна только для чтения, импортировать или удалить данные невозможно. Однако данные, используемые в качестве ключевых файлов, можно экспортировать локально в любой двоичный файл. В течение всего криптографического процесса монтирования или создания тома сертификаты и данные CPLC сохраняются только в оперативной памяти компьютера. После завершения процесса эти области памяти ОЗУ тщательно стираются.
Важно отметить, что эта функция не является обязательной и по умолчанию отключена. Её можно включить в настройках токенов безопасности.

Путь поиска ключевых файлов

Добавив папку в диалоговом окне ключевых файлов (для этого нажмите кнопку Путь), можно указать путь поиска ключевых файлов. Все файлы, обнаруженные в пути поиска ключевых файлов*, будут использоваться как ключевые, за исключением тех, у которых установлен атрибут Скрытый.
ВАЖНО: Обратите внимание, что папки (и содержащиеся в них файлы), найденные в путях поиска ключевых файлов, игнорируются.
Пути поиска ключевых файлов особенно удобны, если вы, например, храните ключевые файлы на USB-накопителе (флешке), который всегда носите с собой. В этом случае можно назначить букву диска USB-накопителя как путь поиска ключевых файлов, принимаемый по умолчанию. Чтобы это сделать, выберите Настройки > Ключевые файлы по умолчанию. Затем нажмите кнопку
Путь, укажите букву диска, присвоенную USB-накопителю, и нажмите OK. Теперь при каждом монтировании тома (при условии, что в окне ввода пароля включена опция Ключевые файлы), VeraCrypt будет просматривать этот путь и использовать все файлы, которые он обнаружит в USB-накопителе, как ключевые.
ВНИМАНИЕ: Когда вы добавляете в список ключевых файлов папку (в отличие от файла), запоминается только путь, но не имена файлов! Это означает, что, например, если создать в этой папке новый файл или скопировать в неё ещё один какой-либо файл, то все тома, которые используют ключевые файлы из этой папки, будет невозможно смонтировать (до тех пор, пока из папки не будет удалён этот новый файл).

Пустой пароль и ключевой файл

Если используется ключевой файл, то пароль может быть пустым, то есть ключевой файл может служить единственным элементом, необходимым для монтирования тома (чего мы делать не рекомендуем). Если при монтировании тома установлены ключевые файлы по умолчанию и включено их использование, то перед запросом пароля VeraCrypt сначала автоматически пытается выполнить монтирование с помощью пустого пароля и ключевых файлов по умолчанию (это, однако, не относится к функции Автомонтирование). Если нужно задать параметры монтирования (например, чтобы смонтировать том как доступный только для чтения, включить защиту скрытого тома и т. д.) для тома, который уже был смонтирован таким способом, то при щелчке по кнопке Монтировать удерживайте нажатой клавишу Control (Ctrl) (или выберите команду Смонтировать том с параметрами в меню Тома). Этим вы откроете диалоговое окно Параметры монтирования.

Быстрый выбор

Ключевые файлы или пути поиска ключевых файлов можно быстро выбирать следующими способами:
  • щёлкните правой кнопкой мыши на кнопке Ключевые файлы в окне ввода пароля и выберите один из пунктов в появившемся меню;
  • перетащите значки соответствующих файлов/папок в окно ключевых файлов или в окно ввода пароля.

Тома > Добавить/удалить ключевые файлы в/из том(а)

Эта функция позволяет перешифровать заголовок тома с ключом, сформированным из любого количества ключевых файлов (с паролем или без него) или вовсе без ключевых файлов. Так, том, для монтирования которого требуется только пароль, можно преобразовать в том, для монтирования которого нужны ключевые файлы (в дополнение к паролю). Обратите внимание, что в заголовке тома содержится мастер-ключ шифрования, с помощью которого зашифрован этот том. Поэтому после использования этой функции хранящиеся в томе данные не потеряются.
Эту функцию также можно использовать, чтобы изменить/установить ключевые файлы тома (то есть чтобы удалить некоторые или все ключевые файлы и применить новые).
Замечание: Эта функция внутренне равносильна функции смены пароля.

Когда VeraCrypt выполняет перешифрование заголовка тома, исходный заголовок сначала перезаписывается 256 раз случайными данными с целью помешать неприятелю воспользоваться такими технологическими способами, как магнитно-силовая микроскопия или магнитно-силовая сканирующая туннельная микроскопия [17] для восстановления перезаписанного заголовка (тем не менее см. также главу Требования безопасности и меры предосторожности).

Тома > Удалить из тома все ключевые файлы

Эта функция позволяет перешифровать заголовок тома с ключом, сформированным из пароля и без ключевых файлов (то есть чтобы для монтирования тома нужно было указывать только пароль, без каких-либо ключевых файлов). Обратите внимание, что в заголовке тома содержится мастер-ключ шифрования, с помощью которого зашифрован этот том. Поэтому после использования этой функции хранящиеся в томе данные не потеряются.
Замечание: Эта функция внутренне равносильна функции смены пароля.

Когда VeraCrypt выполняет перешифрование заголовка тома, исходный заголовок сначала перезаписывается 256 раз случайными данными с целью помешать неприятелю воспользоваться такими технологическими способами, как магнитно-силовая микроскопия или магнитно-силовая сканирующая туннельная микроскопия [17] для восстановления перезаписанного заголовка (тем не менее см. также главу Требования безопасности и меры предосторожности).

Сервис > Генератор ключевых файлов

Эта функция служит для генерирования файла со случайным содержимым, который можно (и рекомендуется) использовать как ключевой файл. В этой функции используется реализованный в VeraCrypt генератор случайных чисел. Обратите внимание, что размер результирующего файла всегда равен 64 байтам (то есть 512 битам), что также является максимально возможной длиной пароля VeraCrypt. Также можно сгенерировать несколько файлов и указать их размер (либо фиксированное значение для них всех, либо позволить VeraCrypt выбирать размеры файлов случайным образом). Во всех случаях размер файла должен составлять от 64 до 1 048 576 байт (что равно 1 МБ – максимальному количеству байтов в ключевом файле, обрабатываемых VeraCrypt).

Настройки > Ключевые файлы по умолчанию

Используйте эту функцию, чтобы установить используемые по умолчанию ключевые файлы и/или пути их поиска. Эта функция особенно удобна, если вы, например, храните ключевые файлы на USB-накопителе (флешке), который всегда носите с собой. В этом случае вы можете добавить его букву диска в используемую по умолчанию конфигурацию ключевых файлов. Чтобы это сделать, нажмите кнопку Путь, укажите букву диска, присвоенную USB-накопителю, и нажмите OK. Теперь при каждом монтировании тома (при условии, что в окне ввода пароля включена опция Ключевые файлы) VeraCrypt будет просматривать этот путь и использовать все файлы, которые он там обнаружит, как ключевые.

ВНИМАНИЕ: Когда вы добавляете в список ключевых файлов папку (в отличие от файла), запоминается только путь, но не имена файлов! Это означает, что, например, если создать в этой папке новый файл или скопировать в неё ещё один какой-либо файл, то все тома, которые используют ключевые файлы из этой папки, будет невозможно смонтировать (до тех пор, пока из папки не будет удалён этот новый файл).

ВАЖНО: Когда вы устанавливаете используемые по умолчанию ключевые файлы и/или пути поиска ключевых файлов, имена файлов и пути сохраняются в файле Default Keyfiles.xml в незашифрованном виде. См. подробности в главе Системные файлы VeraCrypt и программные данные .

* Обнаруженные при монтировании тома, смене его пароля или выполнении любой другой операции, связанной с повторным шифрованием заголовка тома.
** Если вы используете файл MP3 в качестве ключевого, то должны убедиться, что никакая программа не изменяет в нём теги ID3 (например, название песни, имя исполнителя и т. д.). В противном случае тома, использующие этот ключевой файл, будет невозможно смонтировать.


Документация >> Токены безопасности и смарт-карты

Токены безопасности и смарт-карты

VeraCrypt поддерживает токены безопасности (или криптографические токены) и смарт-карты, доступ к которым можно получить с помощью протокола PKCS #11 (2.0 или более поздней версии) [23]. См. подробности в разделе Токены безопасности и смарт-карты в главе Ключевые файлы.

Обратите внимание, что токены безопасности и смарт-карты в настоящее время не поддерживаются для предзагрузочной аутентификации шифрования системы.


Документация >> Портативный (переносной) режим

Портативный (переносной) режим

Программа VeraCrypt может работать в так называемом портативном (portable) режиме. Это означает, что её не нужно устанавливать в операционной системе, в которой она запускается. Тем не менее, при этом нужно помнить о паре вещей:

  1. Чтобы запустить VeraCrypt в портативном режиме, необходимо иметь права администратора компьютера (причины этого см. в главе Использование VeraCrypt без прав администратора).
    Примечание. Независимо от того, какое ПО вы используете, если говорить о защите личных данных, в большинстве случаев небезопасно работать с конфиденциальной информацией в системе, где у вас нет привилегий администратора, так как администратор может без труда получить и скопировать ваши конфиденциальные данные, в том числе пароли и ключи.
  2. Даже если использовался портативный режим, исследовав файл реестра, можно выяснить, что в Windows запускался VeraCrypt (и что монтировался том VeraCrypt).

Примечание. Если для вас это проблема, см. данный вопрос в FAQ.

Запускать VeraCrypt в портативном режиме можно двумя способами:

  1. Извлечь файлы из самораспаковывающегося дистрибутивного пакета VeraCrypt и запустить файл VeraCrypt.exe.
    Чтобы извлечь файлы из самораспаковывающегося дистрибутивного пакета VeraCrypt, запустите его и выберите на второй странице мастера установки опцию Извлечь (вместо Установить).
  2. Воспользоваться средством настройки Переносного диска, чтобы подготовить специальный носимый с собой диск и запускать VeraCrypt с него.

Второй вариант имеет ряд преимуществ, описанных ниже в этой главе.

Примечание. При работе в переносном (portable) режиме драйвер VeraCrypt выгружается, когда он больше не нужен (например, когда закрыты все копии главного приложения и/или мастера создания томов и нет смонтированных томов). Однако если вы принудительно размонтируете том VeraCrypt, когда VeraCrypt запущен в переносном режиме, или смонтируете доступный для записи том с файловой системой NTFS в Vista или более новой версии Windows, драйвер VeraCrypt может не выгрузиться при выходе из VeraCrypt (он будет выгружен только при завершении работы системы или её перезагрузке). Это предотвращает различные проблемы, вызванные ошибкой в ​​Windows (например, было бы невозможно снова запустить VeraCrypt, пока есть приложения, использующие размонтированный том).

Сервис > Настройка Переносного диска

Эта функция позволяет подготовить специальный носимый с собой диск и запускать оттуда VeraCrypt. Обратите внимание, что такой "переносной диск" это не том VeraCrypt, а незашифрованный том. "Переносной диск" исполняемые файлы VeraCrypt и, при необходимости, скрипт autorun.inf (см. ниже раздел Настройка автозапуска (файл autorun.inf)). При выборе Сервис > Настройка Переносного диска появится окно Настройка Переносного диска. Далее описаны некоторые параметры в этом окне, нуждающиеся в пояснении.

С мастером создания томов VeraCrypt

Включите эту опцию, если вам нужно создавать новые тома VeraCrypt с помощью VeraCrypt, запускаемого с этого Переносного диска. Отключение этой опции экономит место на Переносном диске.

Настройка автозапуска (файл autorun.inf)

Данная группа параметров позволяет настроить Переносной диск для автоматического запуска VeraCrypt или монтирования указанного тома VeraCrypt при вставке диска. Это достигается путём создания на Переносном диске специального файла сценария (скрипта) с именем ‘autorun.inf’. Этот файл автоматически запускается операционной системой каждый раз, когда вставляется Переносной диск.

Обратите, однако, внимание, что данная функция работает лишь с такими сменными носителями, как диски CD/DVD (для работы с USB-флешками требуется Windows XP SP2, Vista или более новая версия Windows), и только если это разрешено в операционной системе. В зависимости от конфигурации операционной системы эти функции автозапуска и автомонтирования могут работать только в том случае, если файлы Переносного диска созданы на недоступном для записи CD/DVD-подобном носителе (это не ошибка в VeraCrypt, а ограничение Windows).

Также примите к сведению, что файл autorun.inf должен находиться в корневой папке (то есть, например, в G:\, X:\, Y:\ и т. д.) на незашифрованном диске, иначе эта функция не будет работать.


Документация >> Поддержка TrueCrypt

Поддержка TrueCrypt

ВНИМАНИЕ: Начиная с версии 1.26, поддержка TrueCrypt прекращена.

VeraCrypt (начиная с версии 1.0f) поддерживает загрузку томов и разделов TrueCrypt , как обычных, так и скрытых. Чтобы активировать эту функцию, включите опцию Режим TrueCrypt в окне запроса пароля, как показано ниже.

Примечание. Поддерживаются только тома и разделы, созданные с помощью TrueCrypt версий 6.x и 7.x.


Документация >> Преобразование томов и разделов TrueCrypt в формат VeraCrypt

Преобразование томов и разделов TrueCrypt в формат VeraCrypt

⚠️ Внимание: После преобразования убедитесь, что опция "Режим TrueCrypt" не выбрана при монтировании преобразованного тома. Поскольку это больше не том TrueCrypt, его монтирование с этой опцией приведет к сбою монтирования.

⚠️ Важное уведомление: Начиная с версии 1.26, в VeraCrypt была удалена поддержка "Режима TrueCrypt". Таким образом, конвертация томов и разделов TrueCrypt с использованием этого метода больше невозможна. Пожалуйста, обратитесь к этой странице документации для получения инструкций по работе с томами TrueCrypt в версиях VeraCrypt 1.26 и выше.

Начиная с версии 1.0f и до версии 1.25.9 включительно, в VeraCrypt можно преобразовывать тома и несистемные разделы TrueCrypt (созданные версиями 6.x и 7.x, начиная с версии 6.0, выпущенной 4 июля 2008 года) в формат VeraCrypt. Для этого выполните с томом или разделом любое из следующих действий:

  • Измените пароль тома
  • Задайте алгоритм формирования ключа заголовка
  • Добавьте или удалите ключевые файлы
  • Удалите все ключевые файлы

Если том TrueCrypt содержит скрытый том, его также следует преобразовать аналогичным образом, указав пароль скрытого тома и/или ключевые файлы.

🚨 После преобразования файлового контейнера его расширение останется .tc. При необходимости вручную измените его на .hc, чтобы версии VeraCrypt 1.26 или новее автоматически его распознавали.

При этом должна быть включена опция Режим TrueCrypt, как показано на иллюстрации:

Примечание. Преобразование системных разделов, зашифрованных с помощью TrueCrypt, не поддерживается.


VeraCrypt - Руководство по преобразованию томов для версий 1.26 и новее

Документация >> Руководство по преобразованию томов для версий 1.26 и новее

Руководство по преобразованию томов для версий 1.26 и новее

1. Введение

В VeraCrypt версии 1.26 и новее внесены значительные изменения, в том числе удалена поддержка некоторых функций. Если у вас возникли проблемы с монтированием томов, это руководство поможет вам разобраться и найти решение.

2. Устаревшие функции в VeraCrypt 1.26 и новее

Удалены следующие функции:

  • Режим TrueCrypt
  • Хеш-алгоритм HMAC-RIPEMD-160
  • Алгоритм шифрования GOST89

Если возникают ошибки при монтировании томов, созданных в VeraCrypt версии 1.25.9 или старее, используйте VeraCrypt 1.25.9, чтобы проверить, используются ли в томах устаревшие функции. Выделите том и нажмите "Свойства тома" в интерфейсе для проверки.

3. Процедуры устранения проблем в зависимости от версии

3.1 Сценарий 1: Использование VeraCrypt 1.25.9 или старее

Если вы используете VeraCrypt 1.25.9 или можете обновиться до этой версии, выполните следующие действия:

  • Преобразуйте тома TrueCrypt в тома VeraCrypt
  • Измените устаревший хеш-алгоритм HMAC-RIPEMD-160 на другой
  • Воссоздайте том VeraCrypt заново, если используется алгоритм шифрования GOST89

Загрузите версию 1.25.9 здесь.

3.2 Сценарий 2: Использование VeraCrypt версии 1.26 и новее

Если вы уже используете VeraCrypt версии 1.26 или новее, выполните следующие действия:

  • Преобразуйте тома TrueCrypt в тома VeraCrypt
  • Измените устаревший хеш-алгоритм HMAC-RIPEMD-160 на другой

Если вы используете Linux или macOS, временно понизьте версию VeraCrypt до 1.25.9. Пользователи Windows могут использовать инструмент VCPassChanger, доступный для загрузки здесь.

  • Воссоздайте том VeraCrypt заново, если используется алгоритм шифрования GOST89

Для всех операционных систем временно понизьте версию VeraCrypt до 1.25.9.

4. Процедуры преобразования и устранения проблем

4.1 Преобразование файлов-контейнеров и разделов TrueCrypt в формат VeraCrypt

Файлы-контейнеры и разделы TrueCrypt, созданные с помощью TrueCrypt версий 6.x и 7.x, можно преобразовать в формат VeraCrypt с помощью VeraCrypt версии 1.25.9 или инструмента VCPassChanger в Windows. См. дополнительную информацию в документации.

После преобразования расширение файла останется тем же — .tc. Измените его на .hc вручную, если хотите, чтобы файл автоматически распознавался VeraCrypt версии 1.26 и новее.

4.2 Изменение устаревшего хеш-алгоритма HMAC-RIPEMD-160

Используйте функцию "Изменить алгоритм формирования ключа заголовка", чтобы заменить хеш-алгоритм HMAC-RIPEMD-160 на поддерживаемый в VeraCrypt версии 1.26. См. дополнительные сведения в документации.

4.3 Повторное создание тома VeraCrypt, если использован алгоритм шифрования GOST89

Если в томе используется шифрование GOST89, скопируйте данные в другое место и заново создайте том, выбрав поддерживаемый алгоритм шифрования. Дополнительные сведения по алгоритмам шифрования см. в документации.

5. Важные примечания

Примечание для пользователей, создавших тома с помощью VeraCrypt версии 1.17 или старее:

Чтобы избежать раскрытия информации о том, содержат ли ваши тома скрытый раздел, или если вы полагаетесь на правдоподобное отрицание, необходимо заново создать как внешний, так и скрытый тома, включая шифрование системы и скрытую ОС. Удалите тома, созданные в VeraCrypt версий до 1.18a.

См. дополнительную информацию в разделах:

  • Поддержка TrueCrypt
  • Преобразование томов и разделов TrueCrypt в формат VeraCrypt


Документация >> Параметры монтирования по умолчанию

Параметры монтирования по умолчанию

Начиная с версии 1.0f-2 стало возможным указывать алгоритм PRF и режим TrueCrypt выбранными по умолчанию в окне пароля.

Как показано ниже, выберите пункт Параметры монтирования по умолчанию в меню Настройки:

Menu Default Mount Parameters

Появится следующее окно:

Default Mount Parameters Dialog

Внесите нужные вам изменения и нажмите OK.

Выбранные значения затем будут записаны в основной конфигурационный файл VeraCrypt (Configuration.xml), что сделает их постоянными.

Во всех последующих диалоговых окнах запроса пароля будут использоваться значения по умолчанию, выбранные ранее. Например, если в окне параметров монтирования по умолчанию вы установите флажок Режим TrueCrypt и выберете SHA-512 в качестве PRF, то последующие окна ввода пароля будут выглядеть следующим образом:
Mount Password Dialog using default values

Примечание. Параметры монтирования по умолчанию могут быть переопределены в командной строке ключами /tc и /hash, которые всегда имеют приоритет.


Документация >> Языковые пакеты

Языковые пакеты

Языковые пакеты содержат переводы текстов интерфейса VeraCrypt, выполненные сторонними лицами. В настоящий момент языковые пакеты поддерживаются только версией VeraCrypt для Windows.

Установка

Начиная с версии 1.0e, все языковые пакеты входят в установщик VeraCrypt для Windows, после установки они находятся в папке с VeraCrypt. Чтобы переключить язык в программе, запустите VeraCrypt, выберите Settings > Language (Настройки > Язык), выделите нужный язык и нажмите OK.
Чтобы вернуть английский язык, выберите Настройки > Язык. Выделите English и нажмите OK.
Архив, содержащий все языковые пакеты для новейшей версии, можно скачать отсюда.


Документация >> Алгоритмы шифрования

Алгоритмы шифрования

Для шифрования томов VeraCrypt можно использовать следующие алгоритмы:
Алгоритм | Разработчик(и) | Размер ключа (бит) | Размер блока (бит) | Режим работы
AES | J. Daemen, V. Rijmen | 256 | 128 | XTS
Camellia | Японские Mitsubishi Electric и NTT | 256 | 128 | XTS
Kuznyechik | Национальный стандарт Российской Федерации ГОСТ Р 34.12-2015 | 256 | 128 | XTS
Serpent | R. Anderson, E. Biham, L. Knudsen | 256 | 128 | XTS
SM4 | Центр обеспечения безопасности данных и коммуникаций, Китайская академия наук GB/T 32907-2016 | 128 | 128 | XTS
Twofish | B. Schneier, J. Kelsey, D. Whiting, D. Wagner, C. Hall, N. Ferguson | 256 | 128 | XTS
AES-Twofish |  | 256; 256 | 128 | XTS
AES-Twofish-Serpent |  | 256; 256; 256 | 128 | XTS
Camellia-Kuznyechik |  | 256; 256 | 128 | XTS
Camellia-Serpent |  | 256; 256 | 128 | XTS
Kuznyechik-AES |  | 256; 256 | 128 | XTS
Kuznyechik-Serpent-Camellia |  | 256; 256; 256 | 128 | XTS
Kuznyechik-Twofish |  | 256; 256 | 128 | XTS
Serpent-AES |  | 256; 256 | 128 | XTS
Serpent-Twofish-AES |  | 256; 256; 256 | 128 | XTS
Twofish-Serpent |  | 256; 256 | 128 | XTS
SM4-Kuznyechik |  | 128; 256 | 128 | XTS
SM4-Serpent |  | 128; 256 | 128 | XTS
SM4-Twofish |  | 128; 256 | 128 | XTS
SM4-Twofish-Serpent |  | 128; 256; 256 | 128 | XTS
Информацию о режиме XTS см. в разделе Режимы работы.
Следующий раздел >>


Документация >> Алгоритмы шифрования >> AES

Алгоритм шифрования AES

Advanced Encryption Standard (AES) – это одобренный FIPS (Федеральные стандарты обработки информации) криптографический алгоритм (также известен как Rijndael, авторы: Joan Daemen и Vincent Rijmen, опубликован в 1998 году), разрешённый к применению федеральными ведомствами и учреждениями США для криптостойкой защиты секретной информации [3]. VeraCrypt использует AES с 14 раундами и 256-битовым ключом (то есть стандарт AES-256, опубликованный в 2001 году), работающий в режиме XTS (см. раздел Режимы работы).
В июне 2003 года, после того как Агентство национальной безопасности США (NSA, US National Security Agency) провело исследование и анализ AES, американский комитет CNSS (Committee on National Security Systems) объявил в [1], что реализация и надёжность AES-256 (и AES-192) достаточны для защиты секретной информации вплоть до уровня Top Secret («Совершенно секретно»). Это относится ко всем правительственным ведомствам и учреждениям США, намеревающимся приобрести или использовать продукты, включающие Advanced Encryption Standard (AES), для обеспечения требований информационной безопасности, относящейся к защите национальных систем безопасности и/или информации, связанной с госбезопасностью [1].
Следующий раздел >>


Документация >> Алгоритмы шифрования >> Camellia

Алгоритм шифрования Camellia

Совместная разработка Mitsubishi Electric и NTT of Japan. Camellia это шифр с блоками размером 128 бит, впервые опубликованный в 2000 году. Одобрен к использованию ISO/IEC, проектом NESSIE Евросоюза и японским проектом CRYPTREC.
В VeraCrypt используется шифр Camellia с 24 раундами и 256-битовым ключом, работающий в режиме XTS (см. раздел Режимы работы).
Следующий раздел >>


Документация >> Алгоритмы шифрования >> Kuznyechik («Кузнечик»)

Алгоритм шифрования Kuznyechik

Kuznyechik («Кузнечик») – это алгоритм блочного шифрования с размером блока 128 бит. Впервые опубликован в 2015 году и определён в Национальном стандарте Российской Федерации ГОСТ Р 34.12-2015, а также здесь. Он заменяет старый блочный шифр ГОСТ-89, хотя и не делает его устаревшим.

В VeraCrypt используется «Кузнечик» с 10 раундами и 256-битовым ключом, работающий в режиме XTS (см. раздел Режимы работы).

Следующий раздел >>


Документация >> Алгоритмы шифрования >> Serpent

Алгоритм шифрования Serpent

Разработан Ross Anderson, Eli Biham и Lars Knudsen; опубликован в 1998 году. Использует ключ длиной 256 бит и 128-битовые блоки, работает в режиме XTS (см. раздел Режимы работы). Serpent был одним из финалистов конкурса AES. В результате голосования он занял второе место, уступив алгоритму AES (Rijndael), несмотря на то, что у него был более высокий запас безопасности, чем у победившего Rijndael [4]. Говоря конкретнее, у Serpent был высокий запас безопасности, в то время как у Rijndael этот запас только достаточный [4]. Кроме того, в адрес алгоритма Rijndael раздавались критические замечания о том, что его математическая структура в будущем может привести к атакам [4].

В документе [5] команда Twofish представила таблицу запаса прочности финалистов конкурса AES. Запас прочности определялся следующим образом: число раундов полного шифра делилось на наибольшее число раундов, которые были взломаны. Следовательно, взломанный шифр имеет наименьший запас прочности, равный 1. Среди финалистов конкурса AES наибольший запас прочности оказался у Serpent: 3,56 (для всех поддерживаемых размеров ключей). Запас прочности алгоритма Rijndael-256 составил 1,56.

Несмотря на эти факты, победителем в конкурсе AES был выбран всё-таки Rijndael за его сочетание безопасности, производительности, эффективности, возможностей реализации и гибкости [4]. На последней конференции кандидатов AES алгоритм Rijndael получил 86 голосов, Serpent – 59, Twofish – 31, RC6 – 23, и MARS – 13 голосов [18, 19].*

* Это положительные голоса. Если вычесть отрицательные голоса, то получаются следующие результаты: Rijndael: 76 голосов, Serpent: 52 голоса, Twofish: 10 голосов, RC6: -14 голосов, MARS: -70 голосов [19].

Следующий раздел >>


Документация >> Алгоритмы шифрования >> SM4

Алгоритм шифрования SM4

SM4 — это блочный шифр с блоками размером 128 бит, разработанный и опубликованный Национальным управлением по криптографии Китая в 2006 году как часть стандарта GB/T 32907-2016. Является национальным стандартом шифрования для защиты беспроводных коммуникаций (например, Wi-Fi) и других защищённых систем связи в Китае. Использует 128-битовый ключ.
Алгоритм SM4 использует 32 раунда операций шифрования, основанных на сочетании нелинейной подстановки, линейного преобразования и добавления ключа. По своей структуре в некоторых аспектах схож с другими современными блочными шифрами, применяя S-блок для подстановки и линейное преобразование для диффузии.
SM4 официально стандартизирован ISO/IEC (ISO/IEC 18033-3:2010) и широко используется в государственных, банковских и коммерческих приложениях по всему Китаю. Оптимизирован как для программных, так и для аппаратных реализаций, обеспечивая высокую производительность при сильной криптографической стойкости.
В VeraCrypt используется шифр SM4 с 32 раундами и 128-битовым ключом, работающий в режиме XTS (см. раздел Режимы работы).
Следующий раздел >>


Документация >> Алгоритмы шифрования >> Twofish

Алгоритм шифрования Twofish

Авторы – Bruce Schneier, John Kelsey, Doug Whiting, David Wagner, Chris Hall и Niels Ferguson; алгоритм опубликован в 1998 году. Использует ключ длиной 256 бит и блок размером 128 бит, работает в режиме XTS (см. раздел Режимы работы). Twofish был одним из финалистов конкурса AES. Отличительная особенность – применение зависящих от ключа S-блоков. Twofish можно рассматривать как совокупность 2128 различных криптосистем, где выбором криптосистемы управляют 128 бит, формируемые из 256-битового ключа [4]. В документе [13] команда Twofish утверждает, что зависимые от ключа S-блоки представляют собой форму запаса безопасности против неизвестных атак [4].

Следующий раздел >>


Документация >> Алгоритмы шифрования >> Каскады шифров

Каскады шифров

AES-Twofish

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Twofish (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом AES (с ключом размером 256 бит) также в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

AES-Twofish-Serpent

Последовательно выполняемые (каскадом) [15, 16] три шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS, затем алгоритмом Twofish (с ключом размером 256 бит) в режиме XTS, и, наконец, алгоритмом AES (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Camellia-Kuznyechik

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Kuznyechik (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом Camellia (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Camellia-Serpent

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом Camellia (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Kuznyechik-AES

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом AES (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом Kuznyechik (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Kuznyechik-Serpent-Camellia

Последовательно выполняемые (каскадом) [15, 16] три шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Camellia (с ключом размером 256 бит) в режиме XTS, затем алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS, и, наконец, алгоритмом Kuznyechik (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Kuznyechik-Twofish

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Twofish (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом Kuznyechik (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Serpent-AES

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом AES (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Serpent-Twofish-AES

Последовательно выполняемые (каскадом) [15, 16] три шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом AES (с ключом размером 256 бит) в режиме XTS, затем алгоритмом Twofish (с ключом размером 256 бит) в режиме XTS, и, наконец, алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

Twofish-Serpent

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом Twofish (с ключом размером 256 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

SM4-Kuznyechik

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Kuznyechik (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом SM4 (с ключом размером 128 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

SM4-Serpent

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом SM4 (с ключом размером 128 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

SM4-Twofish

Последовательно выполняемые (каскадом) [15, 16] два шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Twofish (с ключом размером 256 бит) в режиме XTS, а затем алгоритмом SM4 (с ключом размером 128 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.

SM4-Twofish-Serpent

Последовательно выполняемые (каскадом) [15, 16] три шифра, работающие в режиме XTS (см. раздел Режимы работы). Каждый блок размером 128 бит сначала шифруется алгоритмом Serpent (с ключом размером 256 бит) в режиме XTS, затем алгоритмом Twofish (с ключом размером 256 бит) в режиме XTS, и, наконец, алгоритмом SM4 (с ключом размером 128 бит) в режиме XTS. Каждый из этих каскадных шифров использует свой собственный ключ. Все ключи шифрования не зависят друг от друга (обратите внимание, что ключи заголовка тоже независимы, хотя и получены в результате формирования одного пароля – см. раздел Формирование ключа заголовка, соль и количество итераций). Информация о каждом отдельном шифре приведена выше.


Документация >> Алгоритмы хеширования

Алгоритмы хеширования

Выбор алгоритма хеширования предлагается в мастере создания томов, в диалоговом окне смены пароля, а также в окне генератора ключевых файлов. Выбранный пользователем алгоритм хеширования применяется во встроенном в VeraCrypt генераторе случайных чисел как функция псевдослучайного "смешивания", а также в функции формирования ключа заголовка (HMAC – алгоритме усиления криптостойкости других криптоалгоритмов на основе хеш-функции, как определено в PKCS #5 v2.0) как псевдослучайная функция. При создании нового тома, генератором случайных чисел создаются мастер-ключ, вторичный ключ (режим XTS) и соль. Более подробную информацию см. в разделах Генератор случайных чисел и Формирование ключа заголовка, соль и количество итераций.
В настоящее время VeraCrypt поддерживает следующие алгоритмы хеширования:
  • BLAKE2s-256
  • SHA-256
  • SHA-512
  • Whirlpool
  • Streebog

Следующий раздел >>


Документация >> Алгоритмы хеширования >> BLAKE2s-256

BLAKE2s-256

BLAKE2 – это основанная на BLAKE криптографическая хеш-функция (авторы: Jean-Philippe Aumasson, Samuel Neves, Zooko Wilcox-O'Hearn и Christian Winnerlein, опубликована 21 декабря 2012 года). Цель разработки состояла в том, чтобы заменить широко используемые, но взломанные алгоритмы MD5 и SHA-1 в приложениях, требующих высокой производительности программного обеспечения. BLAKE2 обеспечивает лучшую безопасность, чем SHA-2, и похож на SHA-3 (например, невосприимчив к увеличению длины, имеет недифференцируемость от случайного оракула и т. д.).
BLAKE2 убирает добавление констант к словам сообщения из функции раунда BLAKE, изменяет две константы вращения, упрощает заполнение, добавляет блок параметров, который подвергается операции XOR с векторами инициализации, и уменьшает количество раундов с 16 до 12 для BLAKE2b (преемника BLAKE- 512) и с 14 до 10 для BLAKE2s (преемник BLAKE-256).
BLAKE2b и BLAKE2s указаны в документе RFC 7693.

VeraCrypt использует только BLAKE2s с максимальным выходным размером 32 байта (256 бит).

Следующий раздел >>


Документация >> Алгоритмы хеширования >> SHA-256

Хеш-алгоритм SHA-256

Создан Агентством национальной безопасности США (NSA) и опубликован Национальным институтом стандартов и технологий США (NIST) в FIPS PUB 180-2 [14] в 2002 году (первый черновой проект был опубликован в 2001 году). Размер вывода этого алгоритма – 256 бит.
Следующий раздел >>


Документация >> Алгоритмы хеширования >> SHA-512

Хеш-алгоритм SHA-512

Создан Агентством национальной безопасности США (NSA) и опубликован Национальным институтом стандартов и технологий США (NIST) в FIPS PUB 180-2 [14] в 2002 году (первый черновой проект был опубликован в 2001 году). Размер вывода этого алгоритма – 512 бит.
Следующий раздел >>


Документация >> Алгоритмы хеширования >> Whirlpool

Хеш-алгоритм Whirlpool

Авторы алгоритма – Vincent Rijmen (соавтор алгоритма AES) и Paulo S. L. M. Barreto. Размер вывода этого алгоритма – 512 бит. Первая версия Whirlpool, называемая сегодня Whirlpool-0, была опубликована в ноябре 2000 года. Вторая версия Whirlpool, называемая сегодня Whirlpool-T, была отобрана в набор криптографических примитивов (похожий на конкурс AES проект, организованный Европейским союзом) для NESSIE (New European Schemes for Signatures, Integrity and Encryption). VeraCrypt использует третью (последнюю) версию Whirlpool, принятую Международной организацией по стандартизации (ISO) и Международной электротехнической комиссией (IEC) в международном стандарте ISO/IEC 10118-3:2004 [21].
Следующий раздел >>


Документация >> Алгоритмы хеширования >> Streebog

Хеш-алгоритм Streebog

Streebog это семейство из двух алгоритмов хеширования – Streebog-256 и Streebog-512, определённых в Национальном стандарте Российской Федерации ГОСТ Р 34.11-2012 – Информационная технология – Криптографическая защита информации – Функция хэширования. Он также описан здесь. Это конкурент стандарта SHA-3, разработанного Национальным институтом стандартов и технологий США (NIST).

В VeraCrypt используется только Streebog-512, размер вывода которого – 512 бит.


Документация >> Поддерживаемые операционные системы

Поддерживаемые операционные системы

В настоящий момент VeraCrypt поддерживает следующие операционные системы:
  • Windows 11
  • Windows 10
  • Windows Server 2016
  • Mac OS X 14 Sonoma
  • Mac OS X 13 Ventura
  • Mac OS X 12 Monterey
  • Linux x86, x86-64, ARM64 (начиная с Debian 10, Ubuntu 20.04, CentOS 7, OpenSUSE 15.1)
  • FreeBSD x86-64 (начиная с версии 12)
  • Raspberry Pi OS (32- и 64-разрядные)
Примечание:

VeraCrypt 1.25.9 – последняя версия, поддерживающая Windows XP, Windows Vista, Windows 7, Windows 8 и Windows 8.1.
VeraCrypt 1.25.9 – последняя версия, поддерживающая Mac OS X, начиная с версии 10.9 Mavericks и по 11 Big Sur.
VeraCrypt 1.24-Update8 – последняя версия, поддерживающая Mac OS X 10.7 Lion и Mac OS X 10.8 Mountain Lion.

* Следующие операционные системы (помимо прочих) не поддерживаются: Windows RT, Windows 2003 IA-64, Windows 2008 IA-64, Windows XP IA-64 и встроенные/планшетные версии Windows.

См. также раздел Операционные системы, поддерживающие системное шифрование


Документация >> Использование в режиме командной строки

Использование в режиме командной строки

Информация в этом разделе относится к версии VeraCrypt для Windows. Чтобы получить сведения об использовании в режиме командной строки версий для Linux и Mac OS X, выполните следующую команду: veracrypt -h

/help или /? | Показать справку по использованию в командной строке.
/truecrypt или /tc | Активировать режим совместимости с TrueCrypt, который позволяет монтировать тома, созданные в TrueCrypt версий 6.x и 7.x.
/hash | После этого ключа указывается хеш-алгоритм PRF, используемый при монтировании тома. Возможные значения ключа /hash: sha256, sha-256, sha512, sha-512, whirlpool, blake2s и blake2s-256. Если ключ /hash не указан, VeraCrypt будет пробовать все доступные PRF-алгоритмы, тем самым увеличивая время монтирования.
/volume или /v

После этого ключа указывается полное имя (с путём) файла с томом VeraCrypt для монтирования (не используйте при размонтировании) или идентификатор тома (Volume ID) диска/раздела для монтирования.
Синтаксис идентификатора тома следующий: ID:XXXXXX...XX, где часть с XX это строка из 64 шестнадцатеричных символов, которая представляет собой 32-байтовый идентификатор тома для монтирования.

Чтобы смонтировать том на основе раздела/устройства, используйте, например, параметры /v \Device\Harddisk1\Partition3 (узнать путь к разделу/устройству можно, запустив VeraCrypt и нажав кнопку Выбрать устройство). Монтировать раздел или динамический том также можно используя его имя тома (например, /v \\?\Volume{5cceb196-48bf-46ab-ad00-70965512253a}\). Узнать имя тома можно, например, с помощью mountvol.exe. Также помните, что в путях устройств учитывается регистр букв.

Для монтирования также можно указывать идентификатор монтируемого тома (Volume ID) на основе раздела/устройства, например: /v ID:53B9A8D59CC84264004DA8728FC8F3E2EE6C130145ABD3835695C29FD601EDCA. Значение идентификатора тома можно получить с помощью диалогового окна свойств тома.
/letter или /l | После этого ключа указывается буква диска, присваиваемая монтируемому тому. Если ключ /l не указан и используется ключ /a, тогда тому присваивается первая незанятая буква диска.
/explore или /e | Открыть окно Проводника после монтирования тома.
/beep или /b | Звуковой сигнал после успешного монтирования или размонтирования.
/auto или /a | Если этот ключ указан без параметров, то выполняется автоматическое монтирование тома. Если указан параметр devices (например, /a devices), то выполняется автомонтирование всех доступных в данный момент томов VeraCrypt на основе устройств/разделов. Если указан параметр favorites, то выполняется автомонтирование избранных томов. Обратите внимание, что ключ /auto подразумевается, если указаны ключи /quit и /volume. Если требуется подавить вывод на экран окна программы, используйте ключ /quit.
/unmount или /u | Размонтировать том с указанной буквой диска (пример: /u x). Если буква диска не указана, то будут размонтированы все смонтированные на данный момент тома VeraCrypt.
/force или /f | Принудительно размонтировать (если размонтируемый том содержит файлы, используемые системой или какой-либо программой) и принудительно смонтировать в совместно используемом (shared) режиме (то есть без эксклюзивного доступа).
/keyfile или /k | После этого ключа указывается ключевой файл или путь поиска ключевых файлов. Если ключевых файлов несколько, то они указываются, например, так: /k c:\keyfile1.dat /k d:\KeyfileFolder /k c:\kf2. Чтобы указать ключевой файл, находящийся на токене безопасности или смарт-карте, используйте следующий синтаксис: token://slot/SLOT_NUMBER/file/FILE_NAME
/tryemptypass Этот ключ применяется, только если сконфигурирован ключевой файл по умолчанию или ключевой файл указан в командной строке.
Если после этого ключа указан параметр y или yes, либо параметр не указан: попытаться смонтировать, используя пустой пароль и ключевой файл, прежде чем показать запрос пароля.
Если после этого ключа указан параметр n или no: не пытаться смонтировать, используя пустой пароль и ключевой файл, и сразу показать запрос пароля.
/nowaitdlg Если после этого ключа указан параметр y или yes, либо параметр не указан: не показывать окно ожидания при выполнении таких операций, как, например, монтирование томов.
Если после этого ключа указан параметр n или no: принудительно показывать окно ожидания при выполнении операций.
/secureDesktop Если после этого ключа указан параметр y или yes, либо параметр не указан: показывать окно пароля и окно пин-кода токена на выделенном безопасном рабочем столе для защиты от определённых типов атак.
Если после этого ключа указан параметр n или no: окно пароля и окно PIN-кода токена отображаются на обычном рабочем столе.
/tokenlib | После этого ключа указывается библиотека PKCS #11 для токенов безопасности и смарт-карт (пример: /tokenlib c:\pkcs11lib.dll).
/tokenpin | После этого ключа указывается пин-код для аутентификации с помощью токена безопасности или смарт-карты (пример: /tokenpin 0000). ВНИМАНИЕ: Этот метод ввода пин-кода смарт-карты может быть небезопасным, например, когда незашифрованный журнал истории командной строки сохраняется на незашифрованном диске.
/cache или /c Если после этого ключа указан параметр y или yes, либо параметр не указан: включить кэш паролей.
Если после этого ключа указан параметр p или pim: включить кэш паролей и PIM (пример: /c p).
Если после этого ключа указан параметр n или no: отключить кэш паролей (пример: /c n).
Если после этого ключа указан параметр f или favorites: временно кэшировать пароль при монтировании нескольких избранных томов (пример: /c f).
Обратите внимание, что отключение кэша паролей не очищает его (чтобы очистить кэш паролей, используйте ключ /w).
/history или /h Если после этого ключа указан параметр y или параметр не указан: включить сохранение истории смонтированных томов.
Если после этого ключа указан параметр n: отключить сохранение истории смонтированных томов (пример: /h n).
/wipecache или /w | Удалить все пароли, кэшированные (сохранённые) в памяти драйвера.
/password или /p | После этого ключа указывается пароль тома. Если в пароле есть пробелы, его необходимо заключить в двойные кавычки (пример: /p ”My Password”). Чтобы указать пустой пароль, используйте ключ /p ””. ВНИМАНИЕ: Такой метод ввода пароля может быть небезопасен, например, если на незашифрованном диске записывается незашифрованная история операций в командной строке.
/pim | После этого ключа указывается положительное целое число, определяющее PIM (Персональный множитель итераций) для использования с этим томом.
/quit или /q | Автоматически выполнить запрошенные действия и выйти (без отображения главного окна VeraCrypt). Если в качестве параметра указано preferences (пример: /q preferences), то будут загружены/сохранены настройки программы, и они переопределят параметры, указанные в командной строке. Ключ /q background запускает VeraCrypt в фоновом режиме (значок в области уведомлений), если только это не запрещено в настройках.
/silent или /s | При указании вместе с ключом /q подавляет взаимодействие с пользователем (запросы, сообщения об ошибках, предупреждения и т. д.). Если ключ /q не указан, этот параметр никакого действия не оказывает.
/mountoption или /m

После этого ключа указывается один из перечисленных ниже параметров.

ro или readonly: смонтировать том как доступный только для чтения.

rm или removable: смонтировать том как сменный носитель (см. раздел Том, смонтированный как сменный носитель).

ts или timestamp: не сохранять дату и время изменения контейнера.

sm или system: смонтировать без предзагрузочной аутентификации раздел, входящий в область действия шифрования системы (например, раздел на зашифрованном системном диске с другой операционной системой, которая в данный момент не выполняется). Полезно, например, для операций резервного копирования или починки. Примечание: если вы указываете пароль как параметр ключа /p, убедитесь, что пароль набран с использованием стандартной американской раскладки клавиатуры (при использовании графического интерфейса программы это делается автоматически). Это необходимо потому, что пароль требуется вводить на этапе до загрузки операционной системы (до запуска Windows), когда раскладки клавиатуры, отличные от американской, ещё недоступны.

bk или headerbak: смонтировать том, используя встроенную резервную копию заголовка. Примечание: встроенная резервная копия заголовка содержится во всех томах, созданных VeraCrypt (эта копия располагается в конце тома).

recovery: не проверять контрольные суммы, хранящиеся в заголовке тома. Этот параметр следует использовать только при повреждении заголовка тома и когда такой том невозможно смонтировать даже с параметром headerbak. Пример: /m ro

label=LabelValue: использовать указанную строку LabelValue как метку смонтированного тома в Проводнике Windows. Максимальная длина LabelValue – 32 символа для томов NTFS и 11 символов для томов FAT. Например, /m label=MyDrive установит для диска в Проводнике метку тома MyDrive.

noattach: создать только виртуальное устройство без фактического присоединения смонтированного тома к выбранной букве диска.

Обратите внимание, что этот ключ может присутствовать в командной строке несколько раз, чтобы указать несколько вариантов монтирования (пример: /m rm /m ts)
/DisableDeviceUpdate | Отключить периодическую внутреннюю проверку устройств, подключённых к системе, которая используется для обработки избранного, идентифицированного с помощью идентификаторов томов (Volume ID), и заменить её проверками по требованию.
/protectMemory | Активировать механизм защиты памяти процесса VeraCrypt от доступа со стороны других процессов без прав администратора.
/signalExit После этого ключа должен следовать параметр, определяющий имя отправляемого сигнала для разблокирования ожидания команды WAITFOR.EXE при завершении работы VeraCrypt.
Имя сигнала должно совпадать с указанным в команде WAITFOR.EXE (пример: veracrypt.exe /q /v test.hc /l Z /signal SigName с последующим waitfor.exe SigName
Если /q не указан, этот ключ игнорируется.

VeraCrypt Format.exe (Мастер создания томов VeraCrypt):

/create | Создать том на основе файла-контейнера в режиме командной строки. За этим ключом должно следовать имя файла создаваемого контейнера.
/size

(Только с ключом /create)
После этого ключа указывается размер создаваемого файла-контейнера. Если указано просто число без суффикса, то оно обозначает размер в байтах. Если после числа добавить суффикс "K", "M", "G" или "T", то это будет означать размер, соответственно, в килобайтах, мегабайтах, гигабайтах или терабайтах. Примеры:

  • /size 5000000: размер контейнера – 5 000 000 байт
  • /size 25K: размер контейнера – 25 килобайт
  • /size 100M: размер контейнера – 100 мегабайт
  • /size 2G: размер контейнера – 2 гигабайта
  • /size 1T: размер контейнера – 1 терабайт
/password (Только с ключом /create)
После этого ключа указывается пароль к создаваемому тому.
/keyfile или /k (Только с ключом /create)
После этого ключа указывается ключевой файл или путь поиска ключевых файлов к создаваемому тому. Чтобы использовать несколько ключевых файлов, укажите, например, такие параметры: /k c:\keyfile1.dat /k d:\KeyfileFolder /k c:\kf2. Чтобы указать ключевой файл, расположенный на токене безопасности или смарт-карте, используйте следующий синтаксис: token://slot/SLOT_NUMBER/file/FILE_NAME
/tokenlib (Только с ключом /create)
После этого ключа указывается библиотека PKCS #11 для использования с токенами безопасности и смарт-картами (пример: /tokenlib c:\pkcs11lib.dll).
/tokenpin (Только с ключом /create)
После этого ключа указывается пин-код для аутентификации с помощью токена безопасности или смарт-карты (пример: /tokenpin 0000). ВНИМАНИЕ: Этот метод ввода пин-кода смарт-карты может быть небезопасным, например, когда незашифрованный журнал истории командной строки сохраняется на незашифрованном диске.
/hash (Только с ключом /create)
После этого ключа указывается хеш-алгоритм PRF, используемый при создании тома. Синтаксис такой же, как у VeraCrypt.exe.
/encryption (Только с ключом /create)
После этого ключа указывается используемый алгоритм шифрования. По умолчанию это AES, если данный ключ не указан. Возможны следующие значения (регистр букв не учитывается):
  • AES
  • Serpent
  • Twofish
  • Camellia
  • Kuznyechik
  • AES(Twofish)
  • AES(Twofish(Serpent))
  • Serpent(AES)
  • Serpent(Twofish(AES))
  • Twofish(Serpent)
  • Camellia(Kuznyechik)
  • Kuznyechik(Twofish)
  • Camellia(Serpent)
  • Kuznyechik(AES)
  • Kuznyechik(Serpent(Camellia))
/filesystem (Только с ключом /create)
После этого ключа указывается файловая система для использования в томе. Возможны следующие значения:
  • Значение не указано: не использовать никакую файловую систему
  • FAT: форматировать в FAT/FAT32
  • NTFS: форматировать в NTFS (в этом случае появится окно с запросом UAC, если только процесс не выполняется с полными правами администратора)
  • ExFAT: форматировать в ExFAT (этот ключ доступен начиная с Windows Vista SP1)
  • ReFS: форматировать в ReFS (этот ключ доступен начиная с Windows 10)
/dynamic (Только с ключом /create)
Создать динамический том.
/force (Только с ключом /create)
Принудительная перезапись без запроса.
/silent (Только с ключом /create)
Не показывать окна с сообщениями. Если произойдёт какая-либо ошибка, операция завершится без сообщений.
/noisocheck или /n | Не проверять правильность записи на носители дисков восстановления VeraCrypt (Rescue Disk). ВНИМАНИЕ: Никогда не пытайтесь применять этот ключ, чтобы облегчить повторное использование ранее созданного Диска восстановления VeraCrypt. Помните, что при каждом шифровании системного раздела/диска нужно создавать новый Диск восстановления VeraCrypt, даже если используете тот же пароль. Ранее созданный Диск восстановления нельзя использовать повторно, так как он был создан для другого мастер-ключа.
/nosizecheck | Не проверять Не проверять, что заданный размер файлового контейнера меньше, чем доступно на места на диске. Это относится как к пользовательскому интерфейсу, так и к командной строке.
/quick | Выполнять быстрое форматирование томов вместо полного форматирования. Это относится как к пользовательскому интерфейсу, так и к командной строке.
/FastCreateFile | Использовать более быстрый, хотя и потенциально небезопасный метод создания файловых контейнеров. Эта опция сопряжена с риском для безопасности, поскольку способна встроить существующее содержимое диска в файловый контейнер, что может привести к раскрытию конфиденциальных данных, если злоумышленник получит к нему доступ. Обратите внимание, что этот ключ влияет на все методы создания файловых контейнеров, независимо от того, запущены ли они из командной строки с параметром /create или с помощью мастера из интерфейса пользователя.
/protectMemory | Активировать механизм защиты памяти процесса VeraCrypt Format от доступа со стороны других процессов без прав администратора.
/secureDesktop Если после этого ключа указан параметр y или yes, либо параметр не указан: показывать окно пароля и окно PIN-кода токена на выделенном безопасном рабочем столе для защиты от определённых типов атак.
Если после этого ключа указан параметр n или no: окно пароля и окно PIN-кода токена отображаются на обычном рабочем столе.

Синтаксис

VeraCrypt.exe [/tc] [/hash {sha256|sha-256|sha512|sha-512|whirlpool |blake2s|blake2s-256}][/a [devices|favorites]] [/b] [/c [y|n|f]] [/d [буква диска]] [/e] [/f] [/h [y|n]] [/k ключевой файл или путь поиска] [tryemptypass [y|n]] [/l буква диска] [/m {bk|rm|recovery|ro|sm|ts|noattach}] [/p пароль] [/pim значение pim] [/q [background|preferences]] [/s] [/tokenlib путь] [/v том] [/w]

"VeraCrypt Format.exe" [/n] [/create] [/size число[{K|M|G|T}]] [/p пароль]  [/encryption {AES | Serpent | Twofish | Camellia | Kuznyechik | AES(Twofish) | AES(Twofish(Serpent)) | Serpent(AES) | Serpent(Twofish(AES)) | Twofish(Serpent) | Camellia(Kuznyechik) | Kuznyechik(Twofish) | Camellia(Serpent) | Kuznyechik(AES) | Kuznyechik(Serpent(Camellia))}] [/hash {sha256|sha-256|sha512|sha-512|whirlpool|blake2s|blake2s-256}] [/filesystem {пусто|FAT|NTFS|ExFAT|ReFS}] [/dynamic] [/force] [/silent] [/noisocheck] [FastCreateFile] [/quick]

Порядок, в котором указаны параметры, не имеет значения.

Примеры

Смонтировать том d:\myvolume на первую свободную букву диска, используя запрос пароля (основное окно программы не отображается):

veracrypt /q /v d:\myvolume

Размонтировать том, смонтированный как диск X (основное окно программы не отображается):

veracrypt /q /d x

Смонтировать том с именем myvolume.tc, используя пароль MyPassword, как диск X. VeraCrypt откроет окно Проводника и подаст звуковой сигнал; монтирование будет автоматическим:

veracrypt /v myvolume.tc /l x /a /p MyPassword /e /b

Создать файловый контейнер размером 10 МБ, используя пароль test, шифрование Serpent, хеш SHA-512, и отформатировав том в FAT:

"C:\Program Files\VeraCrypt\VeraCrypt Format.exe" /create c:\Data\test.hc /password test /hash sha512 /encryption serpent /filesystem FAT /size 10M /force


Документация >> Модель безопасности

Модель безопасности

Примечание для исследователей безопасности. Если вы намереваетесь сообщить о проблеме с безопасностью или опубликовать атаку на VeraCrypt, пожалуйста, удостоверьтесь, что вы не пренебрегаете описанной ниже моделью безопасности VeraCrypt. В противном случае атака (или проблема с безопасностью) будет расцениваться как недействительная/поддельная.

VeraCrypt это компьютерная программа, в чьи основные цели входят:

  • защита данных с помощью шифрования перед записью на диск;
  • расшифровка зашифрованных данных после их считывания с диска.

В задачи VeraCrypt не входит:

  • шифрование или защита любой области ОЗУ (оперативной памяти ПК);
  • защита данных в компьютере,* если атакующий имеет привилегии† администратора в среде операционной системы, установленной в этом компьютере;
  • защита данных в компьютере, содержащем какое-либо вредоносное ПО (например, вирус, трояна, шпионскую программу) или любую часть ПО (включая TrueCrypt или компонент операционной системы), которая была изменена, создана или может быть подконтрольна атакующему;
  • защита данных в компьютере, если у атакующего был к нему физический доступ до или во время работы VeraCrypt;
  • защита данных в компьютере, если у атакующего есть физический доступ к нему между временем завершения работы VeraCrypt и временем, необходимым для окончательного и безвозвратного стирания/утери всей информации из модулей временной памяти, подключённых к компьютеру (включая модули памяти в периферийных устройствах);
  • защита данных в компьютере, если атакующий может удалённо перехватить излучения от аппаратуры компьютера (например, от монитора или кабелей) во время работы VeraCrypt (или иным образом выполнять удалённый мониторинг аппаратной части ПК и её использования, непосредственно или косвенно, во время работы VeraCrypt в этом ПК);
  • защита данных, хранящихся в томе‡ VeraCrypt, если атакующий без привилегий администратора имеет доступ к содержимому смонтированного тома (например, если права на файл/папку/том не препятствуют такому доступу атакующего);
  • сохранение/контроль целостности или аутентичности зашифрованных и расшифрованных данных;
  • предотвращение анализа трафика при передаче зашифрованных данных по сети;
  • предотвращение определения неприятелем, какие сектора с содержимым тома были изменены (а также когда и сколько раз), если неприятель имеет возможность следить за томом (смонтированным или не смонтированным) до и после записи в него, либо если носитель/устройство хранения информации позволяет неприятелю определять такую информацию (например, том находится на устройстве, сохраняющем метаданные, которые можно использовать для выяснения, когда данные были записаны в конкретный сектор);
  • шифрование "на месте" любых имеющихся незашифрованных данных (или перешифрование/удаление данных) в устройствах/файловых системах с технологией распределения износа ячеек памяти (wear-leveling) или иным перераспределением данных внутренними средствами;
  • гарантия, что пользователь выбирает криптографически надёжные пароли и ключевые файлы;
  • защита любого аппаратного компонента компьютера или всего компьютера;
  • защита данных в компьютере, в котором не соблюдены условия, перечисленные в главе Требования безопасности и меры предосторожности.
  • выполнение чего-либо, указанного в разделе Ограничения (глава Замеченные проблемы и ограничения).

В среде Windows пользователь без привилегий администратора может (при условии, что используются стандартные конфигурации VeraCrypt и операционной системы):

  • монтировать любой том VeraCrypt на основе файла при условии, что это позволено правами на файловый контейнер;
  • монтировать любой том VeraCrypt на основе раздела/устройства;
  • завершать процесс предзагрузочной аутентификации и, таким образом, получать доступ к данным на зашифрованном системном разделе/диске (и запускать зашифрованную операционную систему);
  • пропускать процесс предзагрузочной аутентификации (это можно предотвратить, отключив параметр Настройки > Шифрование системы > Обход предзагрузочной аутентификации по Esc; обратите внимание, что включать/отключать данный параметр может только администратор);
  • размонтировать, используя VeraCrypt, любой смонтированный этим пользователем том VeraCrypt (и, в окне программы VeraCrypt, видеть его путь и свойства). Это, однако, неприменимо к "системным избранным томам", которые пользователь может размонтировать (и т. д.) вне зависимости от того, кто их смонтировал (это можно предотвратить, включив параметр Настройки > Системные избранные тома > Просматривать/размонтировать системные избранные тома могут лишь администраторы; обратите внимание, что включать/отключать данный параметр может только администратор).
  • создавать том VeraCrypt на основе файла с файловой системой FAT или без файловой системы (при условии, что это разрешено правами соответствующей папки);
  • изменять пароль, ключевые файлы и алгоритм формирования ключа заголовка, восстанавливать заголовок или создавать его резервную копию для тома VeraCrypt на основе файла (при условии, что это разрешено правами данного файла);
  • обращаться к файловой системе внутри тома VeraCrypt, смонтированного другим пользователем системы (что, однако, можно запретить, назначив соответствующие права на файл/папку/том);
  • использовать пароли (и обработанные ключевые файлы), сохранённые в кэше паролей (обратите внимание, что кэширование можно отключить; см. подробности в разделе Настройки > Параметры, подраздел Кэшировать пароли в памяти драйвера);
  • просматривать основные свойства (например, размер зашифрованной области, используемые алгоритмы шифрования и хеширования, и т. д.) зашифрованного системного раздела/диска, когда работает зашифрованная система;
  • запускать и использовать программу VeraCrypt (включая мастер создания томов VeraCrypt) при условии, что запущен драйвер устройств VeraCrypt и это позволяют права на файлы.

В среде Linux пользователь без привилегий администратора может (при условии, что используются стандартные конфигурации VeraCrypt и операционной системы):

  • создавать том VeraCrypt на основе файла или раздела/устройства с файловой системой FAT или без файловой системы (при условии, что это разрешено правами соответствующей папки/устройства);
  • изменять пароль, ключевые файлы и алгоритм деривации ключа заголовка, восстанавливать заголовок или делать его резервную копию для тома VeraCrypt на основе файла или раздела/устройства (при условии, что это разрешено правами данного файла/устройства);
  • обращаться к файловой системе внутри тома VeraCrypt, смонтированного другим пользователем системы (что, однако, можно запретить, назначив соответствующие права на файл/папку/том);
  • запускать и использовать программу VeraCrypt (включая мастер создания томов VeraCrypt) при условии, что это позволяют права на файлы;
  • в окне программы VeraCrypt видеть путь и свойства любого тома VeraCrypt, смонтированного этим пользователем.

В среде Mac OS X (macOS) пользователь без привилегий администратора может (при условии, что используются стандартные конфигурации VeraCrypt и операционной системы):

  • монтировать любой том VeraCrypt на основе файла или раздела/устройства (при условии, что это разрешено правами соответствующего файла/устройства);
  • размонтировать, используя VeraCrypt, любой смонтированный этим пользователем том VeraCrypt (и, в окне программы VeraCrypt, видеть его путь и свойства);
  • создавать том VeraCrypt на основе файла или раздела/устройства (при условии, что это разрешено правами соответствующей папки/устройства);
  • изменять пароль, ключевые файлы и алгоритм формирования ключа заголовка, восстанавливать заголовок или делать его резервную копию для тома VeraCrypt на основе файла или раздела/устройства (при условии, что это разрешено правами данного файла/устройства);
  • обращаться к файловой системе внутри тома VeraCrypt, смонтированного другим пользователем системы (что, однако, можно запретить, назначив соответствующие права на файл/папку/том);
  • запускать и использовать программу VeraCrypt (включая мастер создания томов VeraCrypt) при условии, что это позволяют права на файлы.

VeraCrypt не поддерживает корневой режим выполнения set-euid.

Дополнительная информация и подробности о модели безопасности содержатся в главе Требования безопасности и меры предосторожности.

* В этом разделе (Модель безопасности) фраза "данные в компьютере" означает данные на внутренних и внешних запоминающих устройствах/носителях (включая съёмные устройства и сетевые диски), подключённых к компьютеру.

† В этом разделе (Модель безопасности), фраза "привилегии администратора" не обязательно относится к действительной учётной записи администратора. Она также может относиться к злоумышленнику, не имеющему действующей учётной записи администратора, но способному (например, из-за неправильной настройки системы или использования уязвимости в операционной системе или стороннем приложении) выполнить любое действие, что обычно разрешено только пользователю с действительной учётной записью администратора (например, читать или изменять произвольную часть диска или ОЗУ и т. д.).

‡ "Том VeraCrypt" также означает системный раздел/диск, зашифрованный с помощью VeraCrypt (см. главу Шифрование системы).


Документация >> Требования безопасности и меры предосторожности

Требования безопасности и меры предосторожности

ВАЖНО: Если вы хотите пользоваться VeraCrypt, то обязаны соблюдать описанные в этой главе требования безопасности и меры предосторожности.
В этой главе описаны требования безопасности при использовании VeraCrypt и дана информация о том, как неприятель может повлиять на возможности (или ограничить их) VeraCrypt по защите данных и обеспечению правдоподобного отрицания наличия шифрования.
Отказ от ответственности: мы не гарантируем, что в данной главе затронуты все возможные проблемы, связанные с безопасностью, и описаны все атаки, которые может предпринять неприятель с целью повлиять на возможности (или ограничить их) VeraCrypt по защите данных и обеспечению правдоподобного отрицания наличия шифрования.
  • Утечки данных
    • Файл подкачки
    • Файл гибернации
    • Файлы дампа памяти
  • Незашифрованные данные в ОЗУ
  • Защита памяти в VeraCrypt
  • Физическая безопасность
  • Вредоносное ПО (malware)
  • Многопользовательская среда
  • Аутентичность и целостность данных
  • Выбор паролей и ключевых файлов
  • Изменение паролей и ключевых файлов
  • Операция Trim
  • Распределение износа (Wear-Leveling)
  • Перераспределённые сектора
  • Дефрагментация
  • Журналируемые файловые системы
  • Клонирование томов
  • Дополнительные требования безопасности и меры предосторожности


Документация >> Требования безопасности и меры предосторожности >> Утечки данных

Утечки данных

Когда смонтирован том VeraCrypt, операционная система и сторонние приложения могут записывать в незашифрованные тома (обычно в незашифрованный системный том) незашифрованную информацию о данных, хранящихся в томе VeraCrypt (например, имена и пути файлов, к которым недавно было обращение, создаваемые программами индексации базы данных, и т. д.), или собственно данные в незашифрованном виде (временные файлы и т. п.), или незашифрованную информацию о находящейся в томе VeraCrypt файловой системе.

Обратите внимание, что Windows автоматически ведёт запись больших объёмов таких потенциально секретных данных, как имена и пути открываемых вами файлов, запускаемые вами приложения и т. д. Например, Windows при работе с Проводником использует набор ключей реестра, называемых “shellbags” (“скорлупа”) для хранения имени, размера, вида, значка и позиции папки. При каждом открытии папки эта информация обновляется, включая дату и время доступа. Пакеты Windows Shellbags можно найти в нескольких местах, в зависимости от версии операционной системы и профиля пользователя. В Windows XP пакеты shellbags находятся в "HKEY_USERS\{USERID}\Software\Microsoft\Windows\Shell\" и "HKEY_USERS\{USERID}\Software\Microsoft\Windows\ShellNoRoam\". В Windows 7 они располагаются в "HKEY_USERS\{USERID}\Local Settings\Software\Microsoft\Windows\Shell\". Более подробную информацию см. на странице https://www.sans.org/reading-room/whitepapers/forensics/windows-shellbag-forensics-in-depth-34545.

Кроме того, начиная с Windows 8, при каждом монтировании тома VeraCrypt, отформатированном в NTFS, в журнал системных событий записывается Событие 98 (Event 98), содержащее имя устройства (\\device\VeraCryptVolumeXX) тома. Эта "особенность" журнала событий была представлена в Windows 8 как часть недавно введённых проверок состояния NTFS, см. пояснения здесь. Чтобы избежать этой утечки, необходимо монтировать том VeraCrypt как сменный носитель. Большое спасибо Liran Elharar, обнаружившему эту утечку и предложившему способ её обхода.

Чтобы предотвратить утечки данных, вы должны проделать следующее (возможны и альтернативные меры):

  • Если вам не нужно правдоподобное отрицание наличия шифрования:
    • Зашифруйте системный раздел/диск (о том, как это сделать, см. главу Шифрование системы) и убедитесь, что в течение каждого сеанса работы с секретными данными смонтированы только зашифрованные файловые системы или системы, доступные только для чтения.

      или
    • Если вы не можете проделать указанное выше, загрузите или создайте "live CD"-версию своей операционной системы (то есть live-систему, целиком расположенную на CD/DVD и оттуда же загружающуюся) – это гарантирует, что любые записываемые в системный том данные записываются в RAM-диск (диск в ОЗУ). Когда вам требуется поработать с секретными данными, загрузите систему с такого live-CD/DVD и проверьте, что в течение сеанса смонтированы только зашифрованные и/или доступные только для чтения файловые системы.
  • Если вам нужно правдоподобное отрицание наличия шифрования:
    • Создайте скрытую операционную систему. При этом защита от утечек данных будет обеспечена VeraCrypt автоматически. См. подробности в разделе Скрытая операционная система.

      или
    • Если вы не можете проделать вышеуказанное, загрузите или создайте "live CD"-версию своей операционной системы (то есть live-систему, целиком расположенную на CD/DVD и оттуда же загружающуюся) – это гарантирует, что любые записываемые в системный том данные записываются в RAM-диск (диск в ОЗУ). Когда вам требуется поработать с секретными данными, загрузите систему с такого live-CD/DVD. Если вы используете скрытые тома, следуйте требованиям безопасности, указанным в подразделе Требования безопасности и меры предосторожности, касающиеся скрытых томов. Если скрытые тома вами не используются, проверьте, что в течение сеанса смонтированы только несистемные тома VeraCrypt на основе раздела и/или файловые системы, доступные только для чтения.


Документация >> Требования безопасности и меры предосторожности >> Утечки данных >> Файл подкачки

Файл подкачки

Примечание. Описанная ниже проблема вас не касается, если системный раздел или системный диск зашифрован (см. подробности в главе Шифрование системы) и если все файлы подкачки расположены в одном или нескольких разделах в области действия шифрования системы, например, в разделе, на котором установлена Windows (см. подробности в четвёртом абзаце этого подраздела).
Файлы подкачки, иногда также именуемые swap-файлами или файлами обмена, используются операционной системой Windows для хранения частей программ и файлов с данными, не умещающихся в оперативной памяти (ОЗУ) компьютера. Это означает, что секретные данные, которые, как вы полагаете, находятся только в ОЗУ, на самом деле без вашего ведома могут быть записаны Windows в незашифрованном виде на жёсткий диск.

Примите к сведению, что VeraCrypt не может препятствовать сохранению содержимого открытых в ОЗУ секретных файлов в незашифрованном виде в файле подкачки (обратите внимание, что когда вы открываете хранящийся в томе VeraCrypt файл, например, в текстовом редакторе, содержимое этого файла находится в ОЗУ в незашифрованном виде).
Чтобы избежать описанных выше проблем, зашифруйте системный раздел/диск (о том, как это сделать, см. главу Шифрование системы) и убедитесь, что все файлы подкачки расположены на одном или нескольких разделах в области действия шифрования системы (например, в разделе, на котором установлена Windows). Обратите внимание, что в Windows XP последнее условие обычно бывает выполнено по умолчанию. В отличие от Windows XP, в Vista и более новых версиях Windows файлы подкачки по умолчанию создаются на любом подходящем томе. Поэтому прежде чем приступить к использованию VeraCrypt, нужно сделать следующее: щёлкните правой кнопкой мыши по значку Компьютер (или Мой компьютер) на рабочем столе или в меню Пуск, затем выберите Свойства > (в Windows Vista и новее: > Свойства системы >) вкладка Дополнительно > раздел Быстродействие > Параметры > вкладка Дополнительно > раздел Виртуальная память > Изменить. В Windows Vista и новее отключите параметр Автоматически выбирать объем файла подкачки. Затем убедитесь, что в списке томов, доступных для создания файлов подкачки, присутствуют только те, которые входят в область действия шифрования системы (например, том, в котором установлена Windows). Чтобы запретить создание файла подкачки на каком-либо конкретном томе, выделите его, затем выберите пункт Без файла подкачки и нажмите Задать. По окончании нажмите OK и перезагрузите компьютер.

Примечание. Ещё один подходящий вариант – создать скрытую операционную систему (см. подробности в разделе Скрытая операционная система).


Документация >> Требования безопасности и меры предосторожности >> Утечки данных >> Файлы дампа памяти

Файлы дампа памяти

Примечание. Описанная ниже проблема вас не касается, если системный раздел или системный диск зашифрован (см. подробности в главе Шифрование системы) и если система настроена так, что файлы дампа памяти сохраняются на системном диске (по умолчанию обычно это так и есть).
Большинство операционных систем, включая Windows, можно настроить так, чтобы при возникновении ошибки (сбоя системы, "синего экрана") выполнялась запись отладочной информации и содержимого системной памяти в так называемые файлы дампов (их также иногда называют дамп-файлами сбоев). Поэтому в файлах дампа памяти могут содержаться секретные данные. VeraCrypt не может препятствовать сохранению в незашифрованном виде в файлах дампа памяти кэшированных паролей, ключей шифрования и содержимого конфиденциальных файлов, открытых в ОЗУ. Помните, что когда вы открываете хранящийся в томе VeraCrypt файл, например, в текстовом редакторе, содержимое этого файла в незашифрованном виде помещается в ОЗУ (и может там оставаться незашифрованным до выключения компьютера). Также учитывайте, что когда смонтирован том VeraCrypt, его мастер-ключ хранится незашифрованным в ОЗУ. Поэтому хотя бы на время каждого сеанса, в течение которого вы работаете с секретными данными, и на время монтирования тома VeraCrypt необходимо отключать в компьютере создание дампов памяти. Чтобы это сделать в Windows XP или более новой версии Windows, щёлкните правой кнопкой мыши по значку Компьютер (или Мой компьютер) на рабочем столе или в меню Пуск, затем выберите Свойства > (в Windows Vista и новее: > Свойства системы >) вкладку Дополнительно > раздел Загрузка и восстановление > Параметры > раздел Запись отладочной информации > выберите (отсутствует) > OK.
Примечание для пользователей Windows XP/2003. Так как Windows XP и Windows 2003 не предоставляют никакого API для шифрования файлов дампа памяти, в случае, если системный раздел/диск зашифрован с помощью VeraCrypt, и ваша система Windows XP настроена на запись файлов дампа памяти на системный диск, драйвер VeraCrypt автоматически запрещает Windows записывать любые данные в файлы дампа памяти.


Документация >> Требования безопасности и меры предосторожности >> Утечки данных >> Файл гибернации

Файл гибернации

Примечание: описанная ниже проблема вас не касается, если системный раздел или системный диск зашифрован* (см. подробности в главе Шифрование системы) и если файл гибернации расположен на одном из разделов, входящих в область действия шифрования системы (что, как правило, принимается по умолчанию), например, на разделе, в котором установлена. Когда компьютер переходит в состояние гибернации, данные шифруются на лету перед тем, как они будут сохранены в файле гибернации.

Когда компьютер переходит в состояние гибернации (или входит в режим энергосбережения), содержимое его оперативной памяти записывается в так называемый файл гибернации на жёстком диске. Вы можете настроить VeraCrypt (Настройки > Параметры > Размонтировать все тома при: входе в энергосбережение) на автоматическое размонтирование всех смонтированных томов VeraCrypt, удаление их хранящихся в ОЗУ мастер-ключей и очистку кэшированных в ОЗУ паролей (если они есть) перед тем, как компьютер перейдёт в состояние гибернации (или войдёт в режим энергосбережения). Нужно, однако, иметь в виду, что если не используется шифрование системы (см. главу Шифрование системы), VeraCrypt не может надёжно препятствовать сохранению в файле гибернации в незашифрованном виде содержимого конфиденциальных файлов, открытых в ОЗУ. Помните, что когда вы открываете файл, хранящийся в томе VeraCrypt, например, в текстовом редакторе, содержимое этого файла в незашифрованном виде помещается в ОЗУ (и может оставаться в ОЗУ незашифрованным, пока не будет выключен компьютер).

Обратите внимание, что когда компьютер переходит в режим сна, на самом деле он может быть настроен на переход в так называемый гибридный спящий режим, вызывающий гибернацию. Также учтите, что операционная система может быть настроена на переход в режим гибернации или в гибридный спящий режим при выборе пункта «Завершить работу» (см. подробности в документации на свою операционную систему).

Чтобы избежать описанных выше проблем, зашифруйте системный раздел/диск (о том, как это сделать, см. в главе Шифрование системы) и убедитесь, что файл гибернации находится на одном из разделов, входящих в область действия шифрования системы (что, как правило, принимается по умолчанию), например, на разделе, в котором установлена Windows. Когда компьютер переходит в состояние гибернации, данные шифруются на лету перед тем, как они будут сохранены в файле гибернации.

Примечание: ещё один подходящий вариант – создать скрытую операционную систему (см. подробности в разделе Скрытая операционная система).

Если по каким-то причинам вы не можете использовать шифрование системы, отключите или не допускайте гибернации в своём компьютере, по крайней мере, в течение каждого сеанса, когда вы работаете с секретными данными и монтируете том VeraCrypt.

* ОТКАЗ ОТ ОТВЕТСТВЕННОСТИ: Поскольку Windows XP и Windows 2003 не предоставляют никакого API для шифрования файлов гибернации, VeraCrypt пришлось модифицировать недокументированные компоненты Windows XP/2003, чтобы позволить пользователям шифровать файлы гибернации. Поэтому VeraCrypt не может гарантировать, что файлы гибернации Windows XP/2003 будут всегда зашифрованы. В ответ на нашу публичную жалобу на отсутствие API, компания Microsoft начала предоставлять общедоступный API для шифрования файлов гибернации в Windows Vista и более поздних версиях Windows. VeraCrypt использует этот API и поэтому может безопасно шифровать файлы гибернации в Windows Vista и более поздних версиях Windows. Поэтому если вы используете Windows XP/2003 и хотите, чтобы файл гибернации был надёжно зашифрован, настоятельно рекомендуем вам выполнить обновление до Windows Vista или более поздней версии.


Документация >> Требования безопасности и меры предосторожности >> Незашифрованные данные в ОЗУ

Незашифрованные данные в ОЗУ

Важно понимать, что VeraCrypt – это программа для шифрования данных только на дисках, но не в ОЗУ (оперативной памяти).
Не забывайте о том, что большинство программ не очищают область памяти (буферы), где они хранят незашифрованные файлы (или их части) при их загрузке из тома VeraCrypt. Это означает, что после того, как вы выйдете из такой программы, в памяти (в ОЗУ) могут оставаться незашифрованные данные, с которыми она работала, до момента, пока не будет выключен компьютер (а согласно некоторым исследованиям, даже некоторое время после отключения питания*). Также имейте в виду, что когда вы открываете хранящийся в томе VeraCrypt файл, например, в текстовом редакторе, а затем принудительно размонтируете этот том VeraCrypt, данный файл останется незашифрованным в области памяти (ОЗУ), используемой (занятой) текстовым редактором. Это также относится и к принудительному авторазмонтированию.
По сути, незашифрованные мастер-ключи также должны храниться в оперативной памяти. При размонтировании несистемного тома VeraCrypt стирает его мастер-ключи (хранящиеся в ОЗУ). При штатно выполненной перезагрузке (или нормальном завершении работы) компьютера все несистемные тома VeraCrypt автоматически размонтируются, и, соответственно, все хранящиеся в ОЗУ мастер-ключи удаляются драйвером VeraCrypt (за исключением мастер-ключей для системных разделов/дисков — см. ниже). Однако при внезапном отключении питания, при перезагрузке компьютера кнопкой Reset (а не штатно), или при зависании системы VeraCrypt, естественно, перестаёт работать и поэтому не может удалить ни какие-либо ключи, ни любые другие конфиденциальные данные. Более того, поскольку Microsoft не предоставляет соответствующего API для обработки гибернации и завершения работы, используемые для шифрования системы мастер-ключи не могут быть надёжно удалены (и не удаляются) из ОЗУ при переходе компьютера в состояние гибернации, завершении работы или перезагрузке.**
Начиная с версии 1.24, в VeraCrypt появился механизм шифрования мастер-ключей и кэшированных паролей в ОЗУ. Этот механизм шифрования ОЗУ необходимо активировать вручную в окне Настройки > Производительность и драйвер, включив опцию Шифровать ключи и пароли в ОЗУ. Шифрование оперативной памяти сопряжено со снижением производительности (5-15% в зависимости от скорости процессора), и оно отключает гибернацию Windows.
Кроме того, в VeraCrypt 1.24 и выше реализован дополнительный механизм безопасности при шифровании системы, который заставляет VeraCrypt стирать мастер-ключи из ОЗУ при подключении нового устройства к ПК. Этот дополнительный механизм активируется опцией в окне системных настроек.
Несмотря на то, что оба вышеперечисленных механизма обеспечивают надёжную защиту мастер-ключей и кэшированного пароля, пользователи всё равно должны принимать обычные меры предосторожности, связанные с сохранением конфиденциальных данных в оперативной памяти.
Подводя итог, заметим, что VeraCrypt не может и не гарантирует отсутствие в ОЗУ секретной информации (паролей, мастер-ключей или расшифрованных данных). Поэтому после каждого сеанса работы с томом VeraCrypt или в котором запущена зашифрованная операционная система, вы должны завершить работу компьютера (или, если файл гибернации у вас зашифрован, переведите компьютер в режим гибернации), а затем оставить его выключенным как минимум на несколько минут (чем дольше, тем лучше), прежде чем снова включить его. Это необходимо, чтобы очистить ОЗУ (см. также раздел Файл гибернации).

* Предположительно, в течение 1,5-35 секунд при нормальных рабочих температурах (26-44 °C) и до нескольких часов, если модули памяти охлаждаются (при работающем компьютере) до очень низких температур (например, до -50 °C). У новых типов модулей памяти, как утверждается, гораздо более короткое время затухания (например, 1,5-2,5 секунды), чем у более старых типов (по состоянию на 2008 год).
** Прежде чем ключ может быть стёрт из оперативной памяти, должен быть размонтирован соответствующий том VeraCrypt. Для несистемных томов это не вызывает никаких проблем. Однако поскольку Microsoft в настоящее время не предоставляет какого-либо подходящего API для обработки заключительной фазы процесса завершения работы системы, файлы подкачки, расположенные на зашифрованных системных томах, которые размонтируются при завершении работы системы, всё еще могут содержать страницы памяти (включая части системных файлов Windows). Это может привести к ошибкам "синего экрана". Поэтому чтобы предотвратить ошибки "синего экрана", VeraCrypt не размонтирует зашифрованные системные тома и, следовательно, не может очистить мастер-ключи системных томов при выключении или перезагрузке системы.


Документация >> Требования безопасности и меры предосторожности >> Шифрование оперативной памяти в VeraCrypt

Шифрование оперативной памяти в VeraCrypt

Введение

Шифрование ОЗУ в VeraCrypt направлено на защиту ключей шифрования диска, хранящихся в энергонезависимой памяти, от определённых типов атак. Основные цели шифрования:

  • Защита от атак при "холодной" загрузке компьютера (Cold Boot).
  • Добавление уровня обфускации (запутывания кода), чтобы значительно усложнить восстановление мастер-ключей шифрования из дампов памяти, будь то в режиме реального времени или в автономном режиме.

Реализация

Краткое описание того, как достигается шифрование оперативной памяти:

  1. При запуске Windows драйвер VeraCrypt выделяет область памяти размером 1 МиБ. Если это не удаётся, размер уменьшается вдвое до тех пор, пока распределение не завершится успешно (минимальный размер – 8 КиБ). Все эти переменные размещаются в невыгружаемом пространстве памяти ядра.
  2. Затем эта область памяти заполняется случайными байтами, сгенерированными CSPRNG на основе ChaCha20.
  3. Генерируются два случайных 64-битных целых числа: HashSeedMask и CipherIVMask.
  4. Для каждого мастер-ключа тома алгоритм шифрования ОЗУ получает уникальный ключ из комбинации области памяти и уникальных значений, извлечённых из памяти, подлежащей шифрованию. Это обеспечивает отдельный ключ для каждой зашифрованной области памяти. Использование ключей и IV, зависящих от местоположения, предотвращает лёгкое извлечение мастер-ключей из дампов памяти.
  5. Мастер-ключи расшифровываются для каждого запроса, что требует быстрого алгоритма расшифровки. Для этого используется ChaCha12.
  6. После монтирования тома его мастер-ключи немедленно шифруются по описанному алгоритму.
  7. Для каждого запроса ввода-вывода для тома мастер-ключи расшифровываются только на время этого запроса, а затем надёжно удаляются.
  8. При размонтировании тома зашифрованные мастер-ключи надёжно удаляются из памяти.
  9. При завершении работы или перезагрузке Windows область памяти, выделенная во время запуска, надёжно очищается.

Защита от атак при "холодной" перезагрузке ПК (Cold Boot)

Предотвращение атак при "холодной" загрузке достигается благодаря использованию большой страницы памяти для формирования (деривации) ключа. Это гарантирует, что злоумышленники не смогут восстановить мастер-ключ, поскольку части этой большой области памяти, скорее всего, будут повреждены и их нельзя будет восстановить после завершения работы. Более подробную информацию об атаках с "холодной" загрузкой и методах их предотвращения см. в следующих документах:

  • Cold Boot Attacks (BlackHat)
  • RAM Hijacks

Несовместимость с режимом гибернации и быстрым запуском Windows

Шифрование оперативной памяти в VeraCrypt несовместимо с функциями гибернации и быстрого запуска Windows. Перед активацией шифрования ОЗУ эти функции будут отключены VeraCrypt, чтобы обеспечить безопасность и функциональность механизма шифрования.

Выбор алгоритма

Выбор алгоритмов основывался на балансе между безопасностью и производительностью:

  • t1ha2: Некриптографическая хеш-функция, выбранная из-за её чрезвычайно высокой скорости хеширования. Это очень важно, поскольку ключи извлекаются для каждого запроса шифрования/дешифрования из области памяти размером 1 МиБ. Также соблюдаются строгие лавинные критерии, что имеет решающее значение для данного варианта использования.
  • ChaCha12: Этот алгоритм выбран вместо ChaCha20 по соображениям производительности; он обеспечивает достаточную надёжность шифрования при сохранении высокой скорости шифрования/дешифрования.

Ключевые алгоритмы

Для шифрования оперативной памяти основополагающими являются два основных алгоритма:

1. VcGetEncryptionID

Вычисляет уникальный идентификатор для набора буферов оперативной памяти, подлежащих шифрованию.

    – Ввод: pCryptoInfo, переменная CRYPTO_INFO для шифрования/дешифрования
    – Вывод: 64-битное целое число, идентифицирующее переменную pCryptoInfo
    – Шаги:
      – Вычисление суммы адресов виртуальной памяти полей ks и ks2 в pCryptoInfo: encID = ((uint64) pCryptoInfo->ks) + ((uint64) pCryptoInfo->ks2)
      – Возврат результата

2. VcProtectMemory

Шифрует буфер оперативной памяти, используя уникальный идентификатор, сгенерированный VcGetEncryptionID.

    – Ввод:
      – encID, уникальный идентификатор памяти, подлежащей шифрованию
      – pbData, указатель на память, которую нужно зашифровать
      – pbKeyDerivationArea, область памяти, выделяемая драйвером при запуске
      – HashSeedMask и CipherIVMask, два 64-битных случайных целых числа при запуске
    – Вывод:
      – Отсутствует; память в pbData шифруется на месте
    – Шаги:
      – Формирование hashSeed: hashSeed = (((uint64) pbKeyDerivationArea) + encID) ^ HashSeedMask
      – Вычисление 128-битного хеша: hash128 = t1h2 (pbKeyDerivationArea,hashSeed)
      – Разложение hash128 на два 64-битных целых числа: hash128 = hash128_1 || hash128_2
      – Создание 256-битного ключа для ChaCha12: chachaKey = hash128_1 || hash128_2 || (hash128_1 OR hash128_2) || (hash128_1 + hash128_2)
      – Шифрование chachaKey с помощью ChaCha12, используя hashSeed как IV: ChaCha256Encrypt (chachaKey, hashSeed, chachaKey)
      – Формирование 64-битного IV для ChaCha12: chachaIV = (((uint64) pbKeyDerivationArea) + encID) ^ CipherIVMask
      – Шифрование памяти в pbData с помощью ChaCha12: ChaCha256Encrypt (chachaKey, chachaIV, pbData)
      – Надёжное стирание временных значений

Важно отметить, что поскольку ChaCha12 – это потоковый шифр, процессы шифрования и дешифрования идентичны, и функция VcProtectMemory может использоваться для обоих.

Для более глубокого понимания и ознакомления с кодовой базой посетите репозиторий VeraCrypt и изучите упомянутые функции в файле src/Common/Crypto.c.

Дополнительные меры безопасности

Начиная с версии 1.24, в VeraCrypt встроен механизм, который обнаруживает установку новых устройств в систему, когда активно системное шифрование. При установке нового устройства мастер-ключи немедленно удаляются из памяти, что приводит к BSOD ("синему экрану смерти") в Windows. Это защищает от атак с помощью специализированных устройств для извлечения памяти из работающих систем. Однако для максимальной эффективности эта функция должна применяться вместе с шифрованием оперативной памяти.
Чтобы включить эту функцию, в меню Система выберите пункт Установки и активируйте опцию Удалять ключи шифрования из ОЗУ при подключении нового устройства.

Технические ограничения, связанные с гибернацией и быстрым запуском

Функции гибернации и быстрого запуска Windows сохраняют содержимое оперативной памяти на жёстком диске. В контексте шифрования оперативной памяти VeraCrypt поддержка этих функций представляет собой серьёзную проблему.
Для обеспечения безопасности большáя область памяти, используемая для формирования ключа при шифровании ОЗУ, должна храниться в зашифрованном формате, отдельно от обычного шифрования VeraCrypt, применяемого к текущему диску. Это отдельное зашифрованное хранилище также должно быть разблокируемым тем же паролем, который использовался для предзагрузочной аутентификации. Более того, этот процесс должен произойти на ранней стадии загрузки, прежде чем появится доступ к файловой системе, что требует хранения необработанных зашифрованных данных в определённых секторах другого диска.
Хотя это технически осуществимо, сложность и недружественность такого решения к пользователям делают его непрактичным для стандартных применений. Поэтому при включении шифрования оперативной памяти отключаются гибернация и быстрый запуск Windows.


Документация >> Требования безопасности и меры предосторожности >> Защита памяти в VeraCrypt

Защита памяти в VeraCrypt

Введение

VeraCrypt всегда стремится улучшить взаимодействие с пользователем, сохраняя при этом наивысший уровень безопасности. Одна из таких функций безопасности – механизм защиты памяти. Однако для тех пользователей, которым требуются специальные возможности взаимодействия с ОС, мы предоставили возможность отключить этот механизм.

Общие сведения

Защита памяти гарантирует, что процессам, не являющимся административными, запрещён доступ к памяти процесса VeraCrypt. Это служит двум основным целям:

  • ЗАЩИТА ОТ ВРЕДОНОСНЫХ ДЕЙСТВИЙ: Этот механизм предотвращает внедрение вредоносных данных или кода в процесс VeraCrypt неадминистративными процессами.
  • ЗАЩИТА КОНФИДЕНЦИАЛЬНЫХ ДАННЫХ: Хотя VeraCrypt разработан так, чтобы не оставлять конфиденциальных данных в памяти, эта функция обеспечивает дополнительный уровень безопасности, гарантируя, что другие процессы, не являющиеся административными, не смогут получить доступ к потенциально конфиденциальной информации или извлечь её.

Зачем нужна опция отключения защиты памяти?

Некоторым инструментам специальных возможностей, таким как экранный диктор, требуется доступ к памяти процессов ПО для эффективной интерпретации пользовательского интерфейса (UI) и взаимодействия с ним. Защита памяти VeraCrypt непреднамеренно препятствовала работе таких инструментов. Чтобы гарантировать, что пользователи смогут беспрепятственно применять инструменты специальных возможностей в VeraCrypt, мы и ввели эту опцию отключения защиты.

Как включить/отключить защиту памяти?

По умолчанию защита памяти включена. Её можно отключить через главное окно VeraCrypt или во время установки.

  1. Во время установки:
    • В мастере установки найдите опцию Отключить защиту памяти для совместимости со специальными возможностями.
    • Установите флажок, если хотите отключить защиту памяти. Оставьте этот флажок снятым, чтобы продолжать использовать защиту памяти.
    • Приступайте к остальной части установки.
  2. После установки:
    • Откройте VeraCrypt и в меню Настройки выберите пункт Производительность и драйвер.
    • Найдите и установите/снимите флажок с опции Отключить защиту памяти для совместимости со специальными возможностями согласно вашим потребностям. Появится уведомление, что для вступления изменений в силу необходима перезагрузка ОС.
    • Нажмите OK.
  3. При обновлении или исправлении/переустановке:
    • В мастере установки найдите опцию Отключить защиту памяти для совместимости со специальными возможностями.
    • Найдите и установите/снимите флажок с опции Отключить защиту памяти для совместимости со специальными возможностями согласно вашим потребностям.
    • Приступайте к остальной части обновления или исправления/переустановки.
    • Если вы изменили настройку защиты памяти, появится уведомление, что необходима перезагрузка ОС.

О потенциальных рисках

Хотя отключение защиты памяти может быть важным для некоторых пользователей, необходимо понимать связанные с этим риски:

  • ПОТЕНЦИАЛЬНОЕ ВОЗДЕЙСТВИЕ: Отключение защиты может подвергнуть память процесса VeraCrypt воздействию вредоносных процессов.
  • НАИЛУЧШЕЕ РЕШЕНИЕ: Если вам не требуются специальные средства для использования VeraCrypt, рекомендуется оставить защиту памяти включённой.

Вопросы и ответы

По умолчанию защита памяти включена или выключена?
Защита памяти по умолчанию включена.

Как узнать, включена или отключена защита памяти?
Проверить состояние защиты памяти можно из главного окна VeraCrypt. Перейдите в меню Настройки и выберите пункт Производительность и драйвер. Если опция Отключить защиту памяти для совместимости со специальными возможностями включена, то защита памяти отключена. Если эта опция отключена, то защита памяти включена.

Снизит ли отключение защиты памяти надёжность шифрования VeraCrypt?
Нет, алгоритмы шифрования и их надёжность остаются прежними. Затрагивается только защита от потенциального перехвата памяти и внедрения в неё процессов, не являющимися административными.

Я не пользуюсь инструментами специальных возможностей. Нужно ли мне отключить эту функцию?
Нет, лучше оставить защиту памяти включённой для дополнительной безопасности.


Документация >> Требования безопасности и меры предосторожности >> Физическая безопасность

Физическая безопасность

Если у вашего неприятеля есть физический доступ к аппаратной части компьютера, и вы используете компьютер после того, как к нему имел физический доступ неприятель, VeraCrypt может потерять способность защищать данные в этом компьютере.* Это может быть вызвано тем, что неприятелю удалось модифицировать аппаратную часть ПК или подключить какой-либо вредоносный компонент (например, аппаратный модуль слежения на клавиатурой), который будет перехватывать пароли или ключи шифрования (например, когда вы монтируете том VeraCrypt) или как-то иначе компрометировать безопасность данного компьютера. Поэтому на компьютере, к которому имел физический доступ неприятель, использовать VeraCrypt нельзя. Кроме того, вы обязаны удостовериться, что VeraCrypt (в том числе его драйвер) не работает, когда неприятель физически обращается к компьютеру. Дополнительные сведения, относящиеся к аппаратным атакам, когда неприятель имеет непосредственный физический доступ к аппаратуре, приведены в разделе Незашифрованные данные в ОЗУ.
Кроме того, даже если у неприятеля нет физического доступа к аппаратной части компьютера непосредственно, пробить брешь в физической защите ПК можно путём удалённого перехвата и анализа излучений от аппаратуры компьютера (включая монитор и кабели). Например, перехваченные излучения от кабеля, соединяющего клавиатуру с компьютером, могут раскрыть набираемые вами пароли. Перечисление всех видов подобных атак (иногда называемых TEMPEST-атаками) и всех известных способов противодействия им (таких, как экранирование или радиопомехи) выходит за рамки данного документа. Вы обязаны предотвращать такие атаки. И ответственность за это лежит исключительно на вас. Если вы этого не сделаете, VeraCrypt может оказаться неспособным защищать данные в вашем компьютере.

* В этом разделе (Физическая безопасность) фраза "данные в компьютере" означает данные на внутренних и внешних устройствах хранения/носителях (включая съёмные устройства и сетевые диски), подключённых к компьютеру.


Документация >> Требования безопасности и меры предосторожности >> Вредоносное ПО (malware)

Вредоносное ПО (malware)

Термин "вредоносное ПО" (malware) это собирательное название всех типов вредоносных программ, таких как компьютерные вирусы, трояны, шпионское ПО или, в общем смысле, любое ПО (включая VeraCrypt или какой-либо компонент операционной системы), которое было изменено, обработано или может контролироваться неприятелем. Некоторые виды вредоносного ПО созданы, например, для слежения за клавиатурой, включая ввод паролей (перехваченные таким образом пароли затем либо пересылаются неприятелю через Интернет, либо сохраняются на незашифрованном локальном диске, откуда их затем сможет считать неприятель, когда получит физический доступ к компьютеру). Если вы используете VeraCrypt на компьютере, инфицированном любым видом malware, VeraCrypt может оказаться неспособен защищать данные в этом компьютере.* Поэтому использовать VeraCrypt в таком компьютере нельзя.
Важно понимать, что VeraCrypt – программа для шифрования данных, а не для защиты от вредоносного ПО. Ответственность за отсутствие в компьютере вредоносного ПО лежит исключительно на вас. Если вы этого не обеспечите, VeraCrypt может оказаться неспособен защищать данные в вашем компьютере.
Чтобы предотвратить проникновение в компьютер вредоносного ПО, следует соблюдать множество правил. Самые важные из них следующие: регулярно обновляйте операционную систему, интернет-браузер и другое важное ПО. В Windows XP и более новых версиях Windows включите предотвращение выполнения данных (DEP) для всех программ.** Не открывайте подозрительные вложения в почтовых сообщениях, особенно исполняемые файлы, даже если они выглядят так, будто присланы кем-то из ваших знакомых или друзей (их компьютеры могут быть инфицированы вредоносным ПО, самостоятельно рассылающим с их ПК/учётных записей вредоносные письма). Не щёлкайте по подозрительным ссылкам в почтовых сообщениях или на сайтах (даже если почта/сайт не вызывают опасений или заслуживают доверия). Не посещайте никаких подозрительных сайтов. Не скачивайте и не устанавливайте никаких подозрительных программ. Используйте только хорошее, надёжное ПО, не содержащее вредоносного кода.

* В этом разделе (Malware) фраза "данные в компьютере" означает данные на внутренних и внешних устройствах хранения/носителях (включая съёмные устройства и сетевые диски), подключённых к компьютеру.
** DEP расшифровывается как Data Execution Prevention – предотвращение выполнения данных. Подробности о DEP см. на сайтах https://support.microsoft.com/kb/875352 и http://technet.microsoft.com/en-us/library/cc700810.aspx.


Документация >> Требования безопасности и меры предосторожности >> Многопользовательская среда

Многопользовательская среда

Не забывайте, что содержимое смонтированного тома VeraCrypt видно (доступно) всем пользователям, вошедшим в систему. Чтобы этого избежать, можно воспользоваться правами NTFS на файлы/папки, если только том не был смонтирован как сменный носитель (см. раздел Том, смонтированный как сменный носитель) в настольной редакции Windows Vista или более новых версий Windows (сектора тома, смонтированного как сменный носитель, могут быть доступны на уровне томов пользователям без привилегий администратора, вне зависимости от того, доступен ли он им на уровне файловой системы).

Более того, в Windows всем вошедшим в систему пользователям доступен кэш паролей (см. подробности в разделе Настройки > Параметры, подраздел Кэшировать пароли в памяти драйвера).

Обратите также внимание, что при переключении пользователей в Windows XP или более новой версии Windows (функция Быстрое переключение пользователей) размонтирование успешно смонтированного тома VeraCrypt не выполняется (в отличие от перезагрузки системы, при которой размонтируются все смонтированные тома VeraCrypt).

В Windows 2000 права доступа к файлам-контейнерам игнорируются при монтировании тома VeraCrypt на основе файла. Во всех поддерживаемых версиях Windows пользователи без привилегий администратора могут монтировать любой том VeraCrypt на основе раздела/устройства (если указаны правильные пароль и/или ключевые файлы). Пользователь без привилегий администратора может демонтировать только те тома, которые монтировал он сам. Это, однако, не относится к системным избранным томам, если только вы не включили опцию (по умолчанию она выключена) Настройки > Системные избранные тома > Просматривать/размонтировать системные избранные тома могут лишь администраторы.


Документация >> Требования безопасности и меры предосторожности >> Подлинность и целостность данных

Подлинность и целостность данных

VeraCrypt применяет шифрование для сохранения конфиденциальности шифруемых данных. VeraCrypt не сохраняет и не проверяет целостность или подлинность данных, подвергающихся шифрованию и дешифрованию. Следовательно, если вы позволите неприятелю изменить зашифрованные с помощью VeraCrypt данные, он сможет установить у любого 16-байтового блока данных случайное или предыдущее значение, которое ему удалось получить в прошлом. Обратите внимание, что неприятель не может выбрать значение, которое вы получите, когда VeraCrypt расшифровывает изменённый блок – значение будет случайным, если только противник не восстановит старую версию зашифрованного блока, которую ему удалось получить в прошлом. Ответственность за проверку целостности и подлинности данных, зашифрованных или расшифрованных VeraCrypt, лежит только на вас (например, это можно сделать с помощью соответствующего стороннего ПО).

См. также: Физическая безопасность, Модель безопасности


Документация >> Требования безопасности и меры предосторожности >> Выбор паролей и ключевых файлов

Выбор паролей и ключевых файлов

Выбрать хороший пароль – это очень важно! Ни в коем случае не используйте пароль из одного слова, которое можно найти в каком-нибудь словаре (или сочетание из таких слов). В пароле не должно быть никаких имён, дней рождения, номеров телефонов и учётных записей (аккаунтов) и любых других элементов, которые можно угадать. Хороший пароль это случайная комбинация из букв в верхнем и нижнем регистрах, цифр и специальных символов, таких как @ ^ = $ * + и др. Настоятельно рекомендуется выбирать пароль, состоящий не менее чем из 20 символов (чем длиннее, тем лучше), так как короткие пароли несложно взломать методом перебора (brute-force).

Чтобы сделать атаки перебором невозможными, размер ключевого файла должен быть не менее 30 байт. Если для тома используется несколько ключевых файлов, хотя бы один из них должен иметь размер 30 байт или больше. Обратите внимание, что 30-байтовое ограничение предполагает большой объём энтропии в ключевом файле. Если первые 1024 килобайта файла содержат лишь небольшой объём энтропии, такой файл нельзя использовать как ключевой (вне зависимости от размера файла). Если вы не понимаете, что такое энтропия, рекомендуем доверить VeraCrypt создание файла со случайным содержимым и использовать этот файл как ключевой (выберите Сервис > Генератор ключевых файлов).

При создании тома, шифровании системного раздела/диска или изменении паролей/ключевых файлов нельзя позволять никому другому выбирать или изменять пароли/ключевые файлы до тех пор, пока не будет создан том или изменены пароль/ключевые файлы. Например, нельзя использовать никакие генераторы паролей (будь то приложения в Интернете или программы у вас в компьютере), если вы не уверены в их высоком качестве и в том, что они не подконтрольны неприятелю, а в качестве ключевых файлов нельзя использовать файлы, загруженные из Интернета, или которые доступны другим пользователям данного компьютера (неважно, администраторы они или нет).


Документация >> Требования безопасности и меры предосторожности >> Изменение паролей и ключевых файлов

Изменение паролей и ключевых файлов

Обратите внимание, что в заголовке тома (который зашифрован с помощью ключа заголовка, сформированного из пароля/ключевого файла) содержится мастер-ключ (не путайте с паролем), посредством которого зашифрован том. Если у злоумышленника есть возможность сделать копию вашего тома до того, как изменили пароль и/или ключевые файлы, он может использовать свою копию или фрагмент (старый заголовок) тома VeraCrypt, чтобы смонтировать ваш том, используя скомпрометированный пароль и/или скомпрометированные ключевые файлы, которые требовались для монтирования тома до изменения пароля и/или ключевых файлов.

Если вы не уверены, знает ли злоумышленник ваш пароль (или обладает вашими ключевыми файлами), и что у него нет копии вашего тома, когда вам потребовалось изменить его пароль и/или ключевые файлы, то настоятельно рекомендуется создать новый том VeraCrypt и переместить в него файлы из старого тома (у нового тома будет другой мастер-ключ).

Также учтите, что если злоумышленник знает ваш пароль (или обладает вашими ключевыми файлами) и у него есть доступ к вашему тому, он может получить и сохранить его мастер-ключ. Сделав это, он сможет расшифровать ваш том, даже если вы затем изменили пароль и/или ключевые файлы (потому что мастер-ключ не меняется при смене пароля тома и/или ключевых файлов). В этом случае создайте новый том VeraCrypt и переместите в него все файлы из старого тома.

Следующие разделы этой главы содержат дополнительную информацию о возможных проблемах безопасности, связанных со сменой паролей и/или ключевых файлов:

  • Требования безопасности и меры предосторожности
  • Журналируемые файловые системы
  • Дефрагментация
  • Перераспределённые сектора


Документация >> Требования безопасности и меры предосторожности >> Операция TRIM

Операция TRIM

В ряде запоминающих устройств (например, в некоторых твердотельных накопителях, включая USB-флешки) для маркировки секторов как свободных, например, при удалении файла, применяется так называемая операция "TRIM". Вследствие этого такие сектора могут содержать незашифрованные нули или другие неопределённые данные (незашифрованные), даже если они расположены внутри области диска, зашифрованной VeraCrypt.

В Windows программа VeraCrypt позволяет пользователям управлять операцией TRIM как для несистемных, так и для системных томов:
  • Для несистемных томов TRIM по умолчанию заблокирована. Чтобы её включить, нужно в главном окне VeraCrypt в меню Настройки выбрать Производительность и драйвер и включить опцию Разрешить команду TRIM для несистемных SSD-разделов/дисков.
  • Для шифрования системы операция TRIM по умолчанию разрешена (если только не запущена скрытая операционная система). Чтобы отключить TRIM, перейдите в Система > Установки и включите опцию Блокировать команду TRIM на системном разделе/диске.
В Linux программа VeraCrypt не блокирует операцию TRIM на томах, использующих собственные криптографические службы ядра Linux, что является настройкой по умолчанию. Чтобы заблокировать TRIM в Linux, нужно либо включить опцию "Не использовать криптографические службы ядра" в настройках VeraCrypt (применимо только к томам, смонтированным позднее), либо использовать при монтировании ключ --mount-options=nokernelcrypto в командной строке.

В macOS программа VeraCrypt не поддерживает TRIM, поэтому данная операция всегда заблокирована на всех томах.

В случаях, когда выполняется операция TRIM, злоумышленник сможет определить, какие сектора содержат свободное пространство (и может использовать эту информацию для дальнейшего анализа и атак), что может отрицательно сказаться на правдоподобности отрицания шифрования. Чтобы избежать этих проблем, следует либо отключить TRIM в настройках VeraCrypt, как описано выше, либо убедиться, что тома VeraCrypt не расположены на дисках, которые используют операцию TRIM.

Выяснить, используется ли в устройстве операция TRIM, можно в документации на это устройство или у его поставщика/производителя.


Документация >> Требования безопасности и меры предосторожности >> Wear-Leveling

Распределение износа блоков (Wear-Leveling)

Некоторые устройства хранения (например, твердотельные SSD-накопители, включая флеш-накопители USB) и некоторые файловые системы используют так называемые механизмы распределения износа, чтобы продлить срок службы устройства хранения или носителя. Суть работы этих механизмов в том, что даже если какое-либо приложение многократно записывает данные в один и тот же логический сектор, в действительности данные распределяются равномерно по всему носителю (то есть логические сектора переназначаются на разные физические сектора). Отсюда следует, что неприятелю могут оказаться доступны несколько "версий" одного сектора. А это может повлечь за собой различные проблемы с безопасностью. Например, когда вы изменяете у тома пароль и/или ключевые файлы, то – в нормальных условиях – заголовок тома перезаписывается новым, заново зашифрованным заголовком. Если же том находится на устройстве, в котором применяется wear-leveling, VeraCrypt не может гарантировать, что старый заголовок окажется действительно перезаписан. Если неприятель обнаружит в устройстве старый заголовок тома (который должен был быть перезаписан), он сможет воспользоваться им для монтирования тома, указав старый, рассекреченный пароль (и/или скомпрометированные ключевые файлы, служившие для монтирования этого тома до того, как был заново зашифрован заголовок тома). Из соображений безопасности мы не рекомендуем создавать/хранить тома VeraCrypt на устройствах (или в файловых системах), в которых применяется механизм wear-leveling (и не применять VeraCrypt для шифрования любых разделов в таких устройствах или файловых системах).
Если вы решили не следовать этой рекомендации и намереваетесь использовать шифрование "на месте" на устройстве, использующем механизмы wear-leveling, то перед тем как полностью зашифровать раздел/устройство, убедитесь, что в нём не содержится никаких секретных данных (на таком устройстве VeraCrypt не может надёжно выполнить безопасное шифрование имеющихся данных "на месте"; тем не менее, после того, как раздел/диск будет полностью зашифрован, любые записываемые на него новые данные будут надёжно шифроваться "на лету"). При этом нужно соблюдать следующие меры предосторожности.
Прежде чем запускать VeraCrypt для настройки предзагрузочной аутентификации, отключите файлы подкачки и перезагрузите операционную систему (после того, как системный раздел/диск будет полностью зашифрован, файлы подкачки можно будет снова включить). На период между запуском VeraCrypt для настройки предзагрузочной аутентификации и моментом, когда системный раздел/диск будет полностью зашифрован, необходимо отключить гибернацию. Учтите, однако, что даже при соблюдении этих мер предосторожности нельзя гарантировать отсутствие утечек данных и то, что содержащаяся в устройстве секретная информация будет безопасно зашифрована. Более подробную информацию см. в разделах Утечки данных, Файл подкачки, Файл гибернации и Файлы дампа памяти.
Если требуется возможность правдоподобного отрицания наличия шифрования, нельзя использовать VeraCrypt ни для шифрования любой части устройства (или файловой системы), ни для создания на нём зашифрованных контейнеров, если в этом устройстве применяется механизм wear-leveling.

Выяснить, используется ли в устройстве механизм wear-leveling, можно в документации на это устройство или у его поставщика/производителя.


Документация >> Требования безопасности и меры предосторожности >> Перераспределённые сектора

Перераспределённые сектора

Некоторые устройства хранения информации (например, жёсткие диски) перераспределяют/переназначают плохие сектора внутренними методами. Как только устройство обнаруживает сектор, в который невозможно записать данные, оно помечает такой сектор как плохой и переназначает его на другой сектор, расположенный в скрытой зарезервированной области диска. Все последующие операции чтения/записи с этим плохим сектором перенаправляются на сектор в зарезервированной области. Это означает, что любые содержащиеся в плохом секторе данные остаются на диске и их нельзя стереть (перезаписать другими данными), что может повлечь за собой различные проблемы с безопасностью. Например, в плохом секторе могут оставаться незашифрованные данные, которые должны были быть зашифрованы "на месте". Аналогично, в плохом секторе могут сохраниться данные, которые должны быть удалены (например, в процессе создания скрытой операционной системы). Если сектор перераспределён, это может неблагоприятно сказаться на правдоподобности отрицания наличия шифрования (см. раздел Правдоподобное отрицание наличия шифрования). Другие примеры возможных проблем с безопасностью приведены в разделе Требования безопасности и меры предосторожности. Имейте в виду, однако, что этот список неполный (просто примеры). Также учтите, что VeraCrypt не может предотвратить никаких проблем с безопасностью, связанных с перераспределёнными секторами или вызванных ими. Выяснить количество перераспределённых секторов на жёстком диске можно, например, с помощью сторонних программ для чтения так называемой информации S.M.A.R.T.


Документация >> Требования безопасности и меры предосторожности >> Дефрагментация

Дефрагментация

Когда вы (или операционная система) выполняете дефрагментацию файловой системы, в которой находится контейнер VeraCrypt на основе файла, копия этого контейнера (или его фрагмент) может остаться в свободной области хост-тома (в дефрагментированной файловой системе). Это может повлечь за собой ряд проблем с безопасностью. Например, если вы затем измените у тома пароль и/или ключевые файлы, а неприятель обнаружит старую копию или фрагмент (старый заголовок) тома VeraCrypt, он может с его помощью смонтировать том, используя старый скомпрометированный пароль (и/или старые скомпрометированные ключевые файлы, действительные для монтирования этого тома до того, как был перешифрован заголовок тома). Избежать этой и других проблем с безопасностью (таких, как описано в разделе Клонирование томов) поможет одно из следующего:

  • Используйте тома VeraCrypt на основе раздела/устройства, а не на основе файла.
  • После дефрагментации надёжно затирайте свободное место на хост-томе (в дефрагментированной файловой системе). В Windows это можно сделать с помощью бесплатной утилиты Microsoft SDelete (https://technet.microsoft.com/en-us/sysinternals/bb897443.aspx). В Linux для этой цели служит утилита shred из пакета GNU coreutils.
  • Не дефрагментируйте файловые системы, в которых вы храните тома VeraCrypt.


Документация >> Требования безопасности и меры предосторожности >> Журналируемые файловые системы

Журналируемые файловые системы

Если том VeraCrypt на основе файла находится в журналируемой файловой системе (например, в NTFS или Ext3), то в свободной области хост-тома может оставаться копия контейнера VeraCrypt (или его фрагмента). Это может повлечь за собой ряд проблем с безопасностью. Например, если вы измените у тома пароль и/или ключевые файлы, а неприятель обнаружит старую копию или фрагмент (старый заголовок) тома VeraCrypt, он может с его помощью смонтировать том, используя старый скомпрометированный пароль (и/или старые скомпрометированные ключевые файлы, действительные для монтирования этого тома до того, как был перешифрован заголовок тома). Кроме того, некоторые журналируемые файловые системы записывают в своих внутренних ресурсах время доступа к файлам и другую потенциально важную для сохранения конфиденциальности информацию. Если вам нужна возможность правдоподобного отрицания наличия шифрования (см. раздел Правдоподобное отрицание наличия шифрования), хранить контейнеры VeraCrypt на основе файлов в журналируемых файловых системах нельзя. Чтобы предотвратить возможные проблемы безопасности, связанные с журналированием файловых систем, выполните одно из следующего:

  • используйте тома TrueCrypt на основе раздела/устройства, а не на основе файла;
  • храните файловый контейнер в нежурналируемой файловой системе (например, в FAT32).


Документация >> Требования безопасности и меры предосторожности >> Клонирование томов

Клонирование томов

Никогда не создавайте новый том VeraCrypt путём клонирования какого-либо уже существующего тома VeraCrypt. Чтобы создать новый том, всегда используйте мастер создания томов VeraCrypt. Если создать клон тома, а затем начать использовать как этот том, так и его клон так, что оба в конечном итоге будут содержать разные данные, этим вы можете облегчить криптоанализ (поскольку при разном содержимом оба тома будут использовать один и тот же набор ключей). Это особенно критично, если в томе находится скрытый том. Также учтите, что в подобных случаях невозможно правдоподобно отрицать наличие шифрования (см. раздел Правдоподобное отрицание наличия шифрования). См. также главу О безопасном резервном копировании.


Документация >> Требования безопасности и меры предосторожности >> Дополнительные требования безопасности и меры предосторожности

Дополнительные требования безопасности и меры предосторожности

Помимо всего, что описано в главе Требования безопасности и меры предосторожности, вы обязаны помнить и соблюдать требования безопасности, меры предосторожности и ограничения, изложенные в следующих главах и разделах:

  • О безопасном резервном копировании
  • Ограничения
  • Модель безопасности
  • Требования безопасности и меры предосторожности, касающиеся скрытых томов
  • Правдоподобное отрицание наличия шифрования

См. также: Цифровые подписи


Документация >> О безопасном резервном копировании

О безопасном резервном копировании

Из-за аппаратных или программных ошибок/сбоев файлы в томе VeraCrypt могут оказаться повреждёнными. Поэтому мы настоятельно рекомендуем регулярно делать резервные копии всех важных файлов (разумеется, это относится к любым важным данным, а не только к зашифрованным в томах VeraCrypt).

Несистемные тома

Чтобы безопасно создать резервную копию несистемного тома VeraCrypt, рекомендуем следующую последовательность действий:

  1. Создайте новый том VeraCrypt с помощью мастера создания томов VeraCrypt (не включайте опции Быстрое форматирование и Динамический). Это будет ваш резервный том, поэтому он должен совпадать по размеру с основным томом (или быть больше него).

    Если основной том VeraCrypt – скрытый (см. раздел Скрытый том), то резервный том также должен быть скрытым томом VeraCrypt. Прежде чем создать скрытый резервный том, вы должны создать для него новый том, в котором он будет храниться (внешний том), не включая опцию Быстрое форматирование. Кроме того, особенно если резервный том – на основе файла, скрытый резервный том должен занимать лишь очень маленькую часть контейнера, а внешний том должен быть почти целиком заполнен файлами (иначе это может неблагоприятно сказаться на правдоподобности отрицания наличия скрытого тома).
  2. Смонтируйте вновь созданный резервный том.
  3. Смонтируйте основной том.
  4. Скопируйте все файлы из смонтированного основного тома непосредственно в смонтированный резервный том.

ВАЖНО: Если вы храните резервный том в месте, к которому может регулярно обращаться злоумышленник (например, на устройстве, хранящемся в сейфе банка), вам следует повторять все описанные выше действия (включая шаг 1) всякий раз, когда вы будете изготавливать резервную копию тома (см. ниже).

Если вы будете выполнять все указанные выше действия, то этим помешаете неприятелю выяснить:

  • какие сектора томов изменяются (так как вы всегда выполняете шаг 1), что особенно важно, например, если устройство с резервным томом находится в банковском сейфе (или любом другом месте, к которому может регулярно обращаться злоумышленник), и в томе содержится скрытый том (см. подробности в подразделе Требования безопасности и меры предосторожности, относящиеся к скрытым томам в главе Правдоподобное отрицание наличия шифрования);
  • что один из томов является резервной копией другого.

Системные разделы

Примечание: Помимо резервного копирования файлов также рекомендуется делать резервные копии диска восстановления VeraCrypt (выберите Система > Создать Диск восстановления). Более подробную информацию см. в разделе Диск восстановления VeraCrypt.

Чтобы надёжно и безопасно сделать резервную копию зашифрованного системного раздела, рекомендуем следующую последовательность действий:

  1. Если в компьютере установлено несколько операционных систем, загрузите ту из них, которая не требует предзагрузочной аутентификации.

    Если в компьютере установлена только одна операционная система, можно загрузиться с CD/DVD, содержащего WinPE или BartPE (live-версию Windows, целиком хранящуюся на CD/DVD и оттуда же загружающуюся; подробности ищите в главе Вопросы и ответы по ключевому слову ‘BartPE’).

    Если оба указанных выше варианта невозможны, подключите свой системный диск как вторичный накопитель к другому компьютеру и затем загрузите операционную систему, установленную в том компьютере.

    Примечание: Если операционная система, резервную копию которой вы хотите сделать, находится в скрытом томе VeraCrypt (см. раздел Скрытая операционная система), то, из соображений безопасности, операционная система, которую вы загружаете на этом этапе, должна быть либо ещё одной скрытой ОС, либо системой "live-CD" (см. выше). Более подробную информацию см. в подразделе Требования безопасности и меры предосторожности, касающиеся скрытых томов в главе Правдоподобное отрицание наличия шифрования.
  2. Создайте новый несистемный том VeraCrypt с помощью мастера создания томов VeraCrypt (не включая опции Быстрое форматирование и Динамический). Это будет ваш резервный том, поэтому он по размеру должен совпадать с системным разделом (или превосходить его), резервную копию которого вы намереваетесь сделать.

    Если операционная система, резервную копию которой вы хотите создать, установлена в скрытом томе VeraCrypt (см. раздел Скрытая операционная система), то резервный том тоже должен быть скрытым. Прежде чем создать скрытый резервный том, вы должны создать для него новый том, в котором он будет храниться (внешний том), не включая опцию Быстрое форматирование. Кроме того, особенно если резервный том – на основе файла, скрытый резервный том должен занимать лишь очень маленькую часть контейнера, а внешний том должен быть почти целиком заполнен файлами (иначе это может неблагоприятно сказаться на правдоподобности отрицания наличия скрытого тома).
  3. Смонтируйте вновь созданный резервный том.
  4. Смонтируйте системный раздел, резервную копию которого вы хотите сделать, выполнив следующее:
    1. Нажмите кнопку Выбрать устройство и выберите системный раздел, с которого нужно сделать резервную копию (в случае скрытой ОС, выберите раздел, содержащий скрытый том, в котором установлена скрытая ОС).
    2. Нажмите OK.
    3. Выберите Система > Смонтировать без предзагрузочной аутентификации.
    4. Введите свой пароль предзагрузочной аутентификации и нажмите OK.
  5. Смонтируйте резервный том, а затем с помощью какой-либо сторонней программы или средствами Windows создайте образ файловой системы, находящейся в системном разделе (который на предыдущем этапе был смонтирован как обычный том VeraCrypt) и сохраните этот образ непосредственно в смонтированном резервном томе.

ВАЖНО: Если вы храните резервный том в месте, к которому может регулярно обращаться злоумышленник (например, на устройстве, хранящемся в сейфе банка), вам следует повторять все описанные выше действия (включая шаг 2) всякий раз, когда вы будете изготавливать резервную копию тома (см. ниже).

Если вы будете выполнять все указанные выше действия, то этим помешаете неприятелю выяснить:

  • какие сектора томов изменяются (так как вы всегда выполняете шаг 2), что особенно важно, например, если устройство с резервным томом находится в банковском сейфе (или любом другом месте, к которому может регулярно обращаться злоумышленник), и в томе содержится скрытый том (см. подробности в подразделе Требования безопасности и меры предосторожности, касающиеся скрытых томов в главе Правдоподобное отрицание наличия шифрования);
  • что один из томов является резервной копией другого.

Общие замечания

Если вы храните резервную копию тома в месте, где неприятель может сделать копию тома, имеет смысл шифровать том каскадом (последовательностью) алгоритмов (например, AES-Twofish-Serpent). В противном случае, если том зашифрован только одним алгоритмом, и этот алгоритм в дальнейшем удастся взломать (например, вследствие прогресса в криптоанализе), неприятель сумеет расшифровать имеющиеся у него копии тома. Вероятность взлома сразу трёх разных алгоритмов шифрования значительно ниже, чем одного из них.


Документация >> Разное

Разное

  • Использование без прав администратора
  • Общий доступ по сети
  • Работа в фоновом режиме
  • Тома, смонтированные как сменный носитель
  • Системные файлы VeraCrypt
  • Как удалить шифрование
  • Удаление VeraCrypt
  • Цифровые подписи


Документация >> Разное >> Использование без прав администратора

Использование VeraCrypt без прав администратора

В среде Windows пользователь, не имеющий прав администратора, может использовать TrueCrypt, но только после того, как администратор компьютера установит VeraCrypt в систему. Причина в том, что для обеспечения незаметного для пользователя шифрования/дешифрования "на лету" требуется наличие в системе драйвера VeraCrypt, а пользователи без полномочий администратора не имеют прав на установку/запуск драйверов устройств в Windows.

После того как администратор системы установит VeraCrypt, пользователи, не обладающие правами администратора, смогут запускать VeraCrypt , монтировать/демонтировать тома VeraCrypt любого типа, загружать и сохранять в них данные, а также создавать в системе тома VeraCrypt на основе файлов-контейнеров. В то же время, пользователи без привилегий администратора не могут шифровать/форматировать разделы, создавать тома NTFS, устанавливать/удалять VeraCrypt, изменять пароли/ключевые файлы для разделов/устройств VeraCrypt, выполнять резервное копирование и восстановление из резервных копий заголовков разделов/устройств VeraCrypt, а также запускать VeraCrypt в "переносном" (portable) режиме.

ВНИМАНИЕ: Вне зависимости от типа используемого программного обеспечения, с точки зрения сохранности персональной информации в большинстве случаев небезопасно работать с конфиденциальными данными в системе, где у вас нет привилегий администратора, так как администратор может без труда получить и скопировать ваши конфиденциальные данные, в том числе пароли и ключи.


Документация >> Разное >> Общий доступ по сети

Общий доступ по сети

Если требуется доступ к одному и тому же тому VeraCrypt одновременно из нескольких операционных систем, возможны два варианта:

  1. Том VeraCrypt монтируется только на одном компьютере (скажем, на сервере), а по сети совместно используется только содержимое смонтированного тома VeraCrypt (то есть файловая система внутри тома VeraCrypt). Пользователи других компьютеров или систем не монтируют том (он уже смонтирован на сервере).

    Преимущества: все пользователи могут записывать данные в том VeraCrypt. Совместно используемый том может быть как на основе файла, так и на основе раздела/устройства.

    Недостаток: пересылаемые по сети данные не будут зашифрованными. Тем не менее их всё-таки можно шифровать с помощью SSL, TLS, VPN и других технологий.

    Замечания: примите к сведению, что при перезагрузке системы общий сетевой ресурс будет автоматически восстановлен только в случае, если это системный избранный том или зашифрованный системный раздел/диск (о том, как сделать том системным избранным томом, см. в главе Системные избранные тома).

  2. Размонтированный файловый контейнер VeraCrypt хранится на одном компьютере (скажем, на сервере). Этот зашифрованный файл доступен по сети. Пользователи других компьютеров или систем будут локально монтировать этот общий файл. Таким образом, том будет монтироваться одновременно в нескольких операционных системах.

    Преимущество: пересылаемые по сети данные будут зашифрованными (тем не менее, их всё же рекомендуется шифровать с помощью SSL, TLS, VPN или других подходящих технологий, чтобы ещё сильнее осложнить анализ трафика и сохранить целостность данных).

    Недостатки: общий том может быть только на основе файла-контейнера (но не на основе раздела/устройства). В каждой из систем том должен монтироваться в режиме только для чтения (о том, как смонтировать том в режиме только для чтения, см. раздел Параметры монтирования). Обратите внимание, что это требование относится и к незашифрованным томам. Одна из причин, например, в том, что данные, считанные из обычной файловой системы в среде одной ОС, в это же время могут быть изменены другой ОС, и потому окажутся несогласованными (что может привести к повреждению данных).


Документация >> Разное >> Работа в фоновом режиме

Работа VeraCrypt в фоновом режиме

Когда главное окно VeraCrypt закрыто, фоновая задача VeraCrypt выполняет следующие задачи/функции:

  1. Обслуживание горячих клавиш.
  2. Автоматическое размонтирование (например, при завершении сеанса, непреднамеренном извлечении хост-устройства, истечении времени ожидания и т. д.).
  3. Автоматическое монтирование избранных томов.
  4. Оповещения (например, о предотвращении повреждения скрытого тома).
  5. Значок в области уведомлений в панели задач.

ВНИМАНИЕ: Если VeraCrypt не запущен ни в фоновом режиме, ни явно, все указанные выше задачи/функции отключены.

VeraCrypt в фоновом режиме это на самом деле всё та же программа VeraCrypt.exe, продолжающая работать в фоне после того, как было закрыто её главное окно. Определить, работает программа или нет, можно по наличию значка в области уведомлений. Если там есть значок VeraCrypt, значит VeraCrypt работает в фоновом режиме. При щелчке по этому значку левой кнопкой мыши откроется главное окно VeraCrypt. При щелчке правой кнопкой мыши появится всплывающее меню с функциями VeraCrypt.

Прекратить фоновую работу VeraCrypt можно в любой момент, щёлкнув правой кнопкой мыши по значку VeraCrypt в области уведомлений и выбрав пункт Выход. Если вам нужно отключить работу VeraCrypt в фоновом режиме полностью и постоянно, выберите Настройки > Параметры и снимите флажок с опции Включено в группе параметров Работа VeraCrypt в фоновом режиме.


Документация >> Разное >> Том, смонтированный как сменный носитель

Том, смонтированный как сменный носитель

Этот раздел относится к томам VeraCrypt, смонтированным, когда включена одна из следующих опций (если применимо):

  • Настройки > Параметры > Монтировать тома как сменные носители
  • Параметры монтирования > Монтировать том как сменный носитель
  • Избранное > Упорядочить избранные тома > Монтировать выбранный том как сменный носитель
  • Избранное > Упорядочить системные избранные тома > Монтировать выбранный том как сменный носитель

Тома VeraCrypt, смонтированные как сменные носители, имеют следующие преимущества и недостатки:

  • На таких томах VeraCrypt в Windows не создаются автоматически папки Recycled и/или System Volume Information (эти папки в Windows служат для функций Корзины и восстановления системы).
  • Windows 8 и более новые версии не могут записывать в журнал событий Событие 98, содержащее имя устройства (\\device\VeraCryptVolumeXX) томов VeraCrypt, отформатированных в NTFS. Эта "функция" журнала событий была реализована в Windows 8 как часть недавно введённых проверок работоспособности NTFS, см. пояснения здесь. Большое спасибо Liran Elharar, который это обнаружил.
  • Windows может использовать методы кэширования и отложенную запись, которые обычно применяются для сменных носителей (например, для USB-флешек). Это может немного снизить производительность, но в то же время увеличить вероятность того, что можно будет быстро размонтировать том без принудительного размонтирования.
  • Операционная система может стремиться свести к минимуму количество дескрипторов, которые она открывает для такого тома.
  • У томов, смонтированных как сменные носители, в среде Windows Vista и более ранних версий Windows в списке Компьютер (или Мой компьютер) не отображается объём свободного места (это ограничение Windows, а не ошибка в VeraCrypt).
  • В среде Windows Vista и более новых версий Windows для настольных ПК, сектора тома, смонтированного как сменный носитель, могут быть доступны всем пользователям (включая пользователей без прав администратора; см. раздел Многопользовательская среда).


Документация >> Разное >> Системные файлы VeraCrypt

Системные файлы VeraCrypt и программные данные

Примечание. %windir% – это основной путь установки Windows (например, C:\WINDOWS)

Драйвер VeraCrypt

%windir%\SYSTEM32\DRIVERS\veracrypt.sys

Примечание. Этот файл отсутствует, если VeraCrypt работает в переносном (portable) режиме.

Установки VeraCrypt, программные данные и другие системные файлы

ВНИМАНИЕ: VeraCrypt не шифрует никаких из указанных в этом разделе файлов (если только не зашифрован системный раздел/диск).

Следующие файлы сохраняются в папке %APPDATA%\VeraCrypt\. В переносном (portable) режиме эти файлы сохраняются в папке, откуда был запущен файл VeraCrypt.exe (то есть в папке, где расположен VeraCrypt.exe):

  • Configuration.xml (основной конфигурационный файл).
  • System Encryption.xml (временный конфигурационный файл, используемый во время начального процесса шифрования/дешифрования на месте системного раздела/диска).
  • Default Keyfiles.xml
    • Примечание. Этот файл может отсутствовать, если не используется соответствующая функция VeraCrypt.
  • Favorite Volumes.xml
    • Примечание. Этот файл может отсутствовать, если не используется соответствующая функция VeraCrypt.
  • History.xml (список последних 20 файлов/устройств, которые пытались смонтировать как тома VeraCrypt или использовать как хосты для томов VeraCrypt; эту функцию можно отключить – см. подробности в разделе Не сохранять историю)
    • Примечание. Этот файл может отсутствовать, если не используется соответствующая функция VeraCrypt.
  • In-Place Encryption (временный конфигурационный файл, используемый во время начального процесса шифрования/дешифрования несистемного тома на месте).
  • In-Place Encryption Wipe Algo (временный конфигурационный файл, используемый во время начального процесса шифрования/дешифрования несистемного тома на месте).
  • Post-Install Task - Tutorial (временный конфигурационный файл, используемый при установке или обновлении VeraCrypt).
  • Post-Install Task - Release Notes (временный конфигурационный файл, используемый при установке или обновлении VeraCrypt).

Следующий файл сохраняется в папке %ALLUSERSPROFILE%\VeraCrypt\:

  • Original System Loader (резервная копия исходного содержимого первой дорожки диска, сделанная до того, как в неё был записан загрузчик VeraCrypt).
    • Примечание. Этот файл может отсутствовать, если системный раздел/диск не зашифрован.

Следующие файлы сохраняются в папке %windir%\system32 (32-разрядные системы) или в %windir%\SysWOW64 (64-разрядные системы):

  • VeraCrypt System Favorite Volumes.xml
    • Примечание. Этот файл может отсутствовать, если не используется соответствующая функция VeraCrypt.
  • VeraCrypt.exe
    • Примечание. Копия этого файла находится в данной папке только при включённом монтировании системных избранных томов.


Документация >> Разное >> Удаление шифрования

Как удалить шифрование

Учтите, что VeraCrypt может выполнять дешифрование "на месте" только разделов и дисков (выберите Система > Окончательно расшифровать системный раздел/диск для системного раздела/диска, и Тома > Окончательно расшифровать – для несистемного раздела/диска). Если нужно удалить шифрование (например, когда вы больше в нём не нуждаетесь) из тома на основе файла, выполните следующие действия:

  1. Смонтируйте том VeraCrypt.
  2. Перенесите все файлы из тома VeraCrypt в любое место вне тома VeraCrypt (обратите внимание, что файлы будут "на лету" расшифрованы).
  3. Размонтируйте том VeraCrypt.
  4. Удалите этот файл (контейнер), как вы удаляете любой другой файл.

Если дешифрование "на месте" несистемных разделов/дисков нежелательно, в этом случае также возможно выполнить шаги 1-3, описанные выше.

Во всех случаях, если выполняются шаги 1-3, могут быть выполнены следующие дополнительные операции:

  • Если том – на основе раздела (относится также к USB-флешкам)
    1. Щёлкните правой кнопкой мыши по значку Компьютер (или Мой компьютер) на рабочем столе или в меню Пуск и выберите Управление. Появится окно Управление компьютером.
    2. В окне Управление компьютером, из списка слева, выберите Управление дисками (в подветви Запоминающие устройства).
    3. Щёлкните правой кнопкой мыши на разделе, который вы хотите расшифровать, и выберите Изменить букву диска или путь к диску.
    4. Появится окно Изменение буквы диска или путей. Если в этом окне нет никакой буквы диска, нажмите Добавить. В противном случае нажмите Отмена.
      Если вы нажали Добавить, то в появившемся окне Добавление буквы диска или пути выберите букву диска, которую вы хотите присвоить тому, и нажмите OK.
    5. В окне Управление компьютером снова щёлкните правой кнопкой мыши по разделу, который вы хотите расшифровать, и выберите Форматировать. Появится окно Форматирование.
    6. В окне Форматирование нажмите OK. После форматирования раздела больше не потребуется монтировать его с помощью VeraCrypt, чтобы иметь возможность сохранять или загружать в нём файлы.
  • Если том – на основе устройства
  1. Щёлкните правой кнопкой мыши по значку Компьютер (или Мой компьютер) на рабочем столе или в меню Пуск и выберите Управление. Появится окно Управление компьютером.
  2. В окне Управление компьютером, из списка слева, выберите Управление дисками (в подветви Запоминающие устройства).
  3. Появится окно Инициализация диска. Используйте его, чтобы проинициализировать диск.
  4. В окне Управление компьютером щёлкните правой кнопкой мыши по области, где показано место на зашифрованном устройстве, и выберите Создать раздел или Создать простой том.
  5. ВНИМАНИЕ: Прежде чем продолжить, убедитесь, что выбрали именно то устройство, которое хотели, так как все файлы на нём будут уничтожены. В появившемся окне Мастер создания разделов или Мастер создания простых томов следуйте инструкциям, чтобы создать на устройстве новый раздел. После того как раздел будет создан, устройство больше не потребуется монтировать с помощью VeraCrypt, чтобы иметь возможность сохранять или загружать в нём файлы.


Документация >> Разное >> Удаление VeraCrypt

Удаление VeraCrypt

Чтобы удалить (деинсталлировать) VeraCrypt из Windows XP, выберите меню Пуск > Настройка > Панель управления > Установка и удаление программ> VeraCrypt > Изменить/Удалить.

Чтобы удалить VeraCrypt из Windows Vista и более новых версий Windows, выберите меню Пуск > Компьютер > Удаление или изменение программ > VeraCrypt > Удалить.

Чтобы удалить VeraCrypt из Linux, вы должны выполнить следующую команду от имени root: veracrypt-uninstall.sh. Например, в Ubuntu введите следующее в терминале: sudo veracrypt-uninstall.sh

При деинсталляции VeraCrypt никакие тома не удаляются. Вы сможете снова монтировать свои тома VeraCrypt, повторно установив VeraCrypt или запустив в переносном (portable) режиме.


Документация >> Miscellaneous >> Цифровые подписи

Цифровые подписи

Зачем нужно проверять цифровые подписи

Может так случиться, что установочный пакет VeraCrypt, который вы загружаете с нашего сервера, был создан или модифицирован взломщиком. Например, взломщик мог воспользоваться какой-либо уязвимостью в используемом нами серверном ПО и изменить хранящиеся на сервере установочные пакеты, либо он мог изменить любые файлы при их пересылке к вам.

По этой причине следует всегда проверять целостность и аутентичность любого установочного пакета VeraCrypt , который вы загружаете или получаете из какого-либо иного источника. Другими словами, следует всегда проверять, что файл создан именно нами и не был модифицирован злоумышленником. Единственный способ это сделать – проверить у файла так называемые цифровые подписи.

Типы используемых нами цифровых подписей

В настоящий момент мы используем цифровые подписи двух типов:

  • Подписи PGP (доступны для всех пакетов с бинарными файлами и с исходным кодом для всех операционных систем).
  • Подписи X.509 (доступны для пакетов с бинарными файлами для Windows).

Преимущества подписей X.509

По сравнению с подписями PGP, подписи X.509 имеют следующие преимущества:

  • значительно проще проверить, что ключ, которым подписан файл, действительно наш (а не взломщика);
  • чтобы поверить подлинность подписи X.509, не требуется загружать и устанавливать никакого дополнительного ПО (см. ниже);
  • не нужно загружать и импортировать наш открытый ключ (он встроен в подписанный файл);
  • не нужно загружать отдельный файл с подписью (она встроена в подписанный файл).

Преимущества подписей PGP

По сравнению с подписями X.509, подписи PGP имеют следующее преимущество:

  • они не зависят от источника сертификации (который может, например, фильтроваться/контролироваться неприятелем или быть ненадёжным по другим причинам).

Как проверять подписи X.509

Обратите внимание, что в настоящий момент подписи X.509 доступны только для самораспаковывающихся установочных пакетов VeraCrypt для Windows. Подпись X.509, встроенная в каждый из таких файлов вместе с цифровым сертификатом VeraCrypt Foundation, выпущена общественной организацией сертификации. Чтобы проверить целостность и подлинность самораспаковывающегося установочного пакета для Windows, сделайте следующее:

  1. Загрузите (скачайте) самораспаковывающийся установочный пакет VeraCrypt.
  2. В Проводнике Windows щёлкните правой кнопкой мыши по загруженному файлу (‘VeraCrypt Setup.exe’) и выберите в контекстном меню пункт Свойства.
  3. В диалоговом окне Свойства перейдите на вкладку Цифровые подписи.
  4. На вкладке Цифровые подписи в поле Список подписей дважды щёлкните по строке с надписью "IDRIX" или "IDRIX SARL".
  5. Появится диалоговое окно Состав цифровой подписи. Если вверху этого окна вы увидите следующую фразу, значит целостность и подлинность пакета успешно прошли проверку и подтверждены:

    "Эта цифровая подпись действительна."

    Если такой фразы нет, это означает, что файл скорее всего повреждён.
    Примечание. В ряде устаревших версий Windows проверка подписей не работает, так как отсутствуют некоторые необходимые сертификаты.

Как проверять подписи PGP

Чтобы проверить подпись PGP, проделайте следующее:

  1. Установите любую программу шифрования с открытым ключом, поддерживающую подписи PGP. Для Windows можно загрузить Gpg4win. См. подробности на сайте https://www.gnupg.org/.
  2. Создайте закрытый (личный) ключ (о том, как это сделать, см. в документации на ПО шифрования с открытым ключом).
  3. Загрузите наш открытый ключ PGP с сайта AM Crypto (https://amcrypto.jp/VeraCrypt/VeraCrypt_PGP_public_key.asc) или из надёжного репозитария (ID=0x680D16DE) открытых ключей и импортируйте загруженный ключ в свою связку ключей (keyring). О том, как это сделать, см. в документации на ПО шифрования с открытым ключом. Убедитесь, что его отпечаток – 5069A233D55A0EEB174A5FC3821ACD02680D16DE.
    • Для VeraCrypt версии 1.22 и старее проверка должна использовать открытый ключ PGP, доступный по адресу https://amcrypto.jp/VeraCrypt/VeraCrypt_PGP_public_key_2014.asc или из надёжного репозитария открытых ключей (ID=0x54DDD393), чей отпечаток – 993B7D7E8E413809828F0F29EB559C7C54DDD393.
  4. Подпишите импортированный ключ своим личным ключом, чтобы пометить его как надёжный (о том, как это сделать, см. в документации на ПО шифрования с открытым ключом).

    Примечание: если вы пропустите этот шаг и попытаетесь проверить любую нашу PGP-подпись, то получите сообщение об ошибке, гласящее, что цифровая подпись неверна.
  5. Загрузите цифровую подпись, нажав кнопку PGP Signature рядом с файлом, который вы хотите проверить (на странице загрузок).
  6. Проверьте загруженную подпись (о том, как это сделать, см. в документации на ПО шифрования с открытым ключом).

В Linux эти шаги могут быть выполнены с помощью следующих команд:

  • Проверьте, что отпечаток открытого ключа равен 5069A233D55A0EEB174A5FC3821ACD02680D16DE: gpg --import --import-options show-only VeraCrypt_PGP_public_key.asc (для старых версий gpg вместо этого введите: gpg --with-fingerprint VeraCrypt_PGP_public_key.asc)
  • Если отпечаток такой, как ожидалось, импортируйте открытый ключ: gpg --import VeraCrypt_PGP_public_key.asc
  • Проверьте подпись у установочного архива Linux (в этом примере – для версии 1.23): gpg --verify veracrypt-1.23-setup.tar.bz2.sig veracrypt-1.23-setup.tar.bz2


Документация >> Устранение затруднений

Устранение затруднений

В этом разделе приведены возможные решения типичных проблем, с которыми можно столкнуться при использовании VeraCrypt.
Примечание. Если описания вашей проблемы здесь нет, просмотрите следующие разделы:
  • Несовмесимости
  • Замеченные проблемы и ограничения
  • Вопросы и ответы
Убедитесь, что вы используете новейшую стабильную версию VeraCrypt. Если проблема вызвана ошибкой в какой-либо старой версии VeraCrypt, Если проблема вызвана ошибкой в какой-либо старой версии TrueCrypt, возможно, она уже исправлена. Чтобы узнать, какая у вас сейчас версия программы, см. Справка > О программе.

Проблема:
Операции записи/чтения с томом выполняются очень медленно, хотя согласно тесту, скорость используемого шифра выше, чем скорость жёсткого диска.
Вероятная причина:
Возможно, проблема вызвана вмешательством какой-либо сторонней программы.
Возможное решение:
Во-первых, проверьте, не имеет ли ваш файловый контейнер VeraCrypt расширения, зарезервированного за исполняемыми файлами (например, .exe, .sys или .dll). Если это так, Windows и антивирусное ПО могут вмешиваться в операции с таким контейнером и неблагоприятно влиять на скорость работы с томом.
Во-вторых, отключите или удалите приложение, которое может вмешиваться в операции с контейнером (обычно это антивирусное ПО, программы для автоматической дефрагментации дисков и т. д.). Если причина – в антивирусном ПО, часто помогает отключение в его настройках защиты в реальном времени. Если так устранить проблему не удалось, попробуйте временно отключить антивирусное ПО. Если и это не помогло, попробуйте полностью удалить это ПО и перезагрузить компьютер.
Проблема:
Невозможно смонтировать том VeraCrypt; программа выдаёт сообщение "Неверный пароль, либо это не том VeraCrypt".
Возможная причина:
Может быть повреждён заголовок тома в результате действия сторонней программы или некорректной работы аппаратного компонента компьютера.
Возможные решения:
  • Попробуйте восстановить заголовок тома из резервной копии, встроенной в том. Для этого:
    1. Запустите VeraCrypt.
    2. Нажмите кнопку Выбрать устройство или Выбрать файл, чтобы выбрать том.
    3. Выберите Сервис > Восстановить заголовок тома.
Проблема:
После успешного монтирования тома Windows выдаёт сообщение об ошибке "Файловая система тома не распознана" ("This device does not contain a valid file system") или аналогичное.
Вероятная причина:
Может быть повреждена файловая система в томе VeraCrypt (или том не отформатирован).
Возможное решение:
Для исправления файловой системы в томе VeraCrypt можно воспользоваться соответствующими средствами, входящими в состав вашей операционной системы. В Windows это утилита chkdsk. VeraCrypt предоставляет простой способ её использования для своих томов. Сначала создайте резервную копию тома VeraCrypt (так как утилита chkdsk может повредить файловую систему ещё больше), а затем смонтируйте его. Щёлкните правой кнопкой мыши по смонтированному тому в главном окне VeraCrypt (в списке дисков) и выберите в контекстном меню пункт Исправить файловую систему.
Проблема:
При попытке создать скрытый том, его максимально возможный размер – неожиданно маленький (хотя во внешнем томе гораздо больше свободного места).
Возможные причины:
  1. Внешний том отформатирован как NTFS.
  2. Фрагментация.
  3. Слишком маленький размер кластера + слишком много файлов/папок в корневой папке внешнего тома.
Возможные решения:
Решение для случая 1:
В отличие от файловой системы FAT, файловая система NTFS всегда сохраняет внутренние данные точно в середине тома. Поэтому скрытый том может находиться только во второй половине внешнего тома. Если это ограничение для вас неприемлемо, сделайте одно из следующего:
  • Переформатируйте внешний том в FAT и затем создайте внутри него скрытый том.
  • Если внешний том слишком большой, чтобы его можно было отформатировать в FAT, разделите этот том на несколько томов объёмом по 2 терабайта (или по 16 терабайт, если устройство использует 4-килобайтные сектора) и отформатируйте каждый из этих томов в FAT.
Решение для случая 2:
Создайте новый внешний том (дефрагментация не решит проблему, так как неблагоприятно влияет на возможность правдоподобного отрицания наличия шифрования – см. раздел Дефрагментация).
Решение для случая 3:
Примечание. Следующее решение применимо только к скрытым томам, созданным внутри томов с файловой системой FAT.
Дефрагментируйте внешний том (смонтируйте его, щёлкните правой кнопкой мыши по его букве диска в окне Компьютер или Мой компьютер, нажмите Свойства, перейдите на вкладку Сервис и нажмите Выполнить дефрагментацию). После того как том будет дефрагментирован, закройте окно Дефрагментация диска и попытайтесь снова создать скрытый том.

Если это не помогло, удалите все файлы и папки во внешнем томе нажатием клавиш Shift+Delete, но не форматированием (не забудьте заранее отключить для этого диска Корзину и восстановление системы), и попробуйте снова создать скрытый том в этом полностью пустом внешнем томе (только с целью проверки). Если максимально возможный размер скрытого тома не изменился даже сейчас, причина проблемы, вероятнее всего, кроется в расширенной корневой папке. Если вы использовали размер кластеров, отличный от предлагаемого по умолчанию (последний этап в работе мастера), переформатируйте внешний том, на этот раз оставив размер кластера по умолчанию.
Если это не помогло, ещё раз переформатируйте внешний том и скопируйте в его корневую папку меньше файлов/папок, чем в прошлый раз. Если проблема не решается, повторяйте форматирование и уменьшайте количество файлов/папок в корневой папке. Если это неприемлемо или не помогает, переформатируйте внешний том, выбрав больший размер кластеров. Если это не помогло, повторяйте переформатирование, увеличивая размер кластеров, пока проблема не будет решена. В качестве альтернативы попробуйте создать скрытый том внутри тома с файловой системой NTFS.
Проблема:
Возникает одна из следующих проблем:
  • невозможно смонтировать том VeraCrypt
  • невозможно создавать тома VeraCrypt с файловой системой NTFS
Кроме того, возможна следующая ошибка: "Процесс не может получить доступ к файлу, занятому другим процессом".
Вероятная причина:
Возможно, проблема вызвана вмешательством какой-либо сторонней программы. Обратите внимание, что это не ошибка в VeraCrypt. Операционная система сообщает VeraCrypt, что устройство заблокировано для исключительного доступа каким-либо приложением (поэтому VeraCrypt не может к нему обратиться).
Возможное решение:
Как правило, помогает отключение или удаление мешающего приложения (обычно это антивирусное ПО, программы управления дисками и т. д.).
Проблема:
На экране загрузчика VeraCrypt я пытаюсь ввести пароль и/или нажимать другие клавиши, но загрузчик никак на это не реагирует.
Вероятная причина:
У вас клавиатура USB (не PS/2), а в настройках BIOS отключена поддержка USB-клавиатур в фазе до загрузки ОС.
Возможное решение:
Нужно включить поддержку USB-клавиатур в настройках BIOS. Чтобы это сделать, выполните следующее:
Перезагрузите компьютер, нажмите клавишу F2 или Delete (сразу как появится начальный экран BIOS) и дождитесь появления экрана с настройками BIOS. Если этот экран не появился, снова перезагрузите компьютер (нажмите кнопку сброса) и сразу же начните часто нажимать клавишу F2 или Delete. Когда появится экран с настройками BIOS, включите поддержку USB-клавиатур в предзагрузочной среде. Обычно это выполняется выбором Advanced > USB Configuration > Legacy USB Support (или USB Legacy) > Enabled. (Обратите внимание, что слово "legacy", то есть "устаревший", на самом деле вводит в заблуждение, так как предзагрузочные компоненты современных версий Windows требуют, чтобы этот параметр был включён, дабы позволить взаимодействие с пользователем.) Затем сохраните настройки BIOS (обычно это делается нажатием клавиши ) и перезагрузите компьютер. Более подробную информацию см. в документации на BIOS/системную плату или свяжитесь со службой технической поддержки поставщика вашего компьютера.
Проблема:
После шифрования системного раздела/диска компьютер после перезагрузки не может загрузиться (также невозможно войти в экран настроек BIOS).
Вероятная причина:
Ошибка в BIOS компьютера.
Возможные решения:

Сделайте следующее:

  1. Отключите зашифрованный диск.
  2. Подключите незашифрованный диск с установленной операционной системой (или установите её на диск).
  3. Обновите BIOS.
  4. Если проблема не решилась, сообщите об этой ошибке производителю или поставщику компьютера.

ИЛИ

  • Если у поставщика BIOS/системной платы/компьютера нет обновлений, решающих проблему, а вы используете Windows 7 или более новую версию Windows, и на диске есть дополнительный загрузочный раздел (размером менее 1 ГБ), можно попробовать переустановить Windows без этого дополнительного загрузочного раздела (чтобы обойти ошибку в BIOS).
Проблема:
Возникает одна из следующих проблем:
  • После ввода пароля предзагрузочной аутентификации во время предварительного теста шифрования системы компьютер зависает (при появлении сообщения "Booting...").
  • Если зашифрован системный раздел/диск (частично или полностью), и система перезагружена первый раз с момента запуска шифрования системного раздела/диска, компьютер зависает после ввода пароля предзагрузочной аутентификации (при появлении сообщения "Booting...").
  • После клонирования скрытой операционной системы и ввода для неё пароля компьютер зависает (при появлении сообщения "Booting...").
Вероятная причина:
Ошибка в BIOS компьютера или проблема с загрузчиком Windows.
Возможные решения:
  • Обновите BIOS (о том, как это сделать, см. в документации на BIOS/системную плату или свяжитесь со службой технической поддержки поставщика компьютера).
  • Используйте системную плату другой модели/фирмы.
  • Если у поставщика BIOS/системной платы/компьютера нет обновлений, решающих проблему, а вы используете Windows 7 или более новую версию Windows, и на диске есть дополнительный загрузочный раздел (размером менее 1 ГБ), можно попробовать переустановить Windows без этого дополнительного загрузочного раздела (чтобы обойти ошибку в BIOS).
  • Известно два других обходных пути для этой проблемы, которые требуют наличия установочного диска Windows:
    • Загрузите компьютер с установочного диска Windows и выберите восстановление компьютера. Выберите опцию Командная строка (Command Prompt), и когда она откроется, введите приведённые ниже команды, а затем перезагрузите систему:
      • BootRec /fixmbr
      • BootRec /FixBoot
    • Удалите раздел System Reserved размером 100 МБ, расположенный в начале диска, сделайте активным системный раздел рядом с ним (оба действия можно выполнить с помощью утилиты diskpart, доступной на установочном диске Windows). После этого, выполнив перезагрузку, запустите Восстановление при загрузке на установочном диске Windows. См. подробную инструкцию по следующей ссылке: https://www.sevenforums.com/tutorials/71363-system-reserved-partition-delete.html
Проблема:
При попытке шифрования системного раздела/диска, во время предварительного теста, загрузчик VeraCrypt всегда сообщает, что неверно введён пароль предзагрузочной аутентификации (хотя я точно знаю, что пароль правильный).
Возможные причины:
  • Ошибочно нажаты клавиши Num Lock и/или Caps Lock.
  • Повреждение данных.
Возможное решение:
  1. Когда вы устанавливаете пароль предзагрузочной аутентификации, запомните состояние и (в зависимости от производителя, эти клавиши могут иметь разную маркировку, например, ). Примечание. До установки пароля вы можете изменить состояние любой из этих клавиш так, как хотите, нужно лишь запомнить их состояния.
  2. При вводе пароля на экране загрузчика VeraCrypt убедитесь, что состояние каждой из этих клавиш такое же, каким оно было при установке пароля.
Примечание. Другие возможные решения данной проблемы см. в других частях этой главы.
Проблема:
Если зашифрован системный раздел/диск, операционная система каждые 5-60 минут "зависает" примерно на 10-60 секунд (что может также сопровождаться 100%-ной загрузкой ЦП).
Вероятная причина:
Проблема с ЦП и/или системной платой.
Возможные решения:
  • Попробуйте отключить все функции энергосбережения (включая любые особые функции приостановки ЦП), в настройках BIOS и в разделе Электропитание в Панели управления Windows.
  • Замените процессор на другой (другого типа и/или фирмы).
  • Замените системную плату на другую (другого типа и/или фирмы).
Проблема:
При монтировании или размонтировании тома VeraCrypt происходит сбой системы (появляется "синий экран" ошибки, либо компьютер внезапно перезагружается).
ИЛИ
После установки VeraCrypt начались частые сбои в работе операционной системы.
Возможные причины:
  • Ошибка в стороннем приложении (например, в антивирусном ПО, утилите для подстройки системы и т. д.).
  • Ошибка в VeraCrypt.
  • Ошибка в Windows или неисправность в аппаратном компоненте компьютера.
Возможные решения:
  • Попробуйте отключить все антивирусные программы, утилиты для тонкой подстройки системы ("твикеры") и другие аналогичные приложения. Если это не поможет, попробуйте удалить их и перезагрузить Windows.

    Если проблема не исчезает, запустите VeraCrypt выберите Справка > Проанализировать сбой системы вскоре после сбоя или перезагрузки системы. проанализирует файлы дампа сбоев, которые автоматически создаются Windows при аварийных отказах (если они есть). Если VeraCrypt определяет, что сбой вероятнее всего вызван ошибкой в стороннем драйвере, будут показаны имя и поставщик этого драйвера (обратите внимание, что проблему можно устранить, обновив или удалив драйвер). Какой бы результат ни был, вы сможете отправить основную информацию о сбое системы, чтобы мы выяснили, не вызван ли он ошибкой в VeraCrypt.
Проблема:
В Windows 7/Vista (и, возможно, в более новых версиях) не получается использовать утилиту Microsoft Windows Backup (Программу архивации) для резервного копирования данных на несистемный том VeraCrypt.
Причина:
Ошибка в инструменте резервного копирования Windows.
Возможное решение:
  1. Смонтируйте том VeraCrypt, на который вы хотите записать резервную копию данных.
  2. Щёлкните правой кнопкой мыши по папке в этом томе (или по букве диска, на котором он расположен, в списке Компьютер) и выберите в подменю пункт Общий доступ и безопасность (в Windows Vista – Общий доступ).
  3. Следуйте инструкциям, чтобы предоставить общий доступ к папке с вашей учётной записью пользователя.
  4. В средстве резервного копирования Windows выберите общую папку (сетевое местоположение/путь) в качестве места назначения.
  5. Запустите процесс резервного копирования.
Примечание. Указанное выше решение не относится к редакциям Starter (Начальная) и Home (Домашняя) Windows 7 (и, возможно, более новых версий).
Проблема:
В Vista и более новых версиях Windows из окна Компьютер невозможно изменить метку файловой системы у тома VeraCrypt.
Причина:
Из-за проблемы Windows метка записывается только в файл реестра, а не в файловую систему.
Возможные решения:
  • Щёлкните правой кнопкой мыши по смонтированному тому в окне Компьютер, выберите Свойства и введите новую метку для этого тома.
Проблема:
Не удаётся зашифровать раздел/устройство, так как мастер создания томов VeraCrypt сообщает, что раздел/устройство сейчас используется.
Возможное решение:
Закройте, отключите или удалите все программы, которые могут как-либо использовать раздел/устройство (например, антивирусное ПО). Если это не помогает, щёлкните правой кнопкой мыши по значку Компьютер (или Мой компьютер) на рабочем столе и выберите Управление > Запоминающие устройства > Управление дисками. Затем щёлкните правой кнопкой мыши по разделу, который вы хотите зашифровать, и выберите Изменить букву диска или путь к диску. Далее нажмите Удалить и OK. Перезагрузите операционную систему.
Проблема:
При создании скрытого тома мастер сообщает, что невозможно заблокировать внешний том.
Вероятная причина:
Внешний том содержит файлы, используемые одним или несколькими приложениями.
Возможное решение:
Закройте все программы, которые используют файлы во внешнем томе. Если это не помогает, попробуйте отключить или удалить установленное у вас антивирусное ПО и затем перезагрузить систему.
Проблема:
При доступе к файлу-контейнеру, совместно используемому по сети, вы получаете одно или оба из следующих сообщений об ошибках:
"Not enough server storage is available to process this command" (Для обработки этой команды недостаточно места на сервере)
и/или
"Not enough memory to complete transaction" (Недостаточно памяти для завершения транзакции)
Вероятная причина:
Возможно, слишком маленькое значение у ключа IRPStackSize в реестре Windows.
Возможное решение:
Найдите ключ IRPStackSize в реестре Windows и установите более высокое значение, после чего перезагрузите систему. Если этого ключа нет в реестре, создайте его в HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters и установите значение 16 или больше, после чего перезагрузите систему. Более подробную информацию см. на веб-страницах https://support.microsoft.com/kb/285089/ и https://support.microsoft.com/kb/177078/

См. также: Замеченные проблемы и ограничения, Несовместимости


Документация >> Несовместимости

Несовместимости

Активация Adobe Photoshop® и других продуктов с помощью FLEXnet Publisher® / SafeCast

Примечание: описанная ниже проблема вас не касается, если используется алгоритм шифрования без каскадирования (то есть AES, Serpent или Twofish).* Эта проблема вас также не касается, если вы не используете шифрование системы (предзагрузочную аутентификацию).
ПО активации Acresso FLEXnet Publisher, в прошлом – Macrovision SafeCast (применяемое для активации сторонних программ, например, Adobe Photoshop), записывает данные в первую дорожку диска. Если это происходит, когда системный раздел/диск зашифрован с помощью VeraCrypt, часть загрузчика VeraCrypt оказывается повреждённой, и загрузить Windows не удастся. В этом случае воспользуйтесь своим диском восстановления VeraCrypt, чтобы вновь получить доступ к системе. Сделать это можно двумя способами:
  1. Если вы хотите, чтобы у стороннего ПО сохранилась активация, вам придётся каждый раз загружать систему с помощью CD/DVD-диска восстановления VeraCrypt. Для этого просто вставьте свой Диск восстановления в CD/DVD-накопитель и введите пароль на появившемся экране диска.
  2. Если вы не желаете каждый раз загружать систему с CD/DVD-диска восстановления VeraCrypt, то можете восстановить загрузчик VeraCrypt на системном диске. Чтобы это сделать, на экране Диска восстановления выберите Repair Options > Restore VeraCrypt Boot Loader. Однако стороннее ПО будет при этом деактивировано.
О том, как пользоваться диском восстановления VeraCrypt, см. в главе Диск восстановления VeraCrypt.
Возможное постоянное решение: расшифруйте системный раздел/диск, а затем зашифруйте снова, используя алгоритм без каскадирования (то есть AES, Serpent или Twofish).*
Примите к сведению, что это не ошибка в VeraCrypt (данная проблема вызвана некорректным механизмом активации в стороннем ПО).

Outpost Firewall и Outpost Security Suite

Если установлен пакет Outpost Firewall или Outpost Security Suite с включённой проактивной защитой, компьютер на 5-10 секунд полностью перестаёт отзываться при монтировании/демонтировании тома. Это вызвано конфликтом между опцией Outpost System Guard, защищающей объекты «Активный рабочий стол», и окном ожидания VeraCrypt, отображаемым во время операций монтирования/демонтирования.
Эту проблему можно обойти, отключив показ ожидания в настройках VeraCrypt. Для этого выберите Настройки > Параметры и включите опцию Не показывать окно ожидания во время операций.
См. подробности здесь: https://sourceforge.net/p/veracrypt/tickets/100/

* Причина в том, что загрузчик VeraCrypt меньше, чем тот, который используется для каскадов шифров, и поэтому на первой дорожке диска достаточно места для резервной копии загрузчика VeraCrypt. Следовательно, всякий раз, когда загрузчик VeraCrypt повреждается, вместо этого автоматически запускается его резервная копия.

См. также: Замеченные проблемы и ограничения, Устранение затруднений


Документация >> Замеченные проблемы и ограничения

Замеченные проблемы и ограничения

Замеченные проблемы

  • В Windows возможна ситуация, когда смонтированному тому будут назначены две буквы диска вместо одной. Это вызвано проблемой с кэшем диспетчера монтирования Windows, и её можно решить, вводя в командной строке с повышенными правами (от имени администратора) команду "mountvol.exe /r" перед монтированием любого тома. Если проблема не исчезнет после перезагрузки, для её решения можно использовать следующую процедуру:
    • С помощью редактора реестра откройте в реестре ключ "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices". Прокрутите содержимое окна вниз, пока не обнаружите записи, начинающиеся с "\DosDevices\" или "\Global??\", которые указывают буквы дисков, используемые системой. Перед монтированием любого тома дважды щёлкните по каждой из них и удалите те, которые содержат имя "VeraCrypt" и "TrueCrypt".
      Кроме того, есть и другие записи, имя которых начинается с "#{" и "\??\Volume{": дважды щёлкните по каждой из них и удалите те, значение данных которых содержит имя "VeraCrypt" и "TrueCrypt".
  • На некоторых компьютерах с Windows программа VeraCrypt может периодически зависать при монтировании и размонтировании тома. Подобные зависания могут влиять на другие запущенные приложения во время операций монтирования или демонтирования VeraCrypt. Эта проблема вызвана конфликтом между диалоговым окном ожидания VeraCrypt, отображаемым во время монтирования/демонтирования, и другим ПО, установленным в ПК (например, Outpost Firewall Pro). В таких ситуациях проблему можно решить, отключив окно ожидания VeraCrypt в настройках программы: выберите меню "Настройки -> Параметры" и включите опцию "Не показывать окно ожидания во время операций".

Ограничения

  • [Данное ограничение не относится к пользователям Windows Vista и более новых версий Windows.] В Windows XP/2003 VeraCrypt не поддерживает шифрование всего системного диска, если тот содержит расширенные (логические) разделы. Весь системный диск можно зашифровать при условии, что он содержит только первичные разделы. На любом системном диске, который частично или полностью зашифрован, создавать расширенные (логические) разделы нельзя (можно только первичные).
    Примечание: если требуется зашифровать весь диск, содержащий расширенные разделы, можно зашифровать системный раздел и в дополнение создать тома VeraCrypt на основе раздела внутри любых несистемных разделов на этом диске. Либо, как альтернативный вариант, обновить систему до Windows Vista или более новой версии Windows.
  • В настоящее время VeraCrypt не поддерживает шифрование системного диска, преобразованного в динамический диск.
  • Чтобы обойти проблему в Windows XP, загрузчик VeraCrypt всегда автоматически настраивается под версию операционной системы, в которой он установлен. При изменении версии системы (например, загрузчик VeraCrypt устанавливается во время работы Windows Vista, но позже используется для загрузки Windows XP) вы можете столкнуться с различными известными и неизвестными проблемами (например, на некоторых ноутбуках с Windows XP может не отображаться экран входа в систему). Обратите внимание, что это влияет на мультизагрузочные конфигурации, Диски восстановления VeraCrypt и обманные/скрытые операционные системы (поэтому если, к примеру, скрытая система – Windows XP, то обманной системой тоже должна быть Windows XP).
  • Возможность монтировать раздел, находящийся в области действия ключа шифрования системы без предзагрузочной аутентификации, что делается командой Смонтировать без предзагрузочной аутентификации в меню Система, (например, раздел, расположенный на зашифрованном системном диске с другой, не работающей в данный момент операционной системой), ограничена первичными разделами (расширенные/логические разделы таким способом монтировать нельзя).
  • Из-за проблемы с Windows 2000, Диспетчер монтирования Windows в Windows 2000 не поддерживается VeraCrypt. Поэтому некоторые встроенные средства Windows 2000, такие как дефрагментация дисков, не работают с томами VeraCrypt. Кроме того, невозможно использовать службы Диспетчера монтирования в Windows 2000, например, назначить точку монтирования тому VeraCrypt (то есть прикрепить том VeraCrypt к папке).
  • VeraCrypt не поддерживает предзагрузочную аутентификацию для операционных систем, установленных в файлах VHD, за исключением случаев загрузки с использованием соответствующего ПО виртуализации, такого как Microsoft Virtual PC.
  • Служба теневого копирования томов Windows в настоящее время поддерживается только для разделов в пределах области действия ключа шифрования системы (например, системный раздел, зашифрованный VeraCrypt, или несистемный раздел, расположенный на системном диске, зашифрованном VeraCrypt, смонтированный во время работы зашифрованной операционной системы). Примечание: для других типов томов служба теневого копирования томов не поддерживается, поскольку отсутствует документация по необходимому API.
  • Параметры загрузки Windows нельзя изменить из скрытой операционной системы, если система загружается не с раздела, на котором она установлена. Это связано с тем, что в целях безопасности загрузочный раздел монтируется как доступный только для чтения при работающей скрытой системе. Чтобы изменить параметры загрузки, запустите обманную операционную систему.
  • Размер зашифрованных разделов нельзя изменять, за исключением разделов на полностью зашифрованном системном диске, размер которых изменяется во время работы зашифрованной ОС.
  • Если системный раздел/диск зашифрован, система не может быть обновлена до более новой версии ​​(например, с Windows XP до Windows Vista) или восстановлена ​​в предзагрузочной среде (с помощью установочного CD/DVD Windows или предзагрузочного компонента Windows). В таких случаях сначала необходимо расшифровать системный раздел/диск. Примечание: работающую в данный момент операционную систему можно без проблем обновлять (устанавливать патчи безопасности, пакеты обновлений и т. д.), даже если системный раздел/диск зашифрован.
  • Шифрование системы поддерживается только на дисках, подключённых локально через интерфейс ATA/SCSI (обратите внимание, что термин ATA также относится к SATA и eSATA).
  • При использовании шифрования системы (это относится и к скрытым операционным системам) VeraCrypt не поддерживает изменение многозагрузочных конфигураций (например, изменение количества операционных систем и их расположения). В частности, конфигурация должна оставаться такой же, какой она была при запуске мастера создания томов VeraCrypt для подготовки процесса шифрования системного раздела/диска (или создания скрытой операционной системы).
    Примечание. Единственное исключение – многозагрузочная конфигурация, в которой работающая операционная система с шифрованием VeraCrypt всегда находится на диске №0, и это единственная операционная система на диске (или на диске есть одна обманная система, зашифрованная VeraCrypt, и одна скрытая ОС, зашифрованная VeraCrypt, и никакой другой ОС), и диск подключается или отключается до включения компьютера (например, с помощью выключателя питания на корпусе внешнего диска eSATA). На других дисках, подключённых к компьютеру, могут быть установлены любые дополнительные операционные системы (зашифрованные или незашифрованные) (когда диск №0 отключён, диск №1 становится диском №0, и т. д.)
  • Если у ноутбука низкий заряд батареи, Windows может не отправлять соответствующие сообщения запущенным приложениям, когда компьютер переходит в режим энергосбережения. Поэтому в таких случаях VeraCrypt может не выполнить автоматическое размонтирование томов.
  • Сохранение любой временной метки любого файла (например, контейнера или ключевого файла) не гарантируется надёжно и безопасно (например, из-за журналов файловой системы, временных меток атрибутов файла или того, что операционная система не может выполнить это по различным документированным и недокументированным причинам). Примечание. При записи на скрытый том на основе файла, временная метка контейнера может измениться. Это можно правдоподобно объяснить изменением пароля (внешнего) тома. Также обратите внимание, что VeraCrypt никогда не сохраняет временные метки избранных томов системы (независимо от настроек).
  • Специальное программное обеспечение (например, низкоуровневый редактор дисков), которое записывает данные на диск в обход драйверов в стеке драйверов класса DiskDrive (GUID класса – 4D36E967-E325-11CE-BFC1-08002BE10318), может записывать незашифрованные данные на несистемный диск, на котором размещается смонтированный том VeraCrypt (Partition0), а также на зашифрованные разделы/диски, которые находятся в пределах области действия ключа активного шифрования системы (VeraCrypt не шифрует такие данные, записанные этим способом). Точно так же программное обеспечение, которое записывает данные на диск в обход драйверов в стеке драйверов класса Storage Volume (GUID класса – 71A27CDD-812A-11D0-BEC7-08002BE2092F), может записывать незашифрованные данные в тома VeraCrypt на основе раздела (даже если они смонтированы).
  • Из соображений безопасности, когда работает скрытая операционная система, VeraCrypt обеспечивает, что все локальные незашифрованные файловые системы и нескрытые тома VeraCrypt доступны только для чтения. Однако это не относится к файловым системам на CD/DVD-подобных носителях, а также к пользовательским, нетипичным или нестандартным устройствам/носителям (например, к любым устройствам/носителям, класс которых отличается от Windows-класса устройств Storage Volume или не отвечающие требованиям этого класса (GUID класса – 71A27CDD-812A-11D0-BEC7-08002BE2092F)).
  • Тома VeraCrypt на основе устройств, расположенные на дискетах, не поддерживаются. Но вы по-прежнему можете создавать на гибких дисках тома VeraCrypt на основе файлов-контейнеров.
  • Редакции Windows Server не позволяют использовать смонтированные тома VeraCrypt в качестве пути для резервного копирования сервера. Это можно решить, активировав общий доступ к тому VeraCrypt через интерфейс Проводника (конечно, вы должны установить правильные права, чтобы избежать несанкционированного доступа), а затем выбрать опцию Удалённая общая папка (она, разумеется, не удалённая, но Windows нужен сетевой путь). Там можно указать путь к общему диску (например, \\ServerName\sharename) – и резервное копирование будет настроено правильно.
  • Из-за недостатков дизайна Microsoft в обработке разрежённых файлов NTFS вы можете столкнуться с системными ошибками при записи данных в большие динамические тома (более нескольких сотен гигабайт). Чтобы этого избежать, рекомендуем, чтобы размер файла-контейнера динамического тома для максимальной совместимости составлял 300 ГБ. Более подробную информацию об этом ограничении см. здесь: http://www.flexhex.com/docs/articles/sparse-files.phtml#msdn
  • В Windows 8 и Windows 10 для ускорения загрузки системы появилась функция Гибридная загрузка и завершение работы и Быстрый запуск. Эта функция включена по умолчанию и имеет побочные эффекты при использовании томов VeraCrypt. Рекомендуется отключить эту функцию (например, здесь объясняется, как отключить её в Windows 8, а здесь даны эквивалентные инструкции для Windows 10).
    Некоторые примеры проблем:
    • после выключения и перезагрузки смонтированный том продолжит монтироваться без ввода пароля: это связано с тем, что новое завершение работы Windows 8 – не настоящее, а замаскированный режим гибернации/сна.
    • если используется шифрование системы и есть системные избранные тома, настроенные на монтирование во время загрузки, то после завершения работы и перезапуска эти системные избранные тома не будут смонтированы.
  • Диск исправления/восстановления Windows невозможно создать, если том VeraCrypt смонтирован как несъёмный диск (что происходит по умолчанию). Чтобы решить эту проблему, либо размонтируйте все тома, либо смонтируйте тома на съёмных носителях.
  • Дополнительные ограничения перечислены в разделе Модель безопасности.


Документация >> Вопросы и ответы

Вопросы и ответы

Последнее обновление: 1 октября 2023 г.
Мы не обещаем отсутствие ошибок в этом документе, он поставляется "как есть" без всяких гарантий. См. подробности в главе Отказ от обязательств.
Могут ли TrueCrypt и VeraCrypt работать на одном компьютере?
Да. Как правило, между программами TrueCrypt и VeraCrypt нет конфликтов, поэтому их можно установить и использовать на одном компьютере. Однако в Windows, если они обе используются для монтирования одного и того же тома, при его монтировании могут появиться два диска. Это можно решить, выполнив перед монтированием любого тома следующую команду в командной строке с повышенными привилегиями (используя запуск от имени администратора): mountvol.exe /r.
Можно ли использовать тома TrueCrypt в VeraCrypt?
Да. Начиная с версии 1.0f, программа VeraCrypt поддерживает монтирование томов TrueCrypt.
Можно ли преобразовать тома TrueCrypt в формат VeraCrypt?
Да. Начиная с версии 1.0f, программа VeraCrypt умеет преобразовывать контейнеры и несистемные разделы TrueCrypt в формат VeraCrypt. Это можно сделать с помощью команды Изменить пароль тома или Установить алгоритм формирования ключа заголовка. Просто включите опцию Режим TrueCrypt, введите пароль TrueCrypt и выполните операцию – после этого том будет преобразован в формат VeraCrypt.
Перед преобразованием рекомендуется с помощью программы TrueCrypt сделать резервную копию заголовка тома. После преобразования и проверки правильности монтирования преобразованного тома в VeraCrypt эту резервную копию можно безопасно удалить .
Чем VeraCrypt отличается от TrueCrypt?
VeraCrypt добавляет повышенную безопасность к алгоритмам, используемым для шифрования системы и разделов, что делает его невосприимчивым к новым разработкам в атаках перебором.
Кроме того, в VeraCrypt устранено много уязвимостей и проблем безопасности, обнаруженных в TrueCrypt.
Как пример: когда системный раздел зашифрован, TrueCrypt использует PBKDF2-RIPEMD160 с 1000 итераций, тогда как итераций в VeraCrypt – 327 661. А с обычными контейнерами и другими разделами TrueCrypt использует максимум 2000 итераций, в то время как VeraCrypt использует 500 000 итераций.
Эта повышенная безопасность добавляет некоторую задержку только при открытии зашифрованных разделов, не оказывая никакого влияния на производительность на этапе использования приложения. Для законного владельца это приемлемо, а вот злоумышленнику получить доступ к зашифрованным данным гораздо труднее.

Я не могу вспомнить пароль! Есть ли какой-нибудь способ ("лазейка"), чтобы можно было извлечь файлы из моего тома VeraCrypt?
Мы не внедряли никаких "лазеек" ("бэкдоров") в VeraCrypt (и никогда не внедрим их, даже если об этом попросит орган власти), потому что это противоречило бы самой сути данного ПО. VeraCrypt не позволяет восстанавливать никакие зашифрованные данные без знания правильного пароля или ключа. Мы не можем восстановить ваши данные, так как не знаем и не можем узнать выбранный вами пароль или сгенерированный с помощью VeraCrypt ключ. Единственный способ восстановить ваши файлы – попытаться "взломать" пароль или ключ, но на это могут уйти тысячи или миллионы лет (в зависимости от длины и качества пароля или ключевых файлов, быстродействия программной/аппаратной части компьютера, алгоритмов и других факторов). В 2010 году были новости о том, что ФБР не удалось расшифровать том TrueCrypt после года попыток. Пока мы не можем проверить, правда ли это или нет, но в VeraCrypt мы повысили безопасность формирования ключа до уровня, при котором любой перебор пароля практически невозможен при условии соблюдения всех требований безопасности.

Существует ли учебник, как быстро приступить к работе, или какое-то пособие для новичков?
Да. Первая глава, Руководство для начинающих, в Руководстве пользователя VeraCrypt содержит снимки экранов и пошаговые инструкции, как создавать, монтировать и использовать тома VeraCrypt.

Можно ли зашифровать раздел/диск, на котором установлена Windows?
Да, см. раздел Шифрование системы в Руководстве пользователя VeraCrypt.
Предварительная проверка (пре-тест) шифрования системы завершается неудачно, потому что загрузчик зависает на сообщении "booting" ("загрузка") после успешной проверки пароля. Как сделать, чтобы пре-тест прошёл успешно?
Известно два решения этой проблемы (для обоих требуется установочный диск Windows):
  1. Загрузите компьютер с помощью установочного диска Windows и выберите Восстановить компьютер. Выберите опцию Командная строка, а когда она откроется, введите приведённые ниже команды, после чего перезапустите систему:
    • BootRec /fixmbr
    • BootRec /FixBoot
  2. Удалите зарезервированный системой раздел объёмом 100 МБ в начале диска и сделайте системный раздел рядом с ним активным (оба действия выполняются с помощью утилиты diskpart, доступной в опции восстановления установочного диска Windows). Затем запустите восстановление при запуске после перезагрузки на установочном диске Windows. См. здесь подробные инструкции: https://www.sevenforums.com/tutorials/71363-system-reserved-partition-delete.html
Предварительная проверка (пре-тест) шифрования системы завершается неудачно, хотя пароль в загрузчике был введён правильно. Как сделать, чтобы пре-тест прошёл успешно?
Это может быть вызвано драйвером TrueCrypt, который очищает память BIOS до того, как VeraCrypt сможет её прочитать. В этом случае решает проблему удаление TrueCrypt.
Это также может быть вызвано некоторыми драйверами оборудования и другим ПО, которые получают доступ к памяти BIOS. Универсального решения для этого не существует, пользователи, которые с этим столкнулись, должны идентифицировать такое ПО и удалить его из системы.

Можно ли воспроизводить видеофайлы (.avi, .mpg и т. д.) прямо с тома VeraCrypt, где они записаны?
Да, зашифрованные с помощью VeraCrypt тома ведут себя как обычные диски. Вы указываете правильный пароль (и/или ключевой файл) и монтируете (открываете) том VeraCrypt. Когда вы дважды щёлкаете по значку видеофайла, операционная система запускает ассоциированное с этим типом файлов приложение – обычно это медиапроигрываетель. Затем медиапроигрыватель начинает загружать маленькую начальную часть видеофайла из зашифрованного тома VeraCrypt в ОЗУ (оперативную память компьютера), чтобы его воспроизвести. Во время загрузки этой части VeraCrypt автоматически её расшифровывает (в ОЗУ), после чего расшифрованная часть видео (находящаяся в ОЗУ) воспроизводится медиапроигрываетелем. Пока эта часть воспроизводится, медиапроигрыватель начинает загружать другую небольшую часть видеофайла из зашифрованного тома VeraCrypt, и процесс повторяется.

То же самое происходит, например, при записи видео: прежде чем часть видеофайла будет записана в том VeraCrypt, она шифруется TrueCrypt в ОЗУ, и только затем записывается на диск. Такой процесс называется шифрованием/дешифрованием «на лету», и он работает для файлов всех типов (не только видео).

Будет ли VeraCrypt всегда бесплатным и с открытым кодом?
Да, будет. Мы никогда не станем выпускать коммерческие версии VeraCrypt, поскольку уверены, что ПО для обеспечения безопасности должно быть с открытым исходным кодом и бесплатным.

Могу ли я оказать финансовое содействие проекту VeraCrypt?
Да. Можете использовать для этого кнопки пожертвования на веб-странице https://veracrypt.jp/en/Donation.html.

Почему у VeraCrypt открытый исходный код? Каковы преимущества этого?
Поскольку исходный код VeraCrypt доступен всем, у независимых экспертов есть возможность проверить, что он не содержит никаких брешей в безопасности или потайных "лазеек". Если бы исходный код был недоступен, экспертам пришлось бы прибегать к обратному инжинирингу исполняемых файлов. Однако проанализировать и осмыслить такой полученный в результате реинжиниринга код настолько сложно, что это практически невозможно (особенно если код столь большой, как у VeraCrypt).

Примечание: аналогичная проблема касается и аппаратуры для шифрования (например самошифрующихся запоминающих устройств). Выполнить её реинжиниринг и проверить отсутствие брешей в безопасности и потайных "лазеек" крайне сложно.

Исходный код VeraCrypt открыт, но кто-нибудь его на самом деле проверял?
Да. Аудит проводила компания Quarkslab. Технический отчёт можно загрузить здесь. Выявленные в ходе этого аудита проблемы устранены в VeraCrypt 1.19.

Так как VeraCrypt это ПО с открытым исходным кодом, независимые исследователи могут проверить, что исходный код не содержит никаких брешей в безопасности и "лазеек". Могут ли они также проверить, что официально распространяемые исполняемые файлы собраны из публично доступного исходного кода и не содержат никакого дополнительного кода?
Да, могут. Помимо исследования исходного кода, независимые эксперты могут скомпилировать исходный код и сравнить полученные исполняемые файлы с официальными. При этом возможны некоторые расхождения (например, метки времени или встроенные цифровые подписи), но эти различия можно проанализировать и убедиться, что они несут никакого вредоносного кода.

Как использовать VeraCrypt на USB-флешке?
Есть три варианта:
  1. Зашифровать весь флеш-накопитель USB. Однако в этом случае с него не удастся запускать VeraCrypt.
  2. Создать два или более разделов на флеш-накопителе USB. Оставьте первый раздел незашифрованным и зашифруйте другие разделы. Таким образом, на первом разделе можно будет хранить VeraCrypt, чтобы запускать его прямо с флешки.
    Примечание: Windows может получать доступ только к первичному разделу флеш-накопителя USB, тем не менее дополнительные разделы остаются доступными через VeraCrypt.
  3. Создать на флеш-накопителе USB файловый контейнер VeraCrypt (о том, как это сделать, см. в главе Руководство для начинающих в Руководстве пользователя VeraCrypt). Если оставить на флеш-накопителе достаточно места (выбрав соответствующий размер контейнера VeraCrypt), то можно будет также хранить в нём программу VeraCrypt (рядом с контейнером, а не в контейнере) и оттуда же её запускать (cм. также главу Портативный режим в Руководстве пользователя VeraCrypt).

Шифрует ли VeraCrypt также имена файлов и папок?
Да. Вся файловая система внутри тома VeraCrypt зашифрована (включая имена файлов, имена папок и содержимое каждого файла). Это относится к обоим типам томов VeraCrypt – к файлам-контейнерам (виртуальным дискам VeraCrypt) и к зашифрованным с помощью VeraCrypt разделам/устройствам.

Использует ли VeraCrypt распараллеливание?
Да. Увеличение скорости шифрования/дешифрования прямо пропорционально числу ядер/процессоров в компьютере. См. подробности в главе Распараллеливание в документации.

Скорость чтения и записи на зашифрованном томе/диске такая же, как на диске без шифрования?
Да, поскольку VeraCrypt использует конвейеризацию и распараллеливание. См. подробности в главах Конвейеризация и Распараллеливание в документации.

Поддерживает ли VeraCrypt аппаратное ускорение шифрования?
Да. См. подробности в главе Аппаратное ускорение в документации.

Можно ли загружать Windows, установленную в скрытом томе VeraCrypt?
Да, можно. См. подробности в разделе Скрытая операционная система в документации.

Смогу ли я смонтировать свой том (контейнер) VeraCrypt на любом компьютере?
Да, тома VeraCrypt не зависят от операционной системы. Том VeraCrypt можно смонтировать на любом компьютере, на котором способен работать VeraCrypt (см. также вопрос Можно ли использовать VeraCrypt в Windows, если у меня нет прав администратора?).

Можно ли извлекать или выключать устройство с «горячим» подключением (например, USB-флешку или жёсткий диск с интерфейсом USB), когда на нём находится смонтированный том VeraCrypt?
Прежде чем отсоединить или выключить такое устройство, сначала всегда следует в VeraCrypt размонтировать том, а затем выполнить операцию Извлечь, если это доступно (щёлкнув правой кнопкой мыши по устройству в списке Компьютер или Мой компьютер), либо воспользоваться функцией Безопасное извлечение устройства (она встроена в Windows и доступна в области уведомлений на панели задач). Иначе возможна потеря данных.

Что такое «скрытая операционная система»?
См. раздел Скрытая операционная система в документации.

Что такое «правдоподобное отрицание наличия шифрования»?
См. главу Правдоподобное отрицание наличия шифрования в документации.

Смогу ли я монтировать свой раздел/контейнер VeraCrypt после того, как переустановлю или обновлю операционную систему?
Да, тома VeraCrypt не зависят от операционной системы. При этом, однако, нужно убедиться, что программа установки вашей операционной системы не выполняет форматирование раздела, где находится том VeraCrypt.

Примечание: если системный раздел/диск зашифрован, и вы хотите переустановить или обновить Windows, сначала его нужно расшифровать (выберите Система > Окончательно расшифровать системный раздел/диск). В то же время, запущенную операционную систему можно обновлять (устанавливать обновления безопасности, пакеты обновления и т. п.) без всяких проблем, даже если системный раздел/диск зашифрован.

Можно ли обновлять VeraCrypt с более старой версии до новой без каких-либо проблем?
Как правило, да. Тем не менее, перед обновлением ознакомьтесь с примечаниями ко всем версиям VeraCrypt, выпущенным после вашей. Если имеются известные проблемы или несовместимости, касающиеся обновления вашей версии до более новой, они будут там указаны.

Можно ли обновлять VeraCrypt, если зашифрован системный раздел/диск, или нужно сначала его расшифровать?
Как правило, вы можете обновлять программу до самой новой версии без дешифрования системного раздела/диска (просто запустите программу установки VeraCrypt – и она автоматически обновит VeraCrypt в вашей системе). Тем не менее, перед обновлением ознакомьтесь с примечаниями ко всем версиям VeraCrypt, выпущенным после вашей. Если имеются известные проблемы или несовместимости, касающиеся обновления вашей версии до более новой, они будут там указаны. Обратите внимание, что данный ответ адресован и пользователям скрытых операционных систем. Также примите к сведению, что если системный раздел/диск зашифрован, то устанавливать более старую версию VeraCrypt нельзя.

Я использую предзагрузочную аутентификацию. Можно ли сделать, чтобы при включении компьютера не было видно, что я использую VeraCrypt?
Да. Чтобы это сделать, загрузите зашифрованную систему, запустите VeraCrypt, выберите Настройки > Шифрование системы, включите опцию Пустой экран аутентификации и нажмите OK. После этого загрузчик VeraCrypt при включении компьютера не будет выводить на экран никакого текста (даже если введён неправильный пароль). При вводе пароля будет казаться, что компьютер "завис". При этом, однако, важно помнить, что если неприятелю доступно для анализа содержимое жёсткого диска, то он сможет обнаружить и наличие загрузчика VeraCrypt.

Я использую предзагрузочную аутентификацию. Можно ли настроить загрузчик VeraCrypt, чтобы он выводил на экран только обманное сообщение об ошибке?
Да. Чтобы это сделать, загрузите зашифрованную систему, запустите VeraCrypt, выберите Настройки > Шифрование системы, включите опцию Пустой экран аутентификации и введите в соответствующем поле обманное сообщение об ошибке (например, можно ввести сообщение "Missing operating system", которое обычно выводит загрузчик Windows, если ему не удаётся обнаружить загрузочный раздел Windows). При этом, однако, важно помнить, что если неприятелю доступно для анализа содержимое жёсткого диска, то он сможет обнаружить и наличие загрузчика VeraCrypt.

Можно ли настроить VeraCrypt так, чтобы при каждом старте Windows выполнялось автоматическое монтирование несистемного тома VeraCrypt, пароль для которого такой же, как для системного раздела/диска (т. е. пароль предзагрузочной аутентификации)?
Да. Для этого сделайте следующее:
  1. Смонтируйте том (на ту букву диска, на которую вы хотите, чтобы он монтировался каждый раз).
  2. Щёлкните правой кнопкой мыши на томе в списке дисков в главном окне VeraCrypt и выберите Добавить в системные избранные.
  3. В появившемся окне упорядочивания системных избранных томов включите опцию Монтировать системные избранные тома при старте Windows и нажмите OK.
См. подробности в главе Системные избранные тома.

Можно ли автоматически монтировать том при каждом входе в Windows?
Да. Для этого сделайте следующее:
  1. Смонтируйте том (на ту букву диска, на которую вы хотите, чтобы он монтировался каждый раз).
  2. Щёлкните правой кнопкой мыши на томе в списке дисков в главном окне VeraCrypt и выберите Добавить в избранные.
  3. В появившемся окне Избранные тома включите опцию Монтировать выбранный том при входе в систему и нажмите OK.
После этого при каждом входе в Windows вам будет предлагаться указать пароль тома (и/или ключевые файлы), и в случае правильного ввода том будет смонтирован.

Если тома на основе раздела/устройства, и вам не нужно монтировать их всякий раз только на какие-то конкретные буквы дисков, то можно сделать следующее:
  1. Выберите Настройки > Параметры. Появится окно Параметры.
  2. В группе Действия при входе в Windows, включите опцию Монтировать все тома на устройствах и нажмите OK.
Примечание: VeraCrypt не будет спрашивать пароль, если вы включили кэширование пароля предзагрузочной аутентификации (Настройки > Шифрование системы), а у томов такой же пароль, как у системного раздела/диска.

Можно ли автоматически монтировать том при подключении к компьютеру устройства, на котором находится этот том?
Да. Например, если вы храните контейнер VeraCrypt на USB-флешке и хотите, чтобы он автоматически монтировался при вставке флешки в порт USB, сделайте следующее:
  1. Смонтируйте том (на ту букву диска, на которую вы хотите, чтобы он монтировался каждый раз).
  2. Щёлкните правой кнопкой мыши на томе в списке дисков в главном окне VeraCrypt и выберите Добавить в избранные.
  3. В появившемся окне Избранные тома включите опцию Монтировать выбранный том при подключении устройства, на котором он расположен и нажмите OK.
После этого при каждой вставке флешки в USB-разъём вам будет предлагаться указать пароль тома (и/или ключевые файлы) (если только он уже не был помещён в кэш), и в случае правильного ввода том будет смонтирован.

Примечание: VeraCrypt не будет спрашивать пароль, если вы включили кэширование пароля предзагрузочной аутентификации (Настройки > Шифрование системы), а у тома такой же пароль, как у системного раздела/диска.

Можно ли поместить в кэш (запомнить) пароль предзагрузочной аутентификации, чтобы его можно было использовать для монтирования несистемных томов в течение данного сеанса работы?
Да. Выберите Настройки > Шифрование системы и включите опцию Кэшировать пароль в памяти драйвера.

Я живу в стране, где в отношении её граждан нарушаются основные права человека. Существует ли возможность использовать VeraCrypt, не оставляя никаких ‘следов’ в незашифрованной Windows?
Да. Для этого нужно запускать VeraCrypt в переносном (portable) режиме в среде BartPE или аналогичном окружении. BartPE (расшифровывается как "Bart's Preinstalled Environment"), в действительности представляет собой операционную систему Windows, подготовленную таким образом, чтобы она целиком находилась на CD/DVD и оттуда же загружалась (реестр, временные файлы и т. п. хранятся в ОЗУ – жёсткий диск при этом не используется вовсе и даже может отсутствовать). Чтобы преобразовать установочный компакт-диск Windows XP в BartPE CD, можно воспользоваться бесплатным конструктором Bart's PE Builder. Для BartPE даже не требуется никакого особого модуля (плагина) VeraCrypt. Сделайте следующее:
  1. Создайте BartPE CD и загрузитесь с него. (Внимание: все следующие шаги должны выполняться из среды BartPE.)
  2. Загрузите самораспаковывающийся пакет VeraCrypt на RAM-диск (который BartPE создаёт автоматически).

    Примечание: если неприятель имеет возможность перехватывать данные, которые вы отправляете или получаете через Интернет, и вам нужно, чтобы он не знал, что вы загружали VeraCrypt, выполняйте загрузку через I2P, Tor или другие аналогичные анонимайзеры работы в сети.
  3. Проверьте цифровые подписи у загруженного файла (см. подробности здесь).
  4. Запустите загруженный файл и выберите на второй странице мастера установки Извлечь (вместо Установить). Извлеките содержимое на RAM-диск.
  5. Запустите файл VeraCrypt.exe с RAM-диска.
Примечание: в качестве альтернативного варианта можно создать скрытую операционную систему (см. раздел Скрытая операционная система в документации). См. также главу Правдоподобное отрицание наличия шифрования.

Можно ли шифровать системный раздел/диск, если у меня нет клавиатуры со стандартной раскладкой США?
Да, VeraCrypt поддерживает все раскладки клавиатуры. Из-за требований BIOS пароль для предварительной загрузки вводится с использованием американской раскладки клавиатуры. Во время процесса шифрования системы VeraCrypt автоматически и прозрачно переключает клавиатуру на американскую раскладку, чтобы гарантировать, что введённый пароль будет соответствовать паролю, введённому в режиме предварительной загрузки. Таким образом, чтобы избежать ошибок в пароле, необходимо ввести пароль, используя те же клавиши, что и при создании зашифрованной системы.

Можно ли сохранять данные в разделе с обманной системой, не рискуя повредить раздел со скрытой системой?
Да. Вы можете спокойно записывать данные в раздел с обманной системой безо всякого риска повредить скрытый том (потому что обманная система не установлена в том же разделе, где установлена скрытая система. См. подробности в главе Скрытая операционная система в документации.

Можно ли использовать VeraCrypt в Windows, если у меня нет прав администратора?
См. главу Использование VeraCrypt без прав администратора в документации.

Сохраняет ли VeraCrypt пароли на диске?
Нет.

Как VeraCrypt проверяет, что введённый пароль – правильный?
См. раздел Схема шифрования (глава Технические подробности) в документации.

Можно ли зашифровать раздел/диск без потери находящихся там данных?
Да, но должны быть соблюдены следующие условия:
  • Если вы хотите зашифровать весь системный диск (который может содержать несколько разделов) или системный раздел (другими словами, если нужно зашифровать диск или раздел, где установлена Windows), вы можете это сделать при условии, что используете Windows XP или более новую версию Windows (например Windows 7) (выберите Система > Зашифровать системный раздел/диск и следуйте инструкциям мастера).
  • Если вы хотите зашифровать несистемный раздел «на месте», то можете это сделать при условии, что он содержит файловую систему NTFS и что вы используете Windows Vista или более новую версию Windows (например Windows 7) (выберите Тома > Создать том > Зашифровать раздел или диск без системы > Обычный том VeraCrypt > Выбрать устройство > Зашифровать раздел на месте и следуйте инструкциям мастера).

Можно ли использовать VeraCrypt, не устанавливая в систему?
Да, см. главу Переносной (портативный) режим в Руководстве пользователя VeraCrypt.

Некоторые программы шифрования для предотвращения атак применяют криптопроцессор TPM. Будет ли его также использовать и VeraCrypt?
Нет. Такие программы используют TPM для защиты против атак, при которых необходимо, чтобы неприятель имел права администратора или физический доступ к компьютеру, и неприятелю нужно, чтобы после его доступа вы воспользовались компьютером. Однако если удовлетворено любое из этих условий, защитить компьютер в действительности невозможно (см. ниже), поэтому нужно прекратить им пользоваться (а не полагаться на TPM).

Если неприятель обладает правами администратора, он может, например, выполнить сброс TPM, захватить содержимое ОЗУ (с хранящимися там мастер-ключами) или файлов в смонтированных томах VeraCrypt (расшифрованных «на лету»), которое затем может быть переправлено неприятелю через Интернет или сохранено на незашифрованном локальном диске (с которого неприятель считает эту информацию, когда получит физический доступ к компьютеру).

Если у неприятеля есть физический доступ к аппаратной части компьютера (и вы пользовались ПК после того, как с ним имел дело неприятель), он может, например, внедрить в него вредоносный компонент (скажем, аппаратный модуль слежения за нажатием клавиш на клавиатуре), который будет захватывать пароли, содержимое ОЗУ (с хранящимися там мастер-ключами) или файлов в смонтированных томах VeraCrypt (расшифрованных «на лету»), после чего пересылать все эти данные неприятелю по Интернету или сохранять на незашифрованном локальном диске (с которого неприятель сможет считать их, когда нова получит физический доступ к компьютеру).

Единственная вещь, которую TPM почти способен гарантировать, – создание ложного чувства безопасности (одно только имя – "Trusted Platform Module", Модуль доверенной платформы – вводит в заблуждение и создаёт ложное чувство безопасности). Для настоящей защиты TPM в действительности излишен (а внедрение избыточных функций, как правило, ведёт к созданию так называемого bloatware – функционально избыточного и ресурсоёмкого ПО).

См. подробности в разделах Физическая безопасность и Вредоносное ПО (Malware) в документации.

Нужно ли размонтировать тома VeraCrypt перед завершением работы или перезагрузкой Windows?
Нет. При завершении работы или перезагрузке системы VeraCrypt размонтирует все свои смонтированные тома автоматически.

Какой тип тома VeraCrypt лучше – раздел или файловый контейнер?
Файлы-контейнеры это обычные файлы, поэтому с ними можно обращаться точно так же, как с любыми обычными файлами (например, как и другие файлы, их можно перемещать, переименовывать и удалять). Разделы/диски могут быть лучше в плане производительности. Примите к сведению, что если контейнер сильно фрагментирован, операции чтения и записи с ним могут выполняться значительно дольше. Чтобы решить эту проблему, дефрагментируйте файловую систему, в которой хранится этот контейнер (при размонтированном томе VeraCrypt).

Как лучше выполнять резервное копирование (backup) томов VeraCrypt?
См. главу О безопасном резервном копировании в документации.

Что произойдёт, если я отформатирую раздел VeraCrypt?
См. вопрос Можно ли изменить файловую систему в зашифрованном томе? ниже.

Можно ли изменить файловую систему в зашифрованном томе?
Да, будучи смонтированными, тома VeraCrypt могут быть отформатированы в FAT12, FAT16, FAT32, NTFS или в любую другую файловую систему. Тома VeraCrypt ведут себя как обычные дисковые устройства, поэтому можно щёлкнуть правой кнопкой мыши по значку устройства (например, в окне Компьютер или Мой компьютер) и выбрать пункт Форматировать. Текущее содержимое тома будет при этом потеряно, но сам том останется полностью зашифрованным. Если вы отформатируете зашифрованный с помощью VeraCrypt раздел, когда том на основе этого раздела не смонтирован, то этот том будет уничтожен, а раздел перестанет быть зашифрованным (он станет пустым).

Можно ли смонтировать контейнер VeraCrypt, находящийся на CD или DVD?
Да. Однако если требуется монтировать том VeraCrypt на не допускающем записи носителе (таком, как CD или DVD) в среде Windows 2000, файловой системой внутри тома VeraCrypt должна быть FAT (Windows 2000 не может монтировать файловую систему NTFS на носителях, доступных только для чтения).

Можно ли изменить пароль для скрытого тома?
Да, диалоговое окно смены пароля работает как для обычных, так и для скрытых томов. Просто введите в этом окне пароль для скрытого тома в поле Текущий пароль.
Замечание: сначала VeraCrypt пытается расшифровать заголовок обычного тома, и если это не удаётся, то пытается расшифровать область внутри тома, где может находиться заголовок скрытого тома (если внутри есть скрытый том). Если попытка успешна, пароль изменяется у скрытого тома. (При обеих попытках используется пароль, введённый в поле Текущий пароль.)

Как записать на DVD контейнер VeraCrypt размером больше 2 гигабайт?

ПО для записи DVD должно позволять выбирать формат DVD. Выберите формат UDF (в формате ISO файлы размером больше 2 ГиБ не поддерживаются).

Можно ли использовать утилиты chkdsk, дефрагментатор дисков и т. п. для данных, находящихся на смонтированном томе VeraCrypt?
Да, тома VeraCrypt ведут себя как реальные физические дисковые устройства, поэтому с содержимым смонтированного тома VeraCrypt можно использовать любые программы для проверки, исправления и дефрагментации файловых систем.

Поддерживает ли VeraCrypt 64-разрядные версии Windows?
Да, поддерживает.
Примечание: 64-разрядные версии Windows загружают только те драйверы, которые имеют цифровую подпись с цифровым сертификатом, выданным центром сертификации, утверждённым для выдачи сертификатов подписи кода режима ядра. VeraCrypt соответствует этому требованию (драйвер VeraCrypt имеет цифровую подпись с цифровым сертификатом IDRIX, выданным удостоверяющим центром Thawte).

Можно ли монтировать тома VeraCrypt в Windows, Mac OS X (macOS) и Linux?
Да, тома VeraCrypt полностью кроссплатформенные.
Как удалить VeraCrypt в Linux?
Чтобы удалить VeraCrypt в Linux, выполните следующую команду в Терминале от имени пользователя root: veracrypt-uninstall.sh. В Ubuntu используйте "sudo veracrypt-uninstall.sh".

Можно ли где-нибудь ознакомиться со списком всех ОС, поддерживаемых VeraCrypt?
Да, см. раздел Поддерживаемые операционные системы в Руководстве пользователя VeraCrypt.

Можно ли устанавливать приложения в том VeraCrypt и запускать их оттуда?
Да.

Что произойдёт, если повредится часть тома VeraCrypt?
Один повреждённый бит в зашифрованных данных обычно вызывает повреждение всего блока зашифрованного текста, в котором он расположен. В VeraCrypt используются блоки зашифрованного текста размером 16 байт (то есть 128 бит). Применающийся в VeraCrypt режим работы гарантирует, что если данные повреждены в пределах одного блока, остальные блоки это не затронет. См. также вопрос Что делать, если в томе VeraCrypt повреждена зашифрованная файловая система? ниже.

Что делать, если в томе VeraCrypt повреждена зашифрованная файловая система?
Файловая система внутри тома VeraCrypt может повредиться так же, как и любая другая обычная незашифрованная файловая система. Если это произошло, для её исправления можно воспользоваться соответствующими средствами, входящими в состав операционной системы. В Windows это утилита chkdsk. В VeraCrypt реализовано её простое применение: щёлкните правой кнопкой мыши по смонтированному тому в главном окне VeraCrypt (в списке дисков) и выберите в контекстном меню пункт Исправить файловую систему.

Мы используем VeraCrypt в корпоративном окружении/на предприятии. Есть ли способ для администратора сбросить пароль от тома или предзагрузочной аутентификации в случае, если пользователь его забыл (или потерял ключевой файл)?
Да. В VeraCrypt не встроено никаких "лазеек" (бэкдоров). Однако сбросить пароли/ключевые файлы томов и пароли предзагрузочной аутентификации можно. После того, как вы создадите том, сохраните резервную копию его заголовка в файле (выберите Сервис -> Создать резервную копию заголовка тома) до того, как позволите пользователю без прав администратора начать работать с этим томом. Обратите внимание: в заголовке тома (зашифрованного с помощью ключа заголовка, сформированного из пароля/ключевого файла) содержится мастер-ключ, которым зашифрован том. Затем попросите пользователя выбрать пароль и установите его для него/неё (Тома -> Изменить пароль тома) или сгенерируйте для пользователя ключевой файл. После этого вы можете разрешить пользователю начать работать с томом и изменять пароль/ключевые файлы без вашего участия/разрешения. Теперь если пользователь забудет свой пароль или потеряет ключевой файл, вы сможете сбросить пароль/ключевые файлы тома в ваши исходные администраторские пароль/ключевые файлы, восстановив заголовок тома из файла с резервной копией (Сервис -> Восстановить заголовок тома).

Аналогичным образом можно сбросить пароль к предзагрузочной аутентификации . Чтобы создать резервную копию данных мастер-ключа (которая будет сохранена на диске восстановления VeraCrypt и зашифрована вашим паролем администратора), выберите Система > Создать диск восстановления. Чтобы установить пользовательский пароль предзагрузочной аутентификации, выберите Система > Изменить пароль. Чтобы восстановить ваш пароль администратора, загрузитесь с диска восстановления VeraCrypt, выберите Repair Options > Restore key data и введите свой пароль администратора.
Примечание: записывать каждый ISO-образ диска восстановления VeraCrypt на CD/DVD не требуется. Можно завести централизованное хранилище ISO-образов для всех рабочих станций (вместо хранилища дисков CD/DVD). Подробности см. в разделе Использование в командной строке (опция /noisocheck).

Можно ли нашей коммерческой компании использовать VeraCrypt бесплатно?
При условии, что выполняются все условия Лицензии VeraCrypt, вы можете устанавливать и использовать VeraCrypt бесплатно на любом количестве ваших компьютеров.

Мы совместно используем том по сети. Есть ли способ автоматически восстанавливать общий сетевой ресурс при перезапуске системы?
См. главу Общий доступ по сети в Руководстве пользователя VeraCrypt.

Возможен ли одновременный доступ к одному и тому же тому VeraCrypt из нескольких операционных систем (например, к общему том по сети)?
См. главу Общий доступ по сети в Руководстве пользователя VeraCrypt.

Может ли пользователь получить доступ к своему тому VeraCrypt через сеть?
См. главу Общий доступ по сети в Руководстве пользователя VeraCrypt.

После шифрования несистемного раздела его исходная буква диска по-прежнему видна в окне Мой компьютер. Если дважды щёлкнуть мышью по этой букве диска, Windows выдаёт запрос на форматирование этого диска. Можно ли как-нибудь скрыть или высвободить эту букву диска?
Да, можно. Чтобы высвободить букву диска, сделайте следующее:
  1. Щёлкните правой кнопкой мыши по значку Компьютер (или Мой компьютер) на рабочем столе или в меню "Пуск" и выберите пункт Управление. Появится окно Управление компьютером.
  2. В списке слева выберите Управление дисками (в подветви Запоминающие устройства).
  3. Щёлкните правой кнопкой мыши по зашифрованному разделу/устройству и выберите Изменить букву диска или путь к диску.
  4. Нажмите Удалить.
  5. Если Windows попросит подтвердить действие, нажмите Да.

Когда я подключаю к компьютеру зашифрованную USB-флешку, Windows предлагает её отформатировать. Можно ли сделать, чтобы этот запрос не появлялся?
Да, можно, но потребуется удалить присвоенную этому устройству букву диска. О том, как это сделать, см. выше вопрос После шифрования несистемного раздела его исходная буква диска по-прежнему видна в окне Мой компьютер.

Как удалить или отменить шифрование, если оно мне больше не нужно? Как окончательно расшифровать том?
См. раздел Как удалить шифрование в Руководстве пользователя VeraCrypt.

Что изменится, если включить параметр Монтировать тома как сменные носители?
См. раздел Том, смонтированный как сменный носитель в Руководстве пользователя VeraCrypt.

Доступна ли онлайн-документация для загрузки в виде одного файла?
Да, документация содержится в файле VeraCrypt User Guide.chm, включённом в официальный установщик VeraCrypt для Windows. Вы также можете скачать файл CHM по ссылке на главной странице https://veracrypt.jp/en/downloads/. Обратите внимание, что вам не нужно устанавливать VeraCrypt, чтобы получить документацию в файле CHM. Просто запустите самораспаковывающийся установочный пакет и затем на втором экране мастера установки VeraCrypt выберите Извлечь (вместо Установить). Также обратите внимание, что когда вы устанавливаете VeraCrypt, документация в формате CHM автоматически копируется в папку, в которую установлена ​​программа, и она становится доступной через пользовательский интерфейс VeraCrypt (по нажатию F1 или при выборе в меню Справка > Руководство пользователя).

Нужно ли «затирать» свободное место и/или файлы в томе VeraCrypt?
Примечание: "затереть" (wipe) = надёжно стереть; перезаписать конфиденциальные данные, чтобы сделать их невосстановимыми.

Если вы полагаете, что неприятель сможет расшифровать том (например, вынудив вас сообщить пароль), тогда ответ – да. В противном случае в этом нет необходимости, так как том полностью зашифрован.

Как VeraCrypt определяет алгоритм, с помощью которого зашифрован том?
См. раздел Схема шифрования (глава Технические подробности) в документации.
Как выполнить встроенное резервное копирование Windows на томе VeraCrypt? Том VeraCrypt не отображается в списке доступных путей резервного копирования.
Встроенная утилита резервного копирования Windows ищет только физические диски, поэтому не отображает тома VeraCrypt. Тем не менее, вы всё равно можете сделать резервную копию тома VeraCrypt, используя хитрость: активируйте общий доступ к тому VeraCrypt через интерфейс Проводника (разумеется, при этом нужно поставить правильное разрешение, чтобы избежать несанкционированного доступа), а затем выберите опцию "Удалить общую папку (Remote shared folder)" (конечно, она не удалённая, но Windows нужен сетевой путь). Там вы можете ввести путь к общему диску (пример: \\ServerName\sharename), и резервное копирование будет настроено правильно.
Уязвимо ли используемое в VeraCrypt шифрование для квантовых атак?
VeraCrypt использует для шифрования блочные шифры (AES, Serpent, Twofish). Квантовые атаки на эти блочные шифры – это просто более быстрый метод перебора, поскольку наиболее известная атака на эти алгоритмы – полный перебор (атаки на связанные ключи не имеют отношения к нашему случаю, потому что все ключи случайны и независимы друг от друга).
Поскольку VeraCrypt всегда использует 256-битные случайные и независимые ключи, мы уверены в 128-битном уровне защиты от квантовых алгоритмов, что делает шифрование VeraCrypt невосприимчивым к таким атакам.
Как сделать том VeraCrypt доступным для индексации поиска Windows?
Чтобы иметь возможность индексировать том VeraCrypt с помощью поиска Windows, том должен быть смонтирован во время загрузки (быть системным избранным томом), либо службы поиска Windows должны быть перезапущены после монтирования тома. Это необходимо, поскольку поиск Windows может индексировать только те диски, которые доступны при его запуске.
При монтировании файлового контейнера VeraCrypt в macOS возникает ошибка "Операция не разрешена" ("Operation not permitted"). Как решить эту проблему?

Об этой специфической ошибке, которая появляется в виде "Operation not permitted: /var/folders/w6/d2xssyzx.../T/.veracrypt_aux_mnt1/control VeraCrypt::File::Open:232", сообщают некоторые пользователи. Это результат того, что macOS не предоставила VeraCrypt необходимых разрешений. Вот пара способов, которые вы можете попробовать:

  • А. Предоставление VeraCrypt полного доступа к диску:

    1. Перейдите в Apple Menu > System Settings.
    2. Щёлкните по вкладке Privacy & Security.
    3. Прокрутите экран вниз и выберите Full Disk Access.
    4. Нажмите кнопку "+", перейдите в папку Applications, выберите VeraCrypt и нажмите Open.
    5. Убедитесь, что установлен флажок рядом с VeraCrypt.
    6. Закройте окно системных настроек и попробуйте снова использовать VeraCrypt.

  • Б. Использование sudo для запуска VeraCrypt:

    Вы можете запустить VeraCrypt из терминала, используя повышенные разрешения:

    sudo /Applications/VeraCrypt.app/Contents/MacOS/VeraCrypt
    Запуск VeraCrypt с помощью sudo часто позволяет обойти определённые проблемы, связанные с разрешениями, но всегда, когда это возможно, рекомендуется предоставлять необходимые разрешения через системные настройки.

Почему VeraCrypt показывает в своём списке неизвестное устройство, которое не отображается как физический диск в Windows-компоненте "Управление дисками" или в выводе утилиты DiskPart?

Начиная с Windows 10 версии 1903 и в более поздних версиях Microsoft добавила функцию под названием Песочница Windows (Sandbox). Это изолированная среда, предназначенная для безопасного запуска ненадёжных приложений. В рамках этой функции Windows создаёт динамический виртуальный жёсткий диск (VHDX), который представляет собой чистую установку Windows. Этот VHDX содержит базовый образ системы, пользовательские данные и состояние времени выполнения, а его размер может варьироваться в зависимости от конфигурации и использования системы.

Когда VeraCrypt перечисляет устройства в системе, определяются все доступные дисковые устройства, используя формат пути к устройству, например \Device\HardDiskX\PartitionY. VeraCrypt выводит список этих устройств, в том числе виртуальных, например тех, которые связаны с Песочницей Windows, не делая различий по их физической или виртуальной природе. Таким образом, вы можете обнаружить неожиданное устройство в VeraCrypt, даже если оно не отображается как физический диск в таких инструментах, как DiskPart.

Более подробную информацию о Песочнице Windows и связанном с ней виртуальном жёстком диске см. в официальной статье Microsoft.

Что делать, если здесь нет ответа на мой вопрос?
Попробуйте поискать ответ в документации VeraCrypt и на сайте программы.


Документация >> Технические подробности

Технические подробности

  • Система обозначений
  • Схема шифрования
  • Режимы работы
  • Формирование ключа заголовка, соль и количество итераций
  • Генератор случайных чисел
  • Ключевые файлы
  • PIM (Персональный множитель итераций)
  • Спецификация формата томов VeraCrypt
  • Соответствие стандартам и спецификациям
  • Исходный код
  • Сборка VeraCrypt из исходного кода
    • Руководство по сборке в Windows
    • Руководство по сборке в Linux


Документация >> Технические подробности >> Система обозначений

Система обозначений

C | Блок шифротекста
DK() | Алгоритм дешифрования, использующий ключ шифрования/дешифрования K
EK() | Алгоритм шифрования, использующий ключ шифрования/дешифрования K
H() | Функция хеширования
i | Блочный индекс для n-битовых блоков; n зависит от контекста
K | Криптографический ключ
^ | Побитовая операция исключающего ИЛИ (XOR)
⊕ | Сложение по модулю 2n, где n – битовый размер самого левого операнда и результирующего значения (например, если если левый операнд – 1-битовое значение, а правый операнд – 2-битовое значение, то: 1 ⊕ 0 = 1; 1 ⊕ 1 = 0; 1 ⊕ 2 = 1; 1 ⊕ 3 = 0; 0 ⊕ 0 = 0; 0 ⊕ 1 = 1; 0 ⊕ 2 = 0; 0 ⊕ 3 = 1)
⊗ | Модульное умножение двух полиномов в бинарном поле GF(2) по модулю x128+x7+x2+x+1 (GF означает Galois Field – поле Галуа)
|| | Конкатенация

Следующий раздел >>


Документация >> Технические подробности >> Схема шифрования

Схема шифрования

При монтировании тома VeraCrypt (предполагаем, что нет кэшированных паролей/ключевых файлов) или при предзагрузочной аутентификации выполняются следующие операции:

  1. Считываются (помещаются) в ОЗУ первые 512 байт тома (то есть заголовок обычного тома), из которых первые 64 байта это соль (см. Спецификация формата томов VeraCrypt). Для шифрования системы (см. Шифрование системы) в ОЗУ считываются последние 512 байт первой дорожки логического диска (загрузчик VeraCrypt располагается в первой дорожке системного диска и/или Диска восстановления VeraCrypt).
  2. Считываются (помещаются) в ОЗУ байты 65 536–66 047 тома (см. Спецификация формата томов VeraCrypt). Для шифрования системы считываются байты 65 536–66 047 раздела, расположенного сразу за активным разделом* (см. Скрытая операционная система). Если внутри этого тома имеется скрытый том (или внутри раздела, следующего за загрузочным разделом), то в этой точке мы прочитали его заголовок; в противном случае мы просто прочитали случайные данные (есть скрытый том внутри или его нет, определяется только попыткой расшифровать эти данные; подробности см. в разделе Скрытый том).
  3. Сейчас VeraCrypt пытается расшифровать заголовок обычного тома, считанный на этапе 1. Все данные, использованные и сгенерированные в ходе дешифрования, хранятся в ОЗУ (VeraCrypt никогда не сохраняет их на диске). Указанные ниже параметры неизвестны и определяются методом проб и ошибок (то есть проверкой всех возможных комбинаций следующего):
    1. PRF (псевдослучайная функция), применяемая при формировании (деривации) ключа заголовка (как определено в PKCS #5 v2.0; см. Формирование ключа заголовка, соль и количество итераций), которая может быть одной из следующих:

      HMAC-SHA-512, HMAC-SHA-256, HMAC-BLAKE2S-256, HMAC-Whirlpool.

      Если PRF указана пользователем явно, используется непосредственно она, без опробования других функций.

      Введённый пользователем пароль (который может сопровождаться одним или несколькими ключевыми файлами – см. раздел Ключевые файлы), значение PIM (если указано) и соль, считанные на этапе 1, передаются в функцию формирования ключа заголовка, которая производит последовательность значений (см. Формирование ключа заголовка, соль и количество итераций), из которых формируются ключ шифрования заголовка и вторичный ключ заголовка (режим XTS). (Эти ключи используются для дешифрования заголовка тома.)

    2. Алгоритм шифрования: AES-256, Serpent, Twofish, AES-Serpent, AES-Twofish-Serpent и т. д.
    3. Режим работы: поддерживается только XTS
    4. Размеры ключей
  4. Дешифрование считается успешным, если первые четыре байта расшифрованных данных содержат ASCII-строку “VERA” и если контрольная сумма CRC-32 последних 256 байт расшифрованных данных (заголовок тома) совпадает со значением, находящимся в байте №8 расшифрованных данных (неприятелю это значение неизвестно, поскольку оно зашифровано – см. раздел Спецификация формата томов VeraCrypt). Если эти условия не выполнены, процесс продолжается с этапа 3 снова, но на этот раз вместо данных, считанных на этапе 1, используются данные, считанные на этапе 2 (то есть возможный заголовок скрытого тома). Если условия снова не выполнены, монтирование прекращается (неверный пароль, повреждённый том, не том VeraCrypt).
  5. Теперь мы знаем (или предполагаем с очень высокой вероятностью), что у нас правильный пароль, правильный алгоритм шифрования, режим, размер ключа и правильный алгоритм формирования ключа заголовка. Если мы успешно расшифровали данные, считанные на этапе 2, мы также знаем, что монтируется скрытый том, и знаем его размер, полученный из данных, считанных на этапе 2 и расшифрованных на этапе 3.
  6. Подпрограмма шифрования переинициализируется с первичным мастер-ключом** и вторичным мастер-ключом (режим XTS – см. раздел Режимы работы), которые получены из расшифрованного заголовка тома (см. раздел Спецификация формата томов VeraCrypt). Эти ключи могут быть использованы для дешифрования любого сектора тома, за исключением области заголовка тома (или, в случае шифрования системы, области ключевых данных), зашифрованного с помощью ключей заголовка. Том смонтирован.

См. также разделы Режимы работы и Формирование ключа заголовка, соль и количество итераций, а также главу Модель безопасности.

* Если размер активного раздела меньше 256 МБ, то данные считываются из второго раздела, идущего следом за активным (Windows 7 и более поздние версии по умолчанию не загружаются с раздела, на котором они установлены).

† Эти параметры держатся в секрете не для того, чтобы усложнить атаку, а в первую очередь для того, чтобы сделать тома VeraCrypt не идентифицируемыми (неотличимыми от случайных данных), чего было бы трудно добиться, если бы эти параметры хранились в незашифрованном виде в заголовке тома. Также обратите внимание, что в случае устаревшего режима загрузки MBR, если для шифрования системы используется некаскадный алгоритм шифрования, алгоритм известен (его можно определить, проанализировав содержимое незашифрованного загрузчика VeraCrypt, хранящегося на первой дорожке логического диска или на Диске восстановления VeraCrypt).

** Мастер-ключи генерируются во время создания тома и не могут быть изменены позже. Изменение пароля тома выполняется путём повторного шифрования заголовка тома с использованием нового ключа заголовка (сформированным из нового пароля).

Следующий раздел >>


Документация >> Технические подробности >> Режимы работы

Режимы работы

Для шифрования разделов, дисков и виртуальных томов VeraCrypt использует режим работы XTS.

Режим XTS это фактически режим XEX [12], который в 2003 году разработал Phillip Rogaway, с незначительной модификацией (режим XEX использует один ключ для двух разных целей, тогда как режим XTS использует два независимых ключа).

В 2010 году режим XTS был одобрен NIST (Национальным институтом стандартов и технологий США) для защиты конфиденциальных данных на устройствах хранения информации [24]. В 2007 году он был также одобрен IEEE (Институтом инженеров по электротехнике и электронике США) для криптографической защиты данных в блочно-ориентированных устройствах хранения информации (IEEE 1619).

Описание режима XTS:

Ci = EK1(Pi ^ (EK2(n) [image] ai)) ^ (EK2(n) [image] ai)
где:
 | означает умножение двух полиномов в бинарном поле GF(2) по модулю x128+x7+x2+x+1
K1 | это ключ шифрования (256-битовый для каждого поддерживаемого шифра, то есть AES, Serpent и Twofish)
K2 | это вторичный ключ (256-битовый для каждого поддерживаемого шифра, то есть AES, Serpent и Twofish)
i | это индекс шифроблока внутри единицы данных; для первого шифроблока внутри единицы данных i = 0
n | это индекс единицы данных внутри области действия K1; для первой единицы данных n = 0
a | это примитивный элемент поля Галуа (2128), соответствующий полиному x (то есть 2)
Остальные символы определены в разделе Система обозначений.

Размер каждой единицы данных всегда равен 512 байтам (вне зависимости от размера сектора).
См. дополнительную информацию, относящуюся к режиму XTS, например, в [12] и [24].
Следующий раздел >>


Документация >> Технические подробности >> Формирование ключа заголовка, соль и количество итераций

Формирование ключа заголовка, соль и количество итераций

Ключ заголовка используется для шифрования и дешифрования зашифрованной области заголовка тома VeraCrypt (в случае шифрования системы – области ключевых данных), которая содержит мастер-ключ и другую информацию (см. разделы Схема шифрования и Спецификация формата томов VeraCrypt). В томах, созданных с помощью VeraCrypt (и для шифрования системы), эта область зашифрована в режиме XTS (см. раздел Режимы работы). Для генерирования ключа заголовка и вторичного ключа заголовка (режим XTS) VeraCrypt использует метод PBKDF2, определённый в PKCS #5 v2.0; см. [7].
В программе применяется 512-битовая соль, что означает 2512 ключей для каждого пароля. Благодаря этому значительно повышается устойчивость к атакам с офлайн-словарями/"радужной таблицей" (соль крайне осложняет предвычисление всех ключей для словаря паролей) [7]. Соль состоит из случайных значений, созданных генератором случайных чисел VeraCrypt в процессе создания тома. Функция формирования (деривации) ключа заголовка основана на HMAC-SHA-512, HMAC-SHA-256, HMAC-BLAKE2S-256, HMAC-Whirlpool или HMAC-Streebog (см. [8, 9, 20, 22]) – какая из них будет применяться, выбирается пользователем. Длина сформированного ключа не зависит от размера вывода лежащей в основе хеш-функции. Например, длина ключа заголовка для шифра AES-256 всегда равна 256 битам, даже если используется HMAC-SHA-512 (в режиме XTS применяется дополнительный 256-битовый вторичный ключ заголовка; следовательно, для AES-256 в целом применяются два 256-битовых ключа). Более подробную информацию см. в [7]. Для формирования ключа заголовка выполняется большое количество итераций, что увеличивает время, необходимое для полного поиска паролей (то есть атакой методом перебора) [7].

До версии 1.12 в VeraCrypt всегда использовалось фиксированное количество итераций, зависящее только от типа тома и алгоритма формирования ключа.

    Начиная с версии 1.12, поле PIM (Персональный множитель итераций) даёт пользователям больший контроль за количеством итераций, используемых в функции формирования ключа.

    Если PIM не указан или равен нулю, VeraCrypt использует следующие стандартные значения:

    • Для шифрования системы (шифрование загрузки), если используется SHA-256, BLAKE2s-256 или Streebog, число итераций = 200 000.
    • Для шифрования системы, если используется SHA-512 или Whirlpool, а также для несистемных разделов и файловых контейнеров число итераций = 500 000.

    Если PIM указан, то количество итераций функции формирования ключа вычисляется следующим образом:

    • Для шифрования системы, если не используется SHA-512 или Whirlpool, число итераций = PIM × 2048.
    • Для шифрования системы, если используется SHA-512 или Whirlpool, а также для несистемных разделов и файлов-контейнеров число итераций = 15 000 + (PIM × 1000).
    Ключи заголовка, используемые шифрами при каскадном (последовательном) шифровании, не зависят друг от друга, хотя они и сформированы из одного пароля (к которому могут быть применены ключевые файлы). Например, для каскада AES-Twofish-Serpent функция формирования ключа заголовка получает 768-битный ключ шифрования из заданного пароля (и, для режима XTS, вдобавок 768-битовый вторичный ключ заголовка из заданного пароля). Сгенерированный 768-битовый ключ заголовка затем разделяется на три 256-битовых ключа (для режима XTS вторичный ключ разделяется тоже на три 256-битовых ключа, поэтому в действительности каскад в целом использует шесть 256-битовых ключей), из которых первый ключ используется шифром Serpent, второй – шифром Twofish, а третьй – шифром AES (кроме того, для режима XTS первый вторичный ключ используется шифром Serpent, второй вторичный ключ – шифром Twofish, и третий вторичный ключ – шифром AES). Отсюда следует, что даже если у неприятеля окажется один из ключей, он не сможет им воспользоваться для формирования остальных, поскольку не существует реально осуществимого способа определить пароль по полученному из него в результате формирования ключу (за исключением атаки полным перебором при слабом пароле).
    Следующий раздел >>


Документация >> Технические подробности >> Генератор случайных чисел

Генератор случайных чисел

Для генерирования мастер-ключа шифрования, вторичного ключа (режим XTS), соли и ключевых файлов в VeraCrypt используется генератор случайных чисел (RNG). Он создаёт в ОЗУ (оперативной памяти компьютера) пул из случайных значений. Этот пул размером 320 байт заполняется данными, получаемыми из следующих источников:

  • перемещения мыши
  • нажатия клавиш
  • Mac OS X и Linux: значения, генерируемые встроенным RNG (оба – /dev/random и /dev/urandom)
  • только Microsoft Windows: Windows CryptoAPI (регулярно собираются с интервалом 500 мс)
  • только Microsoft Windows: статистика сетевого интерфейса (NETAPI32)
  • только Microsoft Windows: различные дескрипторы Win32, переменные времени и счётчики (регулярно собираются с интервалом 500 мс)

Прежде чем значение, полученное из любого вышеуказанного источника, будет записано в пул, оно разделяется на отдельные байты (например, 32-битовое число делится на четыре байта). Затем эти байты индивидуально записываются в пул операцией сложения по модулю 28 (не заменяя старые значения в пуле) в позиции указателя пула. После записи байта позиция указателя пула перемещается на один байт вперёд. Когда указатель достигает конца пула, его позиция устанавливается в начало пула. После записи в пул каждого шестнадцатого байта, ко всему пулу автоматически применяется функция перемешивания (см. ниже).

Функция перемешивания пула

Назначение этой функции – выполнение диффузии [2]. Диффузия максимально распространяет (рассеивает) влияние индивидуальных "необработанных" ("raw") входных бит по пулу, что также скрывает статистические зависимости. После записи в пул каждого шестнадцатого байта, эта функция применяется ко всему пулу.

Описание функции перемешивания пула:

  1. Пусть R это пул случайных значений
  2. Пусть H это выбранная пользователем функция хеширования (SHA-512, BLAKE2S-256 или Whirlpool)
  3. l = байтовый размер вывода функции хеширования H (то есть если H – BLAKE2S-256, то l = 20; если H – SHA-512, то l = 64)
  4. z = байтовый размер пула случайных значений R (320 байт)
  5. q = z / l – 1 (например, если H – Whirlpool, то q = 4)
  6. R это поделённые на l байт блоки B0...Bq

    Для 0 ≤ i ≤ q (то есть для каждого блока B) выполняются следующие шаги:

    1. M = H (B0 || B1 || ... || Bq) [то есть пул случайных значений хешируется с помощью хеш-функции H, что даёт хеш M]
    2. Bi = Bi ^ M
  7. R = B0 || B1 || ... || Bq

Например, если q = 1, то пул случайных значений будет перемешан следующим образом:

  1. (B0 || B1) = R
  2. B0 = B0 ^ H(B0 || B1)
  3. B1 = B1 ^ H(B0 || B1)
  4. R = B0 || B1

Создаваемые значения

Содержимое пула RNG никогда прямо не экспортируется (даже когда VeraCrypt даёт RNG инструкцию сгенерировать и экспортировать значение). Таким образом, даже если неприятель завладеет созданным RNG значением, это ему никак не поможет в определении или предсказании (с помощью полученного значения) любых других значений, созданных RNG в течение сеанса (определить содержимое пула, основываясь на сгенерированном RNG значении, невозможно).

Генератор случайных чисел обеспечивает это, выполняя следующие шаги всякий раз, когда VeraCrypt даёт указание сгенерировать и экспортировать значение:

  1. Данные, полученные из перечисленных выше источников, добавляются в пул, как описано выше.
  2. Запрошенное число байт копируется из пула в выходной буфер (копирование начинается с позиции указателя пула; по достижении конца пула копирование продолжается с начала пула; если запрошенное число байт больше размера пула, значение не генерируется и возвращается ошибка).
  3. Состояние каждого бита в пуле инвертируется (то есть 0 становится 1, а 1 становится 0).
  4. Данные, полученные из какого-либо перечисленного выше источника, добавляются в пул, как описано выше.
  5. Содержимое пула трансформируется с помощью функции перемешивания пула.
    Примечание. Эта функция использует криптографически стойкую одностороннюю хеш-функцию, выбираемую пользователем (подробности см. выше в разделе Функция перемешивания пула).
  6. Преобразованное содержимое пула подвергается операции XOR в выходной буфер следующим образом:
    1. Указатель записи в выходном буфере устанавливается в 0 (первый байт буфера).
    2. Байт в позиции курсора пула считывается из пула и подвергается операции XOR с байтом в выходном буфере в позиции курсора записи выходного буфера.
    3. Позиция указателя пула смещается вперёд на один байт. По достижении конца пула позиция указателя устанавливается в 0 (первый байт пула).
    4. Позиция указателя записи выходного буфера перемещается вперёд на один байт.
    5. Шаги b–d повторяются для каждого остающегося байта в выходном буфере (чья длина равна запрошенному числу байт).
    6. Содержимое выходного буфера, являющееся окончательным значением, сгенерированным RNG, экспортируется.

Первоисточники

Дизайн и реализация генератора случайных чисел основаны на следующих работах:

  • Software Generation of Practically Strong Random Numbers, автор Peter Gutmann [10]
  • Cryptographic Random Numbers, автор Carl Ellison [11]

Следующий раздел >>


Документация >> Технические подробности >> Ключевые файлы

Ключевые файлы

Ключевой файл VeraCrypt – это файл, содержимое которого объединено с паролем. В качестве ключевого файла можно использовать любой файл. Пользователь также может сгенерировать ключевой файл с помощью встроенного генератора ключевых файлов, который использует VeraCrypt RNG для создания файла со случайным содержимым (см. подробности в разделе Генератор случайных чисел).

Максимальный размер ключевого файла не ограничен, однако обрабатываются только его первые 1 048 576 байт (1 МиБ) (все остальные байты игнорируются, чтобы не жертвовать производительностью из-за обработки очень больших файлов). Можно указывать один или несколько ключевых файлов (количество не ограничено).

Ключевые файлы могут храниться на токенах безопасности и смарт-картах, совместимых с PKCS-11 [23], защищённых несколькими пин-кодами (которые можно ввести с помощью аппаратной пин-панели или через графический интерфейс VeraCrypt).

Ключевые файлы обрабатываются и применяются к паролю следующим способом:

  1. Пусть P это пароль тома VeraCrypt, указанный пользователем (может быть пустым)
  2. Пусть KP это пул ключевых файлов
  3. Пусть kpl это размер пула ключевых файлов KP, в байтах (64, то есть 512 бит);

    kpl должен быть кратен выходному размеру хеш-функции H

  4. Пусть pl это длина пароля P, в байтах (в текущей версии: 0 ≤ pl ≤ 64)
  5. Если kpl > pl, добавляем (kpl – pl) нулевых байт к паролю P (таким образом, pl = kpl)
  6. Заполняем пул ключевых файлов KP нулевыми байтами в количестве kpl.
  7. Для каждого ключевого файла выполняем следующие шаги:
    1. Устанавливаем положение указателя пула ключевых файлов в начало пула
    2. Инициализируем хеш-функцию H
    3. Загружаем все байты ключевого файла один за другим, и для каждого загруженного байта выполняем следующие шаги:
      1. Хешируем загруженный байт с помощью хеш-функции H без инициализации хеша, чтобы получить промежуточный хеш (состояние) M. Не финализируем хеш (состояние сохраняется для следующего раунда).
      2. Делим состояние M на отдельные байты.
        Например, если выходной размер хеша составляет 4 байта, (T0 || T1 || T2 || T3) = M
      3. Записываем эти байты (полученные на шаге 7.c.ii) по отдельности в пул ключевых файлов с помощью операции сложения по модулю 28 (не заменяя старые значения в пуле) в позиции указателя пула. После записи байта позиция указателя пула увеличивается на один байт. Когда указатель достигает конца пула, его положение устанавливается в начало пула.
  8. Применяем содержимое пула ключевых файлов к паролю P, используя следующий метод:
    1. Делим пароль P на отдельные байты B0...Bpl-1.
      Обратите внимание, что если пароль был короче пула ключевых файлов, то пароль дополнялся нулевыми байтами до длины пула на шаге 5 (следовательно, в этот момент длина пароля всегда больше или равна длине пула ключевых файлов).
    2. Делим пул ключевых файлов KP на отдельные байты G0...Gkpl-1
    3. Для 0 ≤ i < kpl выполняем: Bi = Bi ⊕ Gi
    4. P = B0 || B1 || ... || Bpl-2 || Bpl-1
  9. Пароль P (после применения к нему содержимого пула ключевых файлов) теперь передаётся в функцию формирования ключа заголовка PBKDF2 (PKCS #5 v2), которая его обрабатывает (вместе с солью и другими данными) используя выбранный пользователем криптографически безопасный алгоритм хеширования (например, SHA-512). См. подробности в разделе Формирование ключа заголовка, соль и количество итераций.

Роль хеш-функции H заключается просто в выполнении диффузии [2]. В качестве хеш-функции H применяется CRC-32. Обратите внимание, что вывод CRC-32 впоследствии обрабатывается с использованием криптографически безопасного хеш-алгоритма: содержимое пула ключевых файлов (в дополнение к хешированию с помощью CRC-32) применяется к паролю, который затем передаётся в функцию формирования ключа заголовка PBKDF2 (PKCS #5 v2), которая его обрабатывает (вместе с солью и другими данными), используя выбранный пользователем криптографически безопасный алгоритм хеширования (например, SHA-512). Результирующие значения используются для формирования ключа заголовка и вторичного ключа заголовка (режим XTS).

Следующий раздел >>


Документация >> Технические подробности >> PIM

PIM (Персональный множитель итераций)

PIM расшифровывается как "Персональный множитель итераций". Это параметр впервые появился в VeraCrypt 1.12, его значение определяет количество итераций, используемых функцией формирования ключа заголовка. Это значение можно указать в диалоговом окне пароля или в командной строке.

Если значение PIM указано, количество итераций вычисляется следующим образом:

  • Для шифрования системного раздела без использования SHA-512 или Whirlpool количество итераций = PIM × 2048
  • Для шифрования системного раздела с использованием SHA-512 или Whirlpool количество итераций = 15 000 + (PIM × 1000)
  • Для шифрования несистемных разделов и файловых контейнеров количество итераций = 15 000 + (PIM × 1000)

Если значение PIM не указано, будет использоваться количество итераций по умолчанию, применяемое в версиях до 1.12 (см. Формирование ключа заголовка). Это можно резюмировать следующим образом:

  • Для шифрования системного раздела (шифрования загрузки) с использованием SHA-256, BLAKE2s-256 или Streebog применяется 200 000 итераций, что эквивалентно значению PIM 98.
  • Для шифрования системного раздела с использованием SHA-512 или Whirlpool применяется 500 000 итераций, что эквивалентно значению PIM 485.
  • Для шифрования несистемных разделов и файловых контейнеров все алгоритмы формирования ключа (деривации) будут использовать 500 000 итераций, что эквивалентно значению PIM 485.

До версии 1.12 безопасность тома VeraCrypt основывалась только на надёжности пароля, поскольку VeraCrypt использовал фиксированное количество итераций.
Благодаря реализации управления PIM у VeraCrypt появилось двумерное пространство безопасности для томов, основанное на паре (Пароль, PIM). Это обеспечивает большую гибкость при настройке желаемого уровня безопасности, одновременно контролируя производительность операции монтирования/загрузки.

Использование PIM

Указывать PIM не обязательно.

При создании тома или при смене пароля у пользователя есть возможность указать значение PIM, включив опцию Использовать PIM, что, в свою очередь, сделает поле PIM доступным в графическом интерфейсе, чтобы можно было ввести значение PIM.
PIM обрабатывается как секретное значение, которое пользователь должен вводить каждый раз вместе с паролем. Если указано неверное значение PIM, операция монтирования/загрузки завершится ошибкой.
Чем больше PIM, тем выше безопасность, так как увеличивается число итераций, но тем медленнее монтирование/загрузка.
Чем меньше PIM, тем быстрее монтирование/загрузка, но возможно ухудшение безопасности, если используется слабый пароль.
Во время создания тома или шифрования системы VeraCrypt принудительно выставляет значение PIM большим или равным определённому минимальному значению, если пароль меньше 20 символов. Эта проверка выполняется для того, чтобы убедиться, что для коротких паролей уровень безопасности по крайней мере равен уровню по умолчанию, когда PIM пуст.
Минимальное значение PIM для коротких паролей равно 98 для шифрования системы без использования SHA-512 или Whirlpool, и 485 для других случаев. Для пароля, состоящего из 20 и более символов, минимальное значение PIM равно 1. Во всех случаях, если оставить PIM пустым или установить его значение равным 0, VeraCrypt будет использовать большое количество итераций по умолчанию, как это объяснено в разделе Формирование ключа заголовка.

Мотивами применения пользовательского значения PIM могут быть:
  • добавление дополнительного секретного параметра (PIM), который злоумышленнику придётся угадывать;
  • повышение уровня безопасности при использовании больших значений PIM, чтобы воспрепятствовать дальнейшему развитию атак методом перебора;
  • ускорение загрузки или монтирования за счет использования небольшого значения PIM (менее 98 для шифрования системы без использования SHA-512 или Whirlpool, и менее 485 для других случаев)

На приведённых ниже снимках экрана показан шаг монтирования тома с использованием PIM, равного 231:

Изменение/очистка PIM

PIM тома или для шифрования системы можно изменить или очистить с помощью функции смены пароля. На снимках экрана ниже показан пример изменения PIM со стандартного пустого значения на значение, равное 3 (это возможно, поскольку пароль содержит более 20 символов). Для этого нужно сначала включить опцию Использовать PIM в группе Новый, чтобы открыть поле PIM.

Пример с обычным томом

Пример с шифрованием системы

Следующий раздел >>


Документация >> Технические подробности >> Спецификация формата томов VeraCrypt

Спецификация формата томов VeraCrypt

Формат томов на основе файлов идентичен формату томов на основе разделов/устройств (однако "заголовок тома" или ключевые данные для системного раздела/диска хранятся в последних 512 байтах первой дорожки логического диска). Тома VeraCrypt не имеют никаких "сигнатур" или идентифицирующих строк. Пока тома не расшифрованы, они выглядят как состоящие исключительно из случайных данных.
Свободное пространство на каждом томе VeraCrypt заполняется случайными данными при создании тома.* Случайные данные генерируются следующим образом: непосредственно перед началом форматирования тома VeraCrypt генератор случайных чисел создаёт временный ключ шифрования и временный вторичный ключ (режим XTS) (см. раздел Генератор случайных чисел). Выбранный пользователем алгоритм шифрования инициализируется временными ключами. Затем используется алгоритм шифрования для шифрования блоков открытого текста, состоящих из случайных байтов, созданных генератором случайных чисел. Алгоритм шифрования работает в режиме XTS (см. раздел Скрытый том). Полученные блоки зашифрованного текста используются для заполнения (перезаписи) свободного места на томе. Временные ключи хранятся в ОЗУ и стираются после завершения форматирования.

Спецификация формата томов VeraCrypt:

Смещение (байты) | Размер (байты) | Статус шифрования† | Описание
0 | 64 | Не зашифровано§ | Соль
64 | 4 | Зашифровано | ASCII-строка "VERA"
68 | 2 | Зашифровано | Версия формата заголовка тома (2)
70 | 2 | Зашифровано | Минимальная версия программы, необходимая для открытия тома
72 | 4 | Зашифровано | Контрольная сумма CRC-32 (расшифрованных) байтов 256-511
76 | 16 | Зашифровано | Зарезервировано (должно содержать нули)
92 | 8 | Зашифровано | Размер скрытого тома (для нескрытых томов – ноль)
100 | 8 | Зашифровано | Размер тома
108 | 8 | Зашифровано | Байтовое смещение начала области действия мастер-ключа
116 | 8 | Зашифровано | Размер зашифрованного участка в области действия мастер-ключа
124 | 4 | Зашифровано | Биты флагов (бит 0 установлен: шифрование системы; бит 1 установлен: несистемный "на месте" зашифрованный/расшифрованный том; биты 2-31 зарезервированы)
128 | 4 | Зашифровано | Размер сектора (в байтах)
132 | 120 | Зашифровано | Зарезервировано (должно содержать нули)
252 | 4 | Зашифровано | Контрольная сумма CRC-32 (расшифрованных) байтов 64-251
256 | Пер. | Зашифровано | Объединённые первичный и вторичный мастер-ключи**
512 | 65024 | Зашифровано | Зарезервировано (при шифровании системы этот элемент опущен‡‡)
65536 | 65536 | Зашифровано / | Область для заголовка скрытого тома (если внутри тома нет скрытого тома, эта область содержит случайные данные††). При шифровании системы этот элемент опущен.‡‡ См. байты 0-65535
 |  | Не зашифровано§ |
131072 | Пер. | Зашифровано | Область данных (область действия мастер-ключа). При шифровании системы смещение может быть другим (зависит от смещения системного раздела)
S-131072‡ | 65536 | Зашифровано / | Резервная копия заголовка (зашифрованная другим ключом заголовка, сформированным с помощью другой соли). При шифровании системы этот элемент опущен.‡‡ См. байты 0-65535
 |  | Не зашифровано§ |
S-65536‡ | 65536 | Зашифровано / | Резервная копия заголовка скрытого тома (зашифрованная другим ключом заголовка, сформированным с помощью другой соли). Если внутри тома нет скрытого тома, эта область содержит случайные данные.†† При шифровании системы этот элемент опущен.‡‡ См. байты 0-65535
 |  | Не зашифровано§ |
Поля, расположенные с байта №0 (соль) и №256 (мастер-ключи) содержат случайные данные, созданные генератором случайных чисел (см. раздел Генератор случайных чисел) во время создания тома.
Если в томе VeraCrypt содержится скрытый том (внутри его пустого места), заголовок скрытого тома расположен с байта №65536 хост-тома (заголовок хост/внешнего тома расположен с байта №0 хост-тома – см. раздел Скрытый том). Если внутри тома VeraCrypt нет скрытого тома, байты 65536-131071 тома (то есть область, где может находиться заголовок скрытого тома) содержат случайные данные (см. информацию выше о методе заполнения свободного пространства тома случайными данными при создании тома). Расположение заголовка скрытого тома такое же, как и у стандартного тома (байты 0-65535).
Максимально возможный размер тома VeraCrypt – 263 байтов (8 589 934 592 ГБ). Однако из соображений безопасности (с учётом 128-битового размера блоков, используемых алгоритмами шифрования), максимально разрешённый размер тома составляет 1 ПБ (1 048 576 ГБ).

Встроенные резервные копии заголовков

Каждый том VeraCrypt содержит встроенную резервную копию заголовка, расположенную в конце тома (см. выше). Резервная копия заголовка это не копия заголовка тома, так как она зашифрована другим ключом заголовка, сформированным с использованием другой соли (см. раздел Формирование ключа заголовка, соль и количество итераций).
При смене пароля и/или PIM и/или ключевых файлов тома, либо при восстановлении заголовка из встроенной (или внешней) резервной копии выполняется перешифрование заголовка тома и резервной копии заголовка (встроенной в том) с помощью других ключей заголовка (сформированных с использованием вновь сгенерированной соли – соль для заголовка тома отличается от соли для резервной копии заголовка). Каждая соль создаётся генератором случайных чисел VeraCrypt (см. раздел Генератор случайных чисел).
Более подробные сведения о резервных копиях заголовков см. в подразделе Сервис > Восстановить заголовок тома в главе Главное окно программы.
Следующий раздел >>

* При условии, что отключены опции Быстрое форматирование и Динамический, а также что том не содержит файловую систему, которая была зашифрована на месте (обратите внимание, что VeraCrypt не позволяет пользователю создавать скрытый том внутри такого тома).
† Зашифрованные области заголовка тома шифруются в режиме XTS с использованием первичного и вторичного ключей заголовка. См. подробности в разделах Схема шифрования и Формирование ключа заголовка, соль и количество итераций.
‡ S обозначает размер хоста тома (в байтах).
§ Обратите внимание, что соль не нужно шифровать, так как её не требуется держать в секрете [7] (соль это последовательность случайных значений).
** Здесь хранится несколько объединённых мастер-ключей, когда том зашифрован с помощью каскада шифров (вторичные мастер-ключи используются для режима XTS).
†† См. выше в этом разделе информацию о методе заполнения свободного пространства тома случайными данными при создании тома.
‡‡ Здесь значение "шифрование системы" не включает скрытый том, содержащий скрытую операционную систему.


Документация >> Технические подробности >> Соответствие стандартам и спецификациям

Соответствие стандартам и спецификациям

По нашим сведениям, VeraCrypt соответствует следующим стандартам, спецификациям и рекомендациям:

  • ISO/IEC 10118-3:2004 [21]
  • FIPS 197 [3]
  • FIPS 198 [22]
  • FIPS 180-2 [14]
  • FIPS 140-2 (XTS-AES, SHA-256, SHA-512, HMAC) [25]
  • NIST SP 800-38E [24]
  • PKCS #5 v2.0 [7]
  • PKCS #11 v2.20 [23]

Правильность реализации алгоритмов шифрования можно проверить с помощью тестовых векторов (выберите Сервис > Тест алгоритмов генерирования векторов) или изучив исходный код VeraCrypt.

Следующий раздел >>


Документация >> Технические подробности >> Исходный код

Исходный код

VeraCrypt это бесплатное программное обеспечение с открытым исходным кодом. Полный исходный код VeraCrypt (написанный на языках C, C++ и ассемблер) свободно доступен для ознакомления и исследования в следующих Git-репозитариях:

  • https://github.com/veracrypt/VeraCrypt
  • https://sourceforge.net/p/veracrypt/code/ci/master/tree/
  • https://bitbucket.org/veracrypt/veracrypt/src

Исходный код каждой версии можно загрузить из того же места, что и бинарные файлы.


Документация >> Технические подробности >> Сборка VeraCrypt из исходного кода

Сборка VeraCrypt из исходного кода

Чтобы собрать VeraCrypt из исходного кода, следуйте этим пошаговым инструкциям:

  • Руководство по сборке в Windows
  • Руководство по сборке в Linux


Документация >> Технические подробности >> Сборка VeraCrypt из исходного кода >> Руководство по сборке в Windows

В этом руководстве описано, как настроить систему Windows для компилирования VeraCrypt и как cкомпилировать программу.
Здесь как пример приведена процедура для Windows 10, процедуры для других версий Windows аналогичны.
Для компиляции VeraCrypt необходимы следующие компоненты:
  1. Microsoft Visual Studio 2010
  2. Microsoft Visual Studio 2010 Service Pack 1
  3. NASM
  4. YASM
  5. Visual C++ 1.52
  6. Windows SDK 7.1
  7. Windows Driver Kit 7.1
  8. Windows 8.1 SDK
  9. gzip
  10. UPX
  11. 7-Zip
  12. WiX3
  13. Microsoft Visual Studio 2019
  14. Windows 10 SDK
  15. Windows Driver Kit 1903
  16. Средства сборки Visual Studio
Ниже приведены шаги процедуры. Нажав на любую ссылку, вы сразу перейдёте к соответствующему шагу:
  • Установка Microsoft Visual Studio 2010
  • Установка Microsoft Visual Studio 2010 Service Pack 1
  • Установка NASM
  • Установка YASM
  • Установка Microsoft Visual C++ 1.52
  • Установка Windows SDK 7.1
  • Установка Windows Driver Kit 7.1
  • Установка Windows 8.1 SDK
  • Установка gzip
  • Установка UPX
  • Установка 7-Zip
  • Установка WiX3
  • Установка Microsoft Visual Studio 2019
  • Установка Windows Driver Kit 2004
  • Установка средств сборки Visual Studio
  • Загрузка исходных файлов VeraCrypt
  • Компиляция Win32/x64-версий VeraCrypt
  • Компиляция ARM64-версии VeraCrypt
  • Сборка исполняемых файлов VeraCrypt
  • Импорт сертификатов
  • Известные проблемы
Установка Microsoft Visual Studio 2010

  1. Посетите следующий сайт Microsoft и войдите в систему с помощью бесплатной учётной записи Microsoft:
    https://my.visualstudio.com/Downloads?q=Visual%20Studio%202010%20Professional&pgroup=
  2. Загрузите (пробную) версию "Visual Studio Professional 2010".
  3. Смонтируйте загруженный файл ISO, дважды щёлкнув по нему.
  4. Запустите файл "autorun.exe" от имени администратора.
  5. Установите Microsoft Visual Studio 2010 с настройками по умолчанию.
Установка Microsoft SQL Server 2008 Express Service Pack 1 (x64) может завершиться ошибкой, но это не требуется для компиляции VeraCrypt.

Установка Microsoft Visual Studio 2010 Service Pack 1

ПРИМЕЧАНИЕ: Содержимое, которое пытается загрузить официальный установщик Microsoft, больше недоступно. Поэтому необходимо использовать автономный установщик.

  1. Посетите сайт интернет-архива и загрузите ISO-образ Microsoft Visual Studio 2010 Service Pack 1:
    https://archive.org/details/vs-2010-sp-1dvd-1
  2. Смонтируйте загруженный файл ISO, дважды щёлкнув по нему.
  3. Запустите файл "Setup.exe" от имени администратора.
  4. Установите Microsoft Visual Studio 2010 Service Pack 1 с настройками по умолчанию.

Установка NASM

  1. Загрузите файл "nasm-2.08-installer.exe" отсюда:
    https://www.nasm.us/pub/nasm/releasebuilds/2.08/win32/
  2. Запустите файл от имени администратора.
  3. Установите NASM с настройками по умолчанию.
  4. Добавьте путь к папке NASM в системную переменную PATH. Это сделает команду доступной отовсюду при вызове из командной строки.
    1. Откройте Проводник.
    2. В левой панели щёлкните правой кнопкой мыши по "Этот компьютер" и выберите "Свойства".
    3. В правой части окна щёлкните по "Дополнительные параметры системы".
    4. Нажмите кнопку "Переменные среды".
    5. В поле "Системные переменные" выберите переменную "Path" и нажмите кнопку "Изменить...".
    6. Нажмите кнопку "Создать" и добавьте следующее значение:

      C:\Program Files (x86)\nasm

    7. Закройте окна, нажимая кнопки OK.
  5. Чтобы проверить, правильно ли работает конфигурация, откройте командную строку и посмотрите вывод следующей команды:

    nasm

Установка YASM

  1. Создайте следующую папку:
    C:\Program Files\YASM
  2. Загрузите файл "Win64 VS2010 .zip" отсюда:
    https://yasm.tortall.net/Download.html
  3. Ваш интернет-браузер может сообщить, что, возможно, файл представляет угрозу безопасности, так как редко скачивается или из-за незашифрованного соединения. Тем не менее официальный сайт – наиболее надёжный источник этого файла, поэтому мы рекомендуем разрешить загрузку.
  4. Распакуйте загруженный zip-архив и скопируйте извлечённые файлы в папку "C:\Program Files\YASM".
  5. Загрузите файл "Win64 .exe" отсюда:
    https://yasm.tortall.net/Download.html
  6. Ваш интернет-браузер может сообщить, что, возможно, файл представляет угрозу безопасности, так как редко скачивается или из-за незашифрованного соединения. Тем не менее официальный сайт – наиболее надёжный источник этого файла, поэтому мы рекомендуем разрешить загрузку.
  7. Переименуйте файл в "yasm.exe" и скопируйте его в папку "C:\Program Files\YASM".
  8. Добавьте путь к папке YASM в переменную PATH и создайте новую системную переменную для YASM. Это сделает команду доступной отовсюду при вызове из командной строки.
    1. Откройте Проводник.
    2. В левой панели щёлкните правой кнопкой мыши по "Этот компьютер" и выберите "Свойства".
    3. В правой части окна щёлкните по "Дополнительные параметры системы".
    4. Нажмите кнопку "Переменные среды".
    5. В поле "Системные переменные" выберите переменную "Path" и нажмите кнопку "Изменить...".
    6. Нажмите кнопку "Создать" и добавьте следующее значение:

      C:\Program Files\YASM

    7. Закройте верхнее окно, нажав OK.
    8. В поле "Системные переменные" нажмите кнопку "Создать...".
    9. Заполните форму следующими значениями:

      Имя переменной: YASMPATH
      Значение переменной: C:\Program Files\YASM

    10. Закройте окна, нажимая кнопки OK.
  9. Чтобы проверить, правильно ли работает конфигурация, откройте командную строку и посмотрите вывод следующей команды:

    yasm

    и

    vsyasm

Установка Microsoft Visual C++ 1.52

  1. Пакет Visual C++ 1.52 доступен по платной подписке Microsoft MSDN. Если у вас нет подписки, загрузите образ ISO через интернет-архив:
    https://archive.org/details/ms-vc152
  2. Создайте папку "C:\MSVC15".
  3. Смонтируйте файл ISO и скопируйте содержимое папки "MSVC" в "C:\MSVC15".
  4. Создайте системную переменную для Microsoft Visual C++ 1.52.
    1. Откройте Проводник.
    2. В левой панели щёлкните правой кнопкой мыши по "Этот компьютер" и выберите "Свойства".
    3. В правой части окна щёлкните по "Дополнительные параметры системы".
    4. Нажмите кнопку "Переменные среды".
    5. В поле "Системные переменные" нажмите кнопку "Создать...".
    6. Заполните форму следующими значениями:

      Имя переменной: MSVC16_ROOT
      Значение переменной: C:\MSVC15

    7. Закройте окна, нажимая кнопки OK.

Установка Windows SDK 7.1

Для установки требуется платформа .NET Framework 4 (более новая, например .NET Framework 4.8, не годится!). Поскольку вместе с Windows 10 уже предустановлена более новая версия, установщик придётся обмануть:

  1. Нажмите кнопку Пуск и найдите "regedit.exe". Запустите первое найденное.
  2. Перейдите в ветвь "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\".
  3. Измените разрешения у папки "Client", чтобы можно было редактировать ключи:
    1. Щёлкните правой кнопкой мыши по подпапке "Client" и выберите "Разрешения...".
    2. Нажмите кнопку "Дополнительно".
    3. Измените владельца на своего пользователя и нажмите "Добавить".
    4. Укажите субъектом своего пользователя, включите опцию "Полный доступ" и нажмите OK.
    5. В папке "Client" запишите значение элемента "Version".
    6. Дважды щёлкните мышью по элементу "Version" и измените значение на "4.0.30319".
  4. Измените разрешения у папки "Full", чтобы можно было редактировать ключи:
    1. Щёлкните правой кнопкой мыши по подпапке "Full" и выберите "Разрешения...".
    2. Нажмите кнопку "Дополнительно".
    3. Измените владельца на своего пользователя и нажмите "Добавить".
    4. Укажите субъектом своего пользователя, включите опцию "Полный доступ" и нажмите OK.
    5. В папке "Full" запишите значение элемента "Version".
    6. Дважды щёлкните мышью по элементу "Version" и измените значение на "4.0.30319".
  5. Загрузите Windows SDK 7.1 отсюда:
    https://www.microsoft.com/en-us/download/details.aspx?id=8279
  6. Запустите загруженный файл от имени администратора и установите приложение с настройками по умолчанию.
  7. После установки отмените изменения, сделанные в редакторе реестра.
    ПРИМЕЧАНИЕ: Владельца "TrustedInstaller" можно восстановить, выполнив поиск: "NT Service\TrustedInstaller".

Установка Windows Driver Kit 7.1

  1. Загрузите ISO-файл Windows Diver Kit 7.1 отсюда:
    https://www.microsoft.com/en-us/download/details.aspx?id=11800
  2. Смонтируйте загруженный файл ISO, дважды щёлкнув по нему.
  3. Запустите файл "KitSetup.exe" от имени администратора. Выберите для установки все компоненты.
    ПРИМЕЧАНИЕ: Возможно, во время установки вас попросят установить .NET Framework 3.5. В этом случае нажмите "Загрузить и установить".
  4. Установите комплект драйверов в папку по умолчанию.

Установка Windows 8.1 SDK

  1. Загрузите ISO-файл Windows 8.1 SDK отсюда:
    https://developer.microsoft.com/de-de/windows/downloads/sdk-archive/
  2. Запустите загруженный файл от имени администратора и установите Windows 8.1 SDK с настройками по умолчанию.
  3. Создайте системную переменную для Windows 8.1 SDK.
    1. Откройте Проводник.
    2. В левой панели щёлкните правой кнопкой мыши по "Этот компьютер" и выберите "Свойства".
    3. В правой части окна щёлкните по "Дополнительные параметры системы".
    4. Нажмите кнопку "Переменные среды".
    5. В поле "Системные переменные" нажмите кнопку "Создать...".
    6. Заполните форму следующими значениями:

      Имя переменной: WSDK81
      Значение переменной: C:\Program Files (x86)\Windows Kits\8.1\

    7. Закройте окна, нажимая кнопки OK.

Установка gzip

  1. Создайте следующую папку:
    C:\Program Files (x86)\gzip
  2. Загрузите версию gzip отсюда:
    https://sourceforge.net/projects/gnuwin32/files/gzip/1.3.12-1/gzip-1.3.12-1-bin.zip/download?use-mirror=netix&download=
  3. Скопируйте содержимое загруженного zip-архива в папку "C:\Program Files (x86)\gzip".
  4. Добавьте путь к папке с gzip в переменную PATH. Это сделает команду доступной отовсюду при вызове из командной строки.
    1. Откройте Проводник.
    2. В левой панели щёлкните правой кнопкой мыши по "Этот компьютер" и выберите "Свойства".
    3. В правой части окна щёлкните по "Дополнительные параметры системы".
    4. Нажмите кнопку "Переменные среды".
    5. В поле "Системные переменные" выберите переменную "Path" и нажмите кнопку "Изменить...".
    6. Нажмите кнопку "Создать" и добавьте следующее значение:

      C:\Program Files (x86)\gzip\bin

    7. Закройте окна, нажимая кнопки OK.
  5. Чтобы проверить, правильно ли работает конфигурация, откройте командную строку и посмотрите вывод следующей команды:

    gzip

Установка UPX

  1. Создайте следующую папку:
    C:\Program Files (x86)\upx
  2. Загрузите новейшую версию файла upx-X.X.X-win64.zip отсюда:
    https://github.com/upx/upx/releases/tag/v4.0.2
  3. Скопируйте содержимое загруженного zip-архива в папку "C:\Program Files (x86)\upx".
  4. Добавьте путь к папке с gzip в системную переменную PATH. Это сделает команду доступной отовсюду при вызове из командной строки.
    1. Откройте Проводник.
    2. В левой панели щёлкните правой кнопкой мыши по "Этот компьютер" и выберите "Свойства".
    3. В правой части окна щёлкните по "Дополнительные параметры системы".
    4. Нажмите кнопку "Переменные среды".
    5. В поле "Системные переменные" выберите переменную "Path" и нажмите кнопку "Изменить...".
    6. Нажмите кнопку "Создать" и добавьте следующее значение:

      C:\Program Files (x86)\upx

    7. Закройте окна, нажимая кнопки OK.
  5. Чтобы проверить, правильно ли работает конфигурация, откройте командную строку и посмотрите вывод следующей команды:

    upx

Установка 7-Zip

  1. Загрузите новейшую версию 7-Zip отсюда:
    https://www.7-zip.org/
  2. Запустите загруженный файл от имени администратора и установите 7-Zip с настройками по умолчанию.

Установка WiX3

  1. Загрузите файл "wix311.exe" отсюда:
    https://github.com/wixtoolset/wix3/releases
  2. Запустите загруженный файл от имени администратора и установите WiX с настройками по умолчанию.

Установка Microsoft Visual Studio 2019

  1. Посетите следующий сайт Microsoft и войдите в систему с помощью бесплатной учётной записи Microsoft:
    https://my.visualstudio.com/Downloads?q=visual%20studio%202019%20Professional
  2. Загрузите новейшую (пробную) версию "Visual Studio Professional 2019".
  3. Запустите загруженный файл от имени администратора и следуйте указаниям мастера.
    Выберите следующие Workloads для установки:
    1. Desktop development with C++
    2. .NET desktop development
    Выберите следующие отдельные компоненты для установки:
    1. .NET
      1. .NET 6.0 Runtime
      2. .NET Core 3.1 Runtime (LTS)
      3. .NET Framework 4 targeting pack
      4. .NET Framework 4.5 targeting pack
      5. .NET Framework 4.5.1 targeting pack
      6. .NET Framework 4.5.2 targeting pack
      7. .NET Framework 4.6 targeting pack
      8. .NET Framework 4.6.1 targeting pack
      9. .NET Framework 4.7.2 targeting pack
      10. .NET Framework 4.8 SDK
      11. .NET Framework 4.8 targeting pack
      12. .NET SDK
      13. ML.NET Model Builder (Preview)
    2. Облако, база данных и сервер
      1. CLR data types for SQL Server
      2. Connectivity and publishing tools
    3. Инструменты кода
      1. NuGet package manager
      2. Text Template Transformation
    4. Компиляторы, инструменты сборки и среды выполнения
      1. .NET Compiler Platform SDK
      2. C# and Visual Basic Roslyn compilers
      3. C++ 2019 Redistributable Update
      4. C++ CMake tools for Windows
      5. C++/CLI support for v142 build tools (Latest)
      6. MSBuild
      7. MSVC v142 - VS 2019 C++ ARM64 build tools (Latest)
      8. MSVC v142 - VS 2019 C++ ARM64 Spectre-mitigated libs (Latest)
      9. MSVC v142 - VS 2019 C++ x64/x86 build tools (Latest)
      10. MSVC v142 - VS 2019 C++ x64/x86 Spectre-mitigated libs (Latest)
    5. Отладка и тестирование
      1. .NET profiling tools
      2. C++ AddressSanatizer
      3. C++ profiling tools
      4. Just-In-Time debugger
      5. Test Adapter for Boost.Test
      6. Test Adapter for Google Test
    6. Средства разработки
      1. C# and Visual Basic
      2. C++ core features
      3. F# language support
      4. IntelliCode
      5. JavaScript and TypeScript language support
      6. Live Share
    7. Эмуляторы
        НЕТ
    8. Игры и графика
      1. Graphics debugger and GPU profiler for DirectX
    9. SDK, библиотеки и фреймворки
      1. C++ ATL for latest v142 build tools (ARM64)
      2. C++ ATL for latest v142 build tools (x86 & x64)
      3. C++ ATL for latest v142 build tools with Spectre Mitigations (ARM64)
      4. C++ ATL for latest v142 build tools with Spectre Mitigations (x86 & x64)
      5. C++ MFC for latest v142 build tools (ARM64)
      6. C++ MFC for latest v142 build tools (x86 & x64)
      7. C++ MFC for latest v142 build tools with Spectre Mitigations (ARM64)
      8. C++ MFC for latest v142 build tools with Spectre Mitigations (x86 & x64)
      9. Entity Framework 6 tools
      10. TypeScript 4.3 SDK
      11. Windows 10 SDK (10.0.19041.0)
      12. Windows Universal C Runtime

Установка Windows Driver Kit 2004

  1. Загрузите Windows Driver Kit (WDK) 2004 отсюда:
    https://docs.microsoft.com/en-us/windows-hardware/drivers/other-wdk-downloads
  2. Запустите загруженный файл от имени администратора и установите WDK с настройками по умолчанию.
  3. В конце установки вас спросят, нужно ли установить расширение Windows Driver Kit Visual Studio.
    Перед закрытием диалогового окна убедитесь, что эта опция включена.
  4. Автоматически запустится другая установка и определит пакет Visual Studio Professional 2019 как цель для расширения.
    Выберите его и продолжите установку.

Установка средств сборки Visual Studio

  1. Посетите следующий сайт Microsoft и войдите в систему с помощью бесплатной учётной записи Microsoft:
    https://my.visualstudio.com/Downloads?q=visual%20studio%202019%20build%20tools
  2. Загрузите новейшую версию "Build Tools for Visual Studio 2019".
  3. Запустите загруженный файл от имени администратора и следуйте указаниям мастера. Выберите для установки следующие отдельные компоненты:
    1. .NET
        НЕТ
    2. Облако, база данных и сервер
        НЕТ
    3. Инструменты кода
        НЕТ
    4. Компиляторы, инструменты сборки и среды выполнения
      1. C++/CLI support for v142 build tools (Latest)
      2. MSVC v142 - VS 2019 C++ ARM64 build tools (Latest)
      3. MSVC v142 - VS 2019 C++ ARM64 Spectre-mitigated libs (Latest)
      4. MSVC v142 - VS 2019 C++ x64/x86 build tools (Latest)
      5. MSVC v142 - VS 2019 C++ x64/x86 Spectre-mitigated libs (Latest)
    5. Отладка и тестирование
        НЕТ
    6. Средства разработки
        НЕТ
    7. SDK, библиотеки и фреймворки
      1. C++ ATL for latest v142 build tools (ARM64)
      2. C++ ATL for latest v142 build tools (x86 & x64)
      3. C++ ATL for latest v142 build tools with Spectre Mitigations (ARM64)
      4. C++ ATL for latest v142 build tools with Spectre Mitigations (x86 & x64)

Загрузка исходных файлов VeraCrypt

  1. Посетите репозитарий VeraCrypt на Github:
    https://github.com/veracrypt/VeraCrypt
  2. Нажмите зелёную кнопку с надписью "Code" и скачайте код.
    Загрузить репозиторий можно в виде zip-архива, но вы, возможно, предпочтёте использовать протокол git для отслеживания изменений.

Компиляция Win32/x64-версий VeraCrypt

  1. Откройте файл "src/VeraCrypt.sln" в Visual Studio 2010.
  2. Выберите "All|Win32" как активную конфигурацию.
  3. Нажмите "Build -> Build Solution".
  4. Процесс компиляции должен завершиться с предупреждениями, но без ошибок. Некоторые проекты следует пропустить.
  5. Выберите "All|x64" как активную конфигурацию.
  6. Нажмите "Build -> Build Solution".
  7. Процесс компиляции должен завершиться с предупреждениями, но без ошибок. Некоторые проекты следует пропустить.
    Закройте Visual Studio 2010 после завершения процесса компиляции.

Компиляция ARM64-версии VeraCrypt

  1. Откройте файл "src/VeraCrypt_vs2019.sln" в Visual Studio 2019.
  2. Выберите "All|ARM64" как активную конфигурацию.
  3. Нажмите "Build -> Build Solution".
  4. Процесс компиляции должен завершиться с предупреждениями, но без ошибок. Один проект следует пропустить.
    Закройте Visual Studio 2019 после завершения процесса компиляции.

Сборка исполняемых файлов VeraCrypt

  1. Откройте командную строку от имени администратора.
  2. Перейдите в папку "src/Signing/".
  3. Запустите скрипт "sign_test.bat".
  4. Сгенерированные исполняемые файлы будут в папке "src/Release/Setup Files".

Импорт сертификатов

С помощью скрипта sign_test.bat вы только что подписали исполняемые файлы VeraCrypt. Это необходимо, поскольку Windows принимает только те драйверы, которым доверяет подписанный центр сертификации.
Поскольку вы использовали не официальный сертификат подписи VeraCrypt для подписи своего кода, а общедоступную версию для разработки, вы должны импортировать и, следовательно, доверять используемым сертификатам.

  1. Откройте папку "src/Signing".
  2. Импортируйте следующие сертификаты в хранилище сертификатов локального компьютера, дважды щёлкнув по ним:
    • GlobalSign_R3Cross.cer
    • GlobalSign_SHA256_EV_CodeSigning_CA.cer
    • TestCertificates/idrix_codeSign.pfx
    • TestCertificates/idrix_Sha256CodeSign.pfx
    • TestCertificates/idrix_SHA256TestRootCA.crt
    • TestCertificates/idrix_TestRootCA.crt

Известные проблемы

  • Этот дистрибутив повреждён.

    В Windows 10 или более новой версии возможно появление указанного выше сообщения об ошибке. Чтобы этого избежать, необходимо сделать следующее:
    • Перепроверьте установку корневого сертификата, выдавшего сертификат подписи тестового кода, в хранилище доверенных корневых центров сертификации локальной машины ("Local Machine Trusted Root Certification Authorities").
    • Вычислите отпечаток SHA512 сертификата подписи тестового кода и соответствующим образом обновите массив gpbSha512CodeSignCertFingerprint в файле "src/Common/Dlgcode.c".
    См. подробности тут: https://sourceforge.net/p/veracrypt/discussion/technical/thread/83d5a2d6e8/#db12.

    Другой подход – отключить проверку подписи в коде VeraCrypt. Это следует делать только в целях тестирования, но не для нормального использования:
    1. Откройте файл "src/Common/Dlgcode.c".
    2. Найдите функцию "VerifyModuleSignature".
    3. Замените следующие строки:
      Найти:

      if (!IsOSAtLeast (WIN_10))
      return TRUE;

      Заменить на:

      return TRUE;

    4. Снова скомпилируйте код VeraCrypt.
  • Ошибка сертификата.

    Windows проверяет подпись каждого устанавливаемого драйвера.
    Из соображений безопасности Windows позволяет загружать только драйверы, подписанные Microsoft.
    Поэтому при использовании пользовательской сборки:
    • Если вы не изменяли исходный код драйвера VeraCrypt, то можете использовать подписанные Microsoft драйверы, включённые в исходный код VeraCrypt (в "src\Release\Setup Files").
    • Если вы внесли изменения, то нужно будет загрузить Windows в "тестовом режиме" ("Test Mode"). Этот режим позволяет Windows загружать драйверы, не подписанные Microsoft. Однако даже в "тестовом режиме" существуют определённые требования к подписям, и сбои всё равно могут возникать по описанным ниже причинам.
    Возможные причины сбоя установки в "тестовом режиме" ("Test Mode"):
    1. Используемый для подписи сертификат не является доверенным для Windows.
      Чтобы проверить, относится ли это к вам, проверьте свойства исполняемого файла:
      1. Щёлкните правой кнопкой мыши по исполняемому файлу VeraCrypt Setup: "src/Release/Setup Files/VeraCrypt Setup 1.XX.exe".
      2. Выберите Свойства.
      3. Сверху выберите вкладку "Цифровые подписи". Здесь вы увидите две подписи.
        4. Проверьте обе, дважды щёлкая по ним. Если в заголовке написано "Подпись сертификата не может быть проверена", то соответствующий сертификат подписи не был правильно импортирован.
        Нажмите кнопку "Просмотр сертификата", а затем "Установить сертификат...", чтобы импортировать сертификат в хранилище сертификатов.

    2. Драйвер был изменён после подписания.
      В этом случае воспользуйтесь скриптом "src/Signing/sign_test.bat", чтобы снова подписать ваш код тестовыми сертификатами.


Документация >> Технические подробности >> Сборка VeraCrypt из исходного кода >> Руководство по сборке в Linux

В этом руководстве описано, как настроить систему Linux для сборки программы VeraCrypt из исходных кодов и как выполнить компиляцию.
Здесь как пример приведена процедура для Ubuntu 22.04 LTS, процедуры для других версий Linux аналогичны.

Для компиляции VeraCrypt необходимы следующие компоненты:
  1. GNU Make
  2. GNU C/C++ Compiler
  3. YASM 1.3.0
  4. pkg-config
  5. Общая библиотека wxWidgets 3.x и заголовочные файлы, установленные системой, либо исходный код библиотеки wxWidgets 3.x
  6. Библиотека FUSE и заголовочные файлы
  7. Библиотека PCSC-lite и заголовочные файлы

Ниже приведены шаги процедуры. Нажав на любую ссылку, вы сразу перейдёте к соответствующему шагу:

  • Установка GNU Make
  • Установка GNU C/C++ Compiler
  • Установка YASM
  • Установка pkg-config
  • Установка wxWidgets 3.2
  • Установка libfuse
  • Установка libpcsclite
  • Загрузка VeraCrypt
  • Компиляция VeraCrypt

Их также можно выполнить, запустив приведённый ниже список команд в терминале или скопировав их в скрипт:
sudo apt update
sudo apt install -y build-essential yasm pkg-config libwxgtk3.0-gtk3-dev
sudo apt install -y libfuse-dev git libpcsclite-dev
git clone https://github.com/veracrypt/VeraCrypt.git
cd ~/VeraCrypt/src
make

Установка GNU Make

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install build-essential

Установка GNU C/C++ Compiler

Если build-essential уже был установлен на предыдущем шаге, этот шаг можно пропустить.

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install build-essential

Установка YASM

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install yasm

Установка pkg-config

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install pkg-config

Установка wxWidgets 3.2

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install libwxgtk3.0-gtk3-dev

Установка libfuse

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install libfuse-dev

Установка libpcsclite

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install libpcsclite-dev

Загрузка VeraCrypt

  1. Откройте терминал.
  2. Выполните следующие команды:
    sudo apt update
    sudo apt install git
    git clone https://github.com/veracrypt/VeraCrypt.git

Компиляция VeraCrypt

Примечания:

  • По умолчанию создаётся универсальный исполняемый файл, поддерживающий как графический, так и текстовый пользовательский интерфейс (через ключ --text).
    В Linux исполняемый файл только для консоли, для которого не требуется библиотека графического интерфейса, может быть создан с использованием параметра "NOGUI".
    Для этого нужно загрузить исходники wxWidgets, извлечь их в любое место по вашему выбору, а затем выполнить следующие команды:
    make NOGUI=1 WXSTATIC=1 WX_ROOT=/path/to/wxWidgetsSources wxbuild
    make NOGUI=1 WXSTATIC=1 WX_ROOT=/path/to/wxWidgetsSources
  • Если вы не используете системную библиотеку wxWidgets, то придётся загрузить и использовать исходники wxWidgets, как указано выше, но на этот раз необходимо выполнить следующие команды для сборки версии VeraCrypt с графическим интерфейсом (NOGUI не указан):
    make WXSTATIC=1 WX_ROOT=/path/to/wxWidgetsSources wxbuild
    make WXSTATIC=1 WX_ROOT=/path/to/wxWidgetsSources
Шаги:
  1. Откройте терминал.
  2. Выполните следующие команды:
    cd ~/VeraCrypt/src
    make
  3. Если всё прошло нормально, исполняемый файл VeraCrypt должен находиться в каталоге "Main".


Документация >> Связь с авторами

Связь с авторами

Вы можете связаться с нами, отправив письмо на адрес veracrypt-contact [собачка] lists [точка] sourceforge [точка] net
Также вы можете использовать адрес veracrypt [собачка] amcrypto [точка] jp, который связан с ключом PGP команды VeraCrypt.
Для непосредственной связи с AM Crypto можно воспользоваться нашей контактной формой.

Кроме того, мы есть в соцсетях:
VeraCrypt on Twitter VeraCrypt on Facebook VeraCrypt on Reddit

Свои замечания и предложения по переводу программы и документации на русский язык вы можете отправлять на адрес erodim [собачка] mail [точка] ru


Документация >> Правовая информация

Правовая информация

Лицензия

Текст лицензионного соглашения, в соответствии с которым распространяется VeraCrypt, содержится в файле License.txt, входящем в состав дистрибутивных пакетов с самой программой VeraCrypt и с её исходным кодом.

Подробности о лицензии можно узнать здесь.

Авторские права

На данное ПО в целом:

Copyright © 2025 AM Crypto. Все права защищены.

На части данного ПО:

Copyright © 2025 AM Crypto. Все права защищены.

Copyright © 2013-2025 IDRIX. Все права защищены.

Copyright © 2003-2012 TrueCrypt Developers Association. Все права защищены.

Copyright © 1998-2000 Paul Le Roux. Все права защищены.

Copyright © 1998-2008 Brian Gladman, Worcester, UK. Все права защищены.

Copyright © 1995-2023 Jean-loup Gailly и Mark Adler.

Copyright © 2016 Disk Cryptography Services for EFI (DCS), Алекс Колотников.

Copyright © 1999-2023 Dieter Baron и Thomas Klausner.

Copyright © 2013, Алексей Дегтярёв. Все права защищены.

Copyright © 1999-2016 Jack Lloyd. Все права защищены.

Copyright © 2013-2019 Stephan Mueller <smueller@chronox.de>

Copyright © 1999-2023 Игорь Павлов.

Дополнительную информацию см. в правовых примечаниях к частям исходного кода.

Торговые марки

Все упомянутые в этом документе торговые марки являются исключительной собственностью их соответствующих владельцев.


Документация >> История версий

История версий

Примечание для тех, кто создавал тома с помощью VeraCrypt версии 1.17 или более ранней:
Чтобы избежать намёков на то, что ваши тома (не) содержат скрытый том, или если вам необходимо правдоподобно отрицать наличие шифрования при использовании скрытых томов/ОС, вы должны создать заново как внешние, так и скрытые тома, включая шифрование системы и скрытую ОС, и удалить существующие тома, созданные версией VeraCrypt старее, чем 1.18a.

1.26.21 (17 мая 2025 года):

  • Все ОС:
    • Добавлена поддержка китайского алгоритма шифрования SM4 (системное шифрование пока не поддерживается).
    • Исправлена реализация хэш-функции Whirlpool для платформ с прямым порядком байтов (big-endian) (GH #1529).
    • В пользовательском интерфейсе "Dismount All" переименовано в "Unmount All". Новая комбинация клавиш: ALT+U вместо ALT+S.
    • Добавлена документация в формате CHM на китайском и русском языках (предоставлена сообществом).
    • Обновлены переводы.
  • Windows:
    • Библиотека libzip обновлена до версии 1.11.3.
  • Linux:
    • Добавлена поддержка формата распространения и использования AppImage.
    • Исправлено использование абсолютного пути к команде 'true' при проверке активности sudo-сессии.
    • Исправлена ошибка, препятствующая использованию венгерских переводов.
    • Улучшены универсальные установочные скрипты (GH #1514).
    • Добавлена поддержка /run/media/veracrypt в качестве префикса монтирования по умолчанию, если /media недоступен (GH #1524).
    • Удалена зависимость от pcsclite в .deb и .rpm-пакетах, так как библиотека теперь обнаруживается и загружается динамически во время выполнения.
  • macOS:
    • Исправлено использование абсолютного пути к команде 'true' при проверке активности sudo-сессии.
    • Исправлена ошибка, препятствующая использованию венгерских переводов.

1.26.20 (3 февраля 2025 года):

  • Все ОС:
    • Ускорено вычисление SHA-256 на платформах ARM64 с помощью инструкций процессора.
    • Обновлены переводы.
    • Во всём интерфейсе и документации (на английском языке) термин "Dismount" заменён на "Unmount" для соответствия ИТ-стандартам.
  • Windows:
    • Устранена регрессия в драйвере, приводившая к постоянному разрешению дефрагментации и вызывавшая другие побочные эффекты.
    • Восстановлен предыдущий метод сбора системной энтропии из-за сообщений пользователей о проблемах со стабильностью.
  • Linux:
    • Исправлена регрессия в Linux Mint, влияющая на аутентификацию администратора по паролю (GH #1473).
      • /usr/bin/true теперь используется вместо /usr/bin/uptime для определения активных sudo-сессий.
      • Если в файле sudoers для veracrypt используется правило NOPASSWD с uptime, его следует заменить на /usr/bin/true.
  • macOS:
    • Исправлена регрессия, из-за которой было невозможно размонтировать тома (GH #1467).
    • Исправлена ошибка утверждения wxWidgets 3.2.6, связанная с неопределённым параметром use-dummy-sudo-password (GH #1470).

1.26.18 (20 января 2025 года):

  • Все ОС:
    • Добавлена поддержка встроенного интерфейса SHA-256 x86 для ускорения PBKDF2-HMAC-SHA256.
    • Добавлена поддержка аппаратного шифрования AES на платформах ARM64 (например, Windows ARM64, macOS на компьютерах с процессорами Apple Silicon Mx).
    • Обновлены переводы.
  • Windows:
    • Прекращена поддержка 32-разрядных версий Windows.
    • Минимально поддерживаемая версия Windows 10 – обновление от октября 2018 года (версия 1809).
    • Уменьшена вероятность взаимоблокировок драйверов при нехватке памяти из-за повторных завершений IRP.
    • Исправлено определение EFI на некоторых компьютерах, где не определена переменная BootOrder (предложено @kriegste, GH #360).
    • Исправлена ошибка отказа в доступе при обновлении VeraCrypt с помощью EXE-установщика после обновления Windows.
    • Исправлены различные проблемы, влияющие на редактор конфигурации шифрования EFI-системы.
    • Исправлена регрессия при создании Переносного (Traveler) диска (GH #886).
    • Теперь для генерации безопасных случайных данных вместо устаревшего CryptGenRandom применяется BCryptGenRandom.
    • Сбор системной энтропии для генерации случайных данных выполняется с помощью современного API вместо устаревших способов.
    • LZMA SDK обновлён до версии 24.09.
    • Библиотека libzip обновлена до версии 1.11.2.
  • Linux:
    • CVE-2024-54187: Добавлены абсолютные пути при выполнении системных двоичных файлов для предотвращения перехвата пути (сотрудничество с SivertPL @__tfr).
    • CVE-2025-23021: Запрещено монтирование томов к системным каталогам и пути к ним (сообщил SivertPL @__tfr).
    • Исправлена ошибка утверждения во включённой в Ubuntu библиотеке wxWidgets.
    • Улучшена логика открытия каталогов: теперь в первую очередь используется xdg-open с добавлением резервных механизмов.
    • Перед началом монтирования проверяется, что том существует.
    • Исправлено сообщение об ошибке "Слишком длинный Пароль", не расширенное до максимальной длины (GH #1456).
    • Упрощена логика обнаружения сеанса sudo.
  • macOS:
    • CVE-2024-54187: Добавлены абсолютные пути при выполнении системных двоичных файлов для предотвращения перехвата пути (сотрудничество с SivertPL @__tfr).
    • CVE-2025-23021: Запрещено монтирование томов к системным каталогам и пути к ним (сообщил SivertPL @__tfr).
    • Захват экрана по умолчанию отключён. Если вам требуется эта функция, используйте ключ --allow-screencapture в командной строке.
    • Перед началом монтирования проверяется, что том существует.
    • Реализована логика обнаружения сеанса sudo.

1.26.15 (2 сентября 2024 года):

  • Windows:
    • Устранены проблемы с установкой/удалением MSI:
      • Исправлена ошибка 1603, возвращаемая автоматической установкой MSI, если указан параметр REBOOT=ReallySuppress и требуется перезагрузка.
      • Добавлены отсутствующие файлы документации и языков из пакета MSI.
      • Исправлена ошибка, из-за которой MSI не устанавливал новую документацию и языковые файлы при обновлении с установки на основе EXE.
      • Исправлена ошибка, из-за которой в некоторых случаях не удалялась установочная папка после удаления MSI.
    • Исправлена регрессия при расшифровке системы UEFI, из-за которой сохранялся загрузчик.

1.26.14 (25 августа 2024 года):

  • Все ОС:
    • Обновлены переводы и документация.
    • Реализован выбор языка в версиях для операционных систем, отличных от Windows.
    • Обеспечена совместимость кодовой базы с wxWidgets 3.3 в версиях для операционных систем, отличных от Windows.
    • Реализовано обнаружение томов, затронутых уязвимостью главного ключа XTS, и предупреждение пользователя об этой уязвимости.
    • Обновлены сообщения об ошибках при монтировании с упоминанием удаления поддержки TrueCrypt и старых алгоритмов.
  • Windows:
    • Улучшено исправление проблем с безопасным рабочим столом в Windows 11 22H2.
      • На безопасном рабочем столе компонент IME теперь отключён, так как известно, что он вызывает проблемы.
    • VeraCrypt Expander: Исправлено расширение томов на дисках с размером сектора, отличным от 512 байтов (от skl0n6).
    • Исправлена запись неправильных дополнительных параметров шифрования системы EFI в реестр.
    • Не закрывается программа установки при выходе из процесса VeraCrypt через меню выхода на панели задач.
    • Исправлена ошибка форматирования некоторых дисков (например, VHDX), вызванная смещением виртуального раздела, не выровненным по 4K.
    • Возврат к абсолютному позиционированию при доступе к дискам в случае сбоя относительного позиционирования.
    • Библиотека zlib обновлена до версии 1.3.1.
  • Linux:
    • Фокусировка на поле PIM при выборе (#1239).
    • Исправлен общий сценарий установки в Konsole в Wayland (#1244).
    • Добавлена возможность сборки с использованием wolfCrypt в качестве криптографического бэкенда. По умолчанию отключено. (Разработано командой wolfSSL, GH PR #1227).
    • Разрешено запускать GUI в среде только с Wayland (GH #1264).
    • CLI: Если PIM уже был указан, то повторно он не запрашивается (GH #1288).
    • CLI: Исправлен неверный максимальный размер скрытого тома для файловых контейнеров (GH #1338).
    • Повышена безопасность ASLR для универсальных установочных бинарных файлов путём добавления связанного флага для старой версии GCC. (Сообщено @morton-f на SourceForge).
  • macOS:
    • Исправлено повреждение значка диска на главном экране программы (GH #1218).
    • Исправлена почти нулевая ширина поля ввода PIM и упрощена логика wxTextValidator (GH #1274).
    • Использование корректного расположения Disk Utility при проверке файловой системы (GH #1273).
    • Добавлена поддержка FUSE-T в качестве альтернативы MacFUSE (GH #1055).
  • FreeBSD:
    • Исправлена ошибка, из-за которой не отображались запросы на повышение привилегий (GH #1349).
    • Поддержка автоматического обнаружения и монтирования файловых систем ext2/3/4, exFAT, NTFS (GH #1350).
    • Использование корректного расположения Disk Utility при проверке файловой системы (GH #1273).

1.26.7 (1 октября 2023 года):

  • Все операционные системы:
    • Безопасность: при создании томов добавлена проверка, гарантирующая, что первичный ключ XTS отличается от вторичного.
      • Проблема маловероятна благодаря свойствам генератора случайных чисел, но эту проверку необходимо было добавить для предотвращения атак.
      • Ссылка: комментарий CCSS,NSA на стр. 3 в этом документе: https://csrc.nist.gov/csrc/media/Projects/crypto-publication-review-project/documents/initial-comments/sp800-38e-initial-public-comments-2021.pdf
    • Удалён режим совместимости с TrueCrypt. Для монтирования или преобразования томов TrueCrypt можно использовать версию 1.25.9.
    • Полностью удалены алгоритмы RIPEMD160 и GOST89. Тома, использующие любой из них, больше нельзя монтировать в VeraCrypt.
    • Добавлена поддержка нового PRF-алгоритма (псевдослучайной функции) BLAKE2s для шифрования как системных дисков, так и обычных томов.
    • В качестве ключевых файлов для несистемных томов можно использовать банковские карты стандарта EMV.
      • Нет необходимости настраивать отдельный модуль PKCS#11.
      • Не требуется PIN-код карты.
      • Для безопасного генерирования содержимого ключевого файла используются уникальные закодированные данные, имеющиеся на банковской карте.
      • Поддерживаются все банковские карты, соответствующие стандарту EMV.
      • Поддержку EMV нужно включить в настройках программы (меню Настройки->Токены безопасности).
      • Разработано командой студентов из Institut national des sciences appliquées de Rennes (Национального института прикладных наук Ренна).
      • Репозитарий проекта на Github: https://github.com/veracrypt-EMV-INSA-Rennes-4INFO/VeraCrypt_EMV
    • Полностью удалены алгоритмы RIPEMD160 и GOST89 (ГОСТ 28147-89). Устаревшие тома, использующие любой из них, больше не могут быть смонтированы в VeraCrypt.
    • Добавлена поддержка корсиканского языка. Обновлено несколько переводов.
    • Обновлена документация.
  • Windows:
    • Официально минимальная поддерживаемая версия теперь – Windows 10. VeraCrypt всё ещё может работать в Windows 7 и Windows 8/8.1, но активные тесты на этих платформах не проводятся.
    • Загрузчик EFI:
      • Исправлена ошибка в обработке значения PasswordTimeout, из-за которой оно ограничивалось 255 секундами.
      • Rescue Disk: если на диске отсутствует исходный загрузчик Windows, то загрузка выполняется из его встроенной резервной копии.
      • Добавлена хеш-функция BLAKE2s, удалены хеш-функция RIPEMD160 и алгоритм шифрования GOST89.
    • По умолчанию включена защита памяти. Чтобы отключить/включить защиту, выберите меню "Настройки > Производительность и драйвер".
      • Защита памяти блокирует чтение памяти VeraCrypt процессами без прав администратора.
      • Защита может блокировать чтение пользовательского интерфейса VeraCrypt программами чтения с экрана (поддержка специальных возможностей), в этом случае её следует отключить.
      • Защиту можно отключить, установив в реестре значение "VeraCryptEnableMemoryProtection" в 0 в ключе "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\veracrypt".
    • Добавлена защита от подстановки кода в память VeraCrypt другими процессами.
    • Незначительные улучшения в реализации шифрования оперативной памяти.
    • Исправлены проблемы с безопасным рабочим столом в Windows 11 22H2.
    • Реализована поддержка монтирования частично зашифрованных системных разделов.
    • Исправлено ложное обнаружение вставки нового устройства, когда включена опция очистки ключей шифрования (только в случае системного шифрования).
    • Улучшена реализация быстрого создания файловых контейнеров, использующих UAC для запроса необходимых привилегий, если они ещё не предоставлены.
    • При создании файловых контейнеров разрешён выбор быстрого создания в интерфейсе мастера форматирования.
    • Исправлены проблемы с форматированием при создании тома на некоторых машинах.
    • Исправлена проблема с зависанием при быстром форматировании больших файловых контейнеров.
    • Добавлено выпадающее меню к кнопке Смонтировать, позволяющее выполнять монтирование без кэша.
    • Решена проблема нарастающего замедления шифрования на месте на больших томах.
    • Расширитель томов (Expander) сначала проверяет наличие файла, прежде чем продолжить.
    • Возможен выбор единицы размера (байты/КиБ/МиБ/ГиБ) для генерируемых ключевых файлов.
    • При создании томов отображается полный список поддерживаемых размеров кластеров для файловых систем NTFS, ReFS и exFAT.
    • Добавлена поддержка перетаскивания файлов и ключевых файлов в Расширителе томов (Expander).
    • Реализован перевод интерфейса Расширителя томов (Expander).
    • Заменён устаревший API выбора файла/папки на современный интерфейс IFileDialog для лучшей совместимости с Windows 11.
    • Улучшения в безопасной загрузке библиотек зависимостей, включая задержку загрузки.
    • Удалена рекомендация по расширениям ключевых файлов, а в документации указаны риски применения сторонних расширений файлов.
    • Добавлена поддержка дополнительных языков в программе установки.
    • Обновлена библиотека LZMA до версии 23.01.
    • Обновлены библиотеки libzip до версии 1.10.1 и zlib до версии 1.3.
  • Linux:
    • Исправлена ошибка в генераторе случайных чисел в Linux при использовании с BLAKE2s, которая вызывала сбой самопроверки.
    • Изменён генератор случайных чисел в Linux, чтобы он точно соответствовал официальной документации и реализации в Windows.
    • Исправлены проблемы совместимости с Ubuntu 23.04.
    • Исправлены сообщения об утверждениях, отображаемые при использовании wxWidgets 3.1.6 и новее.
    • Исправлены проблемы с запуском fsck в Linux.
    • Исправлено игнорирование запросов на повышение привилегий.
    • Исправлен неправильный размер скрытого тома при выборе опции использования всего свободного места.
    • Исправлена при создании скрытого тома на диске с помощью CLI, вызванная неправильным определением максимального размера.
    • Исправлены различные проблемы при работе в текстовом режиме:
      • Запрет выбора файловых систем exFAT/BTRFS, если они отсутствуют или несовместимы с созданным томом.
      • Исправлено неправильное сообщение о размонтировании, отображаемое при монтировании тома.
      • Скрытие PIM при вводе и повторный запрос PIM при вводе неправильного значения.
      • Исправлена ошибка печати при проверке свободного места во время создания тома в несуществующем пути.
    • Для статических сборок (например только консольной версии) используется wxWidgets 3.2.2.1.
    • Исправлена совместимость универсальных установщиков со старыми дистрибутивами Linux.

1.25.9 (19 февраля 2022 года)

  • Все операционные системы:
    • Обновлены переводы (китайский, голландский, французский, немецкий, турецкий).
  • Windows:
    • MSI-установщик сделан совместимым с системным шифрованием.
    • Для MSI-установки требуется Windows 7 или более новая версия Windows.
    • Исправлена ошибка при создании Переносного диска, если программа VeraCrypt установлена с помощью MSI.
    • Пароль внешнего тома не кэшируется при монтировании с включённой защитой скрытого тома, если был указан неправильный пароль скрытого тома.
    • Благодаря использованию сжатия LZMA вместо DEFLATE размер EXE-установщиков уменьшен почти на 50%.
    • Исправлена ошибка, из-за которой в некоторых особых конфигурациях Windows не работал двойной щелчок по смонтированному диску в интерфейсе VeraCrypt.
    • Добавлен раздел реестра для исправления ошибки BSOD при выключении/перезагрузке на некоторых компьютерах, использующих шифрование системы.
      • В ветви HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\veracrypt создайте параметр REG_DWORD с именем VeraCryptEraseKeysShutdown.
      • Если у этого параметра установить значение 0, то будет отключено удаление ключей шифрования системы, что является причиной появления "синего экрана" BSOD во время выключения на некоторых компьютерах.
  • Linux:
    • Исправлено некорректное отображение настроек скрытого тома при включении защиты скрытого тома в окне параметров монтирования.
    • Исправлена ошибка перезаписи /usr/sbin общего установщика Linux, если это символическая ссылка.
    • Устранён сбой при сборке с определёнными _GLIBCXX_ASSERTIONS.
    • Разрешена сборка из исходного кода без поддержки AES-NI.
  • Mac OS X:
    • Исправлено некорректное отображение настроек скрытого тома при включении защиты скрытого тома в окне параметров монтирования.

1.25.7 (7 января 2022 года)

  • Все операционные системы:
    • Обновлены переводы.
  • Windows:
    • Возвращена поддержка Windows Vista, Windows 7 и Windows 8/8.1.
      • Поддержка Windows 7 требует, чтобы было установлено либо обновление KB3033929, либо KB4474419.
      • Поддержка Windows Vista требует, чтобы было установлено либо обновление KB4039648, либо KB4474419.
    • Только при MSI-установке: исправлена ошибка, при которой двойной щелчок по файлу-контейнеру .hc вставлял %1 вместо имени тома в поле пути.
    • Для опытных пользователей добавлены параметры в реестре, управляющие внутренней очередью шифрования драйвера, что позволяет настроить производительность SSD-дисков и повысить стабильность при большой нагрузке.
      • Параметры в ключе реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\veracrypt:
        • VeraCryptEncryptionFragmentSize (REG_DWORD): размер фрагмента зашифрованных данных в кибибайтах (КиБ). По умолчанию – 256. Максимум – 2048.
        • VeraCryptEncryptionIoRequestCount (REG_DWORD): максимальное количество параллельных запросов ввода/вывода. По умолчанию – 16. Максимум – 8192.
        • VeraCryptEncryptionItemCount (REG_DWORD): максимальное количество элементов очереди шифрования, обрабатываемых параллельно. Значение по умолчанию, как и максимальное, равно половине значения VeraCryptEncryptionIoRequestCount.
      • Триплет (Fragmentsize=512, IoRequestCount=128, ItemCount=64) – пример параметров, которые повышают скорость последовательного чтения в некоторых системах с SSD NVMe.
      • Исправлено усечение текста в установщике для некоторых языков.
  • Mac OS X:
    • Исправлены файлы ресурсов внутри пакета приложений VeraCrypt (например, HTML-документация, языковые XML-файлы), доступные для записи во всем мире (сообщил Niall O'Reilly).

1.25.4 (3 декабря 2021 года)

  • Все операционные системы:
    • Ускорен Streebog.
    • Обновлены переводы.
  • Windows:
    • Добавлена поддержка Windows на ARM64 (например Microsoft Surface Pro X), но шифрование системы пока не поддерживается.
    • Добавлен MSI-установщик для развёртывания в автоматическом режиме (в командной строке msiexec должно быть установлено ACCEPTLICENSE=YES).
      • На данный момент MSI-установщик нельзя использовать, если системный раздел зашифрован с помощью VeraCrypt.
      • Для MSI-установщика требуется Windows 10 или новее.
    • Windows Vista, Windows 7, Windows 8 и Windows 8.1 больше не поддерживаются из-за нового требования к подписи кода драйвера.
    • Ускорено монтирование, если выбрано автоматическое определение PRF.
    • Исправлено потенциальное повреждение памяти в драйвере, вызванное переполнением целых чисел в IOCTL_STORAGE_MANAGE_DATA_SET_ATTRIBUTES (сообщил Ilja van Sprundel).
    • Замена небезопасных функций времени выполнения wcscpy/wcscat/strcpy безопасными эквивалентами.
    • Изменения в EFI-загрузчике:
      • Устранена возникавшая в некоторых случаях утечка памяти, вызванная неправильной проверкой указателя для вызова MEM_FREE.
      • При остановке системы из-за фатальной ошибки происходит очистка переменной bootParams, которая может содержать конфиденциальную информацию.
      • Добавлена опция "KeyboardInputDelay" в DcsProp для управления минимальной задержкой между двумя нажатиями клавиш.
    • Попытка обойти проблемы обновлений функций Windows с системным шифрованием путём исправления загрузчика и SetupConfig.ini при возобновлении работы системы или при открытии/разблокировке сеанса.
    • Исправлена ошибка при загрузке локальной HTML-документации, если приложение запущено с правами администратора.
    • Исправлена блокировка при отображении окна пароля на защищённом рабочем столе и попытке доступа к файлам ключей токенов, защищённых ПИН-кодом.
    • Исправлена ошибка при запуске генератора файлов ключей в режиме защищённого рабочего стола.
    • Блокировка Windows от изменения размера системного раздела, если он зашифрован.
    • Добавлено сочетание клавиш для опции "Режим TrueCrypt" в окне монтирования.
  • Mac OS X:
    • Встроенная поддержка Apple Silicon M1.
    • Операционные системы Mac OS X 10.7 Lion и Mac OS X 10.8 Mountain Lion больше официально не поддерживаются.
    • Добавлена поддержка многоязычности с помощью установленных XML-файлов. Язык автоматически определяется по переменной среды "LANG".
    • Добавлены ключ командной строки --size=max и опция в графическом интерфейсе, позволяющие предоставить файлу-контейнеру всё доступное свободное пространство на диске, на котором он создан.
    • Возвращается ошибка, если в командной строке в ключе --filesystem указана неизвестная файловая система. Ранее создание файловой системы молча пропускалось.
  • Linux:
    • Добавлена поддержка многоязычности с помощью установленных XML-файлов. Язык автоматически определяется по переменной среды "LANG".
    • Совместимость с pam_tmpdir.
    • Отображается значок в области уведомлений в Ubuntu 18.04 и новее (помощь от https://unit193.net/).
    • Добавлены ключ командной строки --size=max и опция в графическом интерфейсе, позволяющие предоставить файлу-контейнеру всё доступное свободное пространство на диске, на котором он создан.
    • Возвращается ошибка, если в командной строке в ключе --filesystem указана неизвестная файловая система. Ранее создание файловой системы молча пропускалось.
  • FreeBSD:
    • Системные устройства работают под FreeBSD.
    • Добавлены ключ командной строки --size=max и опция в графическом интерфейсе, позволяющие предоставить файлу-контейнеру всё доступное свободное пространство на диске, на котором он создан.
    • Возвращается ошибка, если в командной строке в ключе --filesystem указана неизвестная файловая система. Ранее создание файловой системы молча пропускалось.
  • OpenBSD:
    • Добавлена базовая поддержка OpenBSD.
    • Добавлены ключ командной строки --size=max и опция в графическом интерфейсе, позволяющие предоставить файлу-контейнеру всё доступное свободное пространство на диске, на котором он создан.
    • Возвращается ошибка, если в командной строке в ключе --filesystem указана неизвестная файловая система. Ранее создание файловой системы молча пропускалось.

1.24-Update8 (28 ноября 2020 года)

  • Mac OS X:
    • Исправлены проблемы совместимости с macOS Big Sur, особенно на Apple Silicon M1 с macFUSE 4.0.x.

1.24-Update7 (7 августа 2020 года)

  • Все операционные системы:
    • Не разрешается, чтобы у скрытого тома были те же пароль, PIM и ключевые файлы, что и у внешнего тома.
    • Исправлен случайный сбой в 32-разрядных сборках при использовании Streebog.
    • Включён режим FIPS в генераторе случайных чисел JitterEntropy.
    • Обновлено Руководство для начинающих в документации: для имени файла-контейнера вместо "My Volume" используется "MyVolume.hc", чтобы избежать путаницы в отношении природы файла.
    • Незначительная очистка кода.
  • Windows:
    • Исправлен вывод неправильных результатов в тесте алгоритмов шифрования при включённом шифровании ОЗУ.
    • Устранена проблема, когда использовалось шифрование ОЗУ, был выбран AES, а AES-NI не поддерживается процессором, что приводило к тому, что свободное пространство вновь созданных томов не заполнялось случайными данными, даже если не было выбрано быстрое форматирование.
    • Исправлен пользовательский интерфейс для блокировки TRIM в системном шифровании, не работающей в режиме загрузки MBR.
    • Поддержка перетаскивания пароля из внешних приложений (например, из KeePass) в поля пользовательского интерфейса пароля, что более безопасно, чем использование буфера обмена.
    • Добавлена совместимость с моделью электропитания Windows 10 Modern Standby и Windows 8.1 Connected Standby. Это делает более надёжным обнаружение входа в режим энергосбережения.
    • Не отображается окно ожидания, если для "VeraCrypt Format" указан ключ /silent при создании файла-контейнера с использованием ключа /create и файловой системы, отличной от FAT.
    • Для форматирования томов используется родная программа форматирования Windows, поскольку она более надёжна и в случае возникновения проблемы использует только функцию FormatEx из fmifs.dll.
    • Программа не использует API для поддержки групп процессоров, если в системе есть только одна группа процессоров. Это может исправить проблему замедления на некоторых ПК с процессорами AMD.
    • Запрет шифрования системного диска, если он уже зашифрован утилитой BitLocker.
    • Реализовано обнаружение гибернации и функции быстрого запуска и их отключение, если активировано шифрование ОЗУ.
    • Предупреждение о функции быстрого запуска, если она включена при установке/обновлении VeraCrypt, при запуске системного шифрования или при создании тома, и предложение её отключить.
    • Добавлены опции в графическом интерфейсе, управляющие поведением автоматического исправления загрузчика при использовании шифрования системы.
    • Запрещено вводить путь к папке для файла-контейнера, создаваемого в мастере форматирования.
    • Программа не пытается использовать исправление для CVE-2019-19501, если оболочка Windows была изменена или не запущена, так как нет надёжного способа исправить это в такой нестандартной конфигурации.
    • MBR-загрузчик: исправлен неправильный размер сжатых данных, передаваемых декомпрессору в загрузочном секторе.
    • Добавлено предупреждение, когда введённый пароль достигает максимальной длины во время работы мастера шифрования системы.
    • Исправлено неправильное сообщение об ошибке, когда кодировка UTF-8 вводимого пароля превышает максимально поддерживаемую длину.
    • Исправлен сбой при использовании переносимого 32-разрядного файла "VeraCrypt Format.exe" для создания скрытого тома на 64-разрядной машине, где VeraCrypt уже установлен.
    • Библиотека libzip обновлена до версии 1.7.3.
    • Обновлены переводы.
  • Linux/Mac OS X:
    • Принудительно считываются не менее 32 байтов из /dev/random, прежде чем позволить корректно завершиться ошибкой.
    • Для внешнего тома можно выбирать файловую систему, отличную от FAT, но отображается предупреждение о рисках такого выбора. В этом случае реализована оценка максимально возможного размера скрытого тома.
    • Явное стирание чувствительной памяти вместо того, чтобы полагаться на то, что компилятор не оптимизирует вызовы метода Memory::Erase.
    • Добавлена поддержка файловой системы Btrfs при создании томов (только Linux).
    • Обновлён wxWidgets для статических сборок до версии 3.0.5.

1.24-Update6 (10 марта 2020 года)

  • Windows:
    • Исправлено усечение текста метки PIM в окне пароля.
    • Исправлена ошибка, из-за которой программа установки использовала неправильный язык, если пользователь выбрал язык, отличный от английского, а затем выбрал английский, прежде чем нажать ОК в окне выбора языка.

1.24-Update5 (9 марта 2020 года)

  • Windows:
    • Оптимизирована производительность для ЦП с более чем 64 логическими процессорами (помог Sachin Keswani из AMD).
    • Поддержка указания ключевых файлов (как в токенах, так и в файловой системе) при создании файловых контейнеров с помощью командной строки (ключи /keyfile, /tokenlib и /tokenpin поддерживаются в VeraCrypt Format).
    • Исправлена утечка пути и имени файлов ключей после завершения процесса VeraCrypt.
    • В VeraCrypt Format добавлен ключ /secureDesktop для командной строки.
    • Библиотека libzip обновлена до версии 1.6.1.
    • Незначительные исправления пользовательского интерфейса.

1.24-Update4 (23 января 2020 года)

  • Windows:
    • Исправлена регрессия в VeraCryptExpander.exe и VeraCrypt Format.exe при включённом шифровании ОЗУ, которая приводила к повреждению заголовков томов.
    • Исправлена ошибка средств чтения с экрана (поддержка специальных возможностей) для чтения пользовательского интерфейса – отключена недавно введённая защита памяти по умолчанию и добавлен ключ /protectMemory в командной строке, позволяющий её включить, если это потребуется.
    • Исправлены побочные эффекты, связанные с исправлением для CVE-2019-19501, из-за которого не открывались ссылки в графическом интерфейсе.
    • Добавлен ключ /signalExit для поддержки уведомления Windows-команды WAITFOR при завершении работы VeraCrypt.exe, если в командной строке был указан ключ /q (см. документацию).
    • Не отображаются примеры монтирования/демонтирования в окне справки по командной строке у VeraCrypt Format.exe и VeraCryptExpander.exe.
    • Обновления документации и переводов.
  • Linux:
    • Исправлена регрессия, ограничивающая размер, доступный для скрытых томов, созданных на диске или разделе.
  • Mac OS X:
    • Исправлена регрессия, ограничивающая размер, доступный для скрытых томов, созданных на диске или разделе.

1.24-Update3 (21 декабря 2019 года)

  • Linux:
    • В сборке для консоли удалена зависимость от GTK, которая нежелательна на серверах без монитора, мыши и клавиатуры.

1.24-Update2 (16 декабря 2019 года)

  • Все операционные системы:
    • Ключ AES удаляется из стековой памяти при использовании неоптимизированной реализации. Не относится к официальной сборке VeraCrypt (сообщил и исправил Hanno Böck).
    • RNG-библиотека Jitterentropy обновлена до версии 2.2.0.
    • Используется согласованное с IEEE 1541 именование байтовых размеров (КиБ, МиБ, ГиБ, ТиБ, ПиБ).
    • Различные усовершенствования документации.
  • Windows:
    • Исправлена возможная уязвимость локального повышения привилегий при работе расширителя томов VeraCrypt Expander (CVE-2019-19501).
    • MBR-загрузчик:
      • Обходной путь проблемы с SSD-накопителями, не позволяющими выполнять операции записи в режиме BIOS с буферами менее 4096 байт.
      • MBR не восстанавливается до значения VeraCrypt, если оно поступает из загрузчика, отличного от нашего или от Microsoft.
    • EFI-загрузчик:
      • Исправлена ошибка, из-за которой не работало "Actionfailed", и добавлено "ActionCancelled", чтобы настроить обработку нажатия пользователем клавиши Esc при вводе пароля.
      • Исправлена ошибка, когда при нажатии F5 отображался предыдущий пароль после неудачной попытки аутентификации. Теперь гарантируется, что из памяти удаляется даже неверный пароль.
    • Исправлена проблема совместимости с загрузкой нескольких ОС путём установки VeraCrypt в качестве первого загрузчика системы, если текущий первый загрузчик – это загрузчик Windows.
    • Добавлены новые флаги реестра для SystemFavoritesService, управляющие обновлением загрузочного меню EFI BIOS при завершении работы.
    • Разрешено монтирование системного зашифрованного диска в WindowsPE, даже если не удаётся изменить раскладку клавиатуры (сообщил и исправил Sven Strickroth).
    • Усовершенствован механизм сохранения временных меток файлов, особенно для ключевых файлов.
    • Исправлена ошибка, из-за которой инструкция RDRAND не обнаруживалась на процессорах AMD.
    • Обнаруживается неисправность RDRAND (например, в AMD Ryzen), чтобы избежать его использования, если он включён пользователем.
    • При изменении через графический интерфейс в конец файла DcsProp не записывается дополнительный байт 0x00.
    • Уменьшено использование памяти обработчиком IOCTL_DISK_VERIFY, используемым при проверке дисков в Windows.
    • Добавлен ключ /FastCreateFile для VeraCrypt Format.exe, ускоряющий создание больших файлов-контейнеров, если выбрано быстрое форматирование.
    • Исправлена опция для пропуска проверки Диска восстановления, не отражающая значение ключа /noisocheck, указанного в командной строке VeraCrypt Format.
    • При монтировании файла-контейнера с расширением .tc, в окне пароля включается опция Режим TrueCrypt.
    • Обновлены языковые XML-файлы.
  • Linux:
    • Исправлена регрессия, из-за которой в некоторых случаях слишком много раз запрашивался пароль администратора.
    • Устранено переполнение буфера в функции Process::Execute (сообщил и исправил Hanno Böck).
    • Добавлена проверка, что пароль удалён в случае внутренней ошибки при монтировании тома (сообщил и исправил Hanno Böck).
    • Исправлена проблема с паролями, использующими юникодные символы, которые не распознаются в текстовом режиме.
    • Устранён сбой при запуске бинарного файла VeraCrypt, созданного для консольного режима, на компьютерах без монитора, клавиатуры и мыши.
    • Добавлен ключ для принудительного использования устаревшей максимальной длины пароля (64 байта UTF-8).
    • Добавлен ключ командной строки (--use-dummy-sudo-password) для принудительного использования старого поведения sudo при отправке фиктивного пароля.
    • При удалении сообщение об ошибке выводится в STDERR вместо STDOUT для лучшей совместимости с менеджерами пакетов.
    • Больше подробностей о несоответствии размера сектора при монтировании дисков.
    • Ускорение SHA256 в 64-разрядном режиме с помощью ассемблерного кода.
  • Mac OS X:
    • Добавлен ключ для принудительного использования устаревшей максимальной длины пароля (64 байта UTF-8).
    • Устранено переполнение буфера в функции Process::Execute (сообщил и исправил Hanno Böck).
    • Исправлена проблема с паролями, использующими юникодные символы, которые не распознаются в текстовом режиме.
    • Больше подробностей о несоответствии размера сектора при монтировании дисков.
    • Ускорение SHA256 в 64-разрядном режиме с помощью ассемблерного кода.
    • Ссылка на последнюю версию wxWidgets 3.1.3.

1.24-Hotfix1 (27 октября 2019 года)

  • Windows:
    • Исправлена регрессия версии 1.24, из-за которой избранное не монтировалось при загрузке системы, если VeraCrypt был только что установлен.
    • Исправлена ошибка шифрования системы, если текущее имя пользователя Windows содержало юникодный символ, отличный от ASCII.
    • VeraCrypt Expander получил возможность возобновлять расширение томов, предыдущее расширение которых было прервано до его завершения.
    • Добавлена опция Quick Expand (Быстрое расширение) в VeraCrypt Expander, чтобы ускорить расширение больших файлов-контейнеров.
    • Добавлено несколько проверок надёжности и корректности для шифрования системы, чтобы лучше справляться в ряде крайних случаев.
    • Небольшие изменения пользовательского интерфейса и документации.
  • Linux:
    • Обход ошибки gcc 4.4.7 в CentOS 6, которая приводила к сбою программы VeraCrypt, собранной в CentOS 6, при использовании хеша Whirlpool.
    • Исправлена ошибка "попытка ввода неверного пароля", записанная в /var/log/auth.log при монтировании томов.
    • Исправлена ошибка, из-за которой при перетаскивании файла в пользовательском интерфейсе не отображался его правильный путь, особенно в GTK-3.
    • Добавлена отсутствующая реализация JitterEntropy.
  • Mac OS X:
    • Исправлена ошибка, из-за которой некоторые устройства и разделы не отображались в окне выбора устройства в OS X 10.13 и новее.
    • Исправлена навигация с клавиатуры между полями пароля на странице Пароль тома мастера создания томов.
    • Добавлена отсутствующая реализация JitterEntropy.
    • Поддержка файловой системы APFS для создания томов.
    • Поддержка тёмного режима.

1.24 (6 октября 2019 года)

  • Все операционные системы:
    • Для несистемных томов максимальная длина пароля увеличена до 128 байт в кодировке UTF-8.
      • По соображениям совместимости добавлена возможность использовать устаревшую максимальную длину пароля (64 символа) вместо новой.
    • Используется аппаратный генератор случайных чисел, основанный на джиттере синхронизации ЦП "Jitterentropy" (автор Stephan Mueller), как хорошая альтернатива процессорного RDRAND (http://www.chronox.de/jent.html)
    • Оптимизация скорости режима XTS на 64-разрядных машинах с использованием SSE2 (до 10% быстрее).
    • Исправлено обнаружение функций AVX2/BMI2 в процессоре. Добавлено обнаружение функций RDRAND/RDSEED. Процессор Hygon определяется как AMD.
  • Windows:
    • Реализовано шифрование ключей и паролей в ОЗУ с использованием шифра ChaCha12, некриптографического быстрого хеширования t1ha и CSPRNG на основе ChaCha20.
      • Доступно только на 64-разрядных машинах.
      • По умолчанию отключено. Включается опцией в графическом интерфейсе.
      • На современных процессорах накладные расходы – менее 10%.
      • Побочный эффект: режим гибернации Windows невозможен, если также используется системное шифрование VeraCrypt.
    • Память приложений VeraCrypt недоступна для пользователей без прав администратора, благодаря чему смягчаются некоторые атаки на память (на основе реализации KeePassXC).
    • Новые функции безопасности:
      • Системные ключи шифрования стираются из памяти при выключении/перезагрузки, чтобы помочь смягчить некоторые атаки с "холодной" загрузкой.
      • Добавлена опция, стирающая все ключи шифрования из памяти при подключении нового устройства к системе, когда используется системное шифрование.
      • Добавлена новая точка входа драйвера, которая может быть вызвана приложениями для удаления ключей шифрования из памяти в случае чрезвычайной ситуации.
    • Загрузчик MBR: динамическое определение сегмента памяти загрузчика вместо жёстко заданных значений (предложено neos6464).
    • Загрузчик MBR: обходной путь для проблемы, влияющей на создание скрытой ОС на некоторых SSD-накопителях.
    • Устранена проблема, связанная с тем, что Центр обновления Windows повреждал UEFI-загрузчик VeraCrypt.
    • Несколько улучшений и исправлений для загрузчика EFI:
      • Реализован механизм истечения времени ожидания для ввода пароля. Ожидание по умолчанию – 3 минуты, действие по умолчанию – выключение.
      • Реализованы новые действия "shutdown" и "reboot" ("выключение" и "перезагрузка") для файла конфигурации EFI DcsProp.
      • Улучшена реализация Диска восстановления для восстановления загрузчика VeraCrypt.
      • Исправлена ошибка, когда нажатие Esc при запросе пароля во время пре-теста не запускало Windows.
      • На Диске восстановления добавлен пункт меню, позволяющий запускать исходный загрузчик Windows.
      • Устранена проблема, из-за которой хеш Streebog нельзя было выбрать вручную во время предзагрузочной аутентификации.
      • Если на Диске восстановления нет папки VeraCrypt, компьютер загружается непосредственно из загрузчика на жёстком диске.
        • Это позволяет легко создать загрузочный диск для VeraCrypt из Диска восстановления, просто удалив/переименовав его папку VeraCrypt.
    • Добавлена опция (по умолчанию отключена) для использования CPU RDRAND или RDSEED в качестве дополнительного источника энтропии для генератора случайных чисел VeraCrypt, если это возможно.
    • Добавлена опция монтирования (как в графическом интерфейсе, так и в командной строке), позволяющая монтировать том, не назначая ему указанную букву диска.
    • Библиотека libzip обновлена до версии 1.5.2.
    • Добавлен запрет создания ярлыка удаления в меню Пуск при установке VeraCrypt (от Sven Strickroth).
    • Разрешён выбор быстрого форматирования для создания файлов-контейнеров. Отдельные опции быстрого форматирования и динамического тома в пользовательском интерфейсе мастера.
    • Исправлен редактор файла конфигурации шифрования системы EFI, который не принимал клавишу Enter для добавления новых строк.
    • Программа избегает одновременных вызовов монтирования избранного, например, если соответствующая горячая клавиша нажата несколько раз.
    • Гарантируется, что создать безопасный рабочий стол может только один поток за раз.
    • Изменён размер некоторых окон в параметрах форматирования и монтирования, чтобы исправить ряд проблем с усечением текста на языках, отличных от английского.
    • Исправлена высокая загрузка ЦП при использовании избранного и добавлен ключ, запрещающий периодическую проверку устройств, чтобы снизить нагрузку на ЦП.
    • Небольшие изменения пользовательского интерфейса.
    • Обновления и исправления в переводах и документации.
  • Mac OS X:
    • Добавлена проверка размера файла-контейнера во время создания, чтобы убедиться, что он меньше доступного свободного места на диске. Добавлен ключ командной строки --no-size-check, запрещающий эту проверку.
  • Linux:
    • Добавлен ключ командной строки --import-token-keyfiles, совместимый с неинтерактивным режимом.
    • Добавлена проверка размера файла-контейнера во время создания, чтобы убедиться, что он меньше доступного свободного места на диске. Добавлен ключ командной строки --no-size-check, запрещающий эту проверку.

1.23-Hotfix-2 (8 октября 2018 года)

  • Windows:
    • Исправлена малоопасная уязвимость, унаследованная от TrueCrypt, которая позволяла считывать 3 байта памяти стека ядра (редко – 25 дополнительных байт).
      • Сообщил Tim Harrison.
    • Отключено быстрое форматирование при создании файлов-контейнеров из командной строки. Добавлен ключ /quick, чтобы включить его, если это необходимо.
    • Добавлен ключ /nosizecheck, отключающий проверку размера контейнера на наличие свободного места во время его создания.
      • Это позволяет обойти ошибку в распределённой файловой системе Microsoft DFS (Distributed File System).

1.23 (12 сентября 2018 года)

  • Windows:
    • VeraCrypt теперь совместим с конфигурацией EFI SecureBoot по умолчанию для системного шифрования.
    • Исправление проблем с шифрованием системы EFI на некоторых машинах (например на HP, Acer).
    • Поддержка системного шифрования EFI в Windows LTSB.
    • Добавлена совместимость шифрования системы с обновлением Windows 10 с помощью механизма ReflectDrivers.
    • EFI-диск восстановления правильно расшифровывает раздел, если его первый сектор был перезаписан программой восстановления Windows.
    • Добавлена опция драйвера в пользовательский интерфейс, чтобы явно разрешить дефрагментатору Windows 8.1 и Windows 10 видеть зашифрованные диски VeraCrypt.
    • Добавлена внутренняя проверка встроенной подписи двоичных файлов для защиты от некоторых типов атак.
    • Исправлена ошибка, из-за которой при некоторых обстоятельствах не работал безопасный рабочий стол для избранных томов, настроенных на монтирование при входе в Windows 10.
    • Когда включён безопасный рабочий стол, он используется для окна параметров монтирования, если оно отображается перед окном пароля.
    • При извлечении файлов в установочном или переносном режиме распаковываются zip-файлы docs.zip и Languages.zip, чтобы иметь готовую к использованию конфигурацию.
    • Если текст, вставленный в поле пароля, превышает максимальную длину, и потому будет усечён, то отображается предупреждающее сообщение.
    • Реализован механизм выбора языка в начале программы установки, чтобы упростить работу пользователям из разных стран.
    • Добавлена проверка размера файла-контейнера во время создания, чтобы убедиться, что он меньше доступного свободного места на диске.
    • Исправлены проблема, из-за которой не отображались кнопки внизу, если в Windows 7 пользователь установил большой системный шрифт.
    • Исправлены проблемы совместимости с некоторыми драйверами дисков, которые не поддерживают IOCTL_DISK_GET_DRIVE_GEOMETRY_EX ioctl.
  • Mac OS X:
    • Поддержка вставки значений в поля пароля с клавиатуры (сочетания клавиш CMD+V и CMD+A теперь работают правильно).
    • В окне параметров монтирования добавлена опция, чтобы при монтировании принудительно использовать встроенную резервную копию заголовка.
    • При резервном копировании заголовка тома программа автоматически пробует использовать встроенную резервную копию заголовка, если не удаётся использовать основной заголовок.
    • Реализован пользовательский интерфейс тестов алгоритмов хеширования и PKCS-5 PRF.
  • Linux:
    • Не разрешено закрывать окно ожидания до завершения соответствующей операции. Это исправляет сбой в Lubuntu 16.04.
    • В окне параметров монтирования добавлена опция, чтобы при монтировании принудительно использовать встроенную резервную копию заголовка.
    • При резервном копировании заголовка тома программа автоматически пробует использовать встроенную резервную копию заголовка, если не удаётся использовать основной заголовок.
    • Реализован пользовательский интерфейс тестов алгоритмов хеширования и PKCS-5 PRF.
    • Удалено ограничение защиты скрытых томов на диске с размером сектора более 512 байт.

1.22 (30 марта 2018 года)

  • Все операционные системы:
    • SIMD-оптимизация скорости для реализации шифра "Кузнечик" (ускорение до двух раз).
    • Добавлено пять новых каскадов алгоритмов шифрования: Camellia-Kuznyechik, Camellia-Serpent, Kuznyechik-AES, Kuznyechik-Serpent-Camellia и Kuznyechik-Twofish.
  • Windows:
    • Загрузчик MBR: исправлена ошибка при загрузке скрытой ОС на некоторых компьютерах.
    • Загрузчик MBR: уменьшена загрузка процессора при запросе пароля.
    • Улучшение безопасности: добавлена опция для блокировки команды TRIM для шифрования системы на твердотельных (SSD) накопителях.
    • Внедрена поддержка TRIM для несистемных твердотельных (SSD) накопителей и добавлена опция для её включения (для несистемных томов TRIM по умолчанию отключена).
    • Улучшено исправление проблем с "Неправильным параметром" во время шифрования системы EFI на некоторых компьютерах.
    • Драйвер: удалена ненужная зависимость от wcsstr, которая может вызвать проблемы на некоторых машинах.
    • Драйвер: исправлена ошибка "Неверный параметр" при монтировании томов на некоторых компьютерах.
    • Исправлена ошибка при монтировании на некоторых компьютерах системных избранных томов во время загрузки.
    • Исправлена ошибка, из-за которой текущее приложение теряет фокус при запуске VeraCrypt с ключами /quit /silent в командной строке.
    • Исправлены некоторые случаи зависания внешних приложений при монтирования/демонтировании.
    • Исправлены редкие случаи, когда не отображалось окно пароля на безопасном рабочем столе, что приводило к блокировке пользовательского интерфейса.
    • Обновлена библиотека libzip до версии 1.5.0, которая включает исправления некоторых проблем безопасности.
    • Расширена функция безопасного рабочего стола до окна ввода ПИН-кода смарт-карты.
    • Исправлено усечение текста лицензии в мастере установки.
    • Добавлен переносимый пакет, позволяющий извлекать двоичные файлы без запроса прав администратора.
    • Упрощение формата языковых XML-файлов.
    • Обходной путь для случаев, когда окно пароля не получает фокуса для ввода с клавиатуры, если не включён безопасный рабочий стол.
  • Linux:
    • Исправлена ошибка при установке версии с графическим интерфейсом в последних версиях KDE.
    • Исправлена ошибка утверждения wxWidgets при резервном копировании/восстановлении заголовка тома.
  • Mac OS X:
    • Устранена проблема, из-за которой некоторые локальные файлы справки не открывались в браузере.

1.21 (9 июля 2017 года)

  • Все операционные системы:
    • Исправлена регрессия в версии 1.20, приводившая к сбою при работе на процессоре, не поддерживающем расширенные функции.
  • Windows:
    • Исправлена регрессия в версии 1.20, из-за которой во время монтирования игнорировалось значение PIM, хранящееся в избранном.
    • Исправлена регрессия в версии 1.20, из-за которой в некоторых случаях не монтировались системные избранные тома.
    • Исправлены некоторые случаи ошибки "Неверный параметр" в мастере шифрования системы EFI.
    • Устанавливаются документы PDF, связанные с конфигурацией шифрования системы EFI для опытных пользователей:
      • disk_encryption_v1_2.pdf – скрытая EFI ОС и полнодисковое шифрование;
      • dcs_tpm_owner_02.pdf – конфигурация TPM для шифрования системы EFI.
  • FreeBSD:
    • Добавлена поддержка сборки на FreeBSD.

1.20 (29 июня 2017 года)

  • Все операционные системы:
    • Используется 64-разрядная оптимизированная реализация сборки Twofish и Camellia от Jussi Kivilinna.
      • Camellia работает в 2½ раза быстрее на процессорах, поддерживающих расширение системы команд AES-NI, и на 30% быстрее без такой поддержки.
    • Оптимизирована реализация SHA-512/SHA256.
      • 33%-ное ускорение на 64-разрядных системах.
    • Локальная документация развёртывается в формате HTML вместо Руководства пользователя в формате PDF.
    • Изменены ссылки в пользовательском интерфейсе со ссылок на Codeplex на ссылки, размещённые на veracrypt.fr.
    • Безопасность: сборка двоичных файлов с поддержкой рандомизации адресного пространства (ASLR).
  • Windows:
    • Несколько исправлений и модификаций для шифрования системы EFI:
      • Исправлена ошибка дешифрования системы EFI с помощью EFI-диска восстановления.
      • Добавлена ​​поддержка TPM 1.2 и TPM 2.0 (экспериментальная) с помощью низкоуровневой конфигурации DCS.
        • https://dc5.sourceforge.io/docs/dcs_tpm_owner_02.pdf
      • Добавлена поддержка полного шифрования диска EFI и скрытой ОС с помощью ручной процедуры (не отображается в пользовательском интерфейсе).
        • https://dc5.sourceforge.io/docs/disk_encryption_v1_2.pdf
    • Для ввода пароля можно использовать безопасный рабочий стол. Чтобы включить эту функцию, добавлена опция в настройках и ключ /secureDesktop в командной строке.
    • При монтировании нескольких избранных томов с кэшированием паролей используются параметры монтирования по умолчанию.
    • Разрешено указывать PRF и Режим TrueCrypt для избранного.
    • Предварительные изменения драйвера для поддержки функциональности скрытой ОС EFI.
    • Исправлена ошибка, из-за которой Streebog не распознавался командной строкой /hash.
    • Добавлена поддержка файловой системы ReFS в Windows 10 при создании обычных томов.
    • Исправлена высокая загрузка ЦП, когда избранное настроено на монтирование с помощью VolumeID при обнаружении.
    • Руководство пользователя предоставляется в формате CHM, а не в PDF.
    • Исправлено ложное предупреждение при шифровании системы EFI о том, что Windows не установлена на загрузочном диске.
    • Улучшения в обработке драйвером различных дисковых IOCTL.
    • Усовершенствования загрузчика EFI. Добавлена возможность вручную редактировать файл конфигурации EFI.
    • Безопасность драйвера: используется усиленная защита пула NX в Windows 8 и новее.
    • Снижено влияние на производительность внутренней проверки отключённых сетевых дисков.
    • Мелкие исправления.
  • Mac OS X:
    • Для запуска VeraCrypt требуется OS X 10.7 Lion или новее.
    • Программа VeraCrypt сделана обработчиком файлов .hc и .tc по умолчанию.
    • В Finder для файлов .hc и .tc добавлен пользовательский значок VeraCrypt.
    • При открытии файла-контейнера с расширением .tc, в окне пароля включается опция Режим TrueCrypt.
  • Linux:
    • При открытии файла-контейнера с расширением .tc, в окне пароля включается опция Режим TrueCrypt.
    • Исправлен исполняемый стек в результирующем двоичном файле, который был вызван файлами криптографической сборки, в которых отсутствовало примечание GNU-stack.

1.19 (17 октября 2016 года)

  • Все операционные системы:
    • Устранены проблемы, выявленные аудитом Quarkslab:
      • Удалён алгоритм шифрования GOST89 (ГОСТ 28147-89).
      • Очищен и сделан проще для анализа код PBKDF2 и HMAC.
      • Добавлены тестовые векторы для алгоритма "Кузнечик".
      • В документацию добавлено предупреждение о рисках использования ключа ”tokenpin” в командной строке.
    • Используется оптимизированная для SSE2 реализация алгоритма Serpent из проекта Botan (в 2½ раза быстрее на 64-разрядных платформах).
  • Windows:
    • Устранены проблемы с клавиатурой в загрузчике EFI.
    • Исправлен сбой на 32-разрядных машинах при создании тома, использующего Streebog в качестве PRF.
    • Исправлено ложное обнаружение атак "Evil Maid" в некоторых случаях (например, создание скрытой ОС).
    • Устранён сбой при доступе к данным EFS на томах VeraCrypt в Windows 10.
    • Исправлена ошибка неправильного пароля в процессе копирования скрытой ОС.
    • Устранены проблемы, выявленные аудитом Quarkslab:
      • Исправлена утечка длины пароля в загрузчике MBR, унаследованном от TrueCrypt.
      • Загрузчик EFI: Исправлены различные утечки и стирание буфера клавиатуры после ввода пароля.
      • Для обработки zip-файла Диска восстановления вместо уязвимой библиотеки XUnzip используется библиотека libzip.
    • Поддержка системного шифрования EFI для 32-разрядных версий Windows.
    • Во время пре-теста шифрования системы EFI для обнаружения несовместимых системных плат выполняется выключение, а не перезагрузка.
    • Небольшие исправления графического интерфейса и переводов.
  • Mac OS X:
    • Удалена зависимость от уровня совместимости MacFUSE в OSXFuse.

1.18a (17 августа 2016 года)

  • Все операционные системы:
    • Поддержка японского стандарта шифрования Camellia, в том числе для системного шифрования Windows (MBR и EFI).
    • Поддержка российских стандартов шифрования и хеширования "Кузнечик", "Магма" и "Стрибог", в том числе для системного шифрования Windows EFI.
    • Исправлена уязвимость TrueCrypt, позволявшая обнаруживать наличие скрытых томов (сообщил Алексей Михайлович Иванов, alekc96 [at] mail dot ru)
      • Чтобы избежать намёков на то, что ваши тома (не) содержат скрытый том, или если вам необходима возможность правдоподобно отрицать наличие шифрования при использовании скрытых томов/ОС, вы должны создать заново как внешние, так и скрытые тома, включая шифрование системы и скрытую ОС, и удалить существующие тома, созданные версией VeraCrypt старее, чем 1.18a.
  • Windows:
    • Поддержка шифрования системы EFI Windows (ограничения: нет скрытой ОС, нет пользовательского сообщения при загрузке).
    • Улучшена защита от атак перехвата DLL.
    • Исправлена проблема с загрузкой на некоторых компьютерах увеличением требуемой памяти на 1 КиБ.
    • Добавлен тест алгоритмов хеширования и PRF с PIM (включая предзагрузку).
    • Для лучшей стабильности система сборки переведена на Visual C++ 2010.
    • Реализован обходной путь для поддержки AES-NI в Hyper-V на Windows Server 2008 R2.
    • Корректное удаление файла драйвера veracrypt.sys при удалении в 64-разрядной Windows.
    • Реализована передача ПИН-кода смарт-карты как аргумента командной строки (/tokenpin) при явном монтировании тома.
    • Если не указана буква диска, выбирается A: или B:, только если нет другой свободной буквы диска.
    • Уменьшена загрузка ЦП, вызванная опцией запрета использования отключённых сетевых дисков.
    • Добавлен новый механизм идентификатора тома, который будет использоваться для идентификации дисков/разделов вместо их имени устройства.
    • Добавлена опция отключения запроса PIM во время предзагрузочной аутентификации, сохраняющая значение PIM в незашифрованном виде в MBR.
    • Добавлены опция и ключ в командной строке, позволяющие скрыть окно ожидания при выполнении операций.
    • В графическом интерфейсе мастера форматирования VeraCrypt добавлена опция, отключающая проверку Диска восстановления во время шифрования системы.
    • Разрешено перетаскивание файлов, когда VeraCrypt работает как процесс с повышенными правами.
    • Небольшие исправления графического интерфейса и переводов.
  • Linux:
    • Исправлена проблема с монтированием в Fedora 23.
    • Исправлена ошибка монтирования при компиляции исходного кода с помощью gcc 5.x.
    • Соответствие спецификации рабочего стола XDG, используя XDG_CONFIG_HOME для определения местоположения файлов конфигурации.
  • Mac OS X:
    • Решена проблема совместимости с новыми версиями OSXFuse.

1.17 (13 февраля 2016 года)

  • Все операционные системы:
    • Поддержка паролей в Юникоде: теперь в паролях принимаются все символы (кроме системного шифрования Windows).
    • Вдвое сокращено время монтирования/загрузки вдвое благодаря оригинальной оптимизации формирования ключей (обнаружил Xavier de Carné de Carnavalet)
    • Оптимизирована производительность Whirlpool PRF (быстрее на 25% по сравнению с предыдущим кодом).
    • Добавлена поддержка создания томов exFAT.
    • Добавлен графический индикатор количества случайностей, собранных с помощью перемещений мыши.
    • Добавлены новые значки и графика, предоставленные Andreas Becker (http://www.andreasbecker.de)
  • Windows:
    • Устранена проблема захвата DLL, влияющая на установщик, который позволяет выполнять код с повышением привилегий (CVE-2016-1281). Сообщил Stefan Kanthak (http://home.arcor.de/skanthak/)
    • Двоичные файлы подписаны как SHA-1, так и SHA-256, чтобы следовать новым рекомендациям Microsoft.
    • Устранены проблемы с Comodo/Kaspersky при запуске приложения с тома VeraCrypt (сообщил и исправил Robert Geisler).
    • В загрузчике добавлена защита длины пароля/PIM заполнением полей до максимальной длины с помощью '*' после Enter.
    • Решена проблема, из-за которой системные избранные тома нельзя было смонтировать на диск A:.
    • Решена проблема с потерей фокуса после отображения окна ожидания.
    • Устранена редкая проблема, из-за которой некоторые разделы были ассоциированы с неправильным диском в окне выбора устройства.
    • Реализовано кэширование PIM как для шифрования системы, так и для обычных томов. Добавлена опция для его активирования.
    • Программа не пытается монтировать тома, используя кэшированные пароли, если пароль и/или ключевой файл указаны в командной строке.
    • Внутренняя переработка, позволившая сделать VeraCrypt полностью юникодным приложением.
    • Добавлен обходной способ, чтобы избежать ложного срабатывания некоторых антивирусных программ.
    • Отключённые сетевые диски не показываются в списке доступных дисков. Добавлена опция, позволяющая сделать их доступными для монтирования.
    • Устранена проблема, из-за которой в некоторых случаях XML-файлы конфигурации и истории обновлялись, даже когда это не требовалось.
    • Устранена утечка пути к выбранным ключевым файлам в ОЗУ.
    • Исправлена ошибка, из-за которой нельзя было отменить выбор терабайтов как единицы размера в VeraCryptExpander.
    • Добавлено клавиатурное сокращение Alt+i для опции Использовать PIM в графическом интерфейсе.
    • Незначительные исправления графического интерфейса и переводов.
  • Linux/Mac OS X:
    • Исправлена ​​ошибка, из-за которой опция --stdin неправильно обрабатывала пароли, содержащие пробел (сообщил и исправил пользователь Codeplex horsley1953).
    • Устранена проблема с созданием томов из командной строки с файловой системой, отличной от FAT.
    • Поддержка суффиксов K/M/G/T в ключе --size, указывающих единицу размера.

1.16 (7 октября 2015 года)

  • Windows:
    • Изменён патч для уязвимости CVE-2015-7358, устраняющий побочные эффекты в Windows, но при этом очень сложно злоупотреблять обработкой букв дисков.
    • Исправлена ошибка восстановления заголовка тома из внешнего файла в некоторых конфигурациях.
    • Добавлена опция отключения обнаружения атак "Evil Maid" для тех, кто сталкивается с ложными срабатываниями (например, проблема с FLEXnet/Adobe issue).
    • По умолчанию программа не пытается монтировать том с пустым паролем, если настроен ключевой файл по умолчанию или в командной строке указан ключевой файл. Добавлена опция, восстанавливающая прежнее поведение.
      • Если требуется монтирование с использованием пустого пароля, это указывается явно: /p ""

1.15 (26 сентября 2015 года)

  • Windows:
    • Исправлены две уязвимости TrueCrypt, о которых сообщил James Forshaw (Google Project Zero).
      • CVE-2015-7358 (критическое): Локальное повышение привилегий в Windows путём злоупотребления обработкой букв дисков.
      • CVE-2015-7359: Локальное повышение привилегий в Windows, вызванное неправильной обработкой токена олицетворения.
    • Исправлена регрессия в монтировании избранных томов при входе пользователя в систему.
    • Исправлено отображение некоторых юникодных языков (например китайского) в мастере форматирования.
    • Фокус клавиатуры устанавливается на поле PIM, если включена опция Использовать PIM.
    • Ключу приложения разрешено открывать контекстное меню в списке букв дисков.
    • Поддержка указания размера томов в терабайтах в графическом интерфейсе (в командной строке это уже поддерживалось).

1.14 (16 сентября 2015 года)

  • Все операционные системы:
    • Подобно паролю, добавлено скрытие/показ значения PIM в графическом интерфейсе и в загрузчике.
  • Windows:
    • Исправлена ошибка, приводившая к повреждению Диска восстановления при использовании каскадных шифров и SHA256 для шифрования системы.
    • Решена проблема, из-за которой опция Кэшировать пароль в памяти драйвера была всегда отключена, даже если она включена в настройках.
    • Решена проблема, из-за которой изменение языка интерфейса не учитывается для новой установки, если не изменена настройка.
    • Реализовано создание файлов-контейнеров из командной строки.
    • Драйвер: по умолчанию отключена поддержка IOCTL_STORAGE_QUERY_PROPERTY и добавлена опция её включения.
    • Драйвер: поддержка возврата StorageDeviceProperty при запросе через IOCTL_STORAGE_QUERY_PROPERTY.
    • Поддержка установки метки тома в Проводнике с помощью параметра монтирования или значения метки избранного.
    • Исправлена проблема с окном назначения горячих клавиш, из-за которой всегда отображается OEM-233 и нельзя изменить.
    • При установке VeraCrypt и при настройке Переносного диска всегда копируются как 32-, так и 64-разрядные исполняемые двоичные файлы.
      • Переносной диск снова будет по умолчанию использовать 32-разрядный исполняемый файл, но также предлагать и 64-разрядный.
      • В 64-разрядной Windows теперь доступны 32-разрядные exe-файлы (например, если нужно использовать 32-разрядную библиотеку PKCS#11).
    • В настройку Переносного диска (Traveler Disk) включён Расширитель томов (Volume Expander).
    • Не предлагается создать точку восстановления, если это отключено в Windows.
    • Добавлена ​​возможность проверки файла ISO-образа Диска восстановления (Rescue Disk).
    • Небольшие исправления в установщике, графическом интерфейсе и драйвере.
  • Linux:
    • Поддержка ввода пароля с использованием stdin в неинтерактивном режиме (помог LouisTakePILLz)
      • Пример: veracrypt -t ${IMAGE_PATH} ${MOUNT_PATH} --mount --non-interactive --stdin <<< "$PWD"

1.13 (9 августа 2015 года)

  • Windows:
    • Устранён сбой TOR при запуске с тома VeraCrypt.

1.12 (5 августа 2015 года)

  • Все операционные системы:
    • Реализован "Динамический режим" поддержкой Персонального множителя итераций (Personal Iterations Multiplier, PIM). См. дополнительную информацию в документации.
  • Windows:
    • Обнаруживается несанкционированный доступа к загрузчику (атаки "Evil Maid") для шифрования системы и предлагаются варианты восстановления.
    • Исправлена проблема с переполнением буфера и другие ошибки, связанные с памятью, при разборе языковых XML-файлов.
    • Исправление, связанное с ошибочно сообщёнными утилитой chkdsk повреждёнными секторами из-за ошибки в обработке IOCTL_DISK_VERIFY.
    • Устранена проблема конфиденциальности, вызванная обновлением файлов конфигурации и истории всякий раз, когда используется VeraCrypt (сообщил Liran Elharar).
    • Исправлена ​​ошибка, из-за которой после холодного запуска не всегда монтировалось системное избранное.
    • Устранена ошибка установщика при обновлении VeraCrypt в Windows 10.
    • Реализовано дешифрование несистемного раздела/диска.
    • Для повышения производительности на 64-разрядных компьютерах в программу установки включены и развёртываются 64-разрядные исполняемые файлы.
    • Для монтирования томов можно использовать буквы дисков A: и B:.
    • Синтаксический анализ аргументов командной строки сделан более строгим и надёжным (например, ключ /lz отклонён, должно быть /l z).
    • Добавлена возможность отображать пароль шифрования системы в графическом интерфейсе Windows и в загрузчике.
    • Устранена возникавшая у некоторых пользователей ошибка "Класс уже существует".
    • Решена проблема, из-за которой некоторые пункты меню и поля графического интерфейса не переводились на другие языки.
    • Тома правильно сообщают в Windows размер физического сектора.
    • Правильно определяются операции отключения пользователя/RDP для автоматического размонтирования при блокировке сеанса.
    • Добавлен ручной выбор раздела при возобновлении шифрования на месте.
    • Добавлен параметр командной строки (/cache f) для временного кэширования пароля во время монтирования избранного.
    • Добавлено окно ожидания для операций автоматического монтирования устройств, чтобы избежать зависания графического интерфейса.
    • Добавлена дополнительная информация к сообщению об ошибке, чтобы помочь в анализе обнаруженных проблем.
    • Отключён пункт меню для изменения PRF шифрования системы, поскольку он ещё не реализован.
    • Исправлена ошибка смены пароля, когда требуется UAC (унаследовано от TrueCrypt).
    • Незначительные исправления ошибок и изменения (см. подробности в git-истории).
  • Linux:
    • Решена проблема с установщиком в KDE, когда недоступен xterm.
    • Исправлены предупреждения в диалогах about/LegalNotice при динамическом связывании wxWidgets (Н/Д для официального двоичного файла).
    • В командной строке поддерживаются имена хешей с дефисом (sha-256, sha-512 и ripemd-160).
    • Удалён ключ "--current-hash" и добавлен "--new-hash" для большей согласованности с имеющимися ключами.
    • Если в командной строке указан только ключевой файл, программа не пытается выполнить монтирование с пустым паролем.
      • Если требуется монтирование с использованием пустого пароля, это указывается явно: -p ""

1.0f-2 (5 апреля 2015 года)

  • Все операционные системы:
    • Ускорено монтирование, на 64-разрядной версии он стало до 20% быстрее (благодарим Nils Maier).
    • Добавлена опция для установки хеша/режима TrueCrypt как используемых по умолчанию для монтирования томов.
    • Использование режима TrueCrypt/хеша, указанных в командной строке, в диалоговом окне пароля.
  • Windows:
    • Устранение уязвимости CryptAcquireContext, обнаруженной Open Crypto Audit Phase II.
    • Правильная обработка сбоев генератора случайных чисел. Информирование пользователя в таких случаях.
    • Изменения, относящиеся к режиму TrueCrypt:
      • Поддержка монтирования системного раздела TrueCrypt (пока без преобразования).
      • Поддержка томов TrueCrypt как системных избранных.
      • Исправлено отображение неправильного режима TrueCrypt в свойствах тома при использовании SHA-256.
    • Решена проблема блокировки ПИН-кода со смарт-картами в особом случае.
    • Правильно обрабатываются ошибки доступа к файлам при монтировании контейнеров.
    • Решено несколько проблем, о которых сообщил анализ статического кода.
    • В загрузчик добавлено сообщение "Verifying Password..." (Проверка пароля...).
    • В случае сбоя запроса UAC (например, из-за истечения времени ожидания) пользователю предлагается повторить операцию.
    • Ссылка для удаления теперь открывает стандартное окно добавления/удаления программ.
    • При удалении программы удаляются все ссылки VeraCrypt из реестра и с диска.
    • В пакет установки включён Расширитель томов VeraCryptExpander.
    • Добавлена опция для временного пароля кэша при монтировании нескольких избранных томов.
    • Незначительные исправления ошибок и улучшения (см. подробности в git-истории).
  • Mac OS X:
    • Решена проблема с тем, что тома не размонтировались автоматически при выходе из VeraCrypt..
    • Решена проблема, когда окно VeraCrypt не открывалось повторно при щелчке по значку в доке.
  • Linux/Mac OS X:
    • Устранена проблема, из-за которой не закрывалось окно настроек при нажатии на значок «X».
    • Устранена возникавшая в некоторых случаях проблема с доступом только для чтения при монтировании томов, отличных от FAT.
    • Поддержка открытия/обзора смонтированных томов на рабочих столах, отличных от Gnome/KDE.
    • Устранены различные проблемы с установщиком при работе в не слишком распространённых конфигурациях.
    • Незначительные исправления (см. подробности в git-истории).

1.0f-1 (4 января 2015 года)

  • Все операционные системы:
    • Добавлена поддержка старого TrueCrypt 6.0.
    • Изменено наименование каскадов алгоритмов в графическом интерфейсе для лучшего описания.
  • Linux/Mac OS X:
    • Кнопка отмены в окне настроек теперь работает.
    • Устранена невозможность ввести одну цифру в размере тома.
    • Добавлено окно ожидания при вычислении в тесте.
  • Windows:
    • В информацию о смонтированном томе добавлен режим TrueCrypt.
    • Исправлены графические артефакты установщика в Windows XP.

1.0f (30 декабря 2014)

  • Все операционные системы:
    • Добавлена поддержка монтирования томов TrueCrypt.
    • Добавлена поддержка преобразования контейнеров и несистемных разделов TrueCrypt.
    • Добавлена поддержка SHA-256 для шифрования томов.
    • SHA-512 сделан алгоритмом формирования ключа по умолчанию, изменён порядок предпочтения алгоритмов формирования ключа: SHA-512 > Whirlpool > SHA-256 > RIPEMD160
    • RIPEMD160 для несистемного шифрования больше не используется.
    • Ускорение монтирования благодаря возможности сразу указать правильный алгоритм хеширования.
    • Во время длительных операций отображается окна ожидания, чтобы избежать зависания графического интерфейса.
    • Реализовано создание сразу нескольких ключевых файлов, с предопределённым или случайным размером.
    • Перед выполнением конфиденциальных операций всегда отображается диалоговое окно случайного сбора.
    • Ссылки в приложении теперь указывают на онлайн-ресурсы Codeplex.
    • Первая версия правильного Руководства пользователя VeraCrypt.
  • Mac OS X:
    • Реализована поддержка жёстких дисков с большим размером секторов (> 512).
    • Ссылка на новую версию wxWidgets 3.0.2.
    • Решена проблема с усечённым текстом в некоторых окнах мастера.
  • Linux:
    • Добавлена ​​поддержка форматирования томов NTFS.
    • Исправлена ​​проблема с открытием руководства пользователя в формате PDF.
    • Улучшена поддержка жёстких дисков с большим размером секторов (> 512).
    • Ссылка на новую версию wxWidgets 3.0.2.
  • Windows:
    • Безопасность: исправлена уязвимость в загрузчике, обнаруженная Open Crypto Audit, загрузчик сделан более надёжным.
    • Добавлена ​​поддержка SHA-256 при шифровании загрузки системы.
    • Различные оптимизации в загрузчике.
    • Полное исправление проблемы безопасности ShellExecute.
    • Драйвер ядра: проверка, что длина пароля, полученного от загрузчика, меньше или равна 64.
    • Исправлен случайный сбой при переходе по ссылке для получения дополнительной информации о ключевых файлах.
    • Реализована возможность автоматического размонтирования, когда сеанс пользователя заблокирован.
    • Добавлены векторы самопроверки для SHA-256.
    • Современный внешний вид благодаря использованию визуальных стилей.
    • Несколько незначительных исправлений.
1.0e (4 сентября 2014 года)
  • Улучшения и исправления ошибок:
    • Исправлено большинство уязвимостей безопасности, о которых сообщил Open Crypto Audit Project.
    • Устранены проблемы безопасности, обнаруженные с помощью статического анализа кода, в основном в Windows.
    • Исправлена ​​проблема с зависанием при смене пароля/ключевого файла тома. Ускорено создание зашифрованного тома/раздела.
    • Незначительные улучшения и исправления ошибок (см. подробности в git-истории).

1.0d (3 июня 2014 года)
  • Улучшения и исправления ошибок:
    • Исправлена ошибка при создании скрытой операционной системы.
    • Незначительные улучшения и исправления ошибок.


Документация >> Благодарности

Благодарности

Выражаем благодарность следующим людям:

Разработчикам программы TrueCrypt, проделавшим потрясающую работу в течение 10 лет. Без их напряжённого труда VeraCrypt сегодня не существовало бы.

Paul Le Roux за предоставление его исходного кода E4M; TrueCrypt 1.0 ведёт своё происхождение от E4M, а некоторые части исходного кода E4M и поныне входят в исходный код текущей версии TrueCrypt.

Brian Gladman, автору превосходных подпрограмм AES, Twofish и SHA-512.

Peter Gutmann за его документ о случайных числах и за создание библиотеки cryptlib, послужившей источником части исходного кода генератора случайных чисел.

Wei Dai, автору подпрограмм Serpent и RIPEMD-160.

Tom St Denis, автору LibTomCrypt, включающей компактные подпрограммы SHA-256.

Mark Adler и Jean-loup Gailly, написавшим библиотеку zlib.

Разработчикам алгоритмов шифрования, хеширования и режима работы:

Horst Feistel, Don Coppersmith, Walt Tuchmann, Lars Knudsen, Ross Anderson, Eli Biham, Bruce Schneier, David Wagner, John Kelsey, Niels Ferguson, Doug Whiting, Chris Hall, Joan Daemen, Vincent Rijmen, Carlisle Adams, Stafford Tavares, Phillip Rogaway, Hans Dobbertin, Antoon Bosselaers, Bart Preneel, Paulo S. L. M. Barreto.

Andreas Becker за создание логотипа и значков VeraCrypt.

Xavier de Carné de Carnavalet, предложившему оптимизацию скорости для PBKDF2, которая вдвое сократила время монтирования/загрузки.

kerukuro за библиотеку cppcrypto (http://cppcrypto.sourceforge.net/), откуда взята реализация шифра «Кузнечик».

Dieter Baron и Thomas Klausner, написавшим библиотеку libzip.

Jack Lloyd, написавшему оптимизированную для SIMD реализацию Serpent.

Всем остальным, благодаря кому стал возможен этот проект, кто нас морально поддерживал, а также тем, кто присылал нам сообщения об ошибках и предложения по улучшению программы.

Большое вам спасибо!

Перевод программы и документации на русский язык выполнил Дмитрий Ерохин.


Документация >> Ссылки

Ссылки

[1] | U.S. Committee on National Security Systems (CNSS), National Policy on the Use of the Advanced Encryption Standard (AES) to Protect National Security Systems and National Security Information, CNSS Policy No. 15, Fact Sheet No. 1, июнь 2003, доступно здесь: http://csrc.nist.gov/groups/STM/cmvp/documents/CNSS15FS.pdf.
[2] | C. E. Shannon, Communication Theory of Secrecy Systems, Bell System Technical Journal, v. 28, n. 4, 1949
[3] | NIST, Advanced Encryption Standard (AES), Federal Information Processing Standards Publication 197, 26 ноября 2001, доступно здесь: http://csrc.nist.gov/publications/fips/fips197/fips-197.pdf.
[4] | J. Nechvatal, E. Barker, L. Bassham, W. Burr, M. Dworkin, J. Foti, E. Roback, NIST, Report on the Development of the Advanced Encryption Standard (AES), 2 октября 2000, Journal of Research of the National Institute of Standards and Technology, Vol. 106, No. 3, май-июнь 2001, доступно здесь: http://csrc.nist.gov/archive/aes/round2/r2report.pdf.
[5] | B. Schneier, J. Kelsey, D. Whiting, D. Wagner, C. Hall, N. Ferguson, T. Kohno, M. Stay, The Twofish Team's Final Comments on AES Selection, 15 мая 2000, доступно здесь: http://csrc.nist.gov/archive/aes/round2/comments/20000515-bschneier.pdf.
[6] | Bruce Schneier, Beyond Fear: Thinking Sensibly About Security in an Uncertain World, Springer, 2003
[7] | RSA Laboratories, PKCS #5 v2.0: Password-Based Cryptography Standard, RSA Data Security, Inc. Public-Key Cryptography Standards (PKCS), 25 марта 1999, доступно здесь: https://www.emc.com/emc-plus/rsa-labs/standards-initiatives/pkcs-5-password-based-cryptography-standard.htm.
[8] | H. Krawczyk, M. Bellare, R. Canetti, HMAC: Keyed-Hashing for Message Authentication, RFC 2104, февраль 1997, доступно здесь: http://www.ietf.org/rfc/rfc2104.txt.
[9] | M. Nystrom, RSA Security, Identifiers and Test Vectors for HMAC-SHA-224, HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512, RFC 4231, декабрь 2005, доступно здесь: http://www.ietf.org/rfc/rfc4231.txt.
[10] | Peter Gutmann, Software Generation of Practically Strong Random Numbers, представлено в 1998 на Usenix Security Symposium, доступно здесь: http://www.cs.auckland.ac.nz/~pgut001/pubs/usenix98.pdf.
[11] | Carl Ellison, Cryptographic Random Numbers, изначально приложение к стандарту P1363, доступно здесь: http://world.std.com/~cme/P1363/ranno.html.
[12] | P. Rogaway, Efficient Instantiations of Tweakable Blockciphers and Refinements to Modes OCB and PMAC, Asiacrypt 2004. LNCS vol. 3329. Springer, 2004. Также доступно здесь: : http://www.cs.ucdavis.edu/~rogaway/papers/offsets.pdf.
[13] | J. Kelsey, Twofish Technical Report #7: Key Separation in Twofish, AES Round 2 public comment, 7 апреля 2000
[14] | NIST, Secure Hash Standard, FIPS 180-2, 1 августа 2002, доступно здесь: http://csrc.nist.gov/publications/fips/fips180-2/fips180-2.pdf.
[15] | U. Maurer, J. Massey, Cascade Ciphers: The Importance of Being First, Journal of Cryptology, v. 6, n. 1, 1993
[16] | Bruce Schneier, Applied Cryptography, Second Edition, John Wiley & Sons, 1996
[17] | Peter Gutmann, Secure Deletion of Data from Magnetic and Solid-State Memory, впервые опубликовано в материалах Шестого симпозиума по безопасности, Сан-Хосе, Калифорния, 22-25 июля 1996, доступно здесь: http://www.cs.auckland.ac.nz/~pgut001/pubs/secure_del.html.
[18] | Веб-страница шифра Serpent: http://www.cl.cam.ac.uk/~rja14/serpent.html.
[19] | M. E. Smid, AES Issues, AES Round 2 Comments, 22 мая 2000, доступно здесь: http://csrc.nist.gov/archive/aes/round2/comments/20000523-msmid-2.pdf.
[20] | A. Menezes, P. van Oorschot, S. Vanstone, Handbook of Applied Cryptography, CRC Press, октябрь 1996
[21] | International Organization for Standardization (ISO), Information technology – Security techniques – Hash-functions – Part 3: Dedicated hash-functions, ISO/IEC 10118-3:2004, 24 февраля 2004
[22] | NIST, The Keyed-Hash Message Authentication Code (HMAC), Federal Information Processing Standards Publication 198, 6 марта 2002, доступно здесь: http://csrc.nist.gov/publications/fips/fips198/fips-198a.pdf.
[23] | RSA Laboratories, PKCS #11 v2.20: Cryptographic Token Interface Standard, RSA Security, Inc. Public-Key Cryptography Standards (PKCS), 28 июня 2004, доступно здесь: https://www.emc.com/emc-plus/rsa-labs/standards-initiatives/pkcs-11-cryptographic-token-interface-standard.htm. PDF доступно здесь: https://www.cryptsoft.com/pkcs11doc/STANDARD/pkcs-11v2-20.pdf
[24] | Morris Dworkin, Recommendation for Block Cipher Modes of Operation: The XTS-AES Mode for Confidentiality on Storage Devices, NIST Special Publication 800-3E, январь 2010, доступно здесь: http://csrc.nist.gov/publications/nistpubs/800-38E/nist-sp-800-38E.pdf.
[25] | NIST, Approved Security Functions for FIPS PUB 140-2, Security Requirements for Cryptographic Modules, 8 октября 2010, доступно здесь: http://csrc.nist.gov/publications/fips/fips140-2/fips1402annexa.pdf


Документация >> Том VeraCrypt

Авторы

Mounir IDRASSI (AM Crypto, https://www.linkedin.com/in/idrassi) – создатель и главный разработчик VeraCrypt. Руководит всеми аспектами разработки и развёртывания на всех поддерживаемых платформах (Windows, Linux и macOS).

Алекс Колотников (https://ru.linkedin.com/in/alex-kolotnikov-6625568b) – автор EFI-загрузчика VeraCrypt. Отвечает за все аспекты поддержки EFI, а его обширный опыт помогает внедрять новые интересные функции в системное Windows-шифрование VeraCrypt.


Полезные ресурсы, предоставленные пользователями VeraCrypt.

Сторонние бинарные файлы:

  • Linux Ubuntu PPA, предоставлено пользователем "Unit 193" (автор сборки – Launchpad):
    • https://launchpad.net/~unit193/+archive/ubuntu/encryption
  • Linux Armv7 GUI/консольная 32-разрядная сборка на ChromeBook, выполненная пользователем haggster:
    • veracrypt-1.0f-1-setup-arm.tar.bz2

Руководства:

  • http://schneckchen.in/veracrypt-anleitung-zum-daten-verschluesseln/:
    • Немецкое руководство по VeraCrypt, автор Andreas Heinz.
  • http://howto.wared.fr/raspberry-pi-arch-linux-arm-installation-veracrypt/:
    • Французское руководство по сборке VeraCrypt на Raspberry Pi Arch Linux, автор Edouard WATTECAMPS.
  • clonezilla_using_veracrypt_ver_1.1.doc:
    • Руководство по использованию VeraCrypt в CloneZilla для доступа к зашифрованным резервным копиям, автор pjc123.
  • https://bohdan-danishevsky.blogspot.fr/2016/11/raspberry-pi-raspbian-installing.html
    • Руководство по установке и использованию официальных бинарных файлов VeraCrypt на Raspberry Pi (Raspbian), автор Bohdan Danishevsky.

Разное:

  • vcsteg2.py: скрипт на Python, пытающийся скрыть том VeraCrypt внутри видеофайла (стеганография).


Документация >> Отказ от обязательств

Отказ от гарантий

СОДЕРЖИМОЕ ЭТОГО САЙТА (И ЛЮБЫХ СВЯЗАННЫХ САЙТОВ/СЕРВЕРОВ) ПРЕДОСТАВЛЯЕТСЯ КАК ЕСТЬ; БЕЗ КАКИХ-ЛИБО ГАРАНТИЙ, ЯВНЫХ, ПОДРАЗУМЕВАЕМЫХ ИЛИ УСТАНОВЛЕННЫХ ЗАКОНОМ. СОДЕРЖИМОЕ ЭТОГО САЙТА (И ЛЮБЫХ СВЯЗАННЫХ САЙТОВ) МОЖЕТ БЫТЬ НЕТОЧНЫМ, НЕПРАВИЛЬНЫМ, НЕДЕЙСТВИТЕЛЬНЫМ, НЕДОСТОВЕРНЫМ, ЛОЖНЫМ, НЕПОЛНЫМ И/ИЛИ ВВОДЯЩИМ В ЗАБЛУЖДЕНИЕ. ВЕСЬ РИСК В ОТНОШЕНИИ КАЧЕСТВА, ПРАВИЛЬНОСТИ, ТОЧНОСТИ ИЛИ ПОЛНОТЫ СОДЕРЖИМОГО ЭТОГО САЙТА (И ЛЮБЫХ СВЯЗАННЫХ САЙТОВ) ЛЕЖИТ НА ВАС. АВТОРЫ, ВЛАДЕЛЬЦЫ, ИЗДАТЕЛИ И АДМИНИСТРАТОРЫ ЭТОГО САЙТА (И СВЯЗАННЫХ САЙТОВ/СЕРВЕРОВ), И СООТВЕТСТВУЮЩИЕ ВЛАДЕЛЬЦЫ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ОТКАЗЫВАЮТСЯ ОТ ЛЮБЫХ ГАРАНТИЙ ЛЮБОГО РОДА.

Отказ от ответственности

АВТОРЫ, ВЛАДЕЛЬЦЫ, ИЗДАТЕЛИ И АДМИНИСТРАТОРЫ ЭТОГО (И СВЯЗАННЫХ С НИМ САЙТОВ/СЕРВЕРОВ), А ТАКЖЕ СООТВЕТСТВУЮЩИЕ ВЛАДЕЛЬЦЫ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ОТКАЗЫВАЮТСЯ ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ И НИ В КОЕМ СЛУЧАЕ НИ ОДНА ИЗ ЭТИХ СТОРОН НЕ НЕСЁТ ОТВЕТСТВЕННОСТИ ПЕРЕД ВАМИ ИЛИ ЛЮБОЙ ДРУГОЙ СТОРОНОЙ ЗА ЛЮБЫЕ УБЫТКИ, ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ, ЛЮБЫЕ ПРЯМЫЕ, КОСВЕННЫЕ, ОБЩИЕ, ОСОБЫЕ, СЛУЧАЙНЫЕ, ШТРАФНЫЕ, ПРИМЕРНЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ (ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ, ЛЮБЫЕ УБЫТКИ, ПОНЕСЁННЫЕ ВАМИ ИЛИ ТРЕТЬИМИ СТОРОНАМИ, ЗАКУПКА УСЛУГ-ЗАМЕНИТЕЛЕЙ ИЛИ ПРЕРЫВАНИЕ БИЗНЕСА), ИЛИ ИНОЕ, ВОЗНИКАЮЩЕЕ В РЕЗУЛЬТАТЕ ЛЮБОГО ИСПОЛЬЗОВАНИЯ ЭТОГО САЙТА (ИЛИ СВЯЗАННЫХ С НИМ САЙТОВ/СЕРВЕРОВ) ИЛИ ЕГО СОДЕРЖИМОГО ИЛИ ЛЮБОГО СТОРОННЕГО САЙТА, СВЯЗАННОГО КАКИМ-ЛИБО ОБРАЗОМ С ЭТИМ САЙТОМ (ИЛИ СО СВЯЗАННЫМИ САЙТАМИ), ДАЖЕ ЕСЛИ ТАКИЕ УБЫТКИ (ИЛИ ВОЗМОЖНОСТЬ ТАКИХ УБЫТКОВ) ЯВЛЯЮТСЯ/БЫЛИ ПРЕДСКАЗУЕМЫ ИЛИ ИЗВЕСТНЫ ЛЮБОМУ АВТОРУ, ВЛАДЕЛЬЦУ, ИЗДАТЕЛЮ, АДМИНИСТРАТОРУ ИЛИ ЛЮБОЙ ДРУГОЙ СТОРОНЕ.


Пожертвование на разработку VeraCrypt

Вы можете поддержать развитие VeraCrypt, отправив пожертвование с помощью PayPal, банковского перевода или криптовалюты (Bitcoin и Ethereum). Также возможно отправить пожертвование с использованием платформы Liberapay.

PayPal

Пожертвовать в евро
Евро
Пожертвовать в долларах США
Доллар США
Пожертвовать в фунтах стерлингов
Фунт стерлингов
Пожертвовать в канадских долларах
Канадский доллар
Пожертвовать в швейцарских франках
Швейцарский франк
Пожертвовать в японских иенах
Японская иена
Пожертвовать в австралийских долларах
Австралийский доллар
Пожертвовать в польских злотых
Польский злотый

Для других валют выберите из списка ниже:

Банковский перевод

Чтобы отправить пожертвование через банковский перевод, используйте банковские данные AM Crypto.

Платформы для пожертвований:

  • Liberapay: Donate using Liberapay

Bitcoin

  • SegWit:

    VeraCrypt BTC SegWit Address

    bc1qrlzz2u302vp4nuu8sm9zkl0vtyfcpmmppedede

  • Legacy:

    VeraCrypt Bitcoin Address

    1CKsjZXqAxK5doo6XdJJtwDyo2GUwzz9ha

Ethereum

VeraCrypt Ethereum Address

0xA73130B89af878ABfAA950c6Db5b82549f600925


Пожертвование на развитие VeraCrypt с помощью банковского перевода

Вы можете поддержать развитие VeraCrypt, отправив пожертвование посредством банковского перевода на один из перечисленных ниже банковских счетов AM Crypto, в зависимости от валюты.
Поддерживаемые валюты: евро [image] , доллар США [image] , британский фунт [image] , австралийский доллар [image] и новозеландский доллар [image] .
Свяжитесь с нами, если вам нужен официальный счёт для вашего пожертвования.

Евро SEPA – банковские детали

Принимаемые типы платежей: SEPA bank transferts или SWIFT только в евро.

Владелец счёта: AM Crypto
IBAN: BE54 9053 4814 2097
Банковский код (SWIFT / BIC): TRWIBEB1XXX
Адрес: Wise, Rue du Trône 100, 3rd floor, Brussels, 1050, Belgium
Назначение: Open Source Donation

Доллар США – банковские детали

Из США, принимаемые типы платежей: ACH и Wire.

Владелец счёта: AM Crypto
Номер счёта: 215667625228
Номер маршрута ACH и Wire: 101019628
Тип счёта: Checking
Адрес: Wise US Inc, 30 W. 26th Street, Sixth Floor, New York NY, 10010, United States
Назначение: Open Source Donation

Не из США, принимаемые типы платежей: SWIFT.

Владелец счёта: AM Crypto
Номер счёта: 215667625228
Номер маршрута: 101019628
Банковский код (SWIFT/BIC): TRWIUS35XXX
Адрес: Wise US Inc, 30 W. 26th Street, Sixth Floor, New York NY, 10010, United States
Назначение: Open Source Donation

Британский фунт стерлингов – банковские детали

Принимаемые типы платежей: Faster Payments (FPS), BACS и CHAPS только из Великобритании.

Владелец счёта: AM Crypto
Номер счёта: 11930731
Код Великобритании: 23-08-01
IBAN (для получения GBP только из Великобритании): GB35 TRWI 2308 0111 9307 31
Адрес: Wise Payments Limited, 1st Floor, Worship Square, 65 Clifton Street, London, EC2A 4JE, United Kingdom
Назначение: Open Source Donation

Австралийский доллар – банковские детали

Принимаемые типы платежей: только локальные банковские переводы AUD.

Владелец счёта: AM Crypto
Номер счёта: 230232302
Код BSB: 774001
Адрес: Wise Australia Pty Ltd, Suite 1, Level 11, 66 Goulburn Street, Sydney, NSW, 2000, Australia.
Назначение: Open Source Donation

Новозеландский доллар – банковские детали

Принимаемые типы платежей: только локальные банковские переводы NZD.

Владелец счёта: AM Crypto
Номер счёта: 04-2021-0294035-03
Адрес: Wise Payments Ltd. - New Zealand Branch, 1st Floor, Worship Square, 65 Clifton Street, London, EC2A 4JE, United Kingdom
Назначение: Open Source Donation


Документация >> Смарт-карты EMV

Смарт-карты EMV

Версии VeraCrypt для Windows и Linux позволяют использовать смарт-карты, совместимые с EMV, в качестве функции. Использование смарт-карт, совместимых с PKCS#11, предназначено для пользователей с определёнными навыками кибербезопасности. Однако в некоторых ситуациях наличие такой карты сильно снижает правдоподобность отрицания пользователем наличия шифрования.

Чтобы решить эту проблему, появилась идея использовать карты, которые есть у каждого, а именно смарт-карты, совместимые с EMV. Согласно одноимённому стандарту, эти карты, распространённые во всем мире, применяются для банковских операций. Использование внутренних данных карты EMV пользователя в качестве ключевых файлов повысит безопасность его тома, сохраняя при этом правдоподобность отрицания наличия шифрования.

Более подробную техническую информацию см. в разделе Смарт-карты EMV в главе Ключевые файлы.


Документация >> Лицензия VeraCrypt

Лицензия VeraCrypt

ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ, ПОСТАВЛЯЕМОЕ ПО ЭТОЙ ЛИЦЕНЗИИ, РАСПРОСТРАНЯЕТСЯ НА УСЛОВИЯХ «КАК ЕСТЬ» БЕЗ КАКИХ-ЛИБО ГАРАНТИЙ. АВТОРЫ И РАСПРОСТРАНИТЕЛИ ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ. ВСЕ, КТО ИСПОЛЬЗУЕТ, КОПИРУЕТ, ИЗМЕНЯЕТ ИЛИ (ПОВТОРНО) РАСПРОСТРАНЯЕТ ЛЮБУЮ ЧАСТЬ ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ, ТАКИМ ДЕЙСТВИЕМ ПРИНИМАЕТ НАСТОЯЩУЮ ЛИЦЕНЗИЮ И СОГЛАШАЕТСЯ СОБЛЮДАТЬ ВСЕ ЕЁ ПОЛОЖЕНИЯ И УСЛОВИЯ. ЕСЛИ ВЫ НЕ ПРИНИМАЕТЕ ИХ, НЕ ИСПОЛЬЗУЙТЕ, НЕ КОПИРУЙТЕ, НЕ ИЗМЕНЯЙТЕ И НЕ РАСПРОСТРАНЯЙТЕ (ПОВТОРНО) ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ИЛИ ЕГО ЧАСТИ.

VeraCrypt имеет мультилицензию Apache License 2.0 и TrueCrypt License версии 3.0, дословную копию обеих лицензий можно найти ниже.

Эта лицензия не даёт вам прав на использование имён, логотипов или торговых марок участников, включая IDRIX, AM Crypto, VeraCrypt и все производные названия. Например, не допускаются следующие имена: VeraCrypt, VeraCrypt+, VeraCrypt Professional, iVeraCrypt и т. д., а также любые другие имена, напоминающие имя VeraCrypt (например, Vera-Crypt, Vera Crypt, VerKrypt и т. д.).

Лицензия Apache
Версия 2.0, январь 2004
http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License.

Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.

3. Grant of Patent License.

Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed.

4. Redistribution.

You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:

1. You must give any other recipients of the Work or Derivative Works a copy of this License; and

2. You must cause any modified files to carry prominent notices stating that You changed the files; and

3. You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

4. If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

5. Submission of Contributions.

Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding such Contributions.

6. Trademarks.

This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty.

Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License.

8. Limitation of Liability.

In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses), even if such Contributor has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability.

While redistributing the Work or Derivative Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability.

Лицензия TrueCrypt версии 3.0

Software distributed under this license is distributed on an "AS
IS" BASIS WITHOUT WARRANTIES OF ANY KIND. THE AUTHORS AND
DISTRIBUTORS OF THE SOFTWARE DISCLAIM ANY LIABILITY. ANYONE WHO
USES, COPIES, MODIFIES, OR (RE)DISTRIBUTES ANY PART OF THE
SOFTWARE IS, BY SUCH ACTION(S), ACCEPTING AND AGREEING TO BE
BOUND BY ALL TERMS AND CONDITIONS OF THIS LICENSE. IF YOU DO NOT
ACCEPT THEM, DO NOT USE, COPY, MODIFY, NOR (RE)DISTRIBUTE THE
SOFTWARE, NOR ANY PART(S) THEREOF.

I. Definitions

1. "This Product" means the work (including, but not limited to, source code, graphics, texts, and accompanying files) made available under and governed by this version of this license ("License"), as may be indicated by, but is not limited to, copyright notice(s) attached to or included in the work.

2. "You" means (and "Your" refers to) an individual or a legal entity (e.g., a non-profit organization, commercial organization, government agency, etc.) exercising permissions granted by this License.

3. "Modification" means (and "modify" refers to) any alteration of This Product, including, but not limited to, addition to or deletion from the substance or structure of This Product, translation into another language, repackaging, alteration or removal of any file included with This Product, and addition of any new files to This Product.

4. "Your Product" means This Product modified by You, or any work You derive from (or base on) any part of This Product. In addition, "Your Product" means any work in which You include any (modified or unmodified) portion of This Product. However, if the work in which you include it is an aggregate software distribution (such as an operating system distribution or a cover CD-ROM of a magazine) containing multiple separate products, then the term "Your Product" includes only those products (in the aggregate software distribution) that use, include, or depend on a modified or unmodified version of This Product (and the term "Your Product" does not include the whole aggregate software distribution). For the purposes of this License, a product suite consisting of two or more products is considered a single product (operating system distributions and cover media of magazines are not considered product suites).

5. "Distribution" means (and "distribute" refers to), regardless of means or methods, conveyance, transfer, providing, or making available of This/Your Product or portions thereof to third parties (including, but not limited to, making This/Your Product, or portions thereof, available for download to third parties, whether or not any third party has downloaded the product, or any portion thereof, made available for download).

II. Use, Copying, and Distribution of This Product

1. Provided that You comply with all applicable terms and conditions of this License, You may make copies of This Product (unmodified) and distribute copies of This Product (unmodified) that are not included in another product forming Your Product (except as permitted under Chapter III). Note: For terms and conditions for copying and distribution of modified versions of This Product, see Chapter III.

2. Provided that You comply with all applicable terms and conditions of this License, You may use This Product freely (См. также Chapter III) on any number of computers/systems for non-commercial and/or commercial purposes.

III. Modification, Derivation, and Inclusion in Other Products

1. If all conditions specified in the following paragraphs in this Chapter (III) are met (for exceptions, see Section III.2) and if You comply with all other applicable terms and conditions of this License, You may modify This Product (thus forming Your Product), derive new works from This Product or portions thereof (thus forming Your Product), include This Product or portions thereof in another product (thus forming Your Product, unless defined otherwise in Chapter I), and You may use (for non-commercial and/or commercial purposes), copy, and/or distribute Your Product.

  1. The name of Your Product (or of Your modified version of This Product) must not contain the name TrueCrypt (for example, the following names are not allowed: TrueCrypt, TrueCrypt+, TrueCrypt Professional, iTrueCrypt, etc.) nor any other names confusingly similar to the name TrueCrypt (e.g., True-Crypt, True Crypt, TruKrypt, etc.)

    All occurrences of the name TrueCrypt that could reasonably be considered to identify Your Product must be removed from Your Product and from any associated materials. Logo(s) included in (or attached to) Your Product (and in/to associated materials) must not incorporate and must not be confusingly similar to any of the TrueCrypt logos (including, but not limited to, the non-textual logo consisting primarily of a key in stylized form) or portion(s) thereof. All graphics contained in This Product (logos, icons, etc.) must be removed from Your Product (or from Your modified version of This Product) and from any associated materials.
  2. The following phrases must be removed from Your Product and from any associated materials, except the text of this License: "A TrueCrypt Foundation Release", "Released by TrueCrypt Foundation", "This is a TrueCrypt Foundation release."
  3. Phrase "Based on TrueCrypt, freely available at www.truecrypt.org" must be displayed by Your Product (if technically feasible) and contained in its documentation. Alternatively, if This Product or its portion You included in Your Product constitutes only a minor portion of Your Product, phrase "Portions of this product are based in part on TrueCrypt, freely available at www.truecrypt.org" may be displayed instead. In each of the cases mentioned above in this paragraph, "www.truecrypt.org" must be a hyperlink (if technically feasible) pointing to www.truecrypt.org and You may freely choose the location within the user interface (if there is any) of Your Product (e.g., an "About" window, etc.) and the way in which Your Product will display the respective phrase.

    Your Product (and any associated materials, e.g., the documentation, the content of the official web site of Your Product, etc.) must not present any Internet address containing the domain name truecrypt.org (or any domain name that forwards to the domain name truecrypt.org) in a manner that might suggest that it is where information about Your Product may be obtained or where bugs found in Your Product may be reported or where support for Your Product may be available or otherwise attempt to indicate that the domain name truecrypt.org is associated with Your Product.
  4. The complete source code of Your Product must be freely and publicly available (for exceptions, see Section III.2) at least until You cease to distribute Your Product. This condition can be met in one or both of the following ways: (i) You include the complete source code of Your Product with every copy of Your Product that You make and distribute and You make all such copies of Your Product available to the general public free of charge, and/or (ii) You include information (valid and correct at least until You cease to distribute Your Product) about where the complete source code of Your Product can be obtained free of charge (e.g., an Internet address) or for a reasonable reproduction fee with every copy of Your Product that You make and distribute and, if there is a web site officially associated with Your Product, You include the aforementioned information about the source code on a freely and publicly accessible web page to which such web site links via an easily viewable hyperlink (at least until You cease to distribute Your Product).

    The source code of Your Product must not be deliberately obfuscated and it must not be in an intermediate form (e.g., the output of a preprocessor). Source code means the preferred form in which a programmer would usually modify the program.

    Portions of the source code of Your Product not contained in This Product (e.g., portions added by You in creating Your Product, whether created by You or by third parties) must be available under license(s) that (however, См. также Subsection III.1.e) allow(s) anyone to modify and derive new works from the portions of the source code that are not contained in This Product and to use, copy, and redistribute such modifications and/or derivative works. The license(s) must be perpetual, non-exclusive, royalty-free, no-charge, and worldwide, and must not invalidate, weaken, restrict, interpret, amend, modify, interfere with or otherwise affect any part, term, provision, or clause of this License. The text(s) of the license(s) must be included with every copy of Your Product that You make and distribute.
  5. You must not change the license terms of This Product in any way (adding any new terms is considered changing the license terms even if the original terms are retained), which means, e.g., that no part of This Product may be put under another license. You must keep intact all the legal notices contained in the source code files. You must include the following items with every copy of Your Product that You make and distribute: a clear and conspicuous notice stating that Your Product or portion(s) thereof is/are governed by this version of the TrueCrypt License, a verbatim copy of this version of the TrueCrypt License (as contained herein), a clear and conspicuous notice containing information about where the included copy of the License can be found, and an appropriate copyright notice.

2. You are not obligated to comply with Subsection III.1.d if Your Product is not distributed (i.e., Your Product is available only to You).

IV. Disclaimer of Liability, Disclaimer of Warranty, Indemnification

You expressly acknowledge and agree to the following:

1. IN NO EVENT WILL ANY (CO)AUTHOR OF THIS PRODUCT, OR ANY APPLICABLE INTELLECTUAL-PROPERTY OWNER, OR ANY OTHER PARTY WHO MAY COPY AND/OR (RE)DISTRIBUTE THIS PRODUCT OR PORTIONS THEREOF, AS MAY BE PERMITTED HEREIN, BE LIABLE TO YOU OR TO ANY OTHER PARTY FOR ANY DAMAGES, INCLUDING, BUT NOT LIMITED TO, ANY DIRECT, INDIRECT, GENERAL, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, CORRUPTION OR LOSS OF DATA, ANY LOSSES SUSTAINED BY YOU OR THIRD PARTIES, A FAILURE OF THIS PRODUCT TO OPERATE WITH ANY OTHER PRODUCT, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES, OR BUSINESS INTERRUPTION), WHETHER IN CONTRACT, STRICT LIABILITY, TORT (INCLUDING, BUT NOT LIMITED TO, NEGLIGENCE) OR OTHERWISE, ARISING OUT OF THE USE, COPYING, MODIFICATION, OR (RE)DISTRIBUTION OF THIS PRODUCT (OR A PORTION THEREOF) OR OF YOUR PRODUCT (OR A PORTION THEREOF), OR INABILITY TO USE THIS PRODUCT (OR A PORTION THEREOF), EVEN IF SUCH DAMAGES (OR THE POSSIBILITY OF SUCH DAMAGES) ARE/WERE PREDICTABLE OR KNOWN TO ANY (CO)AUTHOR, INTELLECTUAL-PROPERTY OWNER, OR ANY OTHER PARTY.

2. THIS PRODUCT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS, IMPLIED, OR STATUTORY, INCLUDING, BUT NOT LIMITED TO, THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THIS PRODUCT IS WITH YOU. SHOULD THIS PRODUCT PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR, OR CORRECTION.

3. THIS PRODUCT MAY INCORPORATE IMPLEMENTATIONS OF CRYPTOGRAPHIC ALGORITHMS THAT ARE REGULATED (E.G., SUBJECT TO EXPORT/IMPORT CONTROL REGULATIONS) OR ILLEGAL IN SOME COUNTRIES. IT IS SOLELY YOUR RESPONSIBILITY TO VERIFY THAT IT IS LEGAL TO IMPORT AND/OR (RE)EXPORT AND/OR USE THIS PRODUCT (OR PORTIONS THEREOF) IN COUNTRIES WHERE YOU INTEND TO USE IT AND/OR TO WHICH YOU INTEND TO IMPORT IT AND/OR FROM WHICH YOU INTEND TO EXPORT IT, AND IT IS SOLELY YOUR RESPONSIBILITY TO COMPLY WITH ANY APPLICABLE REGULATIONS, RESTRICTIONS, AND LAWS.

4. YOU SHALL INDEMNIFY, DEFEND AND HOLD ALL (CO)AUTHORS OF THIS PRODUCT, AND APPLICABLE INTELLECTUAL-PROPERTY OWNERS, HARMLESS FROM AND AGAINST ANY AND ALL LIABILITY, DAMAGES, LOSSES, SETTLEMENTS, PENALTIES, FINES, COSTS, EXPENSES (INCLUDING REASONABLE ATTORNEYS' FEES), DEMANDS, CAUSES OF ACTION, CLAIMS, ACTIONS, PROCEEDINGS, AND SUITS, DIRECTLY RELATED TO OR ARISING OUT OF YOUR USE, INABILITY TO USE, COPYING, (RE)DISTRIBUTION, IMPORT AND/OR (RE)EXPORT OF THIS PRODUCT (OR PORTIONS THEREOF) AND/OR YOUR BREACH OF ANY TERM OF THIS LICENSE.

V. Trademarks

This License does not grant permission to use trademarks associated with (or applying to) This Product, except for fair use as defined by applicable law and except for use expressly permitted or required by this License. Any attempt otherwise to use trademarks associated with (or applying to) This Product automatically and immediately terminates Your rights under This License and may constitute trademark infringement (which may be prosecuted).

VI. General Terms and Conditions, Miscellaneous Provisions

1. ANYONE WHO USES AND/OR COPIES AND/OR MODIFIES AND/OR CREATES DERIVATIVE WORKS OF AND/OR (RE)DISTRIBUTES THIS PRODUCT, OR ANY PORTION(S) THEREOF, IS, BY SUCH ACTION(S), AGREEING TO BE BOUND BY AND ACCEPTING ALL TERMS AND CONDITIONS OF THIS LICENSE (AND THE RESPONSIBILITIES AND OBLIGATIONS CONTAINED IN THIS LICENSE). IF YOU DO NOT ACCEPT (AND AGREE TO BE BOUND BY) ALL TERMS AND CONDITIONS OF THIS LICENSE, DO NOT USE, COPY, MODIFY, CREATE DERIVATIVE WORKS OF, NOR (RE)DISTRIBUTE THIS PRODUCT, NOR ANY PORTION(S) THEREOF.

2. YOU MAY NOT USE, MODIFY, COPY, CREATE DERIVATIVE WORKS OF, (RE)DISTRIBUTE, OR SUBLICENSE THIS PRODUCT, OR PORTION(S) THEREOF, EXCEPT AS EXPRESSLY PROVIDED IN THIS LICENSE (EVEN IF APPLICABLE LAW GIVES YOU MORE RIGHTS). ANY ATTEMPT (EVEN IF PERMITTED BY APPLICABLE LAW) OTHERWISE TO USE, MODIFY, COPY, CREATE DERIVATIVE WORKS OF, (RE)DISTRIBUTE, OR SUBLICENSE THIS PRODUCT, OR PORTION(S) THEREOF, AUTOMATICALLY AND IMMEDIATELY TERMINATES YOUR RIGHTS UNDER THIS LICENSE AND CAN CONSTITUTE COPYRIGHT INFRINGEMENT (WHICH MAY BE PROSECUTED). ANY CONDITIONS AND RESTRICTIONS CONTAINED IN THIS LICENSE ARE ALSO LIMITATIONS ON THE SCOPE OF THIS LICENSE AND ALSO DEFINE THE SCOPE OF YOUR RIGHTS UNDER THIS LICENSE. YOUR FAILURE TO COMPLY WITH THE TERMS AND CONDITIONS OF THIS LICENSE OR FAILURE TO PERFORM ANY APPLICABLE OBLIGATION IMPOSED BY THIS LICENSE AUTOMATICALLY AND IMMEDIATELY TERMINATES YOUR RIGHTS UNDER THIS LICENSE AND CAN CAUSE OR BE CONSIDERED COPYRIGHT INFRINGEMENT (WHICH MAY BE PROSECUTED). NOTHING IN THIS LICENSE SHALL IMPLY OR BE CONSTRUED AS A PROMISE, OBLIGATION, OR COVENANT NOT TO SUE FOR COPYRIGHT OR TRADEMARK INFRINGEMENT IF YOU DO NOT COMPLY WITH THE TERMS AND CONDITIONS OF THIS LICENSE.

3. This License does not constitute or imply a waiver of any intellectual property rights except as may be otherwise expressly provided in this License. This License does not transfer, assign, or convey any intellectual property rights (e.g., it does not transfer ownership of copyrights or trademarks).

4. Subject to the terms and conditions of this License, You may allow a third party to use Your copy of This Product (or a copy that You make and distribute, or Your Product) provided that the third party explicitly accepts and agrees to be bound by all terms and conditions of this License and the third party is not prohibited from using This Product (or portions thereof) by this License (see, e.g., Section VI.7) or by applicable law. However, You are not obligated to ensure that the third party accepts (and agrees to be bound by all terms of) this License if You distribute only the self-extracting package (containing This Product) that does not allow the user to install (nor extract) the files contained in the package until he or she accepts and agrees to be bound by all terms and conditions of this License.

5. Without specific prior written permission from the authors of This Product (or from their common representative), You must not use the name of This Product, the names of the authors of This Product, or the names of the legal entities (or informal groups) of which the authors were/are members/employees, to endorse or promote Your Product or any work in which You include a modified or unmodified version of This Product, or to endorse or promote You or Your affiliates, or in a way that might suggest that Your Product (or any work in which You include a modified or unmodified version of This Product), You, or Your affiliates is/are endorsed by one or more authors of This Product, or in a way that might suggest that one or more authors of This Product is/are affiliated with You (or Your affiliates) or directly participated in the creation of Your Product or of any work in which You include a modified or unmodified version of This Product.

6. IF YOU ARE NOT SURE WHETHER YOU UNDERSTAND ALL PARTS OF THIS LICENSE OR IF YOU ARE NOT SURE WHETHER YOU CAN COMPLY WITH ALL TERMS AND CONDITIONS OF THIS LICENSE, YOU MUST NOT USE, COPY, MODIFY, CREATE DERIVATIVE WORKS OF, NOR (RE)DISTRIBUTE THIS PRODUCT, NOR ANY PORTION(S) OF IT. YOU SHOULD CONSULT WITH A LAWYER.

7. IF (IN RELEVANT CONTEXT) ANY PROVISION OF CHAPTER IV OF THIS LICENSE IS UNENFORCEABLE, INVALID, OR PROHIBITED UNDER APPLICABLE LAW IN YOUR JURISDICTION, YOU HAVE NO RIGHTS UNDER THIS LICENSE AND YOU MUST NOT USE, COPY, MODIFY, CREATE DERIVATIVE WORKS OF, NOR (RE)DISTRIBUTE THIS PRODUCT, NOR ANY PORTION(S) THEREOF.

8. Except as otherwise provided in this License, if any provision of this License, or a portion thereof, is found to be invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of this License, and such invalid or unenforceable provision shall be construed to reflect the original intent of the provision and shall be enforced to the maximum extent permitted by applicable law so as to effect the original intent of the provision as closely as possible.

____________________________________________________________

Сторонние лицензии

Этот Продукт содержит компоненты, созданные сторонними лицами и регулируемые сторонними лицензиями, приведёнными ниже (разделены строками, состоящими из символов подчёркивания). Каждая из сторонних лицензий применяется только к (частям) файла (файлов) исходного кода, в котором содержится сторонняя лицензия или в которых на неё имеется явная ссылка, а также к скомпилированным или иным образом обработанным формам такого исходного кода. Ни одна из сторонних лицензий не применяется к этому Продукту в целом, даже если в нём используются такие термины, как «продукт», «программа» или любые другие эквивалентные термины/фразы. Этот Продукт в целом регулируется Лицензией TrueCrypt (см. выше). Некоторые сторонние компоненты были изменены авторами этого Продукта. Если не указано иное, такие изменения и дополнения регулируются Лицензией TrueCrypt (см. выше).
Примечание. Если не указано иное, графика и файлы, не являющиеся частью исходного кода, регулируются лицензией TrueCrypt.

____________________________________________________________

Лицензионное соглашение на Encryption for the Masses.

Copyright (C) 1998-2000 Paul Le Roux. All Rights Reserved.

This product can be copied and distributed free of charge, including source code.

You may modify this product and source code, and distribute such modifications, and you may derive new works based on this product, provided that:

1. Any product which is simply derived from this product cannot be called E4M, or Encryption for the Masses.

2. If you use any of the source code in your product, and your product is distributed with source code, you must include this notice with those portions of this source code that you use.

Or,

If your product is distributed in binary form only, you must display on any packaging, and marketing materials which reference your product, a notice which states:

"This product uses components written by Paul Le Roux <pleroux@swprofessionals.com>"

3. If you use any of the source code originally by Eric Young, you must in addition follow his terms and conditions.

4. Nothing requires that you accept this License, as you have not signed it. However, nothing else grants you permission to modify or distribute the product or its derivative works.

These actions are prohibited by law if you do not accept this License.

5. If any of these license terms is found to be to broad in scope, and declared invalid by any court or legal process, you agree that all other terms shall not be so affected, and shall remain valid and enforceable.

6. THIS PROGRAM IS DISTRIBUTED FREE OF CHARGE, THEREFORE THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. UNLESS OTHERWISE STATED THE PROGRAM IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

7. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM, INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS, EVEN IF SUCH HOLDER OR OTHER PARTY HAD PREVIOUSLY BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
____________________________________________________________

Copyright (c) 1998-2008, Brian Gladman, Worcester, UK. All rights reserved.

LICENSE TERMS

The free distribution and use of this software is allowed (with or without changes) provided that:

  1. source code distributions include the above copyright notice, this list of conditions and the following disclaimer;
  2. binary distributions include the above copyright notice, this list of conditions and the following disclaimer in their documentation;
  3. the name of the copyright holder is not used to endorse products built using this software without specific written permission.

DISCLAIMER

This software is provided 'as is' with no explicit or implied warranties in respect of its properties, including, but not limited to, correctness and/or fitness for purpose.
____________________________________________________________

Copyright (C) 1995-2023 Jean-loup Gailly and Mark Adler.

This software is provided 'as-is', without any express or implied warranty. In no event will the author be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

  1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.
  2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.
  3. This notice may not be removed or altered from any source distribution.
Jean-loup Gailly Mark Adler
jloup@gzip.org madler@alumni.caltech.edu
____________________________________________________________

Copyright (C) 1999-2023 Dieter Baron and Thomas Klausner

The authors can be contacted at

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. The names of the authors may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
____________________________________________________________

Copyright (c) 2013, Alexey Degtyarev. All rights reserved.

________________________________________________________

Copyright (c) 2016. Disk Cryptography Services for EFI (DCS), Alex Kolotnikov

This program and the accompanying materials are licensed and made available under the terms and conditions of the GNU Lesser General Public License, version 3.0 (LGPL-3.0).

The full text of the license may be found at https://opensource.org/licenses/LGPL-3.0
____________________________________________________________

Copyright (c) 1999-2013,2014,2015,2016 Jack Lloyd.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
____________________________________________________________

Copyright (c) 2013-2019 Stephan Mueller <smueller@chronox.de>

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
  1. Redistributions of source code must retain the above copyright notice, and the entire permission notice in its entirety, including the disclaimer of warranties.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

ALTERNATIVELY, this product may be distributed under the terms of the GNU General Public License, in which case the provisions of the GPL2 are required INSTEAD OF the above restrictions. (This clause is necessary due to a potential bad interaction between the GPL and the restrictions contained in a BSD-style copyright.)

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, ALL OF WHICH ARE HEREBY DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF NOT ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

____________________________________________________________

Copyright (c) 1999-2023 Igor Pavlov

LZMA SDK is written and placed in the public domain by Igor Pavlov.

Some code in LZMA SDK is based on public domain code from another developers:
  1. PPMd var.H (2001): Dmitry Shkarin
  2. SHA-256: Wei Dai (Crypto++ library)

Anyone is free to copy, modify, publish, use, compile, sell, or distribute the
original LZMA SDK code, either in source code form or as a compiled binary, for
any purpose, commercial or non-commercial, and by any means.

____________________________________________________________